Jump to content
freesteve

HQ Player

Rate this topic

Recommended Posts

On 9/7/2019 at 8:11 PM, LoryWiv said:

CPU load is still double that of DSD 128 just like prior version.

 

That's how it should be. The algorithm scales linearly, so every time you double the sampling rate, the load doubles.

 


Signalyst - Developer of HQPlayer

Pulse & Fidelity - Software Defined Amplifiers

Share this post


Link to post
Share on other sites

I can report that I can get the asdm5ec modulator -> dsd256 to work, with version 4.1.1.1, CUDA offload set to convolution only and multicore DSP set to fully enabled. I have a Ryzen Threadripper 1950 with SMT disabled, so 16 real cores only and overclocked to 4 GHz.

CPU cooling is very much under control and everything else is up to date, latest Win10 and latest Nvidia drivers, latest BIOS etc.

 

If I enable full CUDA offload for instance, I get stuttering. Multicore DSP to auto is not helping me either. The configuration in the first paragraph seems to be the best for my hardware and one of the new modulators. Asdm7ec -> dsd256 will still stutter though.

Share this post


Link to post
Share on other sites
On 9/4/2019 at 6:33 PM, maya said:

Thanks for your explanation, if possible I would like to try your special Debian 4.11.2 version with this extra optimization.

 

There's now build 36 for Debian and build 32 for Fedora that puts back that optimization that I removed recently. It also syncs some other small tunings from Desktop.

 


Signalyst - Developer of HQPlayer

Pulse & Fidelity - Software Defined Amplifiers

Share this post


Link to post
Share on other sites
11 hours ago, Miska said:

 

That's how it should be. The algorithm scales linearly, so every time you double the sampling rate, the load doubles.

 

I understand, I didn't express my point well....what I intended to convey was that the there is no evident improvement in cpu efficiency running ASM7EC with 4.111 versus prior version. The cpu utilization is the same as with 4.11.


HQ Player --> iPower 5V / iDefender3.0 --> iGalvanic3.0 --> Singxer SU-1 --> Matrix X-Sabre Pro --> Feliks Audio Elise Mark II 

 

Share this post


Link to post
Share on other sites
52 minutes ago, LoryWiv said:

I understand, I didn't express my point well....what I intended to convey was that the there is no evident improvement in cpu efficiency running ASM7EC with 4.111 versus prior version. The cpu utilization is the same as with 4.11.

 

OK, yes, that's the case. These optimizations are around work load distribution to different CPU cores. 4.1.0 -> 4.1.1 there was one change for multicore enabled case where modulator CPU efficiency got improved at least on my Intel CPUs. Same algorithm, but just different data access pattern.

 


Signalyst - Developer of HQPlayer

Pulse & Fidelity - Software Defined Amplifiers

Share this post


Link to post
Share on other sites

I am not getting connectivity from the microrendu to the dac. in mysonicorbiter I go to dac diagnostics and it shows no dac connected. I tried rebooting the microrendu, tried shutting down the dac and restarting but nothing seems to work. I even pulled the power plug from the rendu and then reinserted. Would appreciate some guidance. I am using Hqplay

Share this post


Link to post
Share on other sites

I'm curious given the years of focus on fanless PC's.  How many currently OC'ing to make EC work did so previously? 

 

Or for that matter how many are silently watching until sense returns to the discussion.  x-D

Share this post


Link to post
Share on other sites
1 hour ago, antonellocaroli said:

Some people use 
Roon > hqplayer 4 > networkaudiod 
?

I have problems with the track change, the play stops

This does not happen with hqplayer 3

 

What does HQPlayer say as a reason in the log file?

 


Signalyst - Developer of HQPlayer

Pulse & Fidelity - Software Defined Amplifiers

Share this post


Link to post
Share on other sites
2 hours ago, antonellocaroli said:

I forgot, where is the log file in linux?

 

It is in "~/.hqplayer" directory a file called HQPlayer4Desktop.log

 

If you are upsampling to DSD, one somewhat likely reason is that

1) You have "Adaptive output rate" checked and

2) You don't have "48k DSD" checked (most DACs don't support this) and

3) Content you are switching to is 48k-base rate

 

Recommended settings:

1) Do not check "48k DSD"

2) Set DSD rate limit to suitable 44.1k base, for example "44.1k x256"

3) Set "Adaptive output rate" to unchecked on grayed

 


Signalyst - Developer of HQPlayer

Pulse & Fidelity - Software Defined Amplifiers

Share this post


Link to post
Share on other sites
18 hours ago, Theobetley said:

I am not getting connectivity from the microrendu to the dac. in mysonicorbiter I go to dac diagnostics and it shows no dac connected. I tried rebooting the microrendu, tried shutting down the dac and restarting but nothing seems to work. I even pulled the power plug from the rendu and then reinserted. Would appreciate some guidance. I am using Hqplay

This is very embarrassing. Unbeknownst to me I had  a power failure in which case my LIO reverts automatically  to an analogue input rather than the digital input. Thanks to all who responded. Problem now fixed. 

Share this post


Link to post
Share on other sites
On 9/9/2019 at 6:11 AM, Miska said:

 

There's now build 36 for Debian and build 32 for Fedora that puts back that optimization that I removed recently. It also syncs some other small tunings from Desktop.

 

Thank you ! I will try 

Share this post


Link to post
Share on other sites
6 hours ago, Miska said:

 

It is in "~/.hqplayer" directory a file called HQPlayer4Desktop.log

 

If you are upsampling to DSD, one somewhat likely reason is that

1) You have "Adaptive output rate" checked and

2) You don't have "48k DSD" checked (most DACs don't support this) and

3) Content you are switching to is 48k-base rate

 

Recommended settings:

1) Do not check "48k DSD"

2) Set DSD rate limit to suitable 44.1k base, for example "44.1k x256"

3) Set "Adaptive output rate" to unchecked on grayed

 

 

these are the settings:

 

image.png.6753be830790b55cd490081ff19cd9f0.png

 

 

log:

 

HQPlayer4Desktop.log

 

HQPlayer4Desktop.log

 

streaming from Qobuz

Share this post


Link to post
Share on other sites
2 hours ago, antonellocaroli said:

 

these are the settings:

 

image.png.6753be830790b55cd490081ff19cd9f0.png

 

 

log:

 

HQPlayer4Desktop.log 10.12 kB · 6 downloads

 

HQPlayer4Desktop.log 8.43 kB · 0 downloads

 

streaming from Qobuz

 

Problem is here:

! 2019/09/10 19:28:26 clHQPlayerEngine::Execute(): clStreamReaderHTTP::Read(): read timeout
 

Roon is not providing data and HQPlayer times out.

 

Other than that, playback doesn't exactly match with those settings. Playback is at DSD128 while output mode in settings is set to "[source]". So output mode is being switched externally.

 


Signalyst - Developer of HQPlayer

Pulse & Fidelity - Software Defined Amplifiers

Share this post


Link to post
Share on other sites

I'd like some clarification about the Min/Max Vol Setting for upsampling to DSD 128.

I've been using -3Min/-3Max for a long time, as per recommendation from Miska.

I've seen -60 Min/0 Max recommended, but I get no sound at all that way.

Does -6 Min/0 Max provide the same clipping protection as -3 Min/-3 Max?

Share this post


Link to post
Share on other sites
15 minutes ago, jimdukey said:

I'd like some clarification about the Min/Max Vol Setting for upsampling to DSD 128.

I've been using -3Min/-3Max for a long time, as per recommendation from Miska.

I've seen -60 Min/0 Max recommended, but I get no sound at all that way.

Does -6 Min/0 Max provide the same clipping protection as -3 Min/-3 Max?

It is my understanding that the Min/Max are the setting for the volume control knob on the main HQP Desktop console. If you are not hearing anything, then check the position of the knob.

 

I have my settings at Min = -60 and Max = -3 for which I keep the volume control knob turned all the way up (clockwise) which translates into a -3 setting for which I believe Miska usually recommends. In my case the Min = -60 is a bit arbitrary given I don't adjust volume using the volume control knob.

 

You can achieve the same thing by having Min = -6 and Max = 0 and have the volume control knob set at the 12 o'clock position which translates into -3.


Eric


Ubuntu Studio Linux box (i5, 4 cores, 16GB RAM, Roon, HQP) > fiber optic > MikroTik CRS305-1G-4S+ > fiber optic > opticalRendu (HQP NAA) > Holo Cyan (DSD version) > Goldpoint passive preamp > Nord One UP NC500MB mono blocks > Klipsch La Scala

Share this post


Link to post
Share on other sites
9 hours ago, Miska said:

 

Problem is here:

! 2019/09/10 19:28:26 clHQPlayerEngine::Execute(): clStreamReaderHTTP::Read(): read timeout
 

Roon is not providing data and HQPlayer times out.

 

Other than that, playback doesn't exactly match with those settings. Playback is at DSD128 while output mode in settings is set to "[source]". So output mode is being switched externally.

 

yes, changed from source to sdm from hplayer4client.

 

so it's a roon problem?

but with hqplayer3 it works well....

 

in fact the scroll bar in roon, with hqp3 it moves with hqp4 no, probably there is an error just at the recognition of the lengths of the tracks

Share this post


Link to post
Share on other sites
3 hours ago, antonellocaroli said:

yes, changed from source to sdm from hplayer4client.

 

so it's a roon problem?

but with hqplayer3 it works well....

 

in fact the scroll bar in roon, with hqp3 it moves with hqp4 no, probably there is an error just at the recognition of the lengths of the tracks

 

Yes, it is either Roon or network problem. Maybe more to do with slow internet connection or server. Version 3 has the same timeout. Both wait for 10 seconds and if there's no data coming in 10 seconds it gives up waiting. You could try if you can reproduce the same problem with local content.

 

For me, the playback position indicator works with v4. Roon doesn't know how to control most of HQPlayer things, so check that you have position indicator set to "Time" in HQPlayer.

 

 

P.S. I have not seen such problems with Roon using local content or Tidal. I cannot test Qobuz because the service is not available in Finland.


Signalyst - Developer of HQPlayer

Pulse & Fidelity - Software Defined Amplifiers

Share this post


Link to post
Share on other sites

Good news for Ryzen 3000 systems.

https://community.amd.com/community/gaming/blog/2019/09/10/ryzen-community-update-bios-updates-for-boost-and-idle-plus-a-new-sdk

 

Please remind me, has anyone successfully run the EC modulators at DSD256 on a Ryzen 3700X or similar?  The upcoming BIOS update should help.


NUC7PJYH/AL --> Berkeley Alpha USB --> Jeff Rowland Aeris --> Jeff Rowland 625 S2 --> Focal Utopia 3 Diablos with 2 x Focal Electra SW 1000 BE subs

 

i7-6700K/Windows 10 Version 1903/HDPLEX 200W/HDPLEX 400W DC-ATX --> EVGA Nu Audio Card --> Focal CMS50's 

Share this post


Link to post
Share on other sites

Cuda Off-load

 

I am running HQ Player on a PC running Windows Server 2016.  Nvidia is saying that there are no drivers for the Geforce RTX Series 20 products for the Windows Server OS.  How are others using a graphics card for cuda off-load while running a windows server OS?  Do I not need a driver since I am not using it for video?  Will the Windows 10 driver work even though they are saying it isn't supported?

 

Any guidance here would be appreciated.

 


Speakers: Vandersteen Model 7s, 4 M&K ST-150Ts, 1 VCC-5; Amplification: 2 Vandersteen M7-HPAs, CI Audio D200 MKII, Ayre V-6xe; Preamp: Doshi Audio Line Stage v3.0; Phono Pre: Doshi Audio Phono Pre; Analog: Wave Kinetics NVS with Durand Telos composite arm; SME 3012R arm, Clearaudio Goldfinger Statement v2; Reel to Reel:  Technics RS-1500; Doshi Tape Pre-Amp; Studer A810, Studer A812, Tascam BR-20; Multi-channel: Bryston SP-3; Digital: Custom PC (WS 2016/AO/HQPlayer/Roon)> Lampizator Big 7 DAC

Share this post


Link to post
Share on other sites
42 minutes ago, dminches said:

Will the Windows 10 driver work even though they are saying it isn't supported?

 

Any guidance here would be appreciated.

 

The Windows 10 driver should work. It did for me with an Nvidia GTX card.


Roon Server: Core i7-3770S, WS2012 + AO => HQP Server: Core, i7-9700K, WS2019 + AO => NAA: Celeron NUC, HQP OS => ISO Regen with UltraCap LPS 1.2 => Mapleshade USB Cable => Lampizator L4 DSD-Only Balanced DAC Preamp => Blue Jeans Belden Balanced Cables => Mivera PurePower SE Amp => Magnepan 3.7i

Share this post


Link to post
Share on other sites
8 hours ago, Miska said:

 

Yes, it is either Roon or network problem. Maybe more to do with slow internet connection or server. Version 3 has the same timeout. Both wait for 10 seconds and if there's no data coming in 10 seconds it gives up waiting. You could try if you can reproduce the same problem with local content.

 

For me, the playback position indicator works with v4. Roon doesn't know how to control most of HQPlayer things, so check that you have position indicator set to "Time" in HQPlayer.

 

 

P.S. I have not seen such problems with Roon using local content or Tidal. I cannot test Qobuz because the service is not available in Finland.

yes, the problem was the "Time" set to Remain

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...