Jump to content
The Computer Audiophile

Audirvana Plus 3 (official thread)

Rate this topic

Recommended Posts

17 hours ago, Russell_L said:

 

Hmmm... I don't see it there.  I do see where I can specify multiple folders for my (single) library, and this is what I do currently.  But what I want is the ability to have a choice between different libraries (each pointing to its own set of folders).  In other words, there's some music I have that I do not want mixed in with my other music, and the only way I see to do this to have 2 (or more) distinct libraries.  iTunes allows this (by holding down the Option key when launching it); does Audirvana?

There's a "+" sign in the lower left of the library tab.  You can specify any library path you want, for as many libraries as you want.  For example, my single library is :  /volumes/drobo/music

Music is my library folder, and each artist has his own folder under that.  I could create another directory on my Drobo (or anywhere else) and add that path.  

 

Does this help?

Share this post


Link to post
Share on other sites
17 minutes ago, catastrofe said:

There's a "+" sign in the lower left of the library tab.  You can specify any library path you want, for as many libraries as you want.  For example, my single library is :  /volumes/drobo/music

Music is my library folder, and each artist has his own folder under that.  I could create another directory on my Drobo (or anywhere else) and add that path.  

 

Does this help?

 

That doesn't create multiple separate libraries: the + sign just adds more directories/folders/drives for A+ to include in it's single library.

Share this post


Link to post
Share on other sites
11 minutes ago, bnbayer said:

 

That doesn't create multiple separate libraries: the + sign just adds more directories/folders/drives for A+ to include in it's single library.

 

Correct. (AFAIK)

Share this post


Link to post
Share on other sites
20 hours ago, Russell_L said:

 

Correct. (AFAIK)

Sorry, I misunderstood that you wanted separate libraries within A+.  I thought you wanted the ability to include multiple external libraries.  As you mention, A+ combines all your external paths into a single large library.

Share this post


Link to post
Share on other sites

Recent Audirvana 3+ user (High Sierra), was absolutely blasted by its SQ.

 

Have some questions that Audirvana site FAQ didn't clear:

 

- I have an old macbook (10.7) on my second listening rig, where I installed the A+2.6 trial.

 

I've purchased an A3+ license, is there any way of applying it to A+2.6? If not, are 2.6 licenses available?

 

- Sorting:

Sorting by clicking on field headers does nothing. How's this???? Doesn't work on any view; the only method of re-ordering I found is to manually drag and drop in playlist view???

 

Does this have to do with how the library was built? (iTunes import vs folder import?)

 

 

 

 

Share this post


Link to post
Share on other sites
On 2/3/2019 at 3:11 PM, catastrofe said:

Sorry, I misunderstood that you wanted separate libraries within A+.  I thought you wanted the ability to include multiple external libraries.  As you mention, A+ combines all your external paths into a single large library.

Would be really great if Damien could look at this!? I know I asked a few years ago.

Share this post


Link to post
Share on other sites

@Giacomino Come to think of it I haven’t seen iTunes or that little symbol for it in a LONG time all I have on A+3 is ‘my library’ and all my TIDAL/Qobuz playlists plus TIDAL and Qobuz A+3 doesn’t even offer a choice for iTunes

Am I missing something?? Or do you have a version younger than A+3

Share this post


Link to post
Share on other sites
5 hours ago, bobbmd said:

@Giacomino A+3 doesn’t even offer a choice for iTunes

Am I missing something?? Or do you have a version younger than A+3

I think you're missing something:

A+ > Preferences > Library > 2nd method

Share this post


Link to post
Share on other sites

@Giacomino you are correct iTunes is 'my library' all my 16000+ tracks am listening now- it took me an entire NFL season(did it twice when my PC died and I bought this Mac Mini now have 4 different backups!) to rip all those cd's( never have been so bored in my entire life not even in P-chem).

Had forgotten what a great playlist it is-all 800 of those cd's! Thanks for your your 'topic' but seriously years ago I thought there was on earlier version of A+ different logos and some device you had to activate but that may have been on a different player.

But I have never had A+ crash on me through all of Damien's different versions

Try going to Audirvana's support page if you are lucky you might get lucky and get an answer otherwise try getting an answer from damien @damien78 (he is the founder and creator but he is a one man show so just keep trying)

I really enjoy A+3 it's SQ and fact it shows what bit rate the source is and then what my DAC playing it at-ROON and just Qobuz/TIDAL desktop apps all have their pluses and minuses ALL of them sound great but A+3 is still my favorite especially because it gives bit rates MQA or not etc for those streaming services

Share this post


Link to post
Share on other sites

 @damien78 

If I can have a request for the next version of the iOS app that you mentioned. Would it be possible to still have compatibility with iOS 9.3.5, the latest version working on the iPad 2?

I'd love to continue being able to use this as my remote and not have to spend a few hundreds $$ on a new iPad just for that function.

Do you think it would be possible? Pretty please?

 

Share this post


Link to post
Share on other sites

greetings

 

need some help please

 

i have mack book pro 2018--- chord qutest-  burson conductor v2+--- and I use a usb to optical converter--- and my headphones are audeze lcd mx4

 

i played around with sox and izotope settings, how can set those to their default settings, as there is no botton that resets those to deaults

 

and i wonder if please anyone can advise what are the best settings to get an euphoric warm detailed sound and to set either sox or izotope to provide that

 

also noticed once every-while I hear noise like cracking that happens every now and then when i use just a usb cable without the usb to optical converter, I do not know why that happens with my macbook pro 2018 but never happens with my windows laptop, could be that since macbook pro 2018 dropped usb input and that we rely on those micro usb to usb adapter that this happens. I tried 3 usb cables and it happens with all of them, its not consistent but it happens as I mentioned every now and then

 

best wishes

Share this post


Link to post
Share on other sites

Hi all,

Apologize if this has been asked before.

May i know if anybody has managed to use the AppleScript to play tracks in Audirvana 3?

I have tried many times and still cannot make it to work, especially the "set playing track" and "set next track" calls.

 

Here's the dictionary from AppleScript editor for Audirvana.

 

460115218_ScreenShot2019-02-10at10_37_30PM.thumb.png.af646d8c23dc6dfd933ebdc359294532.png

 

 

Thank you all for your help.

 

--isep

Share this post


Link to post
Share on other sites

Hi,

 

Since I upgraded to the last version on macOS Sierra (A+ 3.2.15), I'm unable to create new albums. I select a group of tracks I just imported and in the metadata panel on the right, when I enter something in the album field, nothing is recorded. The Save button doesn't even show up, actually. And if I save it using CMD + S, it saves everything except the album information...

 

What is weird is if I check metadata with another app, it's there!

 

Did anybody have the same problem? Does anyone know what could cause this issue?

 

Thanks!

 

PS: I love this app but the support team did not respond to my request a couple of days ago. Maybe because @damien78 is alone and probably very busy. I hope someone here will have a start of answer 🙂

Share this post


Link to post
Share on other sites
4 hours ago, isep said:

May i know if anybody has managed to use the AppleScript to play tracks in Audirvana 3?

I have tried many times and still cannot make it to work, especially the "set playing track" and "set next track" calls.

 

It would help if you'd provide the AppleScript code you've written and what exactly you're trying to accomplish.

 

If you're only trying to simulate the forward and back buttons by moving forward or back one track at a time, the commands are "next track" and "back track", without "set".

 

The AppleScript dictionary says "set playing track" and "set next track" work only in Slave mode.  Do you understand what Slave mode is?  I doubt that is what you want.  Slave mode runs Audirvana as a music renderer without any user interface, library or queue.  It is up to your AppleScript to feed it only one or two tracks at a time using "set playing track" and "set next track" and to use NSDistributedNotifications in Objective-C or Swift to receive notifications when a track is finished and you need to send it the next track to play.

Share this post


Link to post
Share on other sites

If a track currently is playing, "back track" moves to the beginning of the track just as the back arrow button does in the user interface, so you have to send that command twice to move to the previous track.  OTOH, if the track currently is at the 0 seconds position, a single "back track" command moves to the previous track.  This can be confusing.

Share this post


Link to post
Share on other sites

Hi @Bob Stern,

 

Thank you for your reply,

 

I’m trying to write a script to play tracks in Audirvana using other software as the UI (Roon, for example). In order to achieve this I need to be able to play the tracks once I know the file.

 

So for this purpose, Audirvana needs to be in Slave mode which is what I need.

 

Here is the script that I had (and doesn’t work).

 

Quote

tell application "Audirvana Plus"

set control type to Slave

set playing track type AudioFile URL "/Users/isep/test/music/06 - Pieces Of A Heart.flac" playpause

end tell

 

Thank you again for your help.

isep

Share this post


Link to post
Share on other sites

I've only scripted it in interactive mode, not slave mode, in which case I add at track via:

tell application "Audirvana Plus" to open alias trackPath

 

Since I've never used "set playing track" I can only guess at its syntax, but you might try prefacing the URL string with file://

 

How will your script know when you've finished playing a track and you're ready to feed it the next track?

Share this post


Link to post
Share on other sites

 

Quote

Since I upgraded to the last version on macOS Sierra (A+ 3.2.15), I'm unable to create new albums. I select a group of tracks I just imported and in the metadata panel on the right, when I enter something in the album field, nothing is recorded. The Save button doesn't even show up, actually. And if I save it using CMD + S, it saves everything except the album information...

 

Have noticed that too (amongst several issues).

 

There's a trick: after writing the album, click on another field,  Period for example, that will trigger the save button to show.

 

Sometimes this doesn't work; in this case, look at the songs, one from the album will display different data. Select all but that one, do the click to another field trick with them, then repeat with the "odd" one alone.

 

Quote

What is weird is if I check metadata with another app, it's there!

 

Did anybody have the same problem?

 

Yes, it happens to me too.


 

Quote

 

Does anyone know what could cause this issue?

 

 

A bug.

 

Quote

 

PS: I love this app but the support team did not respond to my request a couple of days ago. Maybe because @damien78 is alone and probably very busy. I hope someone here will have a start of answer 🙂

 

I'm shocked with the nonexistent level of "support" A+ has too. Seriously shocked.  

Share this post


Link to post
Share on other sites
3 hours ago, pukkita said:

Have noticed that too (amongst several issues).

 

There's a trick: after writing the album, click on another field,  Period for example, that will trigger the save button to show.

 

Sometimes this doesn't work; in this case, look at the songs, one from the album will display different data. Select all but that one, do the click to another field trick with them, then repeat with the "odd" one alone.

 

Thank you for for the trick. Unfortunately, it's not working... My problem is probably a bit different. Let me explain a bit more in details, in case it makes a difference.

 

Basically, I'm not able to create any more album. At all. It's actually even worse: I've lost all of the albums from the same artist now... And of course I can't recreate them. It's all starting to look very bad... I'm going to wait for the next update now, and see if it's fixed.

 

 

4 hours ago, pukkita said:

I'm shocked with the nonexistent level of "support" A+ has too. Seriously shocked.  

 

Honestly, I'm on the fence between simply use the iTunes integration instead (which is a bit sad and not as convenient, I find...) or ask for a complete refund (which is really annoying, but it's starting to piss me off).

Share this post


Link to post
Share on other sites
3 hours ago, pukkita said:

Have you tried a database integrity check?

 

File > Library > Optimize Database

 

Have three options there, would start by doing an Integrity check. 

 

Thanks for the tip. I tried that already but I decided to give it another try, just in case. Nothing changed 😞

 

I'm wondering if starting over with a brand new DB and importing everything back would make a difference. I might just try that actually (after backing everything up, of course). We'll see what happens.

 

Thanks again for your help, Pukkita, it's really kind of you 🙂

 

I'll get back here with news as soon as I've done my test.

Share this post


Link to post
Share on other sites

@pukkita, no unfortunately. No .cue files in the folder I added lastely. The only thing I can think of is the fact that I jumped from a 2.X version to 3.X. This might be the reason for the bug. Don't know...

Share this post


Link to post
Share on other sites
14 minutes ago, InVino said:

@pukkita, no unfortunately. No .cue files in the folder I added lastely. The only thing I can think of is the fact that I jumped from a 2.X version to 3.X. This might be the reason for the bug. Don't know...

 

Big chance you still have the old library and the v3 one...

 

Go to A+ prefs panel... Library tab... remove all is there with minus sign.

Close A+


Apple hide the Home Folder in User Library at some time depending on OS System... When you have clicked your Home Folder, and cannot see the Library Folder in there, just do a ''cmd J'' to show the folder settings preferences and see at the bottom... click Show Library Folder and then you'll have access to the rest forever.
 
Go to User... Home Folder... Library... Applications Support... Audirvana Folder...
Trash All the files in that folder (that is your database of music, back it up! or not)
 
Restart Mac.  Restart A+. Add a music folder and wait till it finishes loading.
 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×