Jump to content
kipeta

Call for testers! Daphile

Rate this topic

Recommended Posts

Hi all

 

I have a really peculiar issue. When I set PCM>DSD at DSD64, everything is fine. In fact great, I am incredibly impressed with the conversion SQ. BUT when I set PCM>DSD to DSD128 and play native DSD256 files, I get stuttering!! Back to PCM>DSD at DSD64 and DSD256 files play perfectly.

 

I know this sounds stupid. I mean, when I'm playing native DSD256 files the PCM>DSD conversion program is not being used! But illogical as it sounds, this is what happens. (Incidentally, the PCM>DSD128 plays PCM files just fine.)

 

My server is the Lampizator Komputer but I don't imagine that is relevant since it is altering the settings in Daphile that creates the issue.

 

Any ideas, any one? Cheers

 

Philip

 

I just tried downsampling DSD256 to DSD128 using my SMSL M8. It worked with no issues as I suspected. CPU Load (see info tab, g4400 Pentium cpu, system load) is 1.3. For a dual core CPU peak would be 2.0

 

The Transcode log file shows

 

Untitled.png

 

Are you using Native DSD or DoP in the audio settings? If you are using Native try DoP. I have also had issues with this setting depending on the DAC.

Share this post


Link to post
Share on other sites

Hi all

 

I have just discovered the "Play From RAM" option in the bottom right hand of the main page. I think it improves the SQ significantly, but this could be expectation bias! Have other people tried this?

 

Also, the processing wait for a DSD file was about 90 secs whereas for a FLAC file it was over 5 mins. Is this variation to be expected?

 

Philip

Share this post


Link to post
Share on other sites

Hello All

I was using daphile some months ago but had to stop using as my PC had conked off. Was using a raspberry as source

 

I did install the latest daphile yesterday and was happy to know now we can play from RAM and upsample as we can do on Hqplayer

 

I could manage to enable PLAY FROM RAM but somehow cannot find settings for PCM upsampling

 

All I could find is some settings in audio devices but it has no noise shaping option

 

So if possible please guide me where the settings are

 

Also my dac does not show what bitrate signal is from transport so anywhere I can confirm up sampling happening

 

 

Thanks in advance

Share this post


Link to post
Share on other sites

Hi,

I noticed some strange noise, like RF static, converting the 48kHz rates (96kHz; 192 kHz) to DSD and streaming DSD in native mode.

 

Strangely it doesn't appear when I do the same with 44,1kHz group of rates, i.e. 88,2kHz; 176,4kHz, or streaming all rates in DSD DoP mode...

 

Since I'm not sure if it's Daphile or my DAC (Geek Pulse XFi 2V0), asking the testers and developer kindly to respond.

 

Alex

Share this post


Link to post
Share on other sites

I'm looking at building a high quality fanless silent music server using daphile based on a mini itx mobo with m.2 ssd, 4tb of storage and capable of dsd 256 up sampling. Itx gives me flexibility re the inclusion of a pcie usb card.

What is the recommended CPU? I have tried an Intel g4400 which runs 50%.

Should I consider a dual core 4 thread i3 6100.?

Would an i5 or i7 add any value other than cost?

Why do windows music audiophiles insist on an i7?

Would a nuc with external USB drive be much of a compromise?

What about a second hand notebook as a dedicated server?

Share this post


Link to post
Share on other sites
Hi all

 

I have just discovered the "Play From RAM" option in the bottom right hand of the main page. I think it improves the SQ significantly, but this could be expectation bias! Have other people tried this?

 

Also, the processing wait for a DSD file was about 90 secs whereas for a FLAC file it was over 5 mins. Is this variation to be expected?

 

Philip

 

Hi Philip ----- I also have a Lampizator Komputer - but with a Big 7 DAC -- but have not had much luck trying to upconvert to DSD.

 

I've read all the messages in this thread & made various adjustments/ tweaks over the past few weeks - I've also set it to play from RAM ( but realize this step needs to be re-activated whenever the power is toggled). But I can't seem to get it to play DSD without massive stuttering/ buffering -- even converting just to DSD64. ( my Big 7 is only capable of DSD 128 -- but I'd be happy just getting DSD64 to work -- not that I'm unhappy with the PCM sound quality)

 

I've checked PCM resampling steep filter -- set attenuation to -5 db ---Noise shaping to SDM-4--- it will play fine for about 5 minutes - but then starts buffering -- so I switch back to straight PCM

 

Are you having any difficulties playing DSD & what sample rate can you play at ?

 

thanks for any help or advice you can provide on the settings you are using.

 

Bart

Share this post


Link to post
Share on other sites
Hi Philip ----- I also have a Lampizator Komputer - but with a Big 7 DAC -- but have not had much luck trying to upconvert to DSD.

 

I've read all the messages in this thread & made various adjustments/ tweaks over the past few weeks - I've also set it to play from RAM ( but realize this step needs to be re-activated whenever the power is toggled). But I can't seem to get it to play DSD without massive stuttering/ buffering -- even converting just to DSD64. ( my Big 7 is only capable of DSD 128 -- but I'd be happy just getting DSD64 to work -- not that I'm unhappy with the PCM sound quality)

 

I've checked PCM resampling steep filter -- set attenuation to -5 db ---Noise shaping to SDM-4--- it will play fine for about 5 minutes - but then starts buffering -- so I switch back to straight PCM

 

Are you having any difficulties playing DSD & what sample rate can you play at ?

 

thanks for any help or advice you can provide on the settings you are using.

 

Bart

 

Check the cpu usage (system load) in the info tab. This gives the sum of the cpu thread utilisation (eg. 4 threads @ 50% usage would be 2.0). This should have an Intel i5 cpu with 4 threads. More than 60% (?) and you will probably get some stuttering. Make sure you tick all the boxes in the settings -> power section and raise the cpu frequency to max. Finally check the attenuation in the audio devices advanced player settings.

Share this post


Link to post
Share on other sites

Hi Bart

 

My Komputer/GG plays native DSD fine all the way to DSD256 so long as I set PCM>DSD64 but native DSD256 stutters when I set PCM>DSD128 (don't have a clue why!!).

 

It will convert PCM to DSD without stuttering on both PCM>DSD64 and PCM>DSD128, but I keep the setting at PCM>DSD64 for the reason described above.

 

My Audio Device Advance settings are:

 

PCM Resampling filter: Quality Very High, Phase Response Minimum Phase, Bandwidth Steep Filter Unchecked, Attenuation -3db, Track Transition Delays both 1000ms, Player buffering both at 2048MB, Buffer time 400ms, Period Count 10.

 

Hope this helps. Let me know how you get on.

 

Cheers

 

Philip

Share this post


Link to post
Share on other sites

Hi triplefun

 

Yes. I have 16.07.

 

The CPU usage seems low (0.15, 0.15, 0.14) so that seems OK. I will try your power suggestions later today.

 

Thanks for your interest.

 

Philip

Share this post


Link to post
Share on other sites

Thanks Philip & Triplefun -- I also have 16.07 ------- CPU usage is at 0.24 0.19 0.15 -- which I assume is okay.

 

I've revised my Audio Device Advanced settings to the ones you are using -- in most areas - mine were not even close to yours. I'll stick to DSD 64 rate for now & see how it handles it -------- Do you play from Ram or not & what Noise shaping settings do you use in the audio devices settings?

 

thanks again

Bart

Share this post


Link to post
Share on other sites

I use sdm-4 but only because that was how it set initially.

 

I've tried Play from RAM but the loading time is irritating. Do you think it improves the sound?

Share this post


Link to post
Share on other sites

I only tried playing from Ram yesterday & with the load times -- it's impossible to do any meaningful A/B -- I'm sure it can't hurt - but I don't think it's worth the trouble. I seem to be playing PCM to DSD at 64 now -- but I had to make some changes to my settings that differ from yours ( see attached) -- but at least it's working for now.

 

I'm a little nervous changing the CPU load settings -- the unit has a 3.6 Ghtz Xeon E3-1200 V3 4th gen -- but the CPU settings are set at 1.000 Ghtz -- likely to reduce overhead and heat -( I'm just guessing) - & I assume the lower the settings the better as long as it's not stuttering -- which seems to be under control for now - Hyperthreading is off an all the power management boxes are unchecked

 

thanks again settings.JPG

Share this post


Link to post
Share on other sites

I i'm new in the forum. I want to use daphile on a netbook with touchscreen and i would use the web interface, to reach the goal i've downloaded the beta version to access via ssh and install necessary packages. Unfortunately apt and dpkg are missing. Have you ever done this before? is there a different way to obtain the same thing? i don't like jivelite of the local ui and i would prefer the original web interface. Thanks and sorry for my english

Share this post


Link to post
Share on other sites
Hi Barth

 

At least try dsd128. Perhaps raise the CPU to 2ghz. Dsd128 is a noticeable improvement on dsd64. Dsd256 is also noticeable but not as much!

 

Thanks Triplefun -- did just that & so far so good.

 

Bart

Share this post


Link to post
Share on other sites
I i'm new in the forum. I want to use daphile on a netbook with touchscreen and i would use the web interface, to reach the goal i've downloaded the beta version to access via ssh and install necessary packages. Unfortunately apt and dpkg are missing. Have you ever done this before? is there a different way to obtain the same thing? i don't like jivelite of the local ui and i would prefer the original web interface. Thanks and sorry for my english

 

My-fault!! Daphile is gentoo based, all my toughts had no sense considering that. Thanks anyway

Share this post


Link to post
Share on other sites
Check the cpu usage (system load) in the info tab. This gives the sum of the cpu thread utilisation (eg. 4 threads @ 50% usage would be 2.0). This should have an Intel i5 cpu with 4 threads. More than 60% (?) and you will probably get some stuttering. Make sure you tick all the boxes in the settings -> power section and raise the cpu frequency to max. Finally check the attenuation in the audio devices advanced player settings.

 

Hi Triplefun

 

How do you manage to raise the cpu frequency in Daphile settings? Or do you in your pc bios ?

I have stutters converting to DSD256 "on the fly", but cpu load remains low ..

 

Thanks, Alex

Share this post


Link to post
Share on other sites

Hi Alex

 

The CPU frequency is found under settings -> power. The default is 1GHz. Set it to the maximum.

You may also need to look at the attenuation under Settings -> audio devices -> advanced player settings. This decreases the 'volume' and reduces the overhead on the cpu.

Share this post


Link to post
Share on other sites

Hi

 

I don't think this is necessary. However, try switching them all on to see if it makes any difference. I can't really help without knowing your cpu type and then any answer would invariably be a googled.

Share this post


Link to post
Share on other sites

Hi,

Strangely, the CPU frequency tab doesn't display in Power section on my Daphile setup, that's why I asked you.. Maybe it's due to BIOS Power Management not being enabled on my PC. Can't check it now (run it headless with no graphic card installed). It's i5 CPU of older generation, converting to DSD256 online it stutters with 1.0 load, a 25% per core. Converting to DSD128 online and original files in DSD256 play just fine.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...