Jump to content
austinpop

A novel way to massively improve the SQ of computer audio streaming

Rate this topic

Recommended Posts

There is no need to enter ip address information into any device but the bridge adapter created by Windows.

 

OK, so when we do, do we make both ethernet 1 and 2 static, or do we tell the bridge to use DHCP on the internet-connected one? Then, after that, where do we tell (something) what to do with microRendu?

Share this post


Link to post
Share on other sites
There is no need to enter ip address information into any device but the bridge adapter created by Windows.

 

Thanks. I only tried that, blindly, after the Touch couldn't connect. In 2016 you'd think these things would be as simple as plugging a lamp in a wall socket. Apparently not.

 

Edit: I forgot this is 2017! Should be even easier.

Edited by Emcee

Share this post


Link to post
Share on other sites
OK, so when we do, do we make both ethernet 1 and 2 static, or do we tell the bridge to use DHCP on the internet-connected one? Then, after that, where do we tell (something) what to do with microRendu?

Step 1:

 

You have the following..

 

Ethernet Adaptor 1 eg. USB Adaptor ...: Internet

 

Ethernet Adaptor 2 eg. Intel...: microRendu

 

type cmd into your windows search, and right click> open as administrator.command prompt opens, type ipconfig /all

 

Now record the following for Ethernet Adaptor 1, in my example, this description should say "USB Adaptor..." (it won't say 'internet', you'll need to look for the brand name of the adaptor):

 

IPv4 Address

Subnet Mask

Default Gateway

DNS Servers

 

Step 2:

Control-click on Ethernet 1 and Ethernet 2 and select 'bridge'. (virtual) Ethernet 3 adaptor magically appears: this is your Bridge.

 

Now right click Ethernet Adaptor 3 (the bridge), click 'properties', then go to Internet Protocol Version 4 at the bottom and click "properties" for that.

Click 'use the following IP address'.

Fill in the info from step 1.

Click OK

 

Step 3:

And you're done. No need to change settings for Ethernet 1 and 2. No need to do anything to microRendu. What you're basically telling Windows here is that your microRendu will be connecting to the Internet using the settings from Ethernet 1. Each device that connects to the internet, however, still can be assigned its own IP Address by the router or switch. It's just accessing that IP Address via Ethernet 1.

Share this post


Link to post
Share on other sites
Thanks. I only tried that, blindly, after the Touch couldn't connect. In 2016 you'd think these things would be as simple as plugging a lamp in a wall socket. Apparently not.

So did you get it to work in the end? I also spent a long time, but it finally worked, no problems now.

Share this post


Link to post
Share on other sites
OK, so when we do, do we make both ethernet 1 and 2 static, or do we tell the bridge to use DHCP on the internet-connected one? Then, after that, where do we tell (something) what to do with microRendu?

The NICs, ethernet 1 and 2, don't need an IP address as they only transmit and receive data. The host machine is an endpoint and needs an address, which is assigned from DHCP or statically as configured in the bridge interface settings.

 

Got it?

 

I usually set a static address as I'm connecting to this machine from multiple points in one or both physical segments and subnets and don't want to search for a dynamic address.

Share this post


Link to post
Share on other sites
So did you get it to work in the end? I also spent a long time, but it finally worked, no problems now.

Nope. I decided to relax and listen to music but I'm about to take another stab at it.

Share this post


Link to post
Share on other sites
The NICs, ethernet 1 and 2, don't need an IP address as they only transmit and receive data. The host machine is an endpoint and needs an address, which is assigned from DHCP or statically as configured in the bridge interface settings.

 

Got it?

 

I usually set a static address as I'm connecting to this machine from multiple points in one or both physical segments and subnets and don't want to search for a dynamic address.

 

FWIW I also set a static address for both my SMS-200 and for my PC- in my router settings. I don't think it would make a difference, especially the SMS-200 one, but it probably makes it faster. For the PC one, I just set it just in case it assigns me a new IP Address and I'd have to reconfigure everything. Not even sure if that can happen, but I don't want to spend another morning fixing it.

Share this post


Link to post
Share on other sites
Stupid question: if all my music pieces (NAS, HQPlayer server, microRendu, router) are through my fiber switch currently (or directly connected someday :) ) does the router even enter into the sonic equation, or is its noise polluting the fiber switch anyway? The main reason I ask is that I have a Hynes SR7 (single rail) that is adjustable from around 9-10V to 19V sitting around and was thinking of using it on my Windows NAA (not always used, only during multichannel) freeing up my JS-2 for LPS-1 energizer work (and possibly other power) but maybe it is a better use on my AT&T Uverse Arris/Motorola NVG589 modem/router ??

 

What I think happened for me at least was that the switch was adding noise. My 'switch' is a router, but same difference. I wouldn't worry about the energiser for the LPS-1. Use your SR-7 for the HQPlayer Server, and directly connect it to the microRendu. Try and see, with the JS-2 to your router, to see if things improve. I plan on trying that too, but I suspect that with direct connections, the router's power is going to be much less important since the router is really just passing an IP Address along.

Share this post


Link to post
Share on other sites
FWIW I also set a static address for both my SMS-200 and for my PC- in my router settings. I don't think it would make a difference, especially the SMS-200 one, but it probably makes it faster. For the PC one, I just set it just in case it assigns me a new IP Address and I'd have to reconfigure everything. Not even sure if that can happen, but I don't want to spend another morning fixing it.

Is that what solved the problem?

I'm getting ready to try this again so I unplugged the cable that goes from my router to my SB Touch and plugged it in the NIC. When I unplugged it from the router, after the buffer had run out, the music stopped but when I plugged it into the NIC strangely the music started again. Only until the end of that track, then it stopped again I and couldn't control the Touch anymore from LMS.

Share this post


Link to post
Share on other sites
Step 1:

 

You have the following..

 

Ethernet Adaptor 1 eg. USB Adaptor ...: Internet

 

Ethernet Adaptor 2 eg. Intel...: microRendu

 

type cmd into your windows search, and right click> open as administrator.command prompt opens, type ipconfig /all

 

Now record the following for Ethernet Adaptor 1, in my example, this description should say "USB Adaptor..." (it won't say 'internet', you'll need to look for the brand name of the adaptor):

 

IPv4 Address

Subnet Mask

Default Gateway

DNS Servers

 

Step 2:

Control-click on Ethernet 1 and Ethernet 2 and select 'bridge'. (virtual) Ethernet 3 adaptor magically appears: this is your Bridge.

 

Now right click Ethernet Adaptor 3 (the bridge), click 'properties', then go to Internet Protocol Version 4 at the bottom and click "properties" for that.

Click 'use the following IP address'.

Fill in the info from step 1.

Click OK

 

Step 3:

And you're done. No need to change settings for Ethernet 1 and 2. No need to do anything to microRendu. What you're basically telling Windows here is that your microRendu will be connecting to the Internet using the settings from Ethernet 1. Each device that connects to the internet, however, still can be assigned its own IP Address by the router or switch. It's just accessing that IP Address via Ethernet 1.

 

Yes, that is exactly what I did all the times I've tried (down to the copying in paint a screengrab from ipconfig /all and pasting it next to my routers list of ip addresses in my home too) and when the bridge is created I go to it and right click. However, it then seems to want me to decide which NIC I want to set properties for. Both are checked but one is highlighted (whichever one I want). I assume I choose the internet-connected one? You don't mention that step.

Share this post


Link to post
Share on other sites
Yes, that is exactly what I did all the times I've tried (down to the copying in paint a screengrab from ipconfig /all and pasting it next to my routers list of ip addresses in my home too) and when the bridge is created I go to it and right click. However, it then seems to want me to decide which NIC I want to set properties for. Both are checked but one is highlighted (whichever one I want). I assume I choose the internet-connected one? You don't mention that step.

 

 

 

Oh that doesn't matter! That group of NICs are all part of the same bridge. The tick/ check matters here, not the highlights. All of those ticked connections that are ticked will use the same IPv4 settings you're defining below, to access the internet.

Just make sure both ethernet 1 and ethernet 2 are ticked. Don't worry about highlighting..

Share this post


Link to post
Share on other sites
Is that what solved the problem?

I'm getting ready to try this again so I unplugged the cable that goes from my router to my SB Touch and plugged it in the NIC. When I unplugged it from the router, after the buffer had run out, the music stopped but when I plugged it into the NIC strangely the music started again. Only until the end of that track, then it stopped again I and couldn't control the Touch anymore from LMS.

 

 

No harm trying it. Use your normal setup first (the working one) and assign static IPs in your switch or router. Then do the bridging routine...

 

Hard to help more because I'm using roon not LMS or touch... the fact that it plays again probably means something is working, though! Can the NIC access the internet after you have bridged your connections?

Share this post


Link to post
Share on other sites
No harm trying it. Use your normal setup first (the working one) and assign static IPs in your switch or router. Then do the bridging routine...

 

Hard to help more because I'm using roon not LMS or touch... the fact that it plays again probably means something is working, though! Can the NIC access the internet after you have bridged your connections?

 

OK it's working now. Funny as I recall I did the same thing as I did this morning. Before trying it I did a network diagnosis on the Touch and it told me everything was OK so I fired it up and it worked.

 

Now, does it sound better? The first guitar plucks sounded mighty clean but I'll hold back. I've been a victim of expectation bias before and I only have a CIAudio PSU which is OK but most likely not at the same level as the the LPS-1 or the Vinnie Rossi.

 

An extra incentive for a PSU upgrade?

Share this post


Link to post
Share on other sites
Not going to happen - I just bought the Synology 916+, and am really happy with it.

 

There may be hope from another angle - I found these instructions 8128blog: Ethernet Bridge For Synology DS412+ : Craig Becker's new blog

 

I'll try them out when I get a chance.

 

Well... still no luck, unfortunately, getting bridging to work on a Synology DS916+ NAS running DSM 6.

 

This time I created a make-bridge.sh file like so:

ash-4.3# cat make-bridge.sh

#!/bin/sh

insmod /lib/modules/stp.ko

insmod /lib/modules/bridge.ko

brctl addbr br0

brctl stp br0 off

brctl addif br0 eth0

brctl addif br0 eth1

brctl show

ifconfig eth0 0.0.0.0 promisc up

ifconfig eth1 0.0.0.0 promisc up

ifconfig br0 192.168.0.240 netmask 255.255.255.0 up

route add default gw 192.168.0.2 dev br0

echo "1" > /proc/sys/net/ipv4/ip_forward

 

Then I ran it:

 

ash-4.3# ./make-bridge.sh

bridge name bridge id STP enabled interfaces

br0 8000.00113262e5d1 no eth0

eth1

 

And then... I lost connectivity, and the NAS does not respond to it's bridge IP address.

 

Now - it's possible this will work if I put this script in the rc.local directory so it's executed at boot, but that scares me, because if it doesn't work, I can't just reboot to recover - I may have to restore my settings from backup.

 

Nah - that is a "bridge too far!" Sorry - I gave it a try.

 

If anyone succeeds with bridging - especially on the current version of DSM on Synology - please educate.

Share this post


Link to post
Share on other sites

Rajiv, i have a hunch, please comment out the line "brctl STP br0 off" and give it another go. I also don't think you need the promiscuous port settings, but try that later.

 

I think you are creating a bridge named STP not br0.

Share this post


Link to post
Share on other sites
Rajiv, i have a hunch, please comment out the line "brctl STP br0 off" and give it another go. I also don't think you need the promiscuous port settings, but try that later.

 

I think you are creating a bridge named STP not br0.

Sorry ignore this, I was wrong, you are good up to this point.

 

Try removing the "up" on the line that assigns the bridge address. I hope you also realize you will need reconnect after the bridge is established using the bridge address as the nic is reset.

 

You could try making an eth1 bridge and test the script that way, adding eth0 later. This lets you test the syntax.

Share this post


Link to post
Share on other sites
Rajiv, i have a hunch, please comment out the line "brctl STP br0 off" and give it another go. I also don't think you need the promiscuous port settings, but try that later.

 

I think you are creating a bridge named STP not br0.

 

I see why you think that, but I did get the output of "brctl show" on my screen and it was:

"bridge name bridge id STP enabled interfaces"

"br0 8000.00113262e5d1 no eth0"

" eth1"

 

EDIT: Gah, I can't get CA to respect the blanks. Anyway you see it created a bridge names br0.

 

I wonder a couple of other things:

  1. Try running this in the background
  2. Since I lose connectivity at the eth0 line, can I move that last.

 

I'll try both. Worst case, 2 more reboots. :D

Share this post


Link to post
Share on other sites
I see why you think that, but I did get the output of "brctl show" on my screen and it was:

"bridge name bridge id STP enabled interfaces"

"br0 8000.00113262e5d1 no eth0"

" eth1"

 

EDIT: Gah, I can't get CA to respect the blanks. Anyway you see it created a bridge names br0.

 

I wonder a couple of other things:

  1. Try running this in the background
  2. Since I lose connectivity at the eth0 line, can I move that last.

 

I'll try both. Worst case, 2 more reboots. :D

Yeh, the gateway syntax here looks strange too. I think it should be "br0" not "dev br0".

Share this post


Link to post
Share on other sites
I wonder a couple of other things:

  1. Try running this in the background
  2. Since I lose connectivity at the eth0 line, can I move that last.

 

I'll try both. Worst case, 2 more reboots. :D

 

@lmiche

 

Larry,

 

Still no luck, but I put some ifconfig's at the end of the script, ran it in the background, and captured output to a file. Everything looks good, but the NAS still does not respond to the bridge IP address.

 

Screen Shot 2017-01-04 at 5.11.45 PM.png

 

I'm sure there's something subtle going on, but I ran out of time for now. I'm also thinking - a bit late, I know, and apologies to OP! - that we should probably move this debug stuff off thread and report back only if anything changes.

 

I'll keep plugging at it as and when I have some free time.

Share this post


Link to post
Share on other sites
OK it's working now. Funny as I recall I did the same thing as I did this morning. Before trying it I did a network diagnosis on the Touch and it told me everything was OK so I fired it up and it worked.

 

Now, does it sound better? The first guitar plucks sounded mighty clean but I'll hold back. I've been a victim of expectation bias before and I only have a CIAudio PSU which is OK but most likely not at the same level as the the LPS-1 or the Vinnie Rossi.

 

An extra incentive for a PSU upgrade?

 

Congrats! Glad you got it working!

Share this post


Link to post
Share on other sites

I am fairly comfortable messing around in basic network stuff, but don't have a lot of theoretical knowledge, especially in things like bridging adapters.

 

In my setup, I don't connect to the internet at all. It is currently a very simple configuration:

 

Zotac Z-Box LMS Server <-> Netgear AV switch <-> FMC <-> FMC <-> R-Pi (Squeezelite)

D-Link Wi-Fi Router setup as access point--^

 

I do have DHCP running on the D-Link to make it easier to insert new gear. I can easily turn it off.

 

Both the LMS Server and the R-Pi(s) have static IP addresses..

 

All are of course on the same subnet

 

If I connected the Zotac LMS Server directly to the R-Pi, should it work? If it does, I could of course control it by plugging a monitor, keyboard, and mouse into the Zotac.

 

Or do I need to add a 2nd ethernet adapter and bridge them? This I could do with a USB-Ethernet adapter, the Zotac is a 2-smartphone sized micro with no internal expansion ports.

 

If I can get it to work, longer term I'd like to go back to controlling via the LMS Server webpage either on a smartphone or a laptop that I connect to the D-Link's WiFi network.

 

The Zotac has built-in Wifi that I could turn back on to connect to the D-Link. Or I can connect a USB WiFi dongle to the Zotac for the same purpose.

 

But I thought I saw one couldn't bridge ethernet to WiFi.

 

Those with more knowledge of more advanced networking techniques, what do you think?

 

Greg in Mississipppi

Share this post


Link to post
Share on other sites
I am fairly comfortable messing around in basic network stuff, but don't have a lot of theoretical knowledge, especially in things like bridging adapters.

 

In my setup, I don't connect to the internet at all. It is currently a very simple configuration:

 

Zotac Z-Box LMS Server <-> Netgear AV switch <-> FMC <-> FMC <-> R-Pi (Squeezelite)

D-Link Wi-Fi Router setup as access point--^

 

I do have DHCP running on the D-Link to make it easier to insert new gear. I can easily turn it off.

 

Both the LMS Server and the R-Pi(s) have static IP addresses..

 

All are of course on the same subnet

 

If I connected the Zotac LMS Server directly to the R-Pi, should it work? If it does, I could of course control it by plugging a monitor, keyboard, and mouse into the Zotac.

 

Or do I need to add a 2nd ethernet adapter and bridge them? This I could do with a USB-Ethernet adapter, the Zotac is a 2-smartphone sized micro with no internal expansion ports.

 

If I can get it to work, longer term I'd like to go back to controlling via the LMS Server webpage either on a smartphone or a laptop that I connect to the D-Link's WiFi network.

 

The Zotac has built-in Wifi that I could turn back on to connect to the D-Link. Or I can connect a USB WiFi dongle to the Zotac for the same purpose.

 

But I thought I saw one couldn't bridge ethernet to WiFi.

 

Those with more knowledge of more advanced networking techniques, what do you think?

 

Greg in Mississipppi

I couldn't get wifi and ethernet to bridge in Mac OSX. In fact, after repeatedly failing, I did some reading and OSX expressly states this isn't possible. It might be possible in other OS's. Give it a try.

 

If both server and NAA have static IPs and are on the same subnet, you could be good to go. Whether you would need a crossover ethernet cable, I'm not sure. As you've stated, you'd be forced to control your NAA only from the computer your NAA is directly attached to and it may not be what you would want to do long term but at least you could hear how this direct connection sounds in your system.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×