Jump to content
IGNORED

Signalyst HQ Player 101


vortecjr
 Share

Recommended Posts

This thread is intended to be a supplement to the Sonore Rendu series user manuals. The manuals contains quick start information that can be viewed here:

Sonicorbiter Rendu Series - User Manuals

 

This guide is intended to be a practical starting point only and covers configuration of settings for bit perfect playback and resampled playback. It's based the latest version of the manual provided by the developer of HQ Player Jussi Laako. Please submit any corrections as needed.

 

Pre requisites - Having read the HQ Player manual. You can download the version 3.14.0 manual here: http://www.sonore.us/HQPlayer-manual.pdf

 

1. Bit perfect Playback for PCM and DSD

This corresponding to bit perfect playback of PCM and DSD. They are set together here, but you can set them independent of each other.

 

I selected Buffer = default (recommended unless there's a specific need to modify it). I have SDM Pack to DoP because most DACs support this format. I set the Sample rate limit and Bit rate limit to reasonable rates for use later. On a quad-core CPU it is good to enable Pipeline SDM setting in HQPlayer to split the load to more cores, especially if the output rate is DSD256 or higher.

 

For bit perfect playback of PCM you need Filter = none and Dither = none under PCM Defaults in Settings. I set the Vol Min = 0.0bd and Vol Max = 0.0db in Settings. You also need the far right dropdown menu (unnamed) from the main page set to Auto.

 

Screen Shot 2016-08-15 at 6.35.35 PM.png

 

For bit perfect playback of DSD you need to check DirectSDM in DSDIFF/DSF settings. You also need the far right dropdown menu (unnamed) from the main page set to Auto.

 

Screen Shot 2016-08-13 at 4.49.33 PM.png

 

2. Up Sampling PCM (PCM to PCM conversions)

The only chance I made here from example 1 above was to set Filter = ploy-sinc-shrt-mp (rock/pop/electronic) and Dither = NS9 (4x rates) under PCM Defaults in Settings. The manual says that Dither (none NS named filters) are for word length reduction. I'm up sampling in this example so I picked NS5 for 8X and 16x rates. I also set Vol Min Vol = -6bd and Max = -3bd to avoid clipping. The Sample rate limit is what HQ Player will resample to during playback.

 

Screen Shot 2016-08-15 at 6.46.15 PM.png

 

3. Up Sampling DSD (DSD to DSD conversions)

The only chance I made here from example 2 above was to uncheck DirectSDM in DSDIFF/DSF settings. From Settings the Bit rate limit under SDM Defaults is what HQ Player will resample to during playback. The Oversampling and Modulator sections will also be used.

 

Screen Shot 2016-08-13 at 5.42.57 PM.png

 

4. Up Sampling PCM to DSD (PCM to DSD conversions)

The only chance I made here from example 2 above was to set the far right dropdown menu (unnamed) from the main page set to SDM. From Settings the Bit rate limit under SDM Defaults is what HQ Player will resample to during playback. The Oversampling and Modulator sections will also be used.

 

Screen Shot 2016-08-13 at 6.09.02 PM.png

 

5. Down Sampling DSD to PCM (DSD to PCM conversions)

The only chance I made here from example 2 above was to set the far right dropdown menu (unnamed) from the main page set to PCM. From Settings the Sample rate limit under PCM Defaults is what HQ Player will resample to during playback. Furthermore it "appears" that the Conversion type, Noise filter and Integrator from DSDIFF/DSF settings is what is used for the conversion.

 

Screen Shot 2016-08-13 at 6.45.34 PM.png

Link to comment
Share on other sites

  • 1 month later...

I've searched around and can't seem to find and answer to my situation. I am running a powerful Win7 machine (dual quadcore with Xeon processors and 128 GB RAM) with a RAID5 setup for my music library, and have Roon on that machine. I've been able to set up MicroRendu with no issues when using Roon directly (no HQ Player), but have issues when trying to set up to run with HQ player. Specifically, the issue is related to the music files getting played back 'quickly' - like fast forwarding while playing. The DAC's I use are PCM only, and one is limited to 24/192 (Empirical Audio OverDrive SE), and the other is limited to 24/96 (Lavry DA2002, fed with an Empirical Audio OffRamp 5). Any tips on how I can resolve this?

Link to comment
Share on other sites

I started over, using the HQ Player 101 link. In fact I did that the first time, but didn't work correctly, so I read the HQ Player manual (again) and tried to use the reco'd settings there. It appears my situation is a bit of a hybrid in that I would like to do all of the following:

 

a or b (for my max 24/192 PCM DAC):

a) leave everything in native rate, unless DSD or over 192. Downconvert to 176, if DSD.

b) convert everything to either 176 or 192 (always moving to 176 or 192, to feed my DAC).

 

or c (for my max 24/96 PCM DAC): same as above, but constrain to 24/96 (or 24/88) max.

 

My current settings are in the attached screenshots. I started completely over, after reading the 101 tutorial. I am able to play PCM fine, but any DSD file creates a freak-out with HQ player and I need to use task manager to close the program down.

 

The 101 tutorial doesn't appear to really lock-down optimal setting for a DA converter that is PCM only, and has a max 24/192 (DA convertor #1) or 24/96 (DA convertor #2). Please see attached screenshots for current settings.

 

Thank you for any guidance you can provide.

Capture1.PNG

capture 2.png

Capture3.PNG

Link to comment
Share on other sites

I started over, using the HQ Player 101 link. In fact I did that the first time, but didn't work correctly, so I read the HQ Player manual (again) and tried to use the reco'd settings there. It appears my situation is a bit of a hybrid in that I would like to do all of the following:

 

a or b (for my max 24/192 PCM DAC):

a) leave everything in native rate, unless DSD or over 192. Downconvert to 176, if DSD.

b) convert everything to either 176 or 192 (always moving to 176 or 192, to feed my DAC).

 

or c (for my max 24/96 PCM DAC): same as above, but constrain to 24/96 (or 24/88) max.

 

My current settings are in the attached screenshots. I started completely over, after reading the 101 tutorial. I am able to play PCM fine, but any DSD file creates a freak-out with HQ player and I need to use task manager to close the program down.

 

The 101 tutorial doesn't appear to really lock-down optimal setting for a DA converter that is PCM only, and has a max 24/192 (DA convertor #1) or 24/96 (DA convertor #2). Please see attached screenshots for current settings.

 

Thank you for any guidance you can provide.

 

In Settings you have it set up for native PCM so it will not down sample. You have to select a filter, dither and max rate for it to down sample.

Link to comment
Share on other sites

In Settings you have it set up for native PCM so it will not down sample. You have to select a filter, dither and max rate for it to down sample.

 

Thank you. I don't mean to be dense, but I do have a specific use case here and was hoping to get some guidance on what specific values to change in the screenshot fields, fully aware that some items are subjective and may need to be tweaked.

 

I've read the 101 tutorial (a few times). I've read the manual (a few times), and find this software documentation to be a bit lacking. The 101 tutorial, as I have interpreted it, doesn't cover my specific use case, and combining tutorial item #1 with modifier #5 has resulted in the screenshots I shared.

 

Following HQ Player's manual settings (as I interpreted) resulted in some files being played back at >2X speed or a high frequency hiss. So, I started over (for the fourth time).

 

Roon as the source 'player' works fine when using with MicroRendu, for both PCM and all DSD.

 

So, given my current settings, and knowing that I:

 

1) Have either a 24/96 PCM DAC to use OR a 24/192 PCM DAC to use for testing...

2) Would like the option to either upsample to DAC's max resolution at a multiple of 2 or 4 <OR> pass-through the bits at native sample rate (I'd like to compare the two methods).

3) Convert all DSD to PCM, and feed to either of these two DACs at highest rate the DAC will accommodate, using simplest math (i.e. 176 or 88, depending on DAC used))

4) Have plenty of processing power under the hood of my PC (loaded Dell Precision 7910)

 

I fully understand there are variables that need to be changed depending on what PCM DAC I use (like sample rate limit of 96 or 192) as well as selecting an appropriate filter (subjective) for DSD to PCM conversion.

 

Can anyone please provide me with a walk through of what needs to be changed, using the the screenshots, and exact verbiage used in the screenshots and menus?

 

Thank you ; -)

Link to comment
Share on other sites

1) Have either a 24/96 PCM DAC to use OR a 24/192 PCM DAC to use for testing...

 

First, you get started with the default settings, just select PCM rate limit based on what you DAC can do.

 

2) Would like the option to either upsample to DAC's max resolution at a multiple of 2 or 4 <OR> pass-through the bits at native sample rate (I'd like to compare the two methods).

3) Convert all DSD to PCM, and feed to either of these two DACs at highest rate the DAC will accommodate, using simplest math (i.e. 176 or 88, depending on DAC used))

 

I'm not sure why you want multiple of 2 or 4 and "simplest math". The math is same complexity regardless if you go for example from 44.1 to 88.2 or 96. Anyway, default settings and select "PCM" as output format in HQPlayer main window, from the right-most drop-list.

 

Enabling "Auto rate family" makes HQPlayer pick up rates within the rate family.

Signalyst - Developer of HQPlayer

Pulse & Fidelity - Software Defined Amplifiers

Link to comment
Share on other sites

First, you get started with the default settings, just select PCM rate limit based on what you DAC can do..

 

Thank you for your response. I did that, as noted in the original screenshot. 'PCM Default" column was set to 192000.

 

I'm not sure why you want multiple of 2 or 4 and "simplest math". The math is same complexity regardless if you go for example from 44.1 to 88.2 or 96.

 

At one of the audio shows dedicated to computer audio, a presenter had mentioned that whole number divisors or multipliers was a best practice. Example SACD/DSD better to be converted to 176 than 192, and 44.1 upsampled to 196 was preferable to upsampling to 176

 

Anyway, default settings and select "PCM" as output format in HQPlayer main window, from the right-most drop-list.

 

Where can I find what you consider to be 'default settings'? Based on page 17 of the HQP manual, if I am to assume those are default settings, then when I tick SDM pack 'DoP' there is a dialog box that pops up to warn against using this with any DAC that isn't DSD capable. This is obviously not a default setting that should be retained (for my non-DSD capable DAC) then...

 

It would be VERY helpful, if you could send a screenshot of what you feel the optimal setting would be, and then note which of the boxes or dropdowns are 'subjective' (to taste).

 

Enabling "Auto rate family" makes HQPlayer pick up rates within the rate family.

 

As noted in the screenshot, I already had this enabled. I will re-attach the screenshots to this e-mail. What I need is for someone to point out what exactly to change vs my referenced screenshots, and if there are fields that are 'dealers choice'- then I can play around with those once I have the base program working across all my files.

 

Thank you.

Capture3.PNG

Capture1.PNG

Capture2.JPG

Link to comment
Share on other sites

At one of the audio shows dedicated to computer audio, a presenter had mentioned that whole number divisors or multipliers was a best practice.

 

Shouldn't be generalized over to HQPlayer... ;)

 

You would just lose bunch of bandwidth when using for example 176.4 vs 192 - roughly 10%.

 

Where can I find what you consider to be 'default settings'?

 

Nowhere, it is what HQPlayer starts up when freshly installed or otherwise when any prior settings don't exist. You can return to defaults by going to folder %LOCALAPPDATA%\HQPlayer and renaming or moving out the HQPlayer.xml file there.

 

It would be VERY helpful, if you could send a screenshot of what you feel the optimal setting would be, and then note which of the boxes or dropdowns are 'subjective' (to taste).

 

As said in above, reset back to defaults and start from there. For starters, only select correct backend, audio device and PCM output rate limit. In main window, select PCM output mode.

 

Then the settings to play with are available in HQPlayer main window, use the descriptions in manual as help when selecting those. Once you have made up your mind, you can go back to the Settings dialog and set those as default values.

 

The definite settings are the ones in main window, the ones in Settings dialog are just default values to be set in the main window when the application is started. Nothing more.

Signalyst - Developer of HQPlayer

Pulse & Fidelity - Software Defined Amplifiers

Link to comment
Share on other sites

Shouldn't be generalized over to HQPlayer... ;)

 

You would just lose bunch of bandwidth when using for example 176.4 vs 192 - roughly 10%.

 

 

 

Nowhere, it is what HQPlayer starts up when freshly installed or otherwise when any prior settings don't exist. You can return to defaults by going to folder %LOCALAPPDATA%\HQPlayer and renaming or moving out the HQPlayer.xml file there.

 

 

 

As said in above, reset back to defaults and start from there. For starters, only select correct backend, audio device and PCM output rate limit. In main window, select PCM output mode.

 

Then the settings to play with are available in HQPlayer main window, use the descriptions in manual as help when selecting those. Once you have made up your mind, you can go back to the Settings dialog and set those as default values.

 

The definite settings are the ones in main window, the ones in Settings dialog are just default values to be set in the main window when the application is started. Nothing more.

 

Thank you, Miska. I'll load this all up and try again this evening.

Link to comment
Share on other sites

Enabling multicast passthrough will also help on many other protocols like UPnP/DLNA, IPP (Internet Printing Protocol) that uses Bonjour/Avahi, AirPlay (also uses Bonjour), etc. :)

 

The default value of heavy multicast filtering is probably intended for large corporate networks where you don't want regular computers to reach each other directly but want to rely on a directory service or similar instead (Active Directory or LDAP).

 

I would say it is unusual default for SOHO switches because it easily makes things like networked multi-function devices (printer-scanner) inaccessible.

Signalyst - Developer of HQPlayer

Pulse & Fidelity - Software Defined Amplifiers

Link to comment
Share on other sites

Shouldn't be generalized over to HQPlayer... ;)

 

You would just lose bunch of bandwidth when using for example 176.4 vs 192 - roughly 10%.

 

 

 

Nowhere, it is what HQPlayer starts up when freshly installed or otherwise when any prior settings don't exist. You can return to defaults by going to folder %LOCALAPPDATA%\HQPlayer and renaming or moving out the HQPlayer.xml file there.

 

 

 

As said in above, reset back to defaults and start from there. For starters, only select correct backend, audio device and PCM output rate limit. In main window, select PCM output mode.

 

Then the settings to play with are available in HQPlayer main window, use the descriptions in manual as help when selecting those. Once you have made up your mind, you can go back to the Settings dialog and set those as default values.

 

The definite settings are the ones in main window, the ones in Settings dialog are just default values to be set in the main window when the application is started. Nothing more.

@Miska: I did precisely as you stated, rolled back to defaults, then selected PCM in last dropdown menu on main screen. Screenshots attached for all states. PCM works, but no DSD works. I then tried to follow the instructions of 'vortec' and locate the Start playback of some content with a known rate and then go to Apps / DAC Diagnostics in the GUI and see what the momentary frequency is.... But it appears this 'shorthand' reference is not something that translates to my machine, as there is no "Apps / DAC Diagnostics" menu or file folder that I can find in HQ Player or on my Win7 machine.

 

If it isn't too much trouble if someone can simply look at the screenshots, tell me what to change, and then tell me what items are 'personal preference', I could put this to bed ;-)

 

Hell, I'd even pay someone to do a remote screen session to get this all locked-down, if that's what it will take!

 

Capture1.PNG

 

Capture2.PNG

 

Capture3.PNG

Settings in Roon:

Capture4.PNG

 

Link to comment
Share on other sites

Did you try to "uncheck" the DirectSDM box under DSFF/DSF Settings? Otherwise, I believe that HQP tries to play DSD files in their native format without any conversion or upsampling.

Eric


Ubuntu Studio Linux box (i7-9700, 8 cores, 16GB RAM, Intel X520-DA1 NIC, HQP Desktop) > fiber optic > MikroTik CRS305-1G-4S+ > fiber optic > fitlet2 (Linux Mint - HQP NAA) > T+A DAC8 DSD > Rogue Audio DragoN > Klipsch La Scala — digital volume control with HQP via Roon client, DSP with HQP convolution engine, Intel NUC (Roon server)

Link to comment
Share on other sites

But it appears this 'shorthand' reference is not something that translates to my machine, as there is no "Apps / DAC Diagnostics" menu or file folder that I can find in HQ Player or on my Win7 machine.

 

Apps/DAC Diagnostics is neither in HQP nor in Windows but in the Sonicorbiter or microrendu menu (web interface).

Link to comment
Share on other sites

Did you try to "uncheck" the DirectSDM box under DSFF/DSF Settings? Otherwise, I believe that HQP tries to play DSD files in their native format without any conversion or upsampling.

 

Thank you, Eric. That did it ; -) Any other settings I should be tweaking for optimal DSD conversion? Check DSD gain box, or leave unchecked? I also saw some notes about moving the volume down to -2 to -3db. Applicable here, or leave at 0?

 

Thanks again for your help.

Link to comment
Share on other sites

I also saw some notes about moving the volume down to -2 to -3db. Applicable here, or leave at 0?

 

Miska highly recommends setting the max volume to -3db. It has something to do with clipping(?) which will show up under the "Limited" counter on the main panel if that condition is reached (shows a non-zero number), which is not a good thing.

 

There are other means of doing the same thing. For instance, you can set max volume to 0db and min volume at -6db but you would need to also set the master volume knob (main panel) to the 12 o'clock position which would translate into a -3db setting.

 

By setting the max volume to -3db, you max out the master volume knob (turned full clockwise).

 

As for the DSD gain box, I don't think has to with anything if you uncheck the DirectSDM box.

Eric


Ubuntu Studio Linux box (i7-9700, 8 cores, 16GB RAM, Intel X520-DA1 NIC, HQP Desktop) > fiber optic > MikroTik CRS305-1G-4S+ > fiber optic > fitlet2 (Linux Mint - HQP NAA) > T+A DAC8 DSD > Rogue Audio DragoN > Klipsch La Scala — digital volume control with HQP via Roon client, DSP with HQP convolution engine, Intel NUC (Roon server)

Link to comment
Share on other sites

Miska highly recommends setting the max volume to -3db. It has something to do with clipping(?) which will show up under the "Limited" counter on the main panel if that condition is reached (shows a non-zero number), which is not a good thing.

 

There are other means of doing the same thing. For instance, you can set max volume to 0db and min volume at -6db but you would need to also set the master volume knob (main panel) to the 12 o'clock position which would translate into a -3db setting.

 

By setting the max volume to -3db, you max out the master volume knob (turned full clockwise).

 

As for the DSD gain box, I don't think has to with anything if you uncheck the DirectSDM box.

 

Cool. I'll try with:

 

1) Poly-sinc (series) > NS9 > Auto > PCM w/ sample rate limit at 192k for my 192 DAC

 

OR

 

2) Poly-sinc (series) > (NS4 or Shaped) > Auto > PCM w/ sample rate limit at 96k for my 96k DAC

 

Thanks again for the help.

Link to comment
Share on other sites

  • 4 months later...

Is there a way to force HQP to output 32 bits? My DAC supports word lengths up to 32-bit through USB, but I am unable to get HQP to make the conversion of my 16-bit and 24-bit files. I have DAC bits set to 32 but HQP only outputs the original word length.

 

Thanks in advance for your help.

 

 

 

Link to comment
Share on other sites

Is there a way to force HQP to output 32 bits? My DAC supports word lengths up to 32-bit through USB, but I am unable to get HQP to make the conversion of my 16-bit and 24-bit files. I have DAC bits set to 32 but HQP only outputs the original word length.

 

Thanks in advance for your help.

 

I'll ask Jussi to pitch in. The USB interfaces can support 16, 24, and or 32 bit formats so those are what is streamed to your DAC. Most of the USB interfaces use a 32 bit.

Link to comment
Share on other sites

  • 4 months later...

Just noticed the roon - hqplayer nexus.

 

Question @Miska et al - can this be played thru my ultraRendu?

/& how is this implemented, if such is possible ...?

macmini M1>ethernet / elgar iso tran(2.5kVa, .0005pfd)>consonance pw-3 boards>ghent ethernet(et linkway cat8 jssg360)>etherRegen B-side(js-2)>ghent ethernet(et linkway cat8 jssg360) >ultraRendu A-side(clones lpsu split>lps1.2)>uspbc>iso regen(clones lpsu split>lps1.2)>curious regen link>rme adi-2 dac(js-2)>cawsey cables>naquadria sp2 passive pre> 1.naquadria lucien mkII.5 power>elac fs249be + elac 4pi plus.2> 2.perreaux9000b(mods)>2x naquadria 12” passive subs.

Link to comment
Share on other sites

Thanks.

Thought that was how it should work, but it doesn’t ... hqp just not streaming to ultraRendu. But does on its ownsome.

 

Will spend more time on it.

macmini M1>ethernet / elgar iso tran(2.5kVa, .0005pfd)>consonance pw-3 boards>ghent ethernet(et linkway cat8 jssg360)>etherRegen B-side(js-2)>ghent ethernet(et linkway cat8 jssg360) >ultraRendu A-side(clones lpsu split>lps1.2)>uspbc>iso regen(clones lpsu split>lps1.2)>curious regen link>rme adi-2 dac(js-2)>cawsey cables>naquadria sp2 passive pre> 1.naquadria lucien mkII.5 power>elac fs249be + elac 4pi plus.2> 2.perreaux9000b(mods)>2x naquadria 12” passive subs.

Link to comment
Share on other sites

1 minute ago, jamesg11 said:

Thanks.

Thought that was how it should work, but it doesn’t ... hqp just not streaming to ultraRendu. But does on its ownsome.

 

Will spend more time on it.

You have to enable NAA on the Rendu and select it as the output in HQ Player. 

Link to comment
Share on other sites

20 hours ago, vortecjr said:

You have to enable NAA on the Rendu and select it as the output in HQ Player. 

All good - got to it today & now sorted.

 

Nice package therein - Roon is best of database & HQP is best of upsamplers, esp dsd.

/& I still really like the A+ sound.

macmini M1>ethernet / elgar iso tran(2.5kVa, .0005pfd)>consonance pw-3 boards>ghent ethernet(et linkway cat8 jssg360)>etherRegen B-side(js-2)>ghent ethernet(et linkway cat8 jssg360) >ultraRendu A-side(clones lpsu split>lps1.2)>uspbc>iso regen(clones lpsu split>lps1.2)>curious regen link>rme adi-2 dac(js-2)>cawsey cables>naquadria sp2 passive pre> 1.naquadria lucien mkII.5 power>elac fs249be + elac 4pi plus.2> 2.perreaux9000b(mods)>2x naquadria 12” passive subs.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share



×
×
  • Create New...