Jump to content
IGNORED

Sonicorbiter - Tidal/Qobuz


vortecjr

Recommended Posts

This thread is intended to be a supplement to the Sonore Rendu series user manuals. The manuals contain quick start information that can be viewed here:

Sonicorbiter Rendu Series - User Manuals

 

This is the new way to support Tidal and Qobuz on the Rendu series.

This setup requires SonicOrbiter 2.7 or newer. 

 

Playback Tidal or Qobuz with mConnect or Android BubbleUPnP (preferred method) 

 

From the Rendu enter the unit's GUI and go to Settings / MPD DLNA and press Save. 

From the Rendu enter the unit's GUI and go to Apps/Audio App Switcher and confirm that you have a green Active box as shown below. 

Screen Shot 2016-11-18 at 5.33.11 PM.png

 

Download mConnect or Android BubbleUPnP and install it onto your mobile device.

From mConnect or Android BubbleUPnP select the device to stream to.

From mConnect or Android BubbleUPnP select Tidal and enter your account information.

Yep..it's that simple...enjoy!

 

Playback Tidal with Linn Kazoo (alternative method) 

 

From the Rendu enter the unit's GUI and go to Settings / MPD DLNA and press Save. 

From the Rendu enter the unit's GUI and go to Apps/Audio App Switcher and confirm that you have a green Active box as shown below. 

Screen Shot 2016-11-18 at 5.33.11 PM.png

 

Download Linn Kazoo and install it onto your computer or mobile device.

From Kazoo select the device to stream to.

From Kazoo select Tidal and enter your account information.

Yep..it's that simple...enjoy!

Link to comment
  • vortecjr locked this topic
  • 8 months later...

This is the old way to support Tidal and Qobuz on the Rendu series. You can still use it this way if you prefer it. 

 

Playback Tidal or Qobuz with Linn Kazoo and Lumin

 

Download and install the Linn Kazoo or Lumin control application onto your computer or mobile device.

 

From the Rendu enter the unit's GUI and go to Settings / MPD DLNA and press Save.

From the Rendu enter the unit's GUI and go to Apps/Audio App Switcher and select MPD/DLNA

Screen Shot 2016-11-18 at 5.33.11 PM.png

 

From the Rendu enter the unit's GUI and go to Apps/Software Manager/Available Apps. Install BubbleUPnP Server and wait for a link to appear that says, "Back to Package Manager"

Tidal-1.png

 

From the Rendu enter the unit's GUI and go to Apps and click on the BubbleUPnP Server icon (wait a few seconds for the application to open)

Tdal-2.png

 

From within BubbleUPnP server go to Media Renderer and select Create an OpenHome Renderer, add "OH" to the Room name, and click on Gapless Playback

Screen Shot 2016-07-23 at 4.40.51 PM.png

 

From your computer or mobile device open Kazoo and select the Room with the "OH" in the name and you should now see Tidal in Kazoo. On first use, you will need to enter your Tidal Account information.

 

----------------------------------------------------

 

Playback Tidal or Qobuz with BubbleUPNP on Android device:

 

From the Rendu enter the unit's GUI and go to Settings / MPD DLNA and press Save.

From the Rendu enter the unit's GUI and go to Apps/Audio App Switcher and select MPD/DLNA

Screen Shot 2016-11-18 at 5.33.11 PM.png

 

From SonicOrbiter or microRendu GUI go to Apps/Software Manager/Available Apps. Install BubbleUPnP Server and wait for a link to appear that says, "Back to Package Manager"

Tidal-1.png

 

From the Rendu go to Apps and click on the BubbleUPnP Server icon (wait a few seconds for the application to open)

Tdal-2.png

 

From within BubbleUPnP server go to Media Renderer and select Create an OpenHome Renderer, add "OH" to the Room name, and click on Gapless Playback

Screen Shot 2016-07-23 at 4.40.51 PM.png

 

From your Android device in BubbleUPnP go to Settings/Local Media Server/Tidal and enter your Tidal account info. Also, verify Audio Quality = FLAC

 

From your Android device in BubbleUPnP go to Settings/Local Media Server and check off Use Proxy at the bottom.

 

From your Android device in BubbleUPnP exit Settings.

 

From your Android device in BubbleUPnP under Renderer select the Rendu.

 

From your Android device in BubbleUPnP under Library select the Cloud. Then select Tidal or Qobuz.

 

From your Android device in BubbleUPnP pick a title and play it.

 
Link to comment
  • 7 months later...

I am having a new problem accessing Qobuz content using my microrendu 1.4 and Linn Kazoo.  Qobuz says they have recently updated their API and that is the problem.  I have no problems with Tidal.  Is there an update coming for the microrendu?

Thanks,

Jim

Link to comment
2 hours ago, JHG said:

I am having a new problem accessing Qobuz content using my microrendu 1.4 and Linn Kazoo.  Qobuz says they have recently updated their API and that is the problem.  I have no problems with Tidal.  Is there an update coming for the microrendu?

Thanks,

Jim

 

sounds like the problem is with linn kazoo or whatever you're using for your dlna/upnp server.  what are you using for your dlna/upnp server?

main rig:  simaudio moon mind 2 > chord dave > parasound jc-5 > kef reference 1
second rig:  simaudio moon mind 2 > chord qutest > luxman sq-n150 > klipsch heresy 1
Link to comment
5 minutes ago, jcn3 said:

 

sounds like the problem is with linn kazoo or whatever you're using for your dlna/upnp server.  what are you using for your dlna/upnp server?

It  has nothing to do with my server.  I am trying to stream Qobuz (which I was able to do previously without any problems) directly to my microrendu 1.4.  I have no trouble streaming Tidal.

Link to comment

@JHG -- if what you're saying is true, then the microrendu does no communications with qobuz or processing of the file.  it simply takes what you give it and plays it.  based on this, the problem is most likely with kazoo, not the microrendu.

main rig:  simaudio moon mind 2 > chord dave > parasound jc-5 > kef reference 1
second rig:  simaudio moon mind 2 > chord qutest > luxman sq-n150 > klipsch heresy 1
Link to comment
5 minutes ago, jcn3 said:

@JHG -- if what you're saying is true, then the microrendu does no communications with qobuz or processing of the file.  it simply takes what you give it and plays it.  based on this, the problem is most likely with kazoo, not the microrendu.

In this case, as the microrendu is acting as the dlna server, you don't think it could also be the microrendu?

Link to comment

@JHG-- that's why i asked where your server software was running -- you have to have a server somewhere.

 

so if you have dlna server software running on the microrendu, then here's what's happening:

 

* kazoo is communicating with the dlna server on the  microrendu

* the dlna server is communicating with kazoo to get the file and process it

* the dlna server gives the file to the endpoint (the microrendu)

* the microrendu converts the file to an output format capable of transmission via usb (ethernet to usb conversion)

 

i may be mincing words, but the problem is not with the microrendu per se, because fundamentally it is an ethernet to usb endpoint.  the problem is most likely with the dlna server software on the microrendu.  this comes from a third party (i believe), so @vortecjr is at the mercy of whoever developed that software (again, i believe)

 

have you tried any other control software beside linn kazoo just to rule that out?

 

main rig:  simaudio moon mind 2 > chord dave > parasound jc-5 > kef reference 1
second rig:  simaudio moon mind 2 > chord qutest > luxman sq-n150 > klipsch heresy 1
Link to comment

I have two customers reporting the issues so it's on our radar. Unfortunately, Qobuz has revoked the application ID which upmpdcli was using. They also deleted their api doc on github, so that this looks like a lockdown. I don't know that I can do anything about it for now.

 

Some Alternatives:

1. Can you try Kazoo with the OpenHome method outlined above and report back to us here.

https://audiophilestyle.com/forums/topic/27851-sonicorbiter-tidalqobuz/?tab=comments#comment-880956

2. Use Roon / RoonReady

3. Use an official controller on your phone or module device with the Shairport output protocol. This would limit playback to 16/44.1 content.

 

Link to comment
18 hours ago, JHG said:

@jcn3I used to use Lumin, but it doesn't work with streaming.  Perhaps @vortecjr has a suggestion for an alternative that runs on an iPhone/iPad.

 

The mconnect Player app (not free) can be used to control UPnP/DLNA streamers and has Qobuz & TIDAL access. Use the free Lite version to test; the HD version (not free) has been optimised for landscape screen use so is intended for use with the iPad (nothing to do with HD sound or audio quality).

We are far more united and have far more in common with each other than things that divide us.

-- Jo Cox

Link to comment

The problem is indeed that upmpdcli had its Qobuz ids revoked to access the API (it was XBMC/Kodi credentials) for the OpenHome renderer.

 

So the solution is to either to:

 

- use upmpdcli  as a regular UPnP AV renderer with a Control Point that has its own Qobuz support (mconnect, BubbleUPnP). This will not work with OpenHome Control Point such as Kazoo

- make upmpdcli an OpenHome renderer with BubbleUPnP Server as described in https://audiophilestyle.com/forums/topic/27851-sonicorbiter-tidalqobuz/?tab=comments#comment-880956. This works with OpenHome Control Points such as Kazoo

 

Next update of Android BubbleUPnP will have a workaround for being able to play Qobuz to upmpdcli as an OpenHome renderer, but using the app's own Qobuz support rather than through upmpdcli Qobuz OH support that is now not functional

 

Link to comment
  • 3 months later...

Hi, 

 

I installed Linn Kazoo on my MacBook Pro, everything installed fine.  I pulled up my Tidal account in Kazoo, no problem.  

 

I pressed the "play" button to listen to a song, but the tracks won't play.  In other words, the "play" triangle stays the same and does not change to the "pause" symbol, the song timer stays at 0:00.

 

I confirmed MPD/DLNA is lit up with the green active icon in the app switcher.

 

I tried rebooting my UltraRendu.  Still no luck.

 

In sonic orbiter, my DAC Diagnostic shows the following: (I am stuck using my stupid LH Labs Geek Pulse DAC that has been sitting in my closet while I am waiting for my new DAC to arrive)

 

LH Labs Geek Pulse X FI 1V5 at usb-ci_hdrc.1-1.1, high speed : USB Audio

Playback:
  Status: Stop
  Interface 1
    Altset 1
    Format: S32_LE
    Channels: 2
    Endpoint: 1 OUT (ASYNC)
    Rates: 44100, 48000, 88200, 96000, 176400, 192000, 352800, 384000
    Data packet interval: 125 us
  Interface 1
    Altset 2
    Format: SPECIAL DSD_U32_BE
    Channels: 2
    Endpoint: 1 OUT (ASYNC)
    Rates: 
    Data packet interval: 125 us
Status: Unknown (status not available when device is not playing)
amixer: Mixer hw:0 load error: Protocol error

Other Info:  I have used Roon Ready output mode with my UltraRendu and MicroRendu without any issues for years running the following chain: MacBook > wireless > Apple Airport > UltraRendu > Berkeley Alpha USB to AES-EBU converter > Yggdrasil DAC.

 

Recently I sold my Yggrasil.  I swapped in the LH Labs Geek Pulse DAC after selling the Yggdrasil while waiting for my new DAC to arrive.  It worked fine, using it with my Berkeley USB converter.  Then I sold the Berkeley USB converter and tried going USB from the UltraRendu to the Geek Pulse DAC, and that is when the problems started happening in Roon Ready.  Tracks in Roon would rapidly advance from song to song without playing.

 

I then decided to try to play Tidal without going through Roon.  That is when I downloaded Kazoo, but as noted above, the Tidal tracks won't play through Kazoo.

 

Any ideas?

 

Thanks, Blake

 

Speaker Room: Lampizator Golden Gate 2 | Viva Linea | Vinnie Rossi L2 Signature Monoblocks | FinkTeam Kim | Revel B112 subs  

Office Headphone System: Lampizator Big 7 updated to GG 2 specs | Viva Egoista | Hifiman HE-1000SE/Audeze LCD-4z

Link to comment
6 hours ago, Blake said:

Hi, 

 

I installed Linn Kazoo on my MacBook Pro, everything installed fine.  I pulled up my Tidal account in Kazoo, no problem.  

 

I pressed the "play" button to listen to a song, but the tracks won't play.  In other words, the "play" triangle stays the same and does not change to the "pause" symbol, the song timer stays at 0:00.

 

I confirmed MPD/DLNA is lit up with the green active icon in the app switcher.

 

I tried rebooting my UltraRendu.  Still no luck.

 

In sonic orbiter, my DAC Diagnostic shows the following: (I am stuck using my stupid LH Labs Geek Pulse DAC that has been sitting in my closet while I am waiting for my new DAC to arrive)

 

LH Labs Geek Pulse X FI 1V5 at usb-ci_hdrc.1-1.1, high speed : USB Audio

Playback:
  Status: Stop
  Interface 1
    Altset 1
    Format: S32_LE
    Channels: 2
    Endpoint: 1 OUT (ASYNC)
    Rates: 44100, 48000, 88200, 96000, 176400, 192000, 352800, 384000
    Data packet interval: 125 us
  Interface 1
    Altset 2
    Format: SPECIAL DSD_U32_BE
    Channels: 2
    Endpoint: 1 OUT (ASYNC)
    Rates: 
    Data packet interval: 125 us
Status: Unknown (status not available when device is not playing)
amixer: Mixer hw:0 load error: Protocol error

Other Info:  I have used Roon Ready output mode with my UltraRendu and MicroRendu without any issues for years running the following chain: MacBook > wireless > Apple Airport > UltraRendu > Berkeley Alpha USB to AES-EBU converter > Yggdrasil DAC.

 

Recently I sold my Yggrasil.  I swapped in the LH Labs Geek Pulse DAC after selling the Yggdrasil while waiting for my new DAC to arrive.  It worked fine, using it with my Berkeley USB converter.  Then I sold the Berkeley USB converter and tried going USB from the UltraRendu to the Geek Pulse DAC, and that is when the problems started happening in Roon Ready.  Tracks in Roon would rapidly advance from song to song without playing.

 

I then decided to try to play Tidal without going through Roon.  That is when I downloaded Kazoo, but as noted above, the Tidal tracks won't play through Kazoo.

 

Any ideas?

 

Thanks, Blake

 

Update and reboot the unit. Then go to Settings / MPD DLNA and press Save.

Link to comment
13 hours ago, vortecjr said:

Update and reboot the unit. Then go to Settings / MPD DLNA and press Save.

 

Unfortunately this did not solve the problem.

Speaker Room: Lampizator Golden Gate 2 | Viva Linea | Vinnie Rossi L2 Signature Monoblocks | FinkTeam Kim | Revel B112 subs  

Office Headphone System: Lampizator Big 7 updated to GG 2 specs | Viva Egoista | Hifiman HE-1000SE/Audeze LCD-4z

Link to comment

I have a Tidal HiFi account.  I am trying to stream lossless flac.

 

MPD.png

Speaker Room: Lampizator Golden Gate 2 | Viva Linea | Vinnie Rossi L2 Signature Monoblocks | FinkTeam Kim | Revel B112 subs  

Office Headphone System: Lampizator Big 7 updated to GG 2 specs | Viva Egoista | Hifiman HE-1000SE/Audeze LCD-4z

Link to comment

Hi Jesus,

 

It is working now.  I just had to power the DAC on and off and get the UltraRendu to detect it.

Speaker Room: Lampizator Golden Gate 2 | Viva Linea | Vinnie Rossi L2 Signature Monoblocks | FinkTeam Kim | Revel B112 subs  

Office Headphone System: Lampizator Big 7 updated to GG 2 specs | Viva Egoista | Hifiman HE-1000SE/Audeze LCD-4z

Link to comment

The only issue now is, I am not getting any sound.

 

I have a preamp in my system that I use to control volume.  My DAC has a volume control.  Since I am using a preamp, the DAC volume is set to max volume (no attenuation).   

 

In sonicorbiter, under DAC diagnostics, I clicked the button for "Set DAC to max volume".  Linn Kazoo shows the volume at 100.  The songs are playing in Kazoo, but there is no sound.  My power amp is on, my preamp is on and not muted.  Any thoughts?

 

Speaker Room: Lampizator Golden Gate 2 | Viva Linea | Vinnie Rossi L2 Signature Monoblocks | FinkTeam Kim | Revel B112 subs  

Office Headphone System: Lampizator Big 7 updated to GG 2 specs | Viva Egoista | Hifiman HE-1000SE/Audeze LCD-4z

Link to comment

Compatibility Mode is unchecked and I pressed Save.  Still no sound.  I tried RoonReady through Roon, and MPD/DLNA with Kazoo.

 

 

Speaker Room: Lampizator Golden Gate 2 | Viva Linea | Vinnie Rossi L2 Signature Monoblocks | FinkTeam Kim | Revel B112 subs  

Office Headphone System: Lampizator Big 7 updated to GG 2 specs | Viva Egoista | Hifiman HE-1000SE/Audeze LCD-4z

Link to comment
17 hours ago, Blake said:

Compatibility Mode is unchecked and I pressed Save.  Still no sound.  I tried RoonReady through Roon, and MPD/DLNA with Kazoo.

 

If Apps / DAC Diagnostics is showing a Monentary Frequency during playback then the issue is elsewhere downstream of the Rendu.

Link to comment

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


×
×
  • Create New...