Jump to content

Help with connecting pc to dac

Jeff Miller

Recommended Posts

I have my pc with j river connected through Ethernet to a local wireless router (Netgear AC1200). Router connects to Netgear GS105 network switch by Ethernet. Network switch connects with Ethernet to my Bricasti M1 SE. The sound is fantastic. You can follow this thread on Audiogon under best dac. I’m having problems playing dsd files. The signal locks and unlocks like hicupps? Red book and 24/192 work perfect? Can anyone help with this problem? Using router without switch everything works but does not sound as good. Thx Jeff 

Link to comment
Share on other sites

If it's not too mcuh trouble bring the PC to the M1 and use the USB. The test is to see if there are hiccups with the DAC playing DSD on USB. If there are hiccups, the usual way is to increase the buffer size in Jriver.  If there are no hiccups using USB, then the 'actual DAC' is quite capable of playing DSD, so that's a start.


Put back the PC and let's have a look at Jriver.

- The device should be Network Player/Streamer, not a DLNA endpoint.

- In DSP, try to set DSD64 as DoP for now and see what happens. If that works, then DSD128 should as well.

- If that doesn't work give Roon a try, the Bricasti M5 is a qualified endpoint for Roon, the M1 SE might be, please check with either.

AS Profile Equipment List        Say NO to MQA

Link to comment
Share on other sites

Can you try disabling EEE on the switch?


I'm not sure if your model is similar, but you can try following these instructions to test.





To manage the power saving mode on the switch:

  1. Open a web browser from a computer that is connected to the same network as the switch or is connected to the switch directly through an Ethernet cable.
  2. Enter the IP address that is assigned to the switch.
    The login page opens.
  3. Enter the switch password.
    The home page displays.
  4. From the menu at the top of the page, to the right of NETGEAR, click the icon with three dots and select Power Saving.
  5. Enable or disable power saving mode by clicking the slider.
    When the power saving mode is enabled, the slider displays blue. When the power saving mode is disabled, the slider displays white.


Link to comment
Share on other sites

Try using the switch as a hub with everything off it. So switch - router, switch - streamer, switch - pc. Try this instead of connecting pc to router by ethernet and then connecting router to switch if you can. The gs105 also has priority to ports 1 and 5 I think. So streamer to port 1 or 5, pc to other port. Try router port 3?

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Create New...