Jump to content
IGNORED

Revolution Native DSD support on a Mac


stefsam

Recommended Posts

Hi,

New Rev here, extremely happy about SQ but...it seems to be unable to hook into OSX Catalina with "Native DSD" support, see below screenshots in Roon and Audirvana:

961870066_Screenshot2020-12-18at13_57_39.png.176ad17c45b2c46ac32589e57b11a3b2.png410179771_Screenshot2020-12-18at13_04_51.thumb.png.9f56c5ea2c7e2e565226936c430edc8b.png

 

I've tried the following:

1. change USB port

2. reboot OSX Catalina

3. restart from alternative boot volume with OSX El Capitan

4. turn the Rev DAC off/on across all of the above stages

5. Roon: changed Volume Control to Device Volume, still "Native DSD" doesn't come out as an option for DSD Playback Strategy

6. Roon: changed to Fixed Volume, same result as n.5 above

 

..but to no avail.

 

Needless to say, it's OOB with no fiddling on Firmware or others - a Windows laptop does not recognise the device, so I would assume it's XmosID.

 

Is this a faulty DAC that I have to return, or is there anything I'm missing?

 

Warm thanks in advance for your kind advice!

 

 

 

 

Link to comment

UPDATE: the DAC works perfectly when connected to 2 Linux boxes: Raspberry OS Debian/buster, and Ubuntu20. It decodes DSD natively, and it's even recognised by Roon Core as remotely-connected "Native DSD" appliance.

 

It's impossible to hook it into Windows 7, once CemSolutions_UsbAudio_v4.82.0_2020-05-20_setup drivers are installed as per your supplied instructions, the DAC is not visible. Therefore: I've no way to flask ThesyconID, nor to check which FW is on - albeit I suppose it's XmosID.

 

Back to Mac OS: I've tried a second MacBook with Catalina on, same behaviour as on my main iMac: no "Native DSD" Roon support.

 

Any feedback or hints, most welcome! Thank you.

Link to comment

Salut Stefsam,

- according to Allo both firmware versions (Thesycon amd XMOS) are compatible with IOS, while  - due to the USB Audio 2.0 specifiction -  you should be enabled to playing PCM192 and DSD256 with Apple devices that are USB AUDIO 2.0 compliant. That may be dependend on the IOS or OSX in use.
- The CEM solution driver is a Thesycon USB driver. 
- If your device has supposed XMOS FW, why not try de-installing Thesycon drivers and look if the revolution starts now ...
- Allo notes that no usb drivers are needed for the using the Revolution with XMOS firmware. (which imho refers to recent devices).
- b/c for older Windows like XP you may need a specific Audio driver
- If you have a windows device at hand you may have the possibility to change the firmware  according to Allo's instructions or usinge the attached document
Allo-Revolution-Firmware-Update-Converted.pdf

- check with Roon that volume function under DEVICE SETUP is set on device volume to play DSD (bitstream)
underlining refers to embedded links

Good luck, Tom

Link to comment


×
×
  • Create New...