Jump to content
IGNORED

Achieving CD quality sound w/ Macbook Pro and Presonus Firebox?


DJSandro

Recommended Posts

Hello everyone,

 

I'm new here, this is my first post. I've been reading a lot on the site, and initially found this site when I figured out that I needed to get better sound out of iTunes.

 

I am a computer musician, I write and record music (and monitor on headphones) through a Presonus Firebox connected to a Macbook Pro Core 2 Duo OS 10.4. My library of songs is stored on a Glyph Pro Audio Firewire drive in lossless format (using error-checking and Apple's built-in encoder to rip).

 

My question: When monitoring a lowly 256 kbps AAC file from iTunes Plus (let's say a Dance music track, for example) using iTunes > Firebox DAC > Firebox's Headphone out > AKG 240S cans, there is clear distortion and muddiness with iTunes gain set to Unity (all the way up) and Core Audio at 44.1 kHz/24 bit. If I turn down the gain, then distortion goes away, but loss of clarity and image remains.

 

Here's where it gets interesting. When I burn that same dance music AAC file to CDROM and play it back in a Sony CD player with pulse DAC from 15 years ago, using the Sony's headphone out OR the firebox headphone out, it sounds much improved. Clearer, more space, better definition, better stereo image and no audible distortion.

 

What could be going wrong? How is it possible that my music sounds better through an old Sony CD player than through a $300 firewire interace?

 

The obvious corollary: How do I get CD quality sound from my Macbook Pro setup? I don't want hi-rez sound, just CD quality like my old Sony player gives me.

 

Thanks for any input. Sandro

 

 

 

 

 

Link to comment

You shouldn't even need an external soundcard/processor/DAC to match the quality of a basic consumer cdp with your Mac. A line out to your monitoring system should sound fine. Digital out to a really good DAC should sound better, but distortion? I don't know the Presonus, but I suspect something is amiss.

 

Tim

 

I confess. I\'m an audiophool.

Link to comment

My two guesses are iTunes is adding gain to the digital data such that it is clipped (full numeric value for 16 or 24 bits) too much of the time when you play directly, OR, when you rip the music to CD, software scales down music that is too hot and close to clipping. Perhaps you can test with your mixing application for clipping, or disable volume adjustment when ripping.

 

Link to comment

Thanks for your advice. What are the usual suspects that I could check in this case? I don't think the problem is with iTunes, the sound quality is degraded with VLC or Play as well. Also, if I just plug my headphones straight into the computer's headphone out the sound is degraded as well vs. Sony CDP.

 

Could it just be a bad choice of program material? Is dance music just too hot for the DAC to handle gracefully? Somehow the Sony player is more robust in this regard...?

 

 

 

Link to comment

 

Why would iTunes add gain, I thought "full volume" was unity gain, as Chris C has mentioned?

 

Ripping to CD is not the culprit because I can take a store-bought CD and play it back through the Sony CDP and it sounds fine, then burn it to lossless or AIFF or whatever and play it through my Firebox and it is noticeably worse, muddier, less presence, reverb tails are lost,etc...

 

I'm going to borrow my friend's Macbook and try some listening tests to eliminate the possibility that my firewire port is bad or I'm having a system setup issue.

 

Link to comment

Well, I don't really know anything specific to tell you to look for. The first thing I'd do is try bi-passing the external sound card. Plug a set of headphones straight into your Mac, or if you don't have cans, run a line from the headphone jack to your preamp or receiver. See what you get. Yes, you'll be double amping and that's not ideal, but it sounds like what you're getting now is marked distortion. That should disappear if the problem is in the firewire box. If it is still there, then I'd double check all my iTunes preferences and Audio preferences. If you have Sound Check or Sound Enhancer turned on, turn those off. Do you have another Firewire device you can check functionality on to see if it is the Firewire port? Process of elimination....

 

Tim

 

I confess. I\'m an audiophool.

Link to comment

Hi Tim,

 

Thanks again for your reply. I definitely don't have sound check or enhancer turned on and I have run the tests that you described. It doesn't help to run from the laptop out directly into the headphones or the stereo.

 

I tried de-installing the 4 Gb of RAM back to the OEM 2 Gb of RAM. This actually helped and the sound improved noticeably. There is still distortion, but that may be due to my choice of program material.

 

Apparently my MBP 2.2 core2duo was not happy with 4 Gb of RAM of which only 3 was addressable. It was causing logic to crash, and also degrading sound quality.

 

So I wouldn't say "problem solved" but I think that the RAM issue was one aspect of the problem. There is still a difference between the sound coming out of my Firebox and my CD player, but it's pretty minimal now.

 

Thanks everyone for the input.

 

Sandro

 

Link to comment

Hi everyone,

 

Thanks for the comments. I did solve the issue. Tim, you were right on, something was "amiss." In fact, it was a little audio daemon program running in the background on top of core audio. The daemon was installed with a audio shareware program that I installed a few months back on a (stupid) whim and quickly deleted. The program is called "OSS 3D", never use or install this program, it's just awful.

 

I thought that was it once I deleted the application, but the process (located in the library/application support folder) just kept loading into memory on startup. It was sitting there doing something to my audio stream from core audio. Once I located and deleted the daemon, of course, the sound quality now exceeds that of my CD player.

 

So, lesson learned, I guess. Thanks.

 

Sandro

 

Link to comment
  • 1 month later...
  • 6 months later...

Sorry to bump an old thread, but I'm having the exact same problem on my 15" Blackbook. When I use the Presonus Firebox OR a normal line-out to my stereo system, there is annoying distortion. When I plug headphones or computer speakers into the headphone jack, the sound quality is much better. Any ideas about what audio programs/daemons to look for that might be the culprit? OSS is not on my system.

 

Link to comment

I have no idea of what programs/daemons to be looking for - I don't know what you've installed on your computer, so you will have to experiment if that ends up being the cause.

 

I have another 'trail' that you might try though. Open Audio MIDI setup and experiment with different volume fader settings there.

 

That's all I've got - hope that it helps!

 

- markr

 

Link to comment

Hi mark, thanks for the welcome and quick reply!

 

I've done some fooling around with Audio Midi Setup with khz, bitrate, and faders, and also got rid of a couple random things running in the background, to no avail. Here's my activity monitor on startup (plus Firefox, Activity Monitor, and screen capture):

 

http://img93.imageshack.us/img93/1844/59596146.png

 

I have tried a few players (iTunes, Cog, Songbird, Play) and the problem is there with all of them.

 

Link to comment

Well, I have no direct experience with Presonus equipment, but perusing their tech specs for this, I was surprised to find that they claim the Firebox operates at "+10 dBu" for a 0 VU meter reading. That means this unit is operating at pro levels of output voltage (and then some). +10 dBu (about 2.449 volts rms) is kind of a strange rating, as most pro units are rated +4 dBu (about 1.228 volts rms). This is a bit higher than usual. Many pro level units like this offer a switch to allow operation at the consumer electronics standard of -10 dBv (about 0.3162 volts rms). This one doesn't seem to do that.

 

You don't really need to understand this .... yet. .... and unless you want to keep this unit and make it work .... but what it basically says is that the voltage output of the signal from the Presonus at 0 VU level is significantly higher than the voltage input that consumer grade amps and preamps want to see. Hence distorted sound.

 

What type equipment are you feeding with the output of the Firebox?

- markr

 

PS: I know that this doesn't jive with the OP's fix of his system, but I also don't see what type of system he was using for playback. He mentions that he is a musician, so he might have been using pro-level playback equipment. Looking at the diagrams, I see that Presonus recommends powered nearfield monitors be used to monitor the sound (pro level inputs). I just don't know here because I don't have enough information - both about what he was using and what you are using in the playback chain.

 

Link to comment

My "problem" is very similiar to the above. I've been looking to find the answer for ages.

 

I've registered just to post this:

 

 

Mac Pro into Focusrite Saffire into active crossover all set at unity.

 

 

Play ripped media (ripped as mp3,AAC,WAV or AIFF) with iTunes at unity too = lots of red all over the crossover and the Saffire. Too much even for these decibel war days.

 

Load exactly the same file into TRacks and play back at unity = no red. Well . . . . the very occassional red . . . or loads of red if you listen to modern over compressed junk.

 

Exactly as it should be.

 

I thought there was something wrong with the crossover. I'm slowly modding it (I'm into DIY audio) and suspected my own work until I tried the same files in TRacks.

 

It's nice to know I'm not alone and my work on the crossover is OK. With my own experience and after reading the above, the most logical conclusion is that there is some kind of chicanery going on in iTunes. An exciter on all the time perhaps, apart from the one in iTunes preferences that you can turn off.

 

If I remove iTunes fron the equation then my ears, eyes, crossover, soundcard and TRacks agree -

 

 

 

iTunes at unity is too hot !

 

 

 

What we need is an Uber Geek of the first order to tell us how to turn the exciter off. Most music these days is pulverized rather than mastered and I don't want iTunes adding even more distortion.

 

In the mean time if you want to honestly evaluate music or listen for pleasure use a more honest player. Just turning down iTunes won't work.

Yes it will get rid of the red but the "exciter" is still working (distorting) away, just not pushing the signal into clip.

 

VLC has the same problem in Mac and PC too.

 

 

Nice to know we don't have a problem - it's iTunes !

 

Blokeout.

 

 

 

 

Link to comment

Hi Bloke - Interesting things going on in your system. If I understand you correctly, the only application that "works" is TRacks? Hmm, something doesn't seem right. Can you download a trial version of soundBlade from Sonic Studio to see if it works on your system? Just use it as a playback application and ignore all the othercapabilities.

 

Founder of Audiophile Style

UPDATED: My Audio Systems -> https://audiophile.style/system

Link to comment

Sorry, didn't mention that I get exactly the same results using the Cubase LE that came with the sound card (Mac Pro, Boot Camp, XPsp3 - it doesn't like 10.5).

 

The red goes away.

 

Everything works fine in with the pro side, red on the consumer.

 

Try it yourself. Same (loud) file in a DAW of your choice. Then iTunes. All at unity.

 

Check the outputs further down the line. My iTunes and VLC (100%) are too hot. Haven't tried WMP yet. Hang on . . . . christmas tree again, possibly worse than the others. Would need longer to compare properly.

 

It would be nice to know if everyone else's iTunes work OK because that would localize "the problem" to this setup on the consumer side or this machine.

 

Am I somehow using different routing/do they use different routing, Focusrite ASIO vs Direct X ? Red herring ? - I get the same results in mac 10.5 with core audio.

 

The routing should be irrelevant. 0dB is 0dB.

 

From this end it's almost a non problem, the Pro stuff works, the consumer distorts.

 

But would Like to get a consumer player working as they are far better for just enjoying the music.

 

Blokeout

 

 

Link to comment

"Try it yourself. Same (loud) file in a DAW of your choice. Then iTunes. All at unity"

 

I have. All at "unity".

 

When my soundcard is switched to consumer output voltage levels (-10 dBv ) there is little to no difference between iTunes or any other consumer application and any pro application that I use ( Logic, Cubase ). All outputs meter readings are good.

 

When my soundcard is switched to 'pro' output voltage levels ( +4dBu ), meter readings for iTunes go into distortion repeatedly as does VLC, Cog, Play, etc. Some times no amount of level adjustment will stop the red peak reading warning light from coming on! The pro applications are still just fine.

 

The sound output does not distort on my system with either setting on the soundcard (except in extreme cases when I don't dial everything in properly), because I use a mixing desk operating at +4 dBu for my preamp and also a power amplifier operating at that level to power the loudspeakers.

 

I checked your Saffire's specs and it is operating at +16 dBu (!) and looks like it is switchable down to +4 dBu with a "DIM switch".

 

Here is a pretty good starter on understanding line level ratings of pro vs. consumer level sound cards: http://www.sweetwater.com/sweetcare/summits/dB.php . Consumer level playback software seems to have similar sensitivities built in to its algorithms, but I cannot say that for sure, because I'm not a programmer. We do seem to need a super uber geek.

 

- markr

 

 

 

 

Link to comment

 

The dim switch is only applicable to the main line audio outs.

 

I'm using Mac Pro>firewire>spdif>crossover.

 

No analogue until crossover outs.

 

+16dBu is VERY high and I found the dim switch slightly degraded the sound hence digital all the way. There's no point my sound card doing D>A then the crossover doing A>D

 

I want to run at -0dB throughout to get the lowest noise floor then control master volume with an analogue control just before the power amps. At the moment I'm using large pads on the power amp ins to achieve this.

 

I've got an M-Audio CO2 opticaldigital format changer somewhere I'll plug Mac optical into it then spdif to crossover. This will eliminate the Saffire. Unfortunately that also means I'll loose its metering and will have to rely on what the crossover digital in says.

 

Will post when I find it.

 

 

 

 

Link to comment

"The dim switch is only applicable to the main line audio outs." - You didn't mention that you were bypassing the audio outs on the Saffire before. ... or I missed it.

 

Please do post with SPDIF results when you can. That should be interesting. I almost never use SPDIF (or ADAT optical), so I don't know what to expect here. I don't 'think' it would make a difference because by using the SPDIF on the Focusrite, you should be bypassing the whole line-level function of the ADAC, though I suppose that there could still be some upward attenuation there.

 

-markr

 

PS: FWIW, My soundcard operates at 32bit's so I don't have any problem with using the RME software volume control to adjust the volume. All hardware and other software is set to unity (unless I'm recording something).NO noticeable degredation of sound (or 'zipper noise) is evident throughout the range of the soundcard-software. Also, my power amp has built-in pads for volume if necessary.

 

Link to comment

Found the CO2.

 

So now optical out>crossover.

 

Same results across the board, Pro DAWS 1 iTunes 0, still OK on the Pro, too much red in iTunes.

 

Curiously, very close inspection seems to show that my crossover clips when the DAWs are peaking at about -0.3dB ! I know you can get discrepancies with analogue meters. But I'm all digital, thought these were 100% accurate.

 

It's a Behringer DCX 2496, half modded (power supplies only, I haven't altered the in, or output boards yet except giving them clean power. A better clock, ins and outs to follow). The inputs (and out) has loads and loads of cheap opamps and with balanced input connected to my unbalanced Saffire SPDIF out could be the cause here. So the Behringer then for a small quantity of extra reds.

 

But the Saffire still says iTunes clips and the DAWs don't and the Focusrite and DAWs agree. Wierdness.

 

I now think my initial idea that iTunes has a hidden inflator is wrong. Too many other people with too much other kit don't get these results. It IS me again . . . sigh . . . again. Therefore just taking the very top off the gain WILL work as I think the problem is somewhere else now. It's localized to this set up. It happens in Mac and XP. So, specifically this computer.

 

Now I can relax, put all my kit back to normal and enjoy the music.

 

If I ever find the source of the extra reds I'll post here.

 

Thanks for your input and may you stay out of the red forever.

 

Blokeout

 

Link to comment
  • 1 year later...

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


×
×
  • Create New...