Jump to content
IGNORED

Flac to alac, maintain folder structure


Flaudo

Recommended Posts

I want to convert my flac collection to alac since my Ipod isn't able to play flac files.

The problem is that I want to convert my collection but keep the file structure.

 

I have one folder called "Music" with multiple folders in it by genre, in that folder I have multiple folders containing folders by artist etc.

 

Hope this is possible.

Thanks in advance

Link to comment

XLD will do it.

 

In XLD's preferences under 'General' set 'Output format' as Apple Lossless..

 

Also set '#Maximum Threads' to 32..

 

 

Couple of things, I'm assuming you're on a Mac..

 

You have to assign the *.flac files to open with XLD. Get info on any one of the flac files and in the information window under 'Open with' select XLD and click 'Change All...'

 

I suppose you also want to batch convert.

 

Search for all the .flac files in the particular folder you want to convert by typing flac in the Search window and selecting the folder (usually to the right of 'This Mac').

 

Select List view.

 

Select all (command+A) and then double click should automatically start converting to .m4a. (32 at a time but it is continuous until all the files are converted)

 

Your flac files will also be kept intact. Keep a watch on the amount of HDD space you have left.

 

I wouldn't do the whole 'Music' folder in one shot. Perhaps start off with a smaller Genre folder and see how you go.

iMac i7 > Amarra Symphony | Audirvana+ > Intona Industrial > Singxer F-1 DDC > Eastern Electric Minimax DAC+ | iFi nano iDSD > Line Magnetic LM-518IA > ProAc Response 3 + REL R-528

Link to comment

If you're on a PC dbpoweramp is recommended. I haven't used it so can't help but know that it can do what you're asking if you select 'Original Folder' in 'Output Location' under preferences.

iMac i7 > Amarra Symphony | Audirvana+ > Intona Industrial > Singxer F-1 DDC > Eastern Electric Minimax DAC+ | iFi nano iDSD > Line Magnetic LM-518IA > ProAc Response 3 + REL R-528

Link to comment
XLD will do it.

 

In XLD's preferences under 'General' set 'Output format' as Apple Lossless..

 

.

 

XLD won't keep the original directory structure. Pref has two options:

 

a) output dir is same as input dir which will mix individual tracks (original + new format)

b) specify a dir which will dump all tracks (of all albums) into this dir.

 

For some reason the XLD batch option of "preserve dir structures" not working.

 

If I'm missing something here I would appreciate any pointers as I'm in need of this functionality as well.

Link to comment
XLD won't keep the original directory structure. Pref has two options:

 

a) output dir is same as input dir which will mix individual tracks (original + new format)

b) specify a dir which will dump all tracks (of all albums) into this dir.

 

For some reason the XLD batch option of "preserve dir structures" not working.

 

If I'm missing something here I would appreciate any pointers as I'm in need of this functionality as well.

 

Option a) is the one I was referring to mate. I do this through Finder as outlined in my post and yes it 'mixes' the files, which is easily fixed by sorting the folders by file type.

 

I haven't bothered with batch decoding within XLD. Probably tried a long time ago and forgotten that it didn't work :)

iMac i7 > Amarra Symphony | Audirvana+ > Intona Industrial > Singxer F-1 DDC > Eastern Electric Minimax DAC+ | iFi nano iDSD > Line Magnetic LM-518IA > ProAc Response 3 + REL R-528

Link to comment
XLD won't keep the original directory structure […]

 

For some reason the XLD batch option of "preserve dir structures" not working.

 

If I'm missing something here I would appreciate any pointers as I'm in need of this functionality as well.

 

 

It does work correctly for me. However, maybe you've also enabled a filename format specification (in File Naming preferences) that creates folders; in which case, the result should be expected to be different to the original directory structure. Post more details of your problem if you need further help.

Link to comment
It does work correctly for me. However, maybe you've also enabled a filename format specification (in File Naming preferences) that creates folders; in which case, the result should be expected to be different to the original directory structure. Post more details of your problem if you need further help.

 

OK, I identified the culprit. I use "Open Folder as a Disc" instead of "Open..." from the File menu. To preserve Dir structure I needed to use "Open". Problem solved. Thanks for the tip.

Link to comment

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


×
×
  • Create New...