Jump to content
IGNORED

Power management causing clicks and pops


John Atwood
 Share

Recommended Posts

I just came upon something that may be helpful to this group. I first posted this to a Lynx forum (http://www.lynxstudio.com/forum/forum_posts.asp?TID=3062), so to save time, here is the posting:

 

******************************************

...

 

I recently upgraded my music server with a new CPU and motherboard (Intel Core Duo E8400) and at the same time thought I would upgrade from WinXP to Windows 7. I am using a Lynx Two card and am primarily using the AES/EBU output for playback, and use Foobar2000 as my media player. When everything was set-up, I was plagued by occasional random ticks and pops on music playback (not when silent but only during signal output). This never happened before on my old system running WinXP. I tried disabling services, lengthening buffers, etc. but nothing helped. BTW, I was getting the same ticks and pops on an on-board SPDIF output, so I didn't think the problem was with the Lynx board or driver. When I changed hard drives and re-loaded Windows XP, the problem went away, but it came back when I switched back to Windows 7.

 

After lots of Google searching, I found several references in forums to this problem and its apparent cause: The aggressive power management in the newer CPUs (both AMD and Intel) can cause glitches when controlled by the OS. The solution: disable OS control of power management. In my case, I disabled "SpeedStep" in the BIOS, and the problem went away! I was worried that the processor would permanently run hot, but this isn't the case - it seems to control things on its own, and it only gets hot when running a stress test.

 

There is no acknowledgment of this problem or its solution by Microsoft. However, it just about made me abandon Windows 7 and return to WinXP. I still have a few problems with Windows 7 (such as not getting bit-perfect output), but I am still working on these.

 

******************************************

 

David Hoatson, Chief software engineer at Lynx has verified this solution to the problem. As I mentioned above, I am still having a few issues with Windows 7, and if I can't figure them out, I'll post my problems here.

 

Although my system is a conventional Windows system, David Hoatson noted the problem existed on an Intel-based Mac running Windows 7 under boot camp. Since he doesn't have a BIOS, he fixed the problem by changing the power options from "Balanced" to "High Performance".

 

- John Atwood

 

Link to comment
Share on other sites

  • 8 months later...

Hi, John,

 

Where do I "disable OS control of power management. In my case, I disabled "SpeedStep" in the BIOS"?

 

Thanks, Jason

 

Third Floor: AE>Pioneer solid state integrated>Sony PS-x70 turntable>KEF 103.2 speakers

Second Floor: Intel NUC>LampizatOr GA TRP/LampizatOr Integrated Solid State amp>triode wire labs speaker cables & power cord and wywires power cords>vapor über auroras speakers

Old school: VPI Prime Signature turntable w/ Ortofon Bronze Cadenza cartridge and Technics SP-10 mk2

First Floor: AE>lifatec silflex glass toslink>schiit bifrost über>Kimber kable hero RCA>audioengine 5

Link to comment
Share on other sites

To shut down Speed Step, I went into the BIOS (pressed Del after booting) and went to the "Advanced", then "CPU Configuration" menu. At the bottom of the screen was a line where I could disable Speed Step. Different motherboards and BIOSes may have different ways of handling this. I hope this helps.

 

- John

 

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share



×
×
  • Create New...