Jump to content
IGNORED

Lumin App Won't Recognize Tidal Password


Recommended Posts

HI:  As the subject line says, the Lumin app has suddenly stopped recognizing my Tidal password.  It worked last night; won't work tonight.  I have made sure that I am entering my credentials correctly.  I can log in to Tidal on its website using those credentials.  I have tried restarting the app as well as restarting my iPad.  I am not having any problems with Qobuz.  Please help.

 

Thanks

Link to post
Share on other sites

Please power cycle the Lumin X1.

 

Launch Tidal app, and play something.  Tap the speaker icon.  Choose the Lumin as a Tidal Connect device.  See if this works.

 

Please confirm you're running Firmware 14.*

Peter Lie

LUMIN Firmware Lead

Link to post
Share on other sites

Hi Peter:  Thanks for for your quick reply.  Unfortunately, this did not work.  I launched the Tidal app and played something.  When I tapped on the icon, the Lumin did not appear in the list of available devices.  By the way, I am using the X1.  I should have mentioned that in my original post.  I am running Firmware 13.1   I do have "Check for Firmware Updates" enabled; I'm not sure why it hasn't been updated.

 

Thanks

Link to post
Share on other sites

After power cycling the X1, please turn the Firmware Update setting off, then turn it back on.

 

If that does not trigger a firmware update prompt, please set router DNS to 8.8.8.8 and retry.

Peter Lie

LUMIN Firmware Lead

Link to post
Share on other sites

Thanks again Peter.  I was able to update the firmware .  I was ultimately able to access Tidal although not without some difficulty which i will briefly summarize for whatever it may be worth. 

 

Once the firmware update was complete, I again tried to access Tidal.  Upon entering my name and password, Tidal flashed a screen saying that it had recognized me but then immediately crashed the Lumin app. Upon restart, Tidal again asked for my credentials and again the app promptly crashed.  I repeated this process perhaps 5 or 6 times before Tidal finally stabilized.  Everything seems to working OK at the moment.

 

Thanks to you and Lumin for setting the gold standard in customer support.

 

Link to post
Share on other sites

I am afraid we never saw this crash before, and I do not recall another problem report similar to what you described.  What device are you running Lumin app on?  What iOS version?  Please go to iOS Settings -> Privacy -> Analytics and find the crash log of Lumin app, then send it to [email protected] with subject "Tidal login crash"

 

Now that you've updated the firmware, you can now use Tidal app, then tap its speaker icon to play to X1.  You have to grant Local Network permission for the Tidal app when asked.  It can also be done in iOS System Settings for Tidal App.

Peter Lie

LUMIN Firmware Lead

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


×
×
  • Create New...