Jump to content
IGNORED

Problem with Roon and Node 2i


Recommended Posts

People,

 

I've a problem with playing Roon with two DAC's. 

The Bluesound Node 2i is my first DAC for reading MQA files. This Node is connected to a second (non MQA) DAC but with a nicer sound than as the Node 2i. 

Playing this way with Tidal (without Roon) is no problem. So the Node is only to unfold the MQA and send it to the second DAC. 

But, playing with Roon it won't work such way.

I'm getting errors as "slow connection, unable to play", and after a few seconds it stops. 

I don't know what goes wrong. It seems like a bug in Roon? 

 

With kind regards from the Netherlands, 

Ron

Link to post
Share on other sites

Is your Roon server wired or wireless?

 

Because when you play Tidal directly from Node 2i, essentially, Node 2i is downloading the file straight from Tidal through your router.

 

But when you play from Roon, the MQA file is first downloaded from Tidal to the Roon server and then the MQA file is sent from Roon server through your router and then to the Node 2i. So there is a lot more signal traffic through your network. So if your server is on Wi-Fi and your Wi-Fi has lots of interference from the neighbours Wi-Fi, the additional traffic between your router and the Roon server could be the cause of “slow connection” errors.

 

If your Roon server is wired to your router via Ethernet cables, is the Node 2i wired or wireless?

 

Because if the Node 2i is wireless, when you’re playing Tidal directly, I strongly suspect the Tidal on Node 2i just loads the entire music file all at once to Node 2i so even if your Wi-Fi is dropping in and out, you can get the file loaded to the Node 2i and play from Node 2i without dropping. But if you’re playing through Roon, I strongly suspect the file sits on your Roon server and the Node 2i is getting the music data a few seconds at a time so if your Wi-Fi is dropping in and out from your neighbor’s interference, that may be the reason why the Node 2i drops out. But I think this shouldn’t occur as commonly as if your Roon server is wireless.

 

Of course, if your Roon server & Node 2i are both wired, I have no idea what’s going on with the slow connections then.

Roon (convolution filter using Acourate) > ultraRendu > Peachtree X1 (Toslink) > Chord Hugo M-Scaler > Chord DAVE > Chord Etude > Dynaudio Confidence C1 Signature

Link to post
Share on other sites

Thanks for your reply, 

All my network is wired with cat 6 cables. But you could be right. Even with Lan there's al lot of traffic from Macmini to the DAC's, because everything is playing in the highest quality. 

The Node 2i is connected to the DAC with digital coax. 

 

Link to post
Share on other sites

Sounds like a Roon bug to me then. Because audio traffic is very low bandwidth. Unless you’re streaming lots of videos across your network while streaming audio at the same time, there shouldn’t be any drops. 
I presume your switches or routers are 1Gbps. Because obviously no point having CAT6 cables if your switches are running 100Mbps. 

Roon (convolution filter using Acourate) > ultraRendu > Peachtree X1 (Toslink) > Chord Hugo M-Scaler > Chord DAVE > Chord Etude > Dynaudio Confidence C1 Signature

Link to post
Share on other sites

Yes, the internet speed is enough and the router and switch is indeed 1gb.

I've posted the problem also on the Roon users forum. Perhaps they can help, but as you say it might be a Roon bug which I can not solve. 

Link to post
Share on other sites

In Roon did you check in the settings for the node 2i, if there a buffer settings? I have one for my transport, I can adjust it (only up to 500ms though). Same in the node settings, are there any buffer settings available?

Link to post
Share on other sites

There is no Buffer adjustment in the Bluesound settings.

 

Roon core is installed on a Mac mini with the newest software and connected with a Usb A - B cable to my non MQA DAC. (the blue node doesn't have a usb b connection). 

Perhaps that's the main problem:

The Roon core (on the Macmini) is connected to my non MQA DAC with usb cable. 

From the non MQA DAC is a coax cable to the Bluesound Node. 

Don't you think It's the wrong way? 

The Roon core on the Macmini should actually at first stream to the Bluesound (for unfolding MQA) and from there to the non MQA DAC. 

I think I've connected  it  the other way around, because the Bluesound doesn't have a usb connection for the Macmini. 

So perhaps I have made the bug because the Bluesound doesn't have the usb port the Macmini. 

 

Just a guess... 

Link to post
Share on other sites
49 minutes ago, Ron T said:

So perhaps I have made the bug because the Bluesound doesn't have the usb port the Macmini. 

Shouldn’t the node2i act as an endpoint, and hence you use the network interfaces?

Then digital out to second DAC I suppose. 
 

I think you more or less has described the solution your self.

What’s your second DAC ?
 

Remember  to update Roon forum 😀

Link to post
Share on other sites
1 hour ago, Ron T said:

There is no Buffer adjustment in the Bluesound settings.

 

Roon core is installed on a Mac mini with the newest software and connected with a Usb A - B cable to my non MQA DAC. (the blue node doesn't have a usb b connection). 

Perhaps that's the main problem:

The Roon core (on the Macmini) is connected to my non MQA DAC with usb cable. 

From the non MQA DAC is a coax cable to the Bluesound Node. 

Don't you think It's the wrong way? 

The Roon core on the Macmini should actually at first stream to the Bluesound (for unfolding MQA) and from there to the non MQA DAC. 

I think I've connected  it  the other way around, because the Bluesound doesn't have a usb connection for the Macmini. 

So perhaps I have made the bug because the Bluesound doesn't have the usb port the Macmini. 

 

Just a guess... 

ah. I have another hypothesis of what’s going on. 
 

your connections are fine. 
 

now try not using the USB DAC.  But leave your USB DAC On USB input (not coax). Just send music to Node 2i and play music using Roon to Node 2i via the stereo output and see if you get the connection error. If you don’t this is what the problem is…

 

when you have the USB DAC connected the Way you do, you have one Roon zone going with the USB DAC and another Roon zone with the Node 2i. And it’s possible that Roon is set to play both zones at the same time. So when you switch your DAC from USB to coax input, the USB gets disconnected from Roon and Roon stops playing because there is a connection error. But the connection error is between your MacMini and the USB DAC, not between Roon and the Node 2i. 

Roon (convolution filter using Acourate) > ultraRendu > Peachtree X1 (Toslink) > Chord Hugo M-Scaler > Chord DAVE > Chord Etude > Dynaudio Confidence C1 Signature

Link to post
Share on other sites

Actually an easier way to test my hypothesis is to just unplug the USB cable from the DAC. Then Roon would automatically disable the USB DAC zone. Now just set the DAC to coax input and play via Roon to Node 2i to DAC and see if you get any connection errors

Roon (convolution filter using Acourate) > ultraRendu > Peachtree X1 (Toslink) > Chord Hugo M-Scaler > Chord DAVE > Chord Etude > Dynaudio Confidence C1 Signature

Link to post
Share on other sites

I am not sure if I know what you mean. In my opinion there is a false connection. 

 

But.. The only way to stream Roon is through the usb cable. I can't disconnect the usb cable because the core is on the Macmini. 

 

When I play with the Macmini direct from Tidal (Roon off) than there is no problem and plays exactly what I want:

The Macmini is streams to the Node 2i, unfold the mqa and send it in through coax digital to the better non MQA dac. The non MQA DAC is connected with the amplifier. 

Link to post
Share on other sites
10 minutes ago, Ron T said:

I am not sure if I know what you mean.

 

When I play with the Macmini direct from Tidal (Roon off) than there is no problem and plays exactly what I want:

The Macmini is streams to the Node 2i, unfold the mqa and send it in through coax digital to the better non MQA dac. The non MQA DAC is connected with the amplifier. 

Right. What I’m saying is this. 
1. disconnect Mac Mini from non MQA DAC as in remove the USB cable

2. now relaunch Roon, just select Node 2i as the zone to play from. You should be  able to play music from Roon to Node 2i to the non MQA DAC (via coax) without the signal dropping. 

 

 

 

Roon (convolution filter using Acourate) > ultraRendu > Peachtree X1 (Toslink) > Chord Hugo M-Scaler > Chord DAVE > Chord Etude > Dynaudio Confidence C1 Signature

Link to post
Share on other sites
3 hours ago, Gregory said:

In Roon did you check in the settings for the node 2i, if there a buffer settings? I have one for my transport, I can adjust it (only up to 500ms though). Same in the node settings, are there any buffer settings available?

 

Link to post
Share on other sites

Another way to explain it is that you can have Roon play on two DACs. You can have Roon play USB into USB non MQA DAC while playing music to the Node 2i/DAC at the same time. 
 

what you cannot do in Roon is to have Roon play USB into the non MQA DAC at the same time as Roon playing into Node 2i playing into the non MQA DAC at the same time. 
 

you can’t have Roon play two streams of the same music into the same DAC at the same time if the DAC is connected via USB as one of the connection methods

Roon (convolution filter using Acourate) > ultraRendu > Peachtree X1 (Toslink) > Chord Hugo M-Scaler > Chord DAVE > Chord Etude > Dynaudio Confidence C1 Signature

Link to post
Share on other sites

Hi Gregory 

I checked the settings for buffering the Node 2i, but there is no option for that. The Manual explains that there is only one factor setting and that's maximum buffering. You can not change is. 

 

Well, 

I disconnected the usb from the non MQA DAC. Started the Macmini again so also Roon. I selected the Bluesound node for the player. The second DAC is no more connected.

You can see on the picture that there is something wrong. 

The same connection problem, but now without the second DAC. 

I am surprised by that but I can not explain it because it is a Lan connection. 

 

I really don't know. 

But what I also  don't understand is why can I play Roon from the computer without usb. Are all the bits going through the network cable? In that case what is the purpose of the usb cable... 

(the Macmini doesn't have rca, coax nor optic connection, only usb and hdmi)

Link to post
Share on other sites

Ah. A picture is worth a thousand words. Bluesound is a RoonReady device. So it shouldn’t say Airplay on the zone. 
 

you need to remove this bluesound zone. And then try to setup a new one where the bluesound is recognized as a room ready device. 

Roon (convolution filter using Acourate) > ultraRendu > Peachtree X1 (Toslink) > Chord Hugo M-Scaler > Chord DAVE > Chord Etude > Dynaudio Confidence C1 Signature

Link to post
Share on other sites

Wait a minute. The Tidal media is loading slowly is a different problem. It means your MacMini Roon is not connecting to Tidal. Maybe you need to log out of Tidal within Roon and try to re log in. 

Roon (convolution filter using Acourate) > ultraRendu > Peachtree X1 (Toslink) > Chord Hugo M-Scaler > Chord DAVE > Chord Etude > Dynaudio Confidence C1 Signature

Link to post
Share on other sites

Thanks for all the help so far. 

1. The picture shows bluesound airplay. That was just a trial of me. I use Bluesound with Lan. So forget the airplay. Problems are still the same. 

 

2. I logged Tidal off and logged in again. It makes no difference. 

 

3. Tidal through the Bluesound webbased player gives no problem at all. Streaming to Bluesound node and than to the non MQA is possible. But not in Roon. 

 

4. When I play my own ripped cd's (aiff files in Roon thus not with Tidal) en it gives the same problem. It plays allright with one DAC but not through bluesound and my second non MQA DAC. See the picture. 

So I am pretty sure the problem is within Roon, a connection bug or something in Roon. 

 

Again, playing without Roon is possible with two DAC's. 

 

Well, I'm going to bed right now. 

 

20210822_221003.jpg

Link to post
Share on other sites
2 hours ago, Ron T said:

The only way to stream Roon is through the usb cable. I can't disconnect the usb cable because the core is on the Macmini. 


As said, you can use ethernet. Remove usb. Use Ethernet or WiFi to bluenode. You may delete all the zones you have created as well. Agree ?

Link to post
Share on other sites

I think re-reading what @Ron T had posted, the USB connection to a DAC is a red herring.

 

Just to verify, the main problem is:

He cannot play anything using Roon to Bluesound Node 2i.

No local audio files playback from Roon to Bluesound Node 2i

No Tidal files playback from Roon to Bluesound Node 2i

 

And he is able to use Roon to play music (audio files/Tidal) into his USB DAC which is connected to his Mac mini which is the Roon core/server.

 

To me, it is always possible that there is a software issue between Roon and Node 2i although I believe RoonReady support for Node 2i has been around for a long time so that’s unlikely. Just make sure the latest firmware for Node 2i is installed and Roon is running the latest version and reconfigure Node 2i as a RoonReady device.

 

The other possibility is that even if the MacMini & Node 2i are on the same network, depending on how the network switches are arranged or how the router is programmed, sometimes the router/switches would block MacMini from sending audio files to Node 2i. Obviously, the MacMini can run a web browser to control the Node 2i to run its native Bluesound apps but that doesn’t involve an internal network streaming large files from one device (Mac mini) to another device (Node 2i). It usually helps if the MacMini and Node 2i are on the same network switch/router. One thing I did find odd is that the internal network IP for all the devices are 192.168.2.xx. That’s interesting as most network routers use 192.168.1.xx, even if you add another switch. Not sure how the home network is hooked up. Maybe it’s just normal for some routers to use 192.168.2.xx.

Roon (convolution filter using Acourate) > ultraRendu > Peachtree X1 (Toslink) > Chord Hugo M-Scaler > Chord DAVE > Chord Etude > Dynaudio Confidence C1 Signature

Link to post
Share on other sites

I think It's a network problem. 

I just switched the cat cables from the Macmini and the Bluesound in the switch. So just change the ports in the swich and the connection imoroved. Less hickups. Still hickups but less. 

I've the latest firmware in the Bluesound. 

 

Here some pictures of the internet connection in the Mac. 

20210823_084917.jpg

20210823_085034.jpg

20210823_085043.jpg

20210823_085059.jpg

20210823_084954.jpg

Link to post
Share on other sites

I figured out so far... 👍

I disconnected the lan cable from the Bluesound and did a hard reset. Then I removed it from Roon and started Roon again in the Mac computer.

I've made the Bluesound wireless and put it back again in Roon and it's playing for some time wireless with Roon. 

 

So, now Roon is playing from the Core on the Mac, which is connected with usb to my non MQA DAC. 

Roon is streaming to the Bluesound and unfolds the MQA tracks.

The Bluesound is coax digital connected to my second DAC and that DAC is with good Audioquest analogue connected to my pre-amplifier. 

I wonder if I should make the Bluesound Lan again. It plays stable wireless. 

20210823_165230.jpg

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


×
×
  • Create New...