Jump to content
IGNORED

Clicking noise on digital inputs Mytek Brooklyn DAC+


Recommended Posts

Greetings,

I wonder if anyone has any solution to this issue.  I have tried contacting Mytek direct but no answer so far and I remembered this forum last used so long ago that I had to re-register.

 

I have been trying out some raspberry pi streamers recently and noticed a clicking sound when I turned up the volume. I assumed this was down to the Pi but when I disconnected it altogether and tried my cd transport, and also USB feed from a SOtM, the clicking sound remained. Even when I disconnected cables from all inputs it was still there and scrolling through the inputs it only went when I switched to the analogue input. If you have any ideas or can suggest a way to track down the cause I'd be most grateful for the help.

 

I have since been going around the house turning off appliances but I haven't found any that make a difference. I've also tried another DAC in my system without having the same noise. I've also tried my Mytek DAC in another system and the noise remains which suggests there is a fault with the unit.  I would have upgraded to the latest Mytek firmware version but this appears to be impossible as to upgrade to FIRMWARE V1.28 it says I have to first upload "Mytek_BrooklynDAC+_firmware_v1.23_for1.11upgrade" and this doesn't appear on the website......

 

Maybe Mytek is not supporting anymore?

 

I've attached a recording of the clicking sound if that helps.

 

Cheers,

George

20210503_183101_Normal.m4a

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


×
×
  • Create New...