Jump to content
IGNORED

Old newb struggles with HQPlayer


Recommended Posts

My setup (which will change with New DAC and music server) is SGC (small green computer) feeding a uRendu feeding my DAC using Roon. No problem, almost always works.

 

Now I wish to get familiar with HQPlayer software for my next setup. There's an app inside the uRendu, the HQP app. I run it (I think). I mean, how the hell do I know it's running? Where's the interface? OK, so I go to my desktop computer and download the desktop interface and client. I load a library (with a terrible interface) but OK, I'll use Roon but I couldn't get Roon to play. I actually got music to play through to my stereo using HQPlayer interface, WooHoo! But for <30 minutes. I'm told there's a license key that is embedded in the Rendu HQPlayer app. Really, where? And how do I know if the Rendu is using/running HQplayer? Maybe music comes from my Windows desktop computer runing HQPlayer streamed through the Rendu to the DAC? At least I have an interface I can play with. But my IPAD located in stereo room doesn't see anything but my SMG computer. 

 

Why does this seem so complicated? What sucks even worse is 25 years ago, I managed IT dept. and solved problems on MAC, Windows, Linux and Unix. Now I can't figure out a simple interface :(

 

So I'm waiting for an epiphany. 🤔

Link to post
Share on other sites

So I managed to get music flowing well from my desktop computer and control from Roon on my tablet. Not I need to figure out how to get HQPlayer working for more than 30 minutes.

 

I'm pretty sure too that I don't want Roon in exclusive mode as it might ignore HQPlayer?

 

Thanks!

Link to post
Share on other sites

It sounds like you are using the evaluation version of HQP which will play for a short period of time before shutting down. It allows you to test drive HQP before buying.

 

If you want to purchase a license, that can be done from here. There is generally no charge for program updates unless there is a major upgrade (e.g. version 3 to 4).

 

In the end, you will need a HQP Desktop license and a Roon license.

 

The other option for HQP is to go with an Embedded license which is Linux only and tied to a specific computer. The Desktop version works on Windows, Mac & Linux and is not tied to a specific computer.

Eric


Ubuntu Studio Linux box (i7-9700, 8 cores, 16GB RAM, Intel X520-DA1 NIC, Roon, HQP) > fiber optic > MikroTik CRS305-1G-4S+ > fiber optic > opticalRendu (HQP NAA) > Holo Cyan (DSD version) > Nord One UP NC500MB mono blocks > Klipsch La Scala — digital volume control with HQP via Roon client, DSP with HQP convolution engine

Link to post
Share on other sites

Thanks ericuco,

 

It seems that my inquiry to Signalyst suggested I didn't need a license due to the fact that uRendu was already licensed. Now I'm understanding that in fact I need a license to control HQPlayer. 

 

For a minute there I thought I didn't need the $265 for software 😁

Link to post
Share on other sites

The uRendu piece is only the HQP NAA which is free. HQP Desktop is what does the heavy lifting and requires a decently configured computer. HQP Desktop sends output via Ethernet to the NAA on uRendu. The uRendu is a nice low noise, low powered device which keeps overall noise low heading into your DAC.

Eric


Ubuntu Studio Linux box (i7-9700, 8 cores, 16GB RAM, Intel X520-DA1 NIC, Roon, HQP) > fiber optic > MikroTik CRS305-1G-4S+ > fiber optic > opticalRendu (HQP NAA) > Holo Cyan (DSD version) > Nord One UP NC500MB mono blocks > Klipsch La Scala — digital volume control with HQP via Roon client, DSP with HQP convolution engine

Link to post
Share on other sites
2 minutes ago, ericuco said:

The uRendu piece is only the HQP NAA which is free. HQP Desktop is what does the heavy lifting and requires a decently configured computer. HQP Desktop sends output via Ethernet to the NAA on uRendu. The uRendu is a nice low noise, low powered device which keeps overall noise low heading into your DAC.

That's why I wanted to get familiar with HQPlayer. I've got the May DAC KTE on order and want to build the music server next. I've got a home with an audio room being built  so my upgrade paths are taking me many places.

 

Thanks again 👍

Link to post
Share on other sites

Well, I had it working, but trying to get Roon working with HQPlayer seems like I'm going backward. It seems I don't understand what device to enable in Roon to create my Zone. I thought I'm supposed to find the uRendu or even the Lindemann but NOT. Worse yet, HQPlayer desktop keeps closing while I'm trying to find the correct configuration and yes I bought and installed the key. 

Link to post
Share on other sites

To connect Roon and HQP, in Roon, go to Settings > Setup > HQPlayer > Add HQPlayer. If you have Roon and HQP on the same computer, then use localhost.  If not on same computer, I believe you can enter IP address of HQP computer.
 

To connect HQP to uRendu, open up File > Settings in HQP to see if HQP is finding uRendu. The Backend should say something like NetworkAudioAdapter and Device should show your DAC info.

 

Note that you need to go into uRendu setup first before doing the above steps.

 

Go to https://www.Sonore.us/

Go to Find My Unit (top right)

The resulting panel should list your uRendu, select Manage

At next panel, go to Apps > Audio App Switcher > HQPlayer NAA (should indicate active)

 

You can check to see if uRendu recognizes your DAC under Settings > System Settings > Custom DAC (Audio device list). If it is blank then you need to resolve that before anything will work.

 

Hope this helps.

 

 

Eric


Ubuntu Studio Linux box (i7-9700, 8 cores, 16GB RAM, Intel X520-DA1 NIC, Roon, HQP) > fiber optic > MikroTik CRS305-1G-4S+ > fiber optic > opticalRendu (HQP NAA) > Holo Cyan (DSD version) > Nord One UP NC500MB mono blocks > Klipsch La Scala — digital volume control with HQP via Roon client, DSP with HQP convolution engine

Link to post
Share on other sites

It helps in that it seems I'm there but not THERE. Meaning, The uRendu is active, the DAC is seen both in Rendu and in HQPlayer. 

 

What is not working is the fact that Roon and HQPlayer are not making a handshake. I use localhost because they both reside on my desktop computer. And in Roon I add the HQ player and it comes up in 21 instances as a zone. My Desktop and a name I used for the DAC. Neither works. 

With Roon 1.8, I noted that strangely (cause I'm just getting used to the interface) there's 2 players - seemingly. I'm posting a pic of some configuration settings. The one above the zone is playing to - nothing and the Lower player can't get started.

 

There's probably 1 setting that's wrong. But there's 2649 settings to look at!

 

I had this thing working from my desktop many hours ago. Now nuttin works.

 

HQp.jpg

HQp2.jpg

Roon.jpg

Link to post
Share on other sites

In HQP, File> Settings > Input Device Settings > Backend > None

 

What DAC are you using?

 

When you play a track in Roon, is anything happening in HQP? Generally, you will see Roon show up in the main HQP panel.

Eric


Ubuntu Studio Linux box (i7-9700, 8 cores, 16GB RAM, Intel X520-DA1 NIC, Roon, HQP) > fiber optic > MikroTik CRS305-1G-4S+ > fiber optic > opticalRendu (HQP NAA) > Holo Cyan (DSD version) > Nord One UP NC500MB mono blocks > Klipsch La Scala — digital volume control with HQP via Roon client, DSP with HQP convolution engine

Link to post
Share on other sites

Sounds like HQP and Roon are not setup correctly.

 

Take a look at this Roon article

Eric


Ubuntu Studio Linux box (i7-9700, 8 cores, 16GB RAM, Intel X520-DA1 NIC, Roon, HQP) > fiber optic > MikroTik CRS305-1G-4S+ > fiber optic > opticalRendu (HQP NAA) > Holo Cyan (DSD version) > Nord One UP NC500MB mono blocks > Klipsch La Scala — digital volume control with HQP via Roon client, DSP with HQP convolution engine

Link to post
Share on other sites

You have SDM slected.....does you DAC handle DSD formats?

 

When you log into www.sonicorbiter.com and click on App Switcher for the URendu, is HQplayer NAA selected instead of RoonReady? As mentioned, Backend should be set to none.

 

I am new to HQplayer as well and have the exact same setup as you. I had some struggles getting it up and running myself. Might want to post in the HQplayer thread to get it sorted out.

 

When I created the HQ Player zone in Roon, I used my Ipad to create it instead of the PC where HQplayer Desktop resides. I used the IP address of the PC, not "localhost" when creating the HQplayer zone in Roon. That got music streaming immediately. Do you know the IP address of the HQplayer Desktop PC?

 

Also, can you post the rest of your HQplayer settings? Need to see what you are trying to upsample to. If you have something crazy as an output and your PC isn't capable, you will run into a problem as well. Scroll down to see how my settings compare to yours

 

 

 

unnamed.jpg

Link to post
Share on other sites

Also, if you are trying to output to DSD256 or higher, I had to enable native DSD on the UltraRendu under Roon Settings in Sonicorbiter in order it to play. When "DoP" is selected on the Rendu, I think your limited to DSD128 as the max output if I recall. The settings above let me output to DSD512. What are the specs on your PC?

 

1869702480_unnamed(2).thumb.jpg.065e70bbaadc2d57aa29cc1b63623540.jpg

unnamed (1).jpg

Link to post
Share on other sites

Thanks folks. I checked and changed a few settings based upon your generous recommendations. Still no sound from stereo.

 

There's a smoking gun here. Roon should play at bottom of player but shows song and refuses to play. There's a handshake that's missing and I'm damned if I can see it.

 

Sucks too as I'm getting 2 new cables to evaluate tomorrow.

 

A few more screen shots although I see nothing there.

 

 

0223211447.jpg

0223212020 - Copy.jpg

0223212020a - Copy.jpg

0223212020b (2) - Copy.jpg

Link to post
Share on other sites

try something lower that DSD512. Your PC may not me up to the processing power needs. Try DSD128 first.

 

I ended up buying a new Mac Mini M1 to upsample to DSD512, my i5 couldn't do it. Also try a lesser filter above the one you are using.

 

Delete the two HQplayer zones and start over.... you should only have one

Link to post
Share on other sites

OK so I rebooted the computer (when all else fails). And what I got was the uRendu showing up in Roon. When I enable it it plays music.

 

Then I though but is it using HQP? No. When I load HQP and hit play it does not make the handshake with Roon. Both programs reside on my desktop which is configured localhost. 

 

What I still don't understand is when I'm inside Roon, I see the uRendu and My Desktop as separate zones. I'd like to perform a marriage if needed. I mean, which one should be ignored? Only the Rendu plays. The HQP isn't playing with Roon.

 

In HQP, my Lindemann no longer shows up. This is maddening.

Link to post
Share on other sites
1 minute ago, MichaelHiFi said:

OK so I rebooted the computer (when all else fails). And what I got was the uRendu showing up in Roon. When I enable it it plays music.

 

Then I though but is it using HQP? No. When I load HQP and hit play it does not make the handshake with Roon. Both programs reside on my desktop which is configured localhost. 

 

What I still don't understand is when I'm inside Roon, I see the uRendu and My Desktop as separate zones. I'd like to perform a marriage if needed. I mean, which one should be ignored? Only the Rendu plays. The HQP isn't playing with Roon.

Log into www.sonicorbiter.com and click on the app switcher app and change from Roon ready to HQPlayer NAA but first try to get Roon to upsample to dsd128 or 256 to your DAC first and see what happens

Link to post
Share on other sites

Looks like I'm going back to basics here. I had uRendu showing in Roon and now its gone. I have HQ player showing in devices. Is there supposed to be an 'enable' associated with it? It will play but to nowhere because I see it in the icon playing but not at the bottom of Roon. 

 

Settings too seem to change magically. When I went back to Rendu home, it changed back to Roon Ready. Why did it do that? I changed back to HQP which maybe why I lost Rendu in Roon. But it's HQP that I want to stream. So frustrating...

Link to post
Share on other sites

I would post your question in the Sonore forum and ask why they think your Rendu keeps switching on it's own back and forth to Roon Ready versus HQplayer NAA.

 

https://audiophilestyle.com/forums/forum/24-sonore-sponsored/

 

And yes, when you use the "App Switcher" and toggle it to HQPlayer NAA, the Rendu will no longer show up as an endpoint in Roon. That's exactly how it's supposed to work. Toggle it back to "Roon Ready", UltraRendu will show up as an endpoint in Roon

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


×
×
  • Create New...