Jump to content
IGNORED

JCAT USB XE and AudioLinux/Euphony


Recommended Posts

Has anyone else had an issue making the JCAT USB XE card work with either AudioLinux or Euphony?  
 

My JCAT Net Card XE works just fine, but I cannot get the USB XE card to work in any slot with my DAC or external USB drive.  If I plug in a mouse or keyboard to the card they work just fine.  Plugging the DAC into the motherboard USB slots also work.
 

The motherboard is an Asus Rog Strix Crosshair Hero VII with Ryzen 7 3900X.  I’ve also tried with an Asus Rog Strix Z270H.  
 

Thanks

Colin

Link to post
Share on other sites
14 minutes ago, frederick184 said:

Has anyone else had an issue making the JCAT USB XE card work with either AudioLinux or Euphony?  
 

My JCAT Net Card XE works just fine, but I cannot get the USB XE card to work in any slot with my DAC or external USB drive.  If I plug in a mouse or keyboard to the card they work just fine.  Plugging the DAC into the motherboard USB slots also work.
 

The motherboard is an Asus Rog Strix Crosshair Hero VII with Ryzen 7 3900X.  I’ve also tried with an Asus Rog Strix Z270H.  
 

Thanks

Colin

I would message @Marcin_gps 

Link to post
Share on other sites
1 minute ago, ASRMichael said:

I would message @Marcin_gps 

Thanks, yes I’ve already emailed with Marcin on this subject.  He thought maybe a driver was required, but it didn’t make any difference.  If you have Euphony you can’t load drivers, other than have Euphony do it for you.  I wanted to see if anyone else had this issue and how they solved it.

 

Colin

Link to post
Share on other sites

Here’s the response from Euphony -

 

Yes, it seems that ASMedia ASM3142 requires special treatment in the kernel because its xHCI controller doesn't actually support 64 bit addressing, although it has a corresponding bit set as if it should.
The patches for this are not present in our kernel version.
We have a policy not to change kernels often as this influences SQ in unpredictable ways so this is not an immediate option (we are preparing next major Euphony version with newest kernel but it is far from completed).

We may be able to incorporate ASM3142 (and ASM2142) patches related to this into our kernel and recompile it, but we have to determine if this is worth the effort regarding:
- how complicated these changes are (they certainly involve at least several files)
- how great is the possibility to introduce a bug with such a hand crafted patch 
- given the fact that it only occurs on this specific card
- all of the above given the fact that it will be automatically supported in Euphony next major version with newer kernel

Link to post
Share on other sites

Hi Guys, 

 

AudioLinux uses latest kernel and there are no issues there.

 

Euphony for now does not work - it will work with an update. Željko, Euphony developer, informed me the patch which will fix the issue won't be available for at least several months.

 

Best regards,
Marcin

JPLAY & JCAT Founder

Link to post
Share on other sites
1 hour ago, Marcin_gps said:

Hi Guys, 

 

AudioLinux uses latest kernel and there are no issues there.

 

Euphony for now does not work - it will work with an update. Željko, Euphony developer, informed me the patch which will fix the issue won't be available for at least several months.

 

Best regards,
Marcin

Hi Marcin,

 

I have the latest AudioLinux kernel and neither the USB XE nor the Netcard XE work.  I have emailed Piero at AudioLinux for his comments.

 

Thanks

Colin

Link to post
Share on other sites
58 minutes ago, frederick184 said:

Hi Marcin,

 

I have the latest AudioLinux kernel and neither the USB XE nor the Netcard XE work.  I have emailed Piero at AudioLinux for his comments.

 

Thanks

Colin

Colin, please verify if the cards are getting power. 

 

Regards, 

Marcin

JPLAY & JCAT Founder

Link to post
Share on other sites
31 minutes ago, Tokyokyoto said:

Hi Marcin, or anyone, can you confirm whether or not these same issues also apply to the standard (non xe) version USB/Ethernet?

There is no issue with Euphony and NET  or NET XE card.

 

The issue is only with Euphony & USB XE

JPLAY & JCAT Founder

Link to post
Share on other sites
12 minutes ago, Marcin_gps said:

Colin, please verify if the cards are getting power. 

 

Regards, 

Marcin

Marcin, yes, both cards are getting power.  If I use Euphony, the Netcard XE works but the USB XE doesn’t, as you mentioned.  If I switch to AudioLinux, neither card works.

 

Colin

Link to post
Share on other sites
23 minutes ago, frederick184 said:

Marcin, yes, both cards are getting power.  If I use Euphony, the Netcard XE works but the USB XE doesn’t, as you mentioned.  If I switch to AudioLinux, neither card works.

 

Colin

Hmm, then it seems sth specific to AudioLinux. Please let me know if you want me to contact Piero or would you perfer to do it directly? 

JPLAY & JCAT Founder

Link to post
Share on other sites
2 minutes ago, Marcin_gps said:

Hmm, then it seems sth specific to AudioLinux. Please let me know if you want me to contact Piero or would you perfer to do it directly? 

I contacted Piero and he made some suggestions.  This could help others, so I’ll post his response here -

 

Hello,
both chips are supported in mainline linux. 
The kernel 5.10.x is the last kernel with the realtime patch, equivalent to last mainline.
If it is not working in Audiolinux, it should not work on all distributions using the last kernel.
Another user of the card has verified that (booting with Auiolinux) it was working in one PC but not in another.

What can you do?

1) Try to poweroff completely the PC. Detach the power cord, re-attach it and boot. Some cards with ASMEDIA chip need a complete poweroff to work, a reboot is not enough.
2) Check that you have the last BIOS version
3) Check if you have special configuration options for the card in BIOS
4) Do you know if your motherboard is using one of these chips inside? There could be a conflict. You can type
lspci
or 
lspci -v
or
lspci -vv
5) Is the power supply giving enough power?

For further debug, look at the output of
sudo journalctl | grep ASM3142
or
sudo journalctl | grep ASM2142
or some other search 
sudo journalctl | grep ASMedia
etc.

and

dmesg | grep xhci
dmesg | grep ASM3142
dmesg | grep ASMedia
etc.

Best regards,
Piero

Link to post
Share on other sites
  • 3 weeks later...
19 minutes ago, Johnseye said:

Does the USB XE card work with Euphony now as well?

No, they said it would be the next release before it worked.  I got it to work with AudioLinux.  It worked for one day then stopped working, so I gave up on it and went to a different solution.  Others may have more success.  This is not a reflection on the product, as I know others have spoken highly of it.

 

Colin

Link to post
Share on other sites
  • 2 months later...


×
×
  • Create New...