Jump to content
IGNORED

HQPlayer NAA playback breaks - send(): Unknown error ?


Recommended Posts

I have been using Roon+HQPlayer combo with my audio setup on a Raspberry Pi 4b running NAA for a good several months until this issue came up recently...

It occurs randomly - sometimes after a 5 minutes normal playback, sometimes 20 minutes. Totally unpredictable.

Though it is not catastrophically fatal, any help or advice is appreciated.

 

What I know is that sound coming from my headphones stops all in a sudden, playback time indicator in Roon and HQPlayer stops as well. If I immediately open HQPlayer's settings panel at this moment, I can see that the RPi entry in output device settings section disappears. But after closed the panel and wait for a brief period, say, 20 seconds, then open the settings again, RPi shows up normally as if nothing happened. Modify the setting for dac output and hit play button in Roon, then everything will work fine - until the next time the whole process starts.

 

I looked into HQPlayer's log file and found that every time this issue occurs brings up an error:

! 2020/11/17 12:58:31 clNetMiniEngine::PushPCM(): clNetMiniEngine::SendStreamPCM(): clSocket::Send(): send(): Unknown error
! 2020/11/17 12:58:31 clHQPlayerEngine::Execute(): push to FIFO failed
  2020/11/17 12:58:31 Stop request (reset)
& 2020/11/17 12:58:31 Stop...
- 2020/11/17 12:58:31 Network engine stopping...
- 2020/11/17 12:58:31 Playback engine stopped
& 2020/11/17 12:58:31 ...stopped

...Followed by these lines indicating that HQPlayer has lost connection to the NAA and cannot dicover it on LAN again in a short period:

  2020/11/17 12:58:32 Network Audio IPv6 support enabled
  2020/11/17 12:58:32 Discovery from 0.0.0.0
  2020/11/17 12:58:33 Discovery from ::
  2020/11/17 12:58:34 Discovered 0 Network Audio Adapters
  2020/11/17 12:58:35 Network Audio IPv6 support enabled
  2020/11/17 12:58:35 Discovery from 0.0.0.0
  2020/11/17 12:58:36 Discovery from ::
  2020/11/17 12:58:37 Discovered 0 Network Audio Adapters

(more omitted)

 

Switching to ipv4 in HQPlayer during this phase won't help. The only way to get things working again is to wait until HQPlayer discovered the NAA again:

& 2020/11/17 12:59:33 Discovered network audio: name='raspberrypi' version='Signalyst Network Audio Daemon 4.1.1'  @[fe80::59da:25a4:4e9b:9876%13]:43210
& 2020/11/17 12:59:33 Discovered network audio: name='raspberrypi' version='Signalyst Network Audio Daemon 4.1.1'  @[fe80::59da:25a4:4e9b:9876%13]:43210
  2020/11/17 12:59:34  connect to [fe80::59da:25a4:4e9b:9876%13]:43210 [ipv6]
  2020/11/17 12:59:34  Network endpoint: bcm2835 Headphones: bcm2835 Headphones (hw:CARD=Headphones,DEV=0)
  2020/11/17 12:59:34  Network endpoint: PCM-DSD USB Audio Interface: USB Audio (hw:CARD=Interface,DEV=0)
  2020/11/17 12:59:34 Discovered 1 Network Audio Adapters
+ 2020/11/17 12:59:34 Connect to [fe80::59da:25a4:4e9b:9876%13]:43210 [ipv6]

Then everything works fine until the next identical problem appears...

 

My PC is connected to RPi through an robust Ethernet cable so I suppose there is little to do with network connection.

I have tried switching to another newly flashed MicroSD card as storage on RPi but unfortunately it didn't resolve the issue.

Also tried executing sudo systemctl status networkaudiod  on RPi and the output seems pretty fine with no problems..

 

Any thoughts? Thanks in advance..

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


×
×
  • Create New...