Jump to content

"read only file system" problem in Daphile

Recommended Posts

Dear Sirs: My name Is Juan Crespo and I'm writing to you from Costa Rica. I have an issue installing Daphile that I don't know how to solve. I have been reading very carefully all your  documentation and surfed the web in order to find similar cases, but so far I haven't seen anything similar.


I have a Mac Mini 2.1 with a 1TB HD installed. I want to dedicate this computer entirely to Daphile. I have downloaded the recommended 64 bits version (I have tested the other two versions but the problem is exactly the same so I am going to focus on the recommended 64 bit version).


The beginning appears to be normal, I start from the bootable USB, it asks me to click F11, I skip wifi option, I write as desired IP, I write as mask and as both router and DNS server (I have searched the info in other computer ) I skip search domains and I write "y". Then the options about drives appear and I select my HD and then the four digit key code appears and I write the four digit code and then "continue) Then it appears "remove media and press any key" and the system starts.


As I want to use the computer only for Daphile I go directly to Settings and system firmware, I select the 1tb drive and I select the options you recommend for mac: GUID and UEFI. I click install and a series of messages that partitions are being created and everything appears to be. The issue begins after that, A message still appears "running daphile from the read only file system. changes cannot be saved" as you can see in this image




If I go to storage options, all the units appear as disabled, I only can set sd3 for music as you can see in




if I go back to system firmware, I can see my HD and the install button but then the partition table and boot loader options disappear as you can see here




If I try to restart the system (because I was wandering if it could be necessary for the changes to be set) the computer remains "waiting for a network connection" and nothing happens


I am fairly confident that the situation has something to do with the read only file system, as mentioned, if I restart all info is lost and the computer can't access the network connection, the ip previously written is gone. So far I don't know what to do in order to achieve another state different from "read only file system".


Could you please give me some advice or guidance on how to solve this issue.


Thanks in advance and yours sincerely,


Juan Crespo

Link to comment
  • 2 years later...
19 minutes ago, markshaz said:

Hi could you tell me how you fixed this please as I have the same issue.



When you see this message

running daphile from the read only file system. changes cannot be saved”

in the top red banner it means that you need to finalize your Daphile installation on the same usb key or an internal hdd/ssd … be careful that if you choose internal drive it will be formatted and any content will be lost.

You can find in Settings System firmare section the option to proceed with the definitive installation.

Once done you need to reboot, if you installed on an internal drive you can remove the usb key



My audio system

Link to comment

Thanks Stefano,


I tried that, I boot off of usb and want to install it onto a nvme internal drive, I clear the drive by pressing F1 on boot and then continue then it says go to the web interface, so I do that and do the install under settings which it says its completed and then I reboot go to the web interface and it says the same thing. "Running Daphile from the read only file system. Settings cannot be saved.



Link to comment

I’ve never installed Daphile in that way.

  • I burn the usb key with the Daphile image,
  • then boot the pc from usb (no initial setting or whatsoever),
  • using the browser (on iPad or another pc) I go to the Daphile web page
  • then I go to Settings/System firmware and I choose to install on internal drive
  • once done I remove the usb key and reboot the pc

be careful that the internal drive must be empty and formatted in order to be able to make the final installation on it.

Try this procedure please, it has always worked for me



My audio system

Link to comment

I did it the way @markshazhas suggested. I update using the web browser.

Current:  Daphile on an AMD A10-9500 with 16 GB RAM


Pre-amp - Rotel RC-1590

Amplification - Benchmark AHB2 amplifier

Speakers - Revel M126Be with 2 REL 7/ti subwoofers

Cables - Tara Labs RSC Reference and Blue Jean Cable Balanced Interconnects

Link to comment

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Create New...