Jump to content
torrid

digione spdif output with flac

Recommended Posts

Im using rpi 3 with volumio 2.779 (latest) and a digione.

 

I can play mp3 and wav files ok.

 

However, when I try and play a flac, there is no sound.

 

volumio seems to play the file ok, but the digione never "locks" onto the DAC. The connection is via Coax (spdif)

 

My DAC is very old (meridian 518 -> meridian 566) are 1990's technology. I don't think 96k, 24 bit technology was invented then.

 

Could this cause a problem? 

If so, can it be fixed by configuration?

Can I set digione to a lower bitrate?

 

fwiw, on a different PI, if I just say use "ouput PI:hdmi" and then split off the sp/dif in a little box, the same flac file (its stored on a NAS) plays perfectly.

 

Also if I switch between the two PI on the dac, the allo  is much much louder at the same amp volume levels (heart attack shock levels).

Is there anyway to set the volume level in volumio/digione to be less loud?

 

Thanks in advance

 

 

Share this post


Link to post
Share on other sites
7 hours ago, torrid said:

Im using rpi 3 with volumio 2.779 (latest) and a digione.

 

I can play mp3 and wav files ok.

 

However, when I try and play a flac, there is no sound.

 

volumio seems to play the file ok, but the digione never "locks" onto the DAC. The connection is via Coax (spdif)

 

My DAC is very old (meridian 518 -> meridian 566) are 1990's technology. I don't think 96k, 24 bit technology was invented then.

 

Could this cause a problem? 

If so, can it be fixed by configuration?

Can I set digione to a lower bitrate?

 

fwiw, on a different PI, if I just say use "ouput PI:hdmi" and then split off the sp/dif in a little box, the same flac file (its stored on a NAS) plays perfectly.

 

Also if I switch between the two PI on the dac, the allo  is much much louder at the same amp volume levels (heart attack shock levels).

Is there anyway to set the volume level in volumio/digione to be less loud?

 

Thanks in advance

 

 

 

the manual for the 566 is very obtuse with regard to specifications.  it looks like it is limited to 44k sample rates.  it claims it is a 24 d/a converter, but it's not specific on whether it can do better than 16 bit inputs.

 

since the dac is from the early/mid 90s -- cd-quality was 'the best' then -- i would bet it will only accept a 16/44k wav file.


source:  intel nuc8i5 (roon rock) > intel nuc6i5 (win 10, ao, roon bridge, dirac v1) > schiit yggdrasil (unison, analog 2)
headphone rig:  bryston bha-1 > senn hd600
two-channel rig:  bryston bha-1 > parasound a21 > kef reference 1

Share this post


Link to post
Share on other sites
8 hours ago, torrid said:

My DAC is very old (meridian 518 -> meridian 566) are 1990's technology. I don't think 96k, 24 bit technology was invented then.

 

Could this cause a problem? 

If so, can it be fixed by configuration?

Can I set digione to a lower bitrate?

 

fwiw, on a different PI, if I just say use "ouput PI:hdmi" and then split off the sp/dif in a little box, the same flac file (its stored on a NAS) plays perfectly.

 

What is your NAS's make & model?

 

If you are using a (UPnP/DLNA) media server on the NAS to supply Volumio with the FLAC files over the network, it might have a setting to transcode the hi-res files to 16-bit/44.1kHz (CD-res). Alternatively, you may be able to install the BubbleUPnP Server helper application on the NAS to do similar.


We will win because our NHS is the beating heart of this country. It is the best of this country. It is unconquerable. It is powered by love.

-- Boris Johnson

 

We are far more united and have far more in common with each other than things that divide us.

-- Jo Cox

Share this post


Link to post
Share on other sites

Thank you for the input.

 

I think I have found the problem and solved it.

 

I use OMV on an RPi as the NAS.  OMV is a real jewel, a wonderful piece of software.

 

On a recommendation from another forum, I changed the sample rate of the Flac.  I used VLC to do this.  File conversion is apparently a standard function of VLC, which I didn't know before.

 

The 48k flac worked perfectly.  So once I was on the right track, I tried setting the resample parameters to 48kin volumio and it worked fine.

 

Thanks again for the help

Share this post


Link to post
Share on other sites

Wow, that was a bit drastic! Presumably you didn't have that many hi-res files to convert.

 

A UPnP/DLNA media server's transcoder would not touch the original stored hi-res file tracks in any way, BTW, as the resampling is done one the fly on the network audio stream.


We will win because our NHS is the beating heart of this country. It is the best of this country. It is unconquerable. It is powered by love.

-- Boris Johnson

 

We are far more united and have far more in common with each other than things that divide us.

-- Jo Cox

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now



×
×
  • Create New...