Jump to content
IGNORED

JPLAY problems


Recommended Posts

I recently bought a NUC8i5BEH, with 16gb Optane and 1x16gb 2400mhz in order to test various Linux audio distributions and stick with one. In the process I read some posts/reviews saying JPLAY is superior, so I give it a try. I have to agree with them, to me JPLAY is another league, much more musical, less harsh, music has flow, it's fantastic.

I'm planning to buy an JPLAY license but first I have to figure out two problems that I have.

 

What I've test:

I have installed it in several windows versions(10, 2019 server and 10 enterprise LTSC).

I have installed Roksan drivers in order to be able to use Kernel Streaming. 

I have used Audirvana and Mconnect(iOS) to stream Tidal.

I have tested with/without MinorityClean and Fidelizer free.

 

Problems:

After I hear 4/5 musics it crashs(I'm testing, so usually I hear 30 seconds of one them switch to another) (see attached image).

Sometimes MQA files doesn't play.

 

Using Roksan K3 Dac directly works perfectly but JPLAY sounds much better.

Note that I'm using and 16gb Optane as disk so I have only 1gb(2gb in 2019 server) of free space in disk, but that doesn't seems to be the problem.

 

Can someone help me?

IMG_1500.JPG

Link to post
Share on other sites

You can see my configuration in the attached file. I also have tested with other "DAC Link" values with same results.

 

I already tried with Bubble UPnP app, but for me Audirvana sounds better.

 

I also have an Beresford Caiman Seg Dac that I've tried but it crashes always, I can't even make it work. 

 

IMG_1529.JPG

Link to post
Share on other sites

Thanks for the screenshot. 

 

You are using the largest buffer size which can be an issue. I'd recommend increasing DAC Link to 10Hz which is  the default value and start from there. 

 

Also, make sure that you have a driver installed from your USB DAC manufacturer. Built in Microsoft USB Audio Class 2 driver is not supported. 

 

if your USB DAC driver has a control panel where you  can adjust buffer size, you may play with this too. 

 

BTW - did you enable 'optimize for single PC option' in JPLAY installation setup? It is recommended. 

 

Regards, 
Marcin

 

 

JPLAY & JCAT Founder

Link to post
Share on other sites

Related to crashes in JPLAY, I think I found the problem.

I was using the wrong DAC drivers, I downloaded them from Roksan Black Integrated Amplifier page because there is no Roksan K3 DAC page(old model). Although they work, apparently they don't work properly.

I contact Roksan to find out if these are the proper drivers and they send me the link to the K3 ones. 

I installed them and until now no crashes from JPLAY.

 

But Audirvana/BubbleUpnp MQA files still don't play and I'm pretty sure that in one of my previous installations I was able to stream MQA files throw Audirvana using JPLAY KS.

Link to post
Share on other sites
9 minutes ago, Marcin_gps said:

Thanks for the screenshot. 

 

You are using the largest buffer size which can be an issue. I'd recommend increasing DAC Link to 10Hz which is  the default value and start from there. 

 

Also, make sure that you have a driver installed from your USB DAC manufacturer. Built in Microsoft USB Audio Class 2 driver is not supported. 

 

if your USB DAC driver has a control panel where you  can adjust buffer size, you may play with this too. 

 

BTW - did you enable 'optimize for single PC option' in JPLAY installation setup? It is recommended. 

 

Regards, 
Marcin

 

 

Yes, I found out that the drivers that I was using are not the correct ones.

MQA problem seems also to be resolved, in the Roksan Dac settings I changed Output format from 2channels 16bits to 2channels 24bits and that did the trick. 

 

Thank you Marcin for the fast support.

I will do more tests, and see if everything is working properly if so I will purchase an JPLAY license.

 

Best Regards, 

 

Mário São João

Link to post
Share on other sites
17 hours ago, mnuno10 said:

Yes, I found out that the drivers that I was using are not the correct ones.

MQA problem seems also to be resolved, in the Roksan Dac settings I changed Output format from 2channels 16bits to 2channels 24bits and that did the trick. 

 

Thank you Marcin for the fast support.

I will do more tests, and see if everything is working properly if so I will purchase an JPLAY license.

 

Best Regards, 

 

Mário São João

Good to hear! Enjoy :) 

 

Regards, 

Marcin

JPLAY & JCAT Founder

Link to post
Share on other sites


×
×
  • Create New...