Jump to content
jrobbins50

FooBar2000 foo_record error on Windows Server 2019

Rate this topic

Recommended Posts

Hi all, including @AudioPhil.  Homeaudiofidelity (https://www.homeaudiofidelity.com/english/plugin/) has developed a plug-in to reduce room resonances.  Because it is not a convolution filter (it operates in the time domain), it can't be loaded into Roon directly.  HAF has a freestanding version of the VST plugin for use with VB-Audio's HIFI virtual cable.

My desire therefore is to use the virtual audio cable to link Roon to FooBar2000 and the HAF time domain filter and then to stream from FooBar2000 over DLNA, as my DAC, a Bel Canto Streamer, only has ethernet for an input and not USB (and anyway, I have found that ethernet sounds better than a USB connection).

My setup:

Roon and FooBar2000 are running on a Windows Server 2019 core PC (i7 processor CAPSZuma design) with Audiophile Optimizer 3.0.  As noted above, I have a Bel Canto Streamer which is ethernet connected to Roon and FooBar2000. I can play tracks successfully in FooBar2000 and they come out through the Bel Canto Streamer.  I have the VB-Audio cable set as both the playback and recording default device in Windows Sound Properties.

 

Where I am stuck is that, as the HAF VST plugin is in the time domain, the way to make it all work through FooBar2000 is to start a blank recording track in FooBar2000 (under Add Location, with the phrase record://) and then go over to Roon to play the tracks.  However, I get the error message seen in the attached photo every time I attempt to play the black recording track in FooBar2000, so of course, I can't get Roon to work through it.  Sometimes the error message references Error Code 1.  In Roon, the audio path correctly shows the VB-Audio cable as the endpoint, so I don't think it is a Roon issue.

 

Thierry from HAF says that the foo_record component add-on for FooBar2000 works on Windows 10.  I run my server normally with the GUI, but Roonserver set as shell.  I get the same error message when returning the server via ST to regular desktop environment, so I don't think it's a AO issue.  I'm merely hoping that someone on this forum who uses Windows Server 2019 may have found a workaround, or has otherwise made it work.  Thanks.  JCR

FooBar Issues.jpg

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...