Jump to content
Alex Kwok

Amanero Combo384 with Windows Server 2019 core

Rate this topic

Recommended Posts

My DAC is using Amanero Combo384 and I'm trying to install Windows server 2019 core with AUDIOPHILE OPTIMIZER 3.0 and JPlay. 

 

After installing the windows 2019 core, I followed the following steps to install the Amanero driver from Amanero web site:

 

https://amanero.com/drivers/combo384_drivers_w10_1062.zip

 

http://jplay.eu/forum/index.php?/topic/2780-amanero-under-all-modes-wasapi-asio-ks-in-ws2016-core/

1. Install AudioPhile Optimizer but do not run it!

2. Run Audiophile Optimizer with the -Wasapi parameter, so as to inject Wasapi in your core Windows system

     > ao -wasapi

3. Copy mmci.dll file in Windows\System32 directory and reboot

4. You need to deactivate the driver signature enforcement, so at the time of boot you need to press F8 and select accordingly
or PRESS "SHIFT" at BIOS logo, then press F8 in the windows menu, then choose disable "driver signature enforement"


5. Then comes manual installation of the HDaudio and HDAudioBus drivers

     > pnputil /add-driver hdaudio.inf /install
     > pnputil /add-driver hdaudbus.inf /install
6. After rebooting, by typing 'devmgmt.msc' you will see 'HD Audio' under a small loudspeaker icon. Do not worry if it is not accordingly written in the device manager. eg under 'Unknown', Everything is installed correctly.
7. Now you are ready to install your Amanero Kernel streaming drivers
8. Only after verifying that everything is working, then you can go to run Audiophile Optimizer.

 

I've completed Step 5 but didn't see "HD Audio" in step 6. Then I tried to install the Amanero Kernel streaming drivers but it showed "!" in device manager. 

 

Please share your experience with me of how to move forward. Many thanks in advance. 

Share this post


Link to post
Share on other sites

Hello Alex

 

May I ask, did you study our PDF manual before you tried all this? Especially the ServiceTool, the DriverHelper and the HD Audio Feature it comes with?

 

There are several errors and also unnecessary steps in your write-up, which rather generate problems than they solve them. That is why I am asking.

 

Best,

AudioPhil

 


ıllıllı [  ...AO 3.00 IS HERE... ] ıllıllı
____________________________________________________________________________________

 

Shop | Core Audio Music Server | Reviews | Reference System | AudiophileOptimizer 3.00 | PDF Guide

 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...