Jump to content
bobfa

Euphony OS w/Stylus player setup and issues thread

Recommended Posts

Hi,

I've been trying Euphony OS + stylus for few days and extremely impressed with the SQ.

I use a single box (a mac mini) to play stylus and send music to my USB DAC which can decodes MQA.

My questions are:

- My music is stored in a NAS, but in Stylus I found no way to import music from NAS. When clicking "Network Drives" I could not find any shared folder from NAS.

- For MQA: Stylus do not support to unfold MQA but passthough it instead. However, when I played 24/96 MQA files from Tidal, my dac showned input signal as 24/48, why not 24/96? The dac also did not show "MQA" signal, which I believed the input signal was PCM, instead of MQA passthough. So did I miss anything in Setting?

 

any advice is highly appreciated

Jacky

 

Share this post


Link to post
Share on other sites
13 hours ago, Cazzesman said:

 

Those lovely Kii 3's are pushed wwwaaaaayyyyy back in the corner bobfa.  Taking full advantage of the tech on offer. 🙂

 

I'm only a tad jealous about the BXT's 😜

 

Regards Cazzesman

This is #FutureFi. I would never go back to a system that requires speakers to be hung out in the middle of the room!

 

image.png.c6c302457a30c5c0f3742ab1e7fd7cf0.png

Share this post


Link to post
Share on other sites
7 hours ago, Brianfromspace said:


ok, thx @bobfa for sharing. Just to be sure, that testing was on the server side right? Cause i have no player NUC but a cambrdige audio network streamer. So if i use Stylus, it’s only for Roon core purposes. I’m a sucker for movie sound over my stereo set, that’s why no second NUC for me.

I am currently using a single computer system. I use USB out to my speakers . 

Share this post


Link to post
Share on other sites

newbie to euphony.

 

i've burned the trial to usb and loaded the system, next step is to register the trial.

 

my baseline is audio-linux in ramroot, hqplayer embedded (no upsampling/filter/dither, pcm only) streaming to an opticalRendu/NAA.

(i have less than zero interest in roon)

 

now i don't know how to set this puppy up.

how do i configure euphony so that

1.  runs hqplayer embedded

2.  streams to opticalRendu/NAA

3.  has no roon

 

thanks

 

Share this post


Link to post
Share on other sites
3 hours ago, cat6man said:

newbie to euphony.

 

i've burned the trial to usb and loaded the system, next step is to register the trial.

 

my baseline is audio-linux in ramroot, hqplayer embedded (no upsampling/filter/dither, pcm only) streaming to an opticalRendu/NAA.

(i have less than zero interest in roon)

 

now i don't know how to set this puppy up.

how do i configure euphony so that

1.  runs hqplayer embedded

2.  streams to opticalRendu/NAA

3.  has no roon

 

thanks

 

 

futzed around with trial and error and eventually got it to play in trial registration mode.

however, when i put it into ramroot, i lose the ability to play music on my attached usb drive (sda1).

sda1 shows up as a 7TB drive but apparently is not loaded for music purposes.

 

what am i missing?

 

next step is to compare with audiolinux

Share this post


Link to post
Share on other sites
3 hours ago, cat6man said:

 

futzed around with trial and error and eventually got it to play in trial registration mode.

however, when i put it into ramroot, i lose the ability to play music on my attached usb drive (sda1).

sda1 shows up as a 7TB drive but apparently is not loaded for music purposes.

 

what am i missing?

 

next step is to compare with audiolinux

Did you choose the option to copy entire app to RAM? That would disallow playing music from your own drive I believe. Also I am not sure if the RAMroot can be done properly with the trial version. Perhaps others know better? 

Share this post


Link to post
Share on other sites

Does anyone still have stability issue running Stylus on euphony?  Now and then a Get a warning about "application cannot find path...or something like that, recommend to reboot.." but even if I reboot, the same message will appear again soon. Also if I quickly click on a track and switch to another track while the track is playing, or even click to replay the track  it kind of freezes. It will play but no sound will come out. Then. need to restart the app and then it will play fine. I have loaded Euphony on Optane M2 drive thinking the shorter latency will give more stability but not really. I am running RAMroot, with the music in the Optane drive itself. 

Share this post


Link to post
Share on other sites

@Chopin75 I had similar issues. I was using the  Copy APP Config to RAM option alongside Stylus and/or Ramroot. Disable the Copy App Config option (it may require going out of Ramroot and a reboot then turn it off before enabling Ramroot then another reboot) and try again.

Share this post


Link to post
Share on other sites
14 hours ago, adamaley said:

@Chopin75 I had similar issues. I was using the  Copy APP Config to RAM option alongside Stylus and/or Ramroot. Disable the Copy App Config option (it may require going out of Ramroot and a reboot then turn it off before enabling Ramroot then another reboot) and try again.

Actually I have not been using Copy App Config, but still has this issue. More so with larger files. Despite me having 32 G RAM!! So not a RAM issue. 

Share this post


Link to post
Share on other sites

Is your server accessible to the web. Euphony likes to call home and becomes unstable if it can't.

Share this post


Link to post
Share on other sites

1.  is the consensus that the connected usb drive will not be visible in ramroot mode?

2.  if so, it seems ramroot is not very useful except for streaming services?

3.  does ramroot sound better than running off the usb stick?  for streaming?  for stored music?

Share this post


Link to post
Share on other sites

On a side note, I have found Euphony's tech support to be excellent and very responsive.  I have been going back and forth with Željko Vranić on my cover art issue.  He has been working OT to try to figure it out.

 


Speakers: Vandersteen Model 7s, 4 M&K ST-150Ts, 1 VCC-5; Amplification: 2 Vandersteen M7-HPAs, CI Audio D200 MKII, Ayre V-6xe; Preamp: Doshi Audio Line Stage v3.0; Phono Pre: Doshi Audio Phono Pre; Analog: Wave Kinetics NVS with Durand Telos composite arm; SME 3012R arm, Clearaudio Goldfinger Statement v2; Reel to Reel:  Technics RS-1500; Doshi Tape Pre-Amp; Studer A810, Studer A812, Tascam BR-20; Multi-channel: Bryston SP-3; Digital: Custom PC (WS 2016/AO/HQPlayer/Roon)> Lampizator Big 7 DAC

Share this post


Link to post
Share on other sites
On 6/26/2020 at 3:54 AM, jacky5555 said:

Hi,

I've been trying Euphony OS + stylus for few days and extremely impressed with the SQ.

I use a single box (a mac mini) to play stylus and send music to my USB DAC which can decodes MQA.

My questions are:

- My music is stored in a NAS, but in Stylus I found no way to import music from NAS. When clicking "Network Drives" I could not find any shared folder from NAS.

- For MQA: Stylus do not support to unfold MQA but passthough it instead. However, when I played 24/96 MQA files from Tidal, my dac showned input signal as 24/48, why not 24/96? The dac also did not show "MQA" signal, which I believed the input signal was PCM, instead of MQA passthough. So did I miss anything in Setting?

 

any advice is highly appreciated

Jacky

 

Assuming you have media server enabled at the NAS, you should be able to enter the nas IP address\”music share name” to attach with “guest” as login ID, no password needed. There’s a media server protocol that defaults to 2.0 with Synology, I had to change it to also support 1.0 to successfully attach my NAS music directory. Will look up the name when I get home.


Regards,

Dave

 

Audio system

Share this post


Link to post
Share on other sites
On 7/1/2020 at 7:12 AM, davide256 said:

Assuming you have media server enabled at the NAS, you should be able to enter the nas IP address\”music share name” to attach with “guest” as login ID, no password needed. There’s a media server protocol that defaults to 2.0 with Synology, I had to change it to also support 1.0 to successfully attach my NAS music directory. Will look up the name when I get home.

Hi Dave,

Thanks for your advice. I followed your guide but could not success.

Stylus shown “mount errror” as attached screenshot.

 

 

BC308D4B-A92C-414C-80F2-3D36808421C5.png

D65CAF22-56FC-4174-84BD-F79BED7D299B.png

Share this post


Link to post
Share on other sites
32 minutes ago, jacky5555 said:

Hi Dave,

Thanks for your advice. I followed your guide but could not success.

Stylus shown “mount errror” as attached screenshot.

 

 

 

 

Euphony apparently defaults to SMB1, I had to enable that for it to find my Synology NAS shared music files.

If you navigate in Diskstation to File Services/   SMB/AFP/NFS   /Advanced Settings, you should see a Min and Max SMB option,

the Min should be changed to SMB1.

Also "Music" is normally the complete logical share name, try using that for path instead of "volume1/music"

 

I note that in Euphony you can also change the Samba Option from 1.0 to 2.1 and 3.0 when adding a network drive, don't know if that

corresponds to SMB version, hadn't noticed it until now. Maybe someone who understands Samba can chime in?


Regards,

Dave

 

Audio system

Share this post


Link to post
Share on other sites
3 hours ago, jacky5555 said:

Hi Dave,

Thanks for your advice. I followed your guide but could not success.

Stylus shown “mount errror” as attached screenshot.

 

 

BC308D4B-A92C-414C-80F2-3D36808421C5.png

D65CAF22-56FC-4174-84BD-F79BED7D299B.png

In Domain box write the word “Workgroup” & username & password

Share this post


Link to post
Share on other sites
On 7/1/2020 at 7:12 AM, davide256 said:

Assuming you have media server enabled at the NAS, you should be able to enter the nas IP address\”music share name” to attach with “guest” as login ID, no password needed. There’s a media server protocol that defaults to 2.0 with Synology, I had to change it to also support 1.0 to successfully attach my NAS music directory. Will look up the name when I get home.

Hi Dave & ASRmichael,

It works now.

i ended up with only address path as “music”, user PW to my synology Nas, and domain as “workgroup”

Thank you!

7A82C282-203B-4308-A355-03533EDAB9F1.thumb.png.511a025273447448d15d48a24b0e6f7d.png

Share this post


Link to post
Share on other sites

Can Euphony run on a server, using internal SSDs for the music storage, and play using Roon and HQPlayer to a Sonore Optical Rendu SE? And, would I control playback as I do now, with either my MacBook Pro or an iPad and the Roon control app?


No electron left behind...

Share this post


Link to post
Share on other sites

While I've been using Audiolinux for years I'm fairly new to Euphony and Stylus.  I typically run Roon to HQPlayer to an NAA.  I had been experimenting with HQPlayer direct and liked what I heard so I thought I'd give Euphony a try.  While I do like what I hear, I have some concerns of which hopefully there are simple answers.

 

  • How good is Euphony support?  I messaged them days ago and have heard nothing.  In contrast if I have a question for Piero at Audiolinux he responds within hours.
  • How often is Euphony updated?  HQPlayer on Euphony isn't running at the latest version with the latest filters and dither options.
  • Can HQPlayer be run as a stand alone player within Euphony or does it require another player in front and an NAA after?
  • Does HQPlayer in Euphony require a license?  I have both Embedded and Desktop 4 but not sure where to apply the license, unless it's included with Euphony.
  • Is it possible to access HQPlayer's config page from ipaddress:8088 or is that locked down and only available through Euphony?

 

 


Digital chain: Synology DS1815+ -> Modified Buffalo switch-> SOtM sNH-10G-> Custom Audiolinux server (sCLK-EX modified motherboard, Mutec REF 10)-> EtherRegen-> AL NUC NA (sCLK-EX modified)->  Holo Spring L3 -> Audio Research LS28-> Benchmark AHB2 -> Paradigm Persona 9H, JL Fathom sub

Power: Paul Hynes SR7, Uptone LPS-1.2, sPS-500, Topaz 91001-31 Isolation Transformer

Analog chain: VPI Prime with Ortofon Quintet Black cart -> Simaudio Neo 310LP-> Audio Research LS28-> Benchmark AHB2 -> Paradigm Persona 9H

Share this post


Link to post
Share on other sites
On 6/30/2020 at 8:29 PM, cat6man said:

1.  is the consensus that the connected usb drive will not be visible in ramroot mode?

2.  if so, it seems ramroot is not very useful except for streaming services?

3.  does ramroot sound better than running off the usb stick?  for streaming?  for stored music?

 

As I haven't spotted any other answers to this, I can provide a partial answer based on my particular setup, which is internal Optane boot drive, USB thumb drive for local music files, and no streaming services:

 

Ramroot, in its default mode (library stays on the boot drive), plays local music files with no loss of functionality compared to non-Ramroot. It plays music in exactly the same way. The only consideration is that you need to hit the "save fs to disc" button if you want to make permanent system changes, such as core isolation settings - otherwise those system changes will be reverted on next boot.

 

I think Ramroot gave a very worthwhile SQ boost compared to Optane drive, so the improvement over USB drive should be even greater.

Share this post


Link to post
Share on other sites
On 6/30/2020 at 5:02 PM, dminches said:

On a side note, I have found Euphony's tech support to be excellent and very responsive.  I have been going back and forth with Željko Vranić on my cover art issue.  He has been working OT to try to figure it out.

 

 

How do you contact Zelijko?  I sent a contact message through their contact webpage and have heard nothing back from them.

 


Digital chain: Synology DS1815+ -> Modified Buffalo switch-> SOtM sNH-10G-> Custom Audiolinux server (sCLK-EX modified motherboard, Mutec REF 10)-> EtherRegen-> AL NUC NA (sCLK-EX modified)->  Holo Spring L3 -> Audio Research LS28-> Benchmark AHB2 -> Paradigm Persona 9H, JL Fathom sub

Power: Paul Hynes SR7, Uptone LPS-1.2, sPS-500, Topaz 91001-31 Isolation Transformer

Analog chain: VPI Prime with Ortofon Quintet Black cart -> Simaudio Neo 310LP-> Audio Research LS28-> Benchmark AHB2 -> Paradigm Persona 9H

Share this post


Link to post
Share on other sites
1 minute ago, Johnseye said:

 

How do you contact Zelijko?  I sent a contact message through their contact webpage and have heard nothing back from them.

 

 

I have been corresponding through a Euphony support ticket.

 


Speakers: Vandersteen Model 7s, 4 M&K ST-150Ts, 1 VCC-5; Amplification: 2 Vandersteen M7-HPAs, CI Audio D200 MKII, Ayre V-6xe; Preamp: Doshi Audio Line Stage v3.0; Phono Pre: Doshi Audio Phono Pre; Analog: Wave Kinetics NVS with Durand Telos composite arm; SME 3012R arm, Clearaudio Goldfinger Statement v2; Reel to Reel:  Technics RS-1500; Doshi Tape Pre-Amp; Studer A810, Studer A812, Tascam BR-20; Multi-channel: Bryston SP-3; Digital: Custom PC (WS 2016/AO/HQPlayer/Roon)> Lampizator Big 7 DAC

Share this post


Link to post
Share on other sites
1 minute ago, Johnseye said:

 

How do you contact Zelijko?  I sent a contact message through their contact webpage and have heard nothing back from them.

 

 

I raise a support ticket directly from the Stylus app  (under Settings).

And usually get a response within hours. Overall, I rate support very highly on the few times I've used it. Zelijko is quite amenable to ad hoc enhancement requests, as long as they are sensible and practical.

Share this post


Link to post
Share on other sites
1 hour ago, TheAttorney said:

 

As I haven't spotted any other answers to this, I can provide a partial answer based on my particular setup, which is internal Optane boot drive, USB thumb drive for local music files, and no streaming services:

 

Ramroot, in its default mode (library stays on the boot drive), plays local music files with no loss of functionality compared to non-Ramroot. It plays music in exactly the same way. The only consideration is that you need to hit the "save fs to disc" button if you want to make permanent system changes, such as core isolation settings - otherwise those system changes will be reverted on next boot.

 

I think Ramroot gave a very worthwhile SQ boost compared to Optane drive, so the improvement over USB drive should be even greater.

 

thanks for the reply.

 

i still can't figure out how to play music in ramroot with my setup though.

if i copy a few songs to the usb stick, then enter ramroot, will those songs be available to play?

not being able to be in ramroot and see an attached HDD seems very odd to me, so maybe i'm missing something?  maybe it's a trial limitation?

 

edit:  found a euphony music directory on the usb drive, so i copied some test tracks over, deleted my HDD as a music library, entered ramroot and think i'll be able to play the test tracks in ramroot..............test round 2 about to start............doesn't solve problem of not seeing HDD but at least i may be able to update my SQ comparisons

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now



×
×
  • Create New...