Jump to content
IGNORED

Euphony OS w/Stylus player setup and issues thread


Recommended Posts

On 8/25/2021 at 11:09 PM, DomiJi said:

My Euphony NUC is directly connected to my router and i want to use Euphony as my Roon Core and use my ifi Pro iDSD as a UPnP / Squeezelite device. So i can leave the Euphony NUC in the other room.

 

I tried to activate the Squeezebox feature in Roon and activate Roon Core + Squeezelite on my Euphony NUC but Roon couldnt find the iDSD Pro.

 

Is this possible at all? 

:D

 

No, it's not possible. Not this way. You need the UPnP/DLNA-plugin running somewhere in your network. Please have a look here: rooupnp roon extension

 

For a quick test you could change to Stylus and activate the 'Find UPnP devices' or something like this in the Stylus settings.

Euphony (NUC7DNKE: Roon or Stylus) --> Euphony EP (NUC7CJYH: Roon Bridge or NAA or StylusEP) --> Matrix Audio X-SPDIF 2 --> Matrix Audio X-Sabre Pro (MQA) (I2S) -->

Euphony (NUC7DNKE: Roon) --> WS 2019 Core (i7-8700: HQPlayer, JPLAY Femto, Roon Bridge, MinorityClean) / Matrix Audio Element H --> Matrix Audio X-Sabre Pro (MQA) (USB) --> B & M Prime 6

Synology DS 112+ (LMS) --> pi3B+/HifiBerry Digi + Pro (PiCorePlayer) --> Matrix Audio X-Sabre Pro (MQA) (SPDIF) -->  

bedroom: pi3/DigiOne (RoPieee) --> S.M.S.L M500 --> KRK Rokit 5 or AKG 712 Pro

Link to post
Share on other sites

The Atom endpoint is working surprisingly well for me, well enough so that I've purchased a Stylus endpoint license.

 

information on the endpoint

https://up-shop.org/up-gateway-atom-x5-z8350-w-4g-memory-32g-emmc-board-w-vesa-plate.html

 

My thanks to @Miska for recommending this as NAA and pointing me to the last one Mouser had in stock.

 

My best setup so far is

Windows Roon i5 server using HQPlayer protocol to Stylus endpoint (NOS) or HQPlayer embedded (OS).

Have been able to use 768/24 with either of these endpoint choices.  Some CPU over-utilization so that

the more discriminating might want the more powerful device below when available

 

Stylus Server to Stylus Endpoint works fine up to 705/24 but changing to 768/24 causes constant CPU over-utilization and play stops

at between 14-17 seconds. Hard to know why, will fire off a question to Euphony support.

 

With only 4gb of RAM, running in RAM not recommended, even as endpoint.

 

Key factor here seems to be that the endpoint device is 5v DC powered + fanless so that USB out is clean. While it ran using an LPS 1.2 @ 1.2A

there were high frequency artifacts which disappeared using a JS-2 @ 5A;  it's stated max power need is 5v @ 4A.

 

Have used other endpoint devices in past, microRendu, Pentium NUC:  this is better. MR was clean but rounded details, Pentium was sharp

but USB out wasn't that clean even with LPS, this combines the best of both.

 

this was also recommended by Miska for a like more powerful device... but at 2x the price plus out of stock

https://up-shop.org/up-squared-edge-8gb-ram.html

Regards,

Dave

 

Audio system

Link to post
Share on other sites
5 hours ago, davide256 said:

The Atom endpoint is working surprisingly well for me, well enough so that I've purchased a Stylus endpoint license.

 

...

Have been able to use 768/24 with either of these endpoint choices.  Some CPU over-utilization so that

the more discriminating might want the more powerful device below when available

 

...

Need to amend this, the 768/24 is with already up-sampled files to 768/24 from PGGB using Stylus endpoint or HQPlayer embedded  USB output.

If you want to use HQPlayer up-sampling this device works up to 384/24 for PCM  but will stutter at anything faster.

Regards,

Dave

 

Audio system

Link to post
Share on other sites
  • 2 weeks later...
9 hours ago, flkin said:

 

A while ago, I wrote above that I liked Euphony version 20201102 best. That has now changed.

 

For various reasons, I decided to do a full reinstall of my downloaded copy of 20201102 from a USB drive. Boot from the USB and choose to install/repair current installation in the streamer. That went smoothly but my playlists stopped working. Reaching out to Željko, he said to try updating to the latest version and see. That I did and my old playlists worked again. I didn't have this issue before during moving from 20201102 to the current 20210716 but that was simply doing a toggle/reboot from the Euphony settings and not via a complete reinstall.

 

Looked like I had no choice but to stick with the 20210716 version. 

 

However, the sound character changed. I earlier felt that 0716 was too hard sounding and not organic enough but now it's organic but yet detailed - a step better than the old 1102. I now believe that my Euphony installation from a series of updates over years 2020/21 corrupted some files. But a fresh reinstallation and update repaired that and now shows what the latest version of Euphony 0716 is capable of. And it is good.

 

Don't do updates to software while Ram Root is being used. I think it was this that caused my issues.

 

At the time I was doing this software switching, I upgraded my pre-amp from Vinnie Rossi's LIO-DHT to the current L2i-SE. Not sure if this has anything to do with the sound changes but it might have contributed to the better organic sounds. Whatever, 0716 sounds very good in my current system today.

 

Thanks for your findings. You raised very good point regarding “Don’t update when in Ramroot” also fresh install. 
 

My findings with regards to fresh install were, it sounded better, but was too embarrassed to say that on here. Now I have, some people might think I’m mad. I now do fresh install every time I can rather than update via the software. Probably now a OCD thing. 

Link to post
Share on other sites
16 minutes ago, ASRMichael said:

Thanks for your findings. You raised very good point regarding “Don’t update when in Ramroot” also fresh install. 
 

My findings with regards to fresh install were, it sounded better, but was too embarrassed to say that on here. Now I have, some people might think I’m mad. I now do fresh install every time I can rather than update via the software. Probably now a OCD thing. 

 

What would we do without these threads? I don't know if a fresh install does matter, but I've surely found myself in this situation many times. At this level, every little things seems to matter, and sometimes it doesn't. I can only go so far on my own before I A/B myself into madness! 

 

Thank you to everybody and great developers like Željko for willing to discuss and share experiences!  

Link to post
Share on other sites
On 8/28/2021 at 1:17 PM, davide256 said:

Anybody know if Euphony will run on an Intel Atom processor? Thinking about buying one as a "play toy" to try as stylus endpoint/NAA

Hi Dave, remember me, you tried helping me out asking good questions when I posted here about Euphony distortion when switching 16/24bit tracks and back (still do :-( it's Upnp related I know at least....I think).

 

I can confirm Euphony will run on Intel Atom only with one Uptone lps 1.2 (gets more warm, I added a 90x90 mm heatsink on each side).*

I am using for 18 months the following:  MOBO : SuperMicro X10SBA (Intel Celeron J1900) - EPS: FaradSuper3 @12v (since 4 months)- ATX Uptone LPS 1.2 @12v.

 

I am not using HQ player or multi-multi cores and prefer the idea of less effort/low power. It's only one Euphony unit BUT I added the FaradSuper3 as 2nd PSU to great result, more open sound, specifically bass more extended and all bass more controlled and better defined. I do not know what sounds better JS-2 vs 2 separate LPS?.

And if I can hear that improvement with my basic setup, imagine some of you ;-).

 

* if you wonder if this LPS 1.2 got too hot, no it did not. I recently posted about LPS life expectancy because two LPS in my setup died almost at the same time. It was not this one. Actually my ISOregen and SSD LPS's died (not even at 4 years). 

Link to post
Share on other sites
39 minutes ago, k27R said:

How are you guys doing the fresh install? Are you formatting the OS hard drive and removing all of the partitions first?

When you (do a clean) install Euphony you get a warning it will erase everything before formatting in 3 partitions. That should be enough I think.

Link to post
Share on other sites

There is no fresh install straight to 20210716.

If image is downloaded from Euphony website, one has to start from 20210421, then perform feature updates to get to the latest version.

 

But if I am wrong above, please point me to where I can download image for 20210716 fresh install.  Thx.

Link to post
Share on other sites
3 hours ago, Anwar said:

There is no fresh install straight to 20210716.

If image is downloaded from Euphony website, one has to start from 20210421, then perform feature updates to get to the latest version.

 

But if I am wrong above, please point me to where I can download image for 20210716 fresh install.  Thx.

You are correct about euphony20210421v3.img; the most recent you can download today.  

 

If you want to compare two versions you can toggle under ''system info'' and ''revert to release'' as described by flkin above. Apparently after many times this could cause a bug as he observed. I toggle(d) for months between 102 and 716, (see image below). Mayby instead of toggles I should do a clean 716 install AND a clean 102 as well IF I want to keep comparing.

 

If you want to compare more than two Euphony versions you need to install from different USB sticks and do a clean install and above all, have an .img file for each version on usb stick. 

 

flkin has been describing very well in this thread in detail what to expect soundwise between different versions. (I thanked him allready for his super detailed sound impressions and here we go again: thanks flkin!) . 

 

The best would be if the most recent version is simply the best. Less stressful for Euphony/Željko too, I think he must have had a hard time with the anti-updaters since he tried to improve on v. 102 ;-), mea culpa

 

---

 

 

euphony20210421v3.img, the most recent you can download today

EuphonyDownloaderSep13_21.jpg

 

Toggle between two Euphony versions

EuphonyTwoVersionToggle_Sep13_21.jpg

Link to post
Share on other sites

I don't have an installation of Euphony to refer to at the moment, perhaps someone here can answer these questions.

1) In a system with more than one storage drive, does Euphony show those as one pooled drive, or separate drives?

 

2) Is it possible to direct Stylus to play to an installation of HQPlayer elsewhere on the network rather than the embedded version included?

No electron left behind...

Link to post
Share on other sites
10 hours ago, di-fi said:

Hi Dave, remember me, you tried helping me out asking good questions when I posted here about Euphony distortion when switching 16/24bit tracks and back (still do :-( it's Upnp related I know at least....I think).

 

I can confirm Euphony will run on Intel Atom only with one Uptone lps 1.2 (gets more warm, I added a 90x90 mm heatsink on each side).*

I am using for 18 months the following:  MOBO : SuperMicro X10SBA (Intel Celeron J1900) - EPS: FaradSuper3 @12v (since 4 months)- ATX Uptone LPS 1.2 @12v.

 

I am not using HQ player or multi-multi cores and prefer the idea of less effort/low power. It's only one Euphony unit BUT I added the FaradSuper3 as 2nd PSU to great result, more open sound, specifically bass more extended and all bass more controlled and better defined. I do not know what sounds better JS-2 vs 2 separate LPS?.

And if I can hear that improvement with my basic setup, imagine some of you ;-).

 

* if you wonder if this LPS 1.2 got too hot, no it did not. I recently posted about LPS life expectancy because two LPS in my setup died almost at the same time. It was not this one. Actually my ISOregen and SSD LPS's died (not even at 4 years). 

 

Hi, can you specify how exactly you use your two LPS? Do you have a USB audio card (JCAT etc.)? 

Link to post
Share on other sites
3 hours ago, AudioDoctor said:

I don't have an installation of Euphony to refer to at the moment, perhaps someone here can answer these questions.

1) In a system with more than one storage drive, does Euphony show those as one pooled drive, or separate drives?

 

2) Is it possible to direct Stylus to play to an installation of HQPlayer elsewhere on the network rather than the embedded version included?


For storage, Stylus can show both - pooled under the main albums and under Files shows the files separately in the drives pointed to

Link to post
Share on other sites
6 hours ago, AudioDoctor said:

I don't have an installation of Euphony to refer to at the moment, perhaps someone here can answer these questions.

1) In a system with more than one storage drive, does Euphony show those as one pooled drive, or separate drives?

 

2) Is it possible to direct Stylus to play to an installation of HQPlayer elsewhere on the network rather than the embedded version included?

 

1) Drives are shown separately (in Files view and Settings)
2) No, Euphony only knows how to connect and control local HQPlayer

Link to post
Share on other sites
13 hours ago, AudioDoctor said:

I don't have an installation of Euphony to refer to at the moment, perhaps someone here can answer these questions.

1) In a system with more than one storage drive, does Euphony show those as one pooled drive, or separate drives?

 

2) Is it possible to direct Stylus to play to an installation of HQPlayer elsewhere on the network rather than the embedded version included?

I haven't been able to get Stylus server to do sustained play using HQplayer embedded  to a Stylus endpoint NAA but have been able to fake it out into initially

using Stylus server with HQPlayer. Hard to understand why what works well for Euphony with Roon/HQP to NAA is unsupported

for Euphony Stylus/HQP to NAA. The basic problem is that if the DAC is remote it gets lost from HQP embedded NAA configuration when using Stylus server.

FWIW the 1 minute of play I can get does sound pretty good.

 

Regards,

Dave

 

Audio system

Link to post
Share on other sites
16 minutes ago, davide256 said:

I haven't been able to get Stylus server to do sustained play using HQplayer embedded  to a Stylus endpoint NAA but have been able to fake it out into initially

using Stylus server with HQPlayer. Hard to understand why what works well for Euphony with Roon/HQP to NAA is unsupported

for Euphony Stylus/HQP to NAA. The basic problem is that if the DAC is remote it gets lost from HQP embedded NAA configuration when using Stylus server.

FWIW the 1 minute of play I can get does sound pretty good.

 

 

I have used it before, and do have a license. I don't remember having an issue playing with Stylus to HQP to an NAA., but it has been a while. Do you have your music connected locally or on the network? Is the network share stable?

No electron left behind...

Link to post
Share on other sites
2 minutes ago, AudioDoctor said:

 

I have used it before, and do have a license. I don't remember having an issue playing with Stylus to HQP to an NAA., but it has been a while. Do you have your music connected locally or on the network? Is the network share stable?

NAS or Qobuz for source. HQP embedded to local attached DAC works fine regardless of player solution and remote NAA works fine as long as the server solution isn't

Stylus server. I don't even use upsampling with HQPlayer, just pass through.

Regards,

Dave

 

Audio system

Link to post
Share on other sites
21 hours ago, al2813 said:

 

Hi, can you specify how exactly you use your two LPS? Do you have a USB audio card (JCAT etc.)? 

It's in my profile under Audio System 

 

Audio system is changing regularly and there are two; I try to keep it updated.

 

SuperMicro X10SBA with two LPS:

1) EPS connector - DC cables: Gotham GAC-4/1 (JSSG360) - FaradSuper3 @12v + SR Fuse upgrade/ AC cables: Furutech cable + connectors
2) ATX connector - DC cables: Gotham GAC-4/1 (JSSG360) - Uptone LPS 1.2 @12v / standard Uptone brick

 

USB audio card:  Eifidelity (temporary) while waiting for new higher Streacom case to install Pink Faun SPDIF bridge.

 

Let me know if you have any questions.

Link to post
Share on other sites

I'm having trouble getting the pcm 1411/1536 to work with HQP on euphony , either as alsa or as NAA. I have a holo spring 3 KTE (usb).  Works perfectly with Miska's HQPlayer OS / NAA images

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


×
×
  • Create New...