Jump to content
T-Bone

ISO Regen & Chord Qutest Incompatibility

Rate this topic

Recommended Posts

I've used my LPS powered ISO Regen with my Singxer/Holo Spring DAC for a long time.  ...and have been happy with the results.

I recently upgraded to Chord Qutest.  I can't get the Qutest to work w/ the ISO Regen in USB signal path.  The Quest only works when its USB input is plugged directly into the PC.  

Any advice?

Share this post


Link to post
Share on other sites

On a whim, I decided to replace the USPCB board with a 6" USB cable and the DAC connected immediately.

 

I tried swapping the USPCB in/out with both the VBUS switch on and off.  It didn't make a difference.  Replacing the USPCB with a cable was the only way to make things work. 

So why would the USPCB board make a difference?

Share this post


Link to post
Share on other sites
3 hours ago, T-Bone said:

On a whim, I decided to replace the USPCB board with a 6" USB cable and the DAC connected immediately.

 

I tried swapping the USPCB in/out with both the VBUS switch on and off.  It didn't make a difference.  Replacing the USPCB with a cable was the only way to make things work. 

So why would the USPCB board make a difference?

Likely that the USPCB failed. I had one fail. Due to the nature of the unit any flexing can cause a crack or the switch failed.

Share this post


Link to post
Share on other sites

I spoke to Alex.  He had me conduct a couple of tests that proved my ISO REGEN was not functioning correctly and I needed to send it in for repair.  

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...