Jump to content

Rate this topic

Recommended Posts

Hi all

 

I'm hoping to use an old Raspberry Pi as a Spotify Connect renderer into a USB DAC. 

 

I don't know much about the Pi and am definitely not a programmer though I can copy and paste. 

 

I'm not sure what model Pi I have but it is old. 

 

Currently installing Raspbian and will put Raspotify on after that. Will I have to do some coding in Raspbian like found below to enable USB out? 

The link seems like the most straight forward walk through I can find. 

https://www.google.com/amp/s/plugable.com/2014/11/06/how-to-switch-to-usb-audio-on-raspberry-pi/amp/

 

Any help or advice will be much appreciated 

Share this post


Link to post
Share on other sites

So a few hours later I got Spotify running but only via headphone or HDMI. 

Can't seem to get it to recognise my DAC or force output to USB 

Share this post


Link to post
Share on other sites

Hey mate,

 

Try Moode Audio. I use it as a Spotify Connect device heaps.

 

Download the image from here and use Ethcher to burn to microSD card:

 

http://moodeaudio.org/

 

Boot up your Pi and wait a few minutes and fire up "moode.local/" on a web browser and do all of the setup there via web browser.

 

No command line stuff required! 


 

Share this post


Link to post
Share on other sites

After it loads, first find the screen to do the system update. Might take a good 20+ minutes, just let it do it's thing to update. Then you can go in and configure stuff, like turn off WiFi (if you want) & bluetooth, turn off HDMI, choose USB audio output etc etc, all via the web browser.

 

You can configure Spotify via the web browser too, like choosing which streaming plan you're on, setting the startup volume etc.

 

Otherwise hopefully someone else can jump in to help with the command line stuff. I never had the patience (or skill) to do it that way. Moode is fantastic and easy.

Share this post


Link to post
Share on other sites

So I've had a play around today. Moode was really easy to get happening. I can get Spotify from my phone to see the Moode Pi and I can set my DAC in the Spotify customise setting. 

 

The problem is no output... In the MPD config for Audio Device there is only 'on-board audio device' in the drop down box. Obviously not seeing my DAC. I have restarted the Pi and my DAC a few times but no result. 

 

Any help appreciated 

Share this post


Link to post
Share on other sites
23 minutes ago, bunno77 said:

The problem is no output... In the MPD config for Audio Device there is only 'on-board audio device' in the drop down box.

 

Can you share a screenshot of the config screen (screen before MPD config).

 

It has a comment there of what to select for USB audio output - supposed to select 'none' for USB audio.
 

Share a screenshot of your MPD config screen too

Share this post


Link to post
Share on other sites

And when you select "none", you need to follow these steps that it tells you

 

1372635637_ScreenShot2019-02-09at8_10_02pm.png.785e6ba3c8b82d59a899c6c32de01ae2.png

 

Other than that, not sure what else to do.

 

Moode has a very up to date Linux kernel and USB DAC and HAT drivers etc, so if it doesn't work for you in Moode, hard to say if another OS/distro will be better.  Tim (the developer) is really good with support - just join the Moode Forum for help from him:

 

http://moodeaudio.org/forum/

 

 

Share this post


Link to post
Share on other sites

So here is the screenshots.... I think I have all of them. With that little pic you sent I couldn't see an apply MPD or edit chip but set i2s to none and hit set again.

 

Can see that my DAC is known so it's not making sense to me. Maybe you pick something up in the screenshots. Might contact Moode too

 

Thank again for your help mate

 

 

Untitled.jpg

Untitledr.jpg

Untitle2d.jpg

Untitledr8p.jpg

Untitledrp.jpg

Share this post


Link to post
Share on other sites

In the Spotify Config screen (of Moode), you can select initial volume. I think the default is 0% from memory. 

 

Did you change that to 100%?

 

Apart from that, I'm out of ideas mate. The hardest part is having it recognise your DAC and you've got that working. Not sure what else it could be. Check with Tim on the Moode forum, he'll get it all sorted.

 

Other thing you can try is Volumio. The install process is the same - burn image to SD card.

 

Then volumio.local/ for all the setup, like Moode. I haven't used it for ages but you can install Spotify Connect via the plugins screen.

 

 

Share this post


Link to post
Share on other sites

Thanks so much for your time mate. 

 

I don't think it is seeing my DAC. It's not an option here as a USB audio device. That's the problem I'm pretty sure but no amount of reboots is helping

 

I'll check in with Tim because the software itself seems excellent and runs well, just no usb output.... 

Untitledrp.webp

Share this post


Link to post
Share on other sites
4 minutes ago, bunno77 said:

I don't think it is seeing my DAC. It's not an option here as a USB audio device.

 

You showed a screen where it showed your LH Labs DAC in system info? That's a good sign.

 

Send those screenshots to Tim.

Share this post


Link to post
Share on other sites

Hi bunno77, I think the problem is not in Moode, but in the fact that the USB dac you are plugging in is not recognized by the OS (Moode is on top of Raspbian) as shown also by your post #2.

Just as an example, this is the alsa device list I see with my USB dac:
 

[email protected]:/etc $ aplay -l

**** List of PLAYBACK Hardware Devices ****

card 0: ALSA [bcm2835 ALSA], device 0: bcm2835 ALSA [bcm2835 ALSA]

  Subdevices: 7/7

  Subdevice #0: subdevice #0

  Subdevice #1: subdevice #1

  Subdevice #2: subdevice #2

  Subdevice #3: subdevice #3

  Subdevice #4: subdevice #4

  Subdevice #5: subdevice #5

  Subdevice #6: subdevice #6

card 0: ALSA [bcm2835 ALSA], device 1: bcm2835 ALSA [bcm2835 IEC958/HDMI]

  Subdevices: 1/1

  Subdevice #0: subdevice #0

card 1: v14 [TDA 1543 DAC 3 v1.4], device 0: USB Audio [USB Audio]

  Subdevices: 1/1

  Subdevice #0: subdevice #0

[email protected]:/etc $ 

 

Yuour Moode config seems fine (i2s device=none).

And the option "USB Audio Device" would show up automatically in the Audio Device combo in MPD setting when the USB dac is recognized.

 

You might want to look inside file "/var/log/moode.log" to see if any evident error is showing.

When all goes well you should find something similar to this

 

...........................................

20190208 093941 worker: - Audio

20190208 093941 worker: ALSA outputs unmuted

20190208 093941 worker: ALSA card number (1)

20190208 093941 worker: Audio output (USB audio device)

...........................................

 

 

 

Share this post


Link to post
Share on other sites
On 2/11/2019 at 10:31 AM, franz159 said:

Hi bunno77, I think the problem is not in Moode, but in the fact that the USB dac you are plugging in is not recognized by the OS (Moode is on top of Raspbian) as shown also by your post #2.

Just as an example, this is the alsa device list I see with my USB dac:
 

[email protected]:/etc $ aplay -l

**** List of PLAYBACK Hardware Devices ****

card 0: ALSA [bcm2835 ALSA], device 0: bcm2835 ALSA [bcm2835 ALSA]

  Subdevices: 7/7

  Subdevice #0: subdevice #0

  Subdevice #1: subdevice #1

  Subdevice #2: subdevice #2

  Subdevice #3: subdevice #3

  Subdevice #4: subdevice #4

  Subdevice #5: subdevice #5

  Subdevice #6: subdevice #6

card 0: ALSA [bcm2835 ALSA], device 1: bcm2835 ALSA [bcm2835 IEC958/HDMI]

  Subdevices: 1/1

  Subdevice #0: subdevice #0

card 1: v14 [TDA 1543 DAC 3 v1.4], device 0: USB Audio [USB Audio]

  Subdevices: 1/1

  Subdevice #0: subdevice #0

[email protected]:/etc $ 

 

Yuour Moode config seems fine (i2s device=none).

And the option "USB Audio Device" would show up automatically in the Audio Device combo in MPD setting when the USB dac is recognized.

 

You might want to look inside file "/var/log/moode.log" to see if any evident error is showing.

When all goes well you should find something similar to this

 

...........................................

20190208 093941 worker: - Audio

20190208 093941 worker: ALSA outputs unmuted

20190208 093941 worker: ALSA card number (1)

20190208 093941 worker: Audio output (USB audio device)

...........................................

 

 

 

Thanks mate. Yep no external usb device is being recognised. Will have a look into that thank you

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×