Jump to content
dajokr

ISO REGEN and PS Audio Sprout100

Rate this topic

Recommended Posts

 

I am using the ISO REGEN in conjunction with a PS Audio Sprout 100.  Anyone else using this combo?  Everything sounds really nice, but I have a minor issue.  The Sprout deenergizes the digital input when selecting another input (e.g., vinyl, analog).  When I go back to the digital input, the ISO REGEN/DAC combo is not recognized until I disconnect and reconnect the USB cable between the PC and REGEN.  I do not have the same issue when using the USB/Digital input without the REGEN.  Any thoughts on how I might avoid having to disconnect each time?  Thanks!

Share this post


Link to post
Share on other sites
14 hours ago, dajokr said:

When I go back to the digital input, the ISO REGEN/DAC combo is not recognized until I disconnect and reconnect the USB cable between the PC and REGEN.

 

Hi David:

 

Glad to hear you are enjoying the ISO REGEN with your PSA Sprout.

What you are experiencing is pretty normal--depending upon the computer being used.  I am even going to guess that you are using a Linux-based computer or streamer/renderer.  Could be a Windows machine running something earlier than Win10; certainly not a Mac.

 

You actually don't need to unplug any USB cable, you could simply remove and reapply power to the ISO REGEN.  It is all about power-on sequence--especially related to 5VBUS signaling between the DAC and the computer though the USB hub (ISO REGEN).

 

Feel free to contact us by telephone if you want more detail about this.

 

Thanks and regards,

--Alex C.

Share this post


Link to post
Share on other sites

Thanks, Alex.  The PC is actually a Windows 10 NUC.  I'll try the power button instead, that will be easier by far than unplugging every time.

 

D

Share this post


Link to post
Share on other sites
12 minutes ago, dajokr said:

Thanks, Alex.  The PC is actually a Windows 10 NUC.  I'll try the power button instead, that will be easier by far than unplugging every time.

 

Hi David:

I just looked and saw you got the ISO REGEN in a bundle with our UltraCap LPS-1.2 (thanks!).  Saying you would use the power button is what made me check.  You will find it faster to briefly remove and reinsert the DC output cable--the one from the LPS-1.2 to the ISO REGEN--at the back of the LPS-1.2.  If you use the LPS-1.2's power button you will have to wait through the entire discharge/diagnostic/boot cycle of the UltraCap supply.  

Best,

ALEX

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×