Jump to content

Audiolinux Server configurations, Software, Hardware, and Listening Impressions


lmitche
 Share

Recommended Posts

4 minutes ago, jkelly said:

Not yet - just running out of the box, with Roon server installed. Running off a 32 gb stick. Euphony was running off a HD so that may be a reason for the edge. I am forcing myself to just enjoy the music and not tweak, but the force is strong! :-)

That sounds even better.  Have you tried RAM Root yet?  I used RAM Root and it does help to improve the SQ.

Link to comment
Share on other sites

  • 2 weeks later...
On 11/9/2020 at 11:30 AM, al2813 said:

Are you running the NUC without a disk? I have an m2 drive there and although I do plan to go Ramroot, I was thinking of installing AL on the M2 internal SSD

Sorry @al2813 as I don't think I ever replied to you, better late than never. always run AL on USB, at some point I ran Ubuntu on the NUC and that was on local SSD

On 11/9/2020 at 11:30 AM, al2813 said:

You're currently using the NUC as the server side. Are you using the standard power supply? 

When I ran the NUC  I was feeding the NUC with a 12V JS-2 LPS, I have been running a dedicated fanless Ryzen 5600X for the last 10 - 11 months

 

On 11/9/2020 at 11:30 AM, al2813 said:

I am thinking of taking the NUC to a fanless case in light of potentially using it in the future as a second end point and adding down the line LPS. only thing is that I am now not sure of the direction to go as Akasa's cases are great value, but they don't allow for a future PCIE USB card. HDPlex H1 does but costs a lot more. 

I repurposed the NUC into an AKASA case but running Jellyfin (a media server like Plex) right next to my bed, works great.

Link to comment
Share on other sites

On 9/4/2021 at 5:58 AM, hifi25nl said:

ps_default=yes

it was on =no but I changed it

 

Still after enabling it it won't load or give an error, shows are enabled but not active

 

Can I get logs somewhere so I can look and check what could be happening?

 

Link to comment
Share on other sites

2 hours ago, hifi25nl said:

The only message available from ramroot is at boot if you connect a monitor.

I need the exact output.

I do have a monitor connected, there is no message from ramroot

I just imaged a new USB and I am reinstalling again, let me see if I run in the same issue

 

Link to comment
Share on other sites

  • 1 month later...

Thanks for the update, @hifi25nl.  Roon just announced "changes to the Linux builds of Roon," and they recommend "new dependencies on your system," including "installing libicu onto your Core."  Looks like the new Linux Roon core will be released on November 3.  Does the new (3.2.0) version of audiolinux headless support the changes to the Roon Core, or are those changes news to you too?  I received the Roon announcement email just a few minutes ago.  Thanks much!

Link to comment
Share on other sites

I have received a beta for testing before and it was working fine.
Tomorrow I will check package dependencies and eventually release a new version if necessary.
 
As always you can install last version with the specific option in Update menu.

AudioLinux --> https://www.audio-linux.com

developer of AudioLinux realtime OS

Link to comment
Share on other sites

4 hours ago, pranabindu said:

Thanks for the update, @hifi25nl.  Roon just announced "changes to the Linux builds of Roon," and they recommend "new dependencies on your system," including "installing libicu onto your Core."  Looks like the new Linux Roon core will be released on November 3.  Does the new (3.2.0) version of audiolinux headless support the changes to the Roon Core, or are those changes news to you too?  I received the Roon announcement email just a few minutes ago.  Thanks much!

Here is what I got concerning Roon on Linux.

 

https://help.roonlabs.com/portal/en/kb/articles/linux-performance-improvements#Whats_happening

Eric


Ubuntu Studio Linux box (i7-9700, 8 cores, 16GB RAM, Intel X520-DA1 NIC, HQP Desktop) > fiber optic > MikroTik CRS305-1G-4S+ > fiber optic > fitlet2 (Linux Mint - HQP NAA) > T+A DAC8 DSD > Rogue Audio DragoN > Klipsch La Scala — digital volume control with HQP via Roon client, DSP with HQP convolution engine, Intel NUC (Roon server)

Link to comment
Share on other sites

The last version is 

[[email protected] ~]$ yay -Ss roonserver
aur/roonserver 1.8.831-2 (+6 0.19) (Installed)
   The music player for music lovers

 

I don't think you have updated it.

 

You can do it also on command line with:

yay -Scc --noconfirm

yay -Sy roonserver --noconfirm

 

I have added the line yay -Scc --noconfirm because if the cache is not deleted, yay could build from it a previous version. The same can be done with the option Clean System in System menu.

 

AudioLinux --> https://www.audio-linux.com

developer of AudioLinux realtime OS

Link to comment
Share on other sites

@hifi25nl -- just curious . . . how do i interpret the below?  what does the installed: 1.8.795-100 mean?

 

image.png.e2adea808fc3b2702f0bffded8b36e07.png

sources:  intel nuc8i7 (audiolinux, roon core) (server) | simaudio moon mind 2 (renderer)
headphone rig:  chord qutest > bryston bha-1 > audeze lcd-3
main rig:  chord dave > parasound jc5 > kef reference 1
Link to comment
Share on other sites

You have an old version of Audiolinux.

You cannot update until you fix the problem or reinstall the last version. This is because of the pacman package manager update upstream.

 

1) I would edit as root ( you can use the File Editor ROOT in System menu) the file /etc/pacman.d/mirrorlist and put # in front of worldwide server, take out # in front of the servers of your country. Italian ones are working nice... :) 
2) sudo rm -f /var/lib/pacman/sync/*
3) sudo pacman -Syy
 

 

 

AudioLinux --> https://www.audio-linux.com

developer of AudioLinux realtime OS

Link to comment
Share on other sites

13 minutes ago, hifi25nl said:

You have an old version of Audiolinux.

You cannot update until you fix the problem or reinstall the last version. This is because of the pacman package manager update upstream.

 

1) I would edit as root ( you can use the File Editor ROOT in System menu) the file /etc/pacman.d/mirrorlist and put # in front of worldwide server, take out # in front of the servers of your country. Italian ones are working nice... :) 
2) sudo rm -f /var/lib/pacman/sync/*
3) sudo pacman -Syy
 

 

 

 

thank you -- but i don't understand why i'm on an old version.  love to know what i was doing wrong.  from the install/update menu, i did the following

 

* updated menu and rebooted (did that process twice to get to 306)

* updated the kernel (lts version) and rebooted

* updated system and rebooted

 

i can certainly download and flash the latest version, but didn't think that was necessary.

 

thanks!

sources:  intel nuc8i7 (audiolinux, roon core) (server) | simaudio moon mind 2 (renderer)
headphone rig:  chord qutest > bryston bha-1 > audeze lcd-3
main rig:  chord dave > parasound jc5 > kef reference 1
Link to comment
Share on other sites

I fear that your system update did not succeed because of the error above.

System update is made with this command:

 

yay -Syu --noconfirm --removemake 

 

but if you cannot download pacman archive...

You can test another time the problem typing that command.

AudioLinux --> https://www.audio-linux.com

developer of AudioLinux realtime OS

Link to comment
Share on other sites

23 minutes ago, hifi25nl said:

I fear that your system update did not succeed because of the error above.

System update is made with this command:

 

yay -Syu --noconfirm --removemake 

 

but if you cannot download pacman archive...

You can test another time the problem typing that command.

 

ok!  thanks again!  fixed the pacman issue and ran the system update again and it seemed to all go smoothly.  rebooted and ran the system update again and noticed that one of the messages did show audiolinux as up to date.  the installed: 1.8.795-100 is still there -- is that okay? (the error messages are gone) (also note that when i go into roon it does show me as running 1.8.831)

 

also, how do you know what version of audiolinux you're running?

 

image.png.06808fd699644cea4ea0162dbaa773a6.png

sources:  intel nuc8i7 (audiolinux, roon core) (server) | simaudio moon mind 2 (renderer)
headphone rig:  chord qutest > bryston bha-1 > audeze lcd-3
main rig:  chord dave > parasound jc5 > kef reference 1
Link to comment
Share on other sites

You can see the version with Web Interface 1. Type cancel and in console you should see it. The version is always the original one at installation, even if updated. I need to know this because I could make some manual changes with new versions.

 

For roonserver, I would update it cleaning cache, as suggested above:

 

yay -Scc --noconfirm

yay -Sy roonserver --noconfirm

AudioLinux --> https://www.audio-linux.com

developer of AudioLinux realtime OS

Link to comment
Share on other sites

@hifi25nl -- thanks for your patience with this.  something is out of sync.  would love your thoughts.  here's the situation:

 

splash screen shows audiolinux 3.0.0

 

image.png.871400167415b4b4d7da5519ef747b3f.png

 

on the audio menu, it shows roonserver as 1.8.795

 

image.png.5b1edf4e81f92c8dff1b72d1e2590e5c.png

 

in roon, it shows running 1.8.831 (latest)

 

image.png.15bce37af714552ef5b328cf237deab7.png

 

if you run the two commands you recommended to clean up the cache and update roonserver, you get these errors at the end:

 

image.png.aef8b0a6686cad81df5729d59875f452.png

 

 

 

sources:  intel nuc8i7 (audiolinux, roon core) (server) | simaudio moon mind 2 (renderer)
headphone rig:  chord qutest > bryston bha-1 > audeze lcd-3
main rig:  chord dave > parasound jc5 > kef reference 1
Link to comment
Share on other sites

ah, this is because of the unfortunate auto-update option of Roon. In Audiolinux you should not update from control point but only with the menu option.

 

You should do:

sudo rm -rf  /opt/RoonServer

yay -Scc --noconfirm

yay -Sy roonserver --noconfirm

 

AudioLinux --> https://www.audio-linux.com

developer of AudioLinux realtime OS

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share



×
×
  • Create New...