Jump to content

Audiolinux Server configurations, Software, Hardware, and Listening Impressions


Recommended Posts

ALSA system wide configuration is there only for special needs. I wouldn't add anything

 

I think that enabling Realtime Expert Configuration could give a substantial improvement.

You can check the configuration file /opt/configuration/realtime_custom.sh and eventually edit it as root

Remove # in front of each line if you want to enable the corresponding configuration
I would enable all (in last Audiolinux versions the # is already removed in front of all options) The option with cpumask should be enabled only if you have isolated some core.

 

 

AudioLinux --> https://www.audio-linux.com

developer of AudioLinux realtime OS

Link to post
Share on other sites

hi folks,

i've just moved from a single NUC solution (LMS & squeezelite running in ramroot) to a two PC solution where the LMS server is running on a separate ubuntu machine which is also my sageTV server/DVR.  moving to two machines made a noticeable improvement in sound quality.  note that for now, the LMS server is not running under AL or in ramroot, just plain old ubuntu.

 

my configuration is

 

LMS (on ubuntu)==>edgerouterX==>etherRegen(opt out)==>opticalModule==>AL(squeezelite)==>slimrunUSB==>totalDAC

 

while doing some testing/comparisons with some other software, i turned on hyperthreading and turbo boost and turned off low power in Bios.  i don't know if that is optimum for AL though as I was running my previous single NUC solution with HT and turbo off and low power on.  since i'm running headless, it's a pain to change bios settings and will probably wait a bit before i do that.

 

has anyone here done comparisons with those bios settings on/off for AL recently?

@Pierro:  do you have any recommendation?

 

has anyone compared a two nuc solution with AL on both server and endpoint,  versus just on the endpoint?  (i.e. should i get a 3rd nuc for just the LMS server?)

 

thanks

Link to post
Share on other sites
24 minutes ago, hifi25nl said:

A good system (from electronic point of view) does not have limitations if power supply is of high quality. There is no evil in high power...

Very good post.  I think your comments match the experience of many users. 

NUC7PJYH/AL --> Berkeley Alpha USB --> Jeff Rowland Aeris --> Jeff Rowland 625 S2 --> Focal Utopia 3 Diablos with 2 x Focal Electra SW 1000 BE subs

 

i7-6700K/Windows 10 Version 2004/HDPLEX 300W/HDPLEX 400W DC-ATX --> EVGA Nu Audio Card --> Focal CMS50's 

Link to post
Share on other sites

09/09/2020 In menu 237 an improved network script with:
 
1 BRIDGE with DHCP automatic IP Address
2 BRIDGE with static IP Address
3 DHCP automatic IP Address (default)
4 STATIC IP Address
5 RESTORE previous configuration
6 ETHERNET speed limit
7 Exit"

 
New options 3 4 without bridge. Now you can also set network mask

AudioLinux --> https://www.audio-linux.com

developer of AudioLinux realtime OS

Link to post
Share on other sites

has anyone experimented with cpu isolation?  any recommendations?

 

i'm running squeezelite in ramroot as the endpoint, with usb out via slimrunUSB

for the server, i have LMS running on a networked separate pc

Link to post
Share on other sites

I have been using AL for couple of years now. I was using RAMROOT, but at this point it does not fit on 8gb RAM, and Miska from HQP suggest it is not best to use HQP in RAM mode. So my question is if AL can be installed on an internal Optane drive.

Link to post
Share on other sites
51 minutes ago, sig8 said:

I have been using AL for couple of years now. I was using RAMROOT, but at this point it does not fit on 8gb RAM, and Miska from HQP suggest it is not best to use HQP in RAM mode. So my question is if AL can be installed on an internal Optane drive.

Which Audiolinux are you running GUI or headless?

nuckleheadaudio.com

Link to post
Share on other sites
8 minutes ago, sig8 said:

I have both, GUI on server and headless on NAA. Thanks.

For a headless installation, AL fits into 8gb using ramroot with RoonServer and Hqplayer embedded without issue. Headless will also fit into a 16 or 32GB Optane NVME drive configured as an SSD.  I recommend the larger of the two as the extra space can be useful for other things like the Roon DB.

 

I haven't booted AL with the GUI for many years and can't speak to that.

 

I am sorry I can't be more helpful.

 

Larry

nuckleheadaudio.com

Link to post
Share on other sites
4 minutes ago, lmitche said:

For a headless installation, AL fits into 8gb using ramroot with RoonServer and Hqplayer embedded without issue. Headless will also fit into a 16 or 32GB Optane NVME drive configured as an SSD.  I recommend the larger of the two as the extra space can be useful for other things like the Roon DB.

 

I haven't booted AL with the GUI for many years and can't speak to that.

 

I hope this helps.

 

Larry

Thanks Larry, sorry for not being clear, I have 8gb on server, and 4gb on headless at this point. I can add RAM to both or install on Optane.

 

How you install on Optane? Thanks.

Link to post
Share on other sites
24 minutes ago, sig8 said:

Thanks Larry, sorry for not being clear, I have 8gb on server, and 4gb on headless at this point. I can add RAM to both or install on Optane.

 

How you install on Optane? Thanks.

Installing on Optane is done by using DD to move the image to the Optane drive from a USB stick. Here is a reference that explains how to use DD: https://wiki.archlinux.org/index.php/Dd#Disk_cloning_and_restore

 

Also, Piero has some copy commands on the headless AL menu that may work as well.

 

Are you saying that headless doesn't ram boot on a 4gb RAM machine? If so, another ram stick is the easiest solution. Headless definitely boots on a 8gb machine. I don't know about the GUI version. Maybe Piero can chime in?

 

 

nuckleheadaudio.com

Link to post
Share on other sites

With 4GB RAM an option is to remove some packages, at the cost of  not being able to install extra kernel modules or compile some applications:

 

yay -R gcc linux-rt-headers

or

yay -R gcc linux-rt-bfq-dev-headers

(if you are using linux bfq)

 

Also the ramroot configuration file /etc/ramroot.conf should be edited to different values. Default is
 

# minimum MiB free ram:
ram_min=500

# minimum MiB free zram:
zram_min=250

# preferred MiB free ram:
ram_pref=4000

# maximum MiB free ram:
zram_max=1000


After disable ramroot
ramroot -D
and re-enable it
ramroot -E

 

AudioLinux --> https://www.audio-linux.com

developer of AudioLinux realtime OS

Link to post
Share on other sites
2 hours ago, hifi25nl said:

No, that should be the max free zram. Zram is a virtual hard disk and that line define the max free space you want to leave on it.

You can go down to 250, if needed.

 

OK so perhaps this should be 400 not 4000?

 

# preferred MiB free ram:
ram_pref=4000

 

nuckleheadaudio.com

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


×
×
  • Create New...