Jump to content
lmitche

Audiolinux Server configurations, Software, Hardware, and Listening Impressions

Recommended Posts

Thank you, yeah nothing extreme or priority or isolation just the defaults, governor is at max although the CPU is unidentified, buffering at 250 still stutters.

Share this post


Link to post
Share on other sites

Just wanted to add on this, it is really not a limitation of the archlinux platform, the archlinux and AMD processing works just fine, as a matter of fact testing with Windows 10 latest updates creates more stuttering than with AL, some people have claimed that HQP on Windows is faster, but not natively on stock Windows, (you probably need to use enhancement tools like Fidelizer and Audiophil)

 

Share this post


Link to post
Share on other sites
23 hours ago, luisma said:

Thank you, yeah nothing extreme or priority or isolation just the defaults, governor is at max although the CPU is unidentified, buffering at 250 still stutters.

Luisma,

 

It looks like you have hyperthreading (aka SMT) turned off either in the BIOS or in the AL config. Hqplayer is happiest with Hyperthreading on in my experience.


nuckleheadaudio.com

Share this post


Link to post
Share on other sites

Luisma,

 

You could also send us a picture of the output from the AL "Show Configuration" choice on the top menu.


nuckleheadaudio.com

Share this post


Link to post
Share on other sites
On 5/24/2020 at 11:28 AM, luisma said:

Good weekend everybody ...

Recently build a new PC, I'm a loyal HQPlayer user, since I am using a fanless chassis with TDP constraints I decided to use a 3800X, I know the AMD platform is not the best for HQPlayer but I was expecting with such CPU to be at least able to run ASDM7EC with DSD256 pushing it at its limits.

I installed latest AL, did all the updates including kernel, currently running 5.4.19-rt11-1-rt-bfq, changed from pstate to acpi, I am not doing any expert or realtime features just the default config, nor isolation cores or such.

When running HQPlayer with 7EC and DSD256 it stutters every 14 seconds or so. 2 cores are maxed out at 99% the remaining 6 will be at 38% average.

 

I suspect that, unfortunately, the AMD 3800X may not be quite up to running HQP ASDM7EC at DSD256:

 

1) the base clock is a bit low

2) no AVX512

 

7EC at DSD256 is taxing and maxes out the single core requirements...


Custom room treatments for headphone users.

Share this post


Link to post
Share on other sites

I have some issues with the Nomachine server on version 4.4 LQXT. It dropped up an update notification and I did it ca. a week ago. I can't use it since. I can't see the NM red icon on the bottom right corner.

 

I can see from a NoMachine client but the server doesn't accept any passwords.

 

Please help to fix it.

Share this post


Link to post
Share on other sites
1 hour ago, lmitche said:

You could also send us a picture

Sure Larry, here it is, I really did a lot of testing, posted on the HQP thread with results etc. enabling multicore on hqplayerd.xml as Miska recommended did made a difference, better core utilization but still not enough
 
image.png
image.png
image.png
 

Share this post


Link to post
Share on other sites
1 hour ago, luisma said:
Sure Larry, here it is, I really did a lot of testing, posted on the HQP thread with results etc. enabling multicore on hqplayerd.xml as Miska recommended did made a difference, better core utilization but still not enough
 
image.png
image.png
image.png
 

Sorry Luisma,

 

The pictures don't seem to open.

 

Larry


nuckleheadaudio.com

Share this post


Link to post
Share on other sites
31 minutes ago, lmitche said:

Sorry Luisma

No problem

 

How about this?

 

image.png.05f09fea14242ee52ab996d1064265cb.png

 

image.png.9cf44536ca83a5829cf6414fb14c9e78.png

 

Share this post


Link to post
Share on other sites
1 hour ago, luisma said:

No problem

 

How about this?

 

image.png.05f09fea14242ee52ab996d1064265cb.png

 

image.png.9cf44536ca83a5829cf6414fb14c9e78.png

 

That looks good, except I'd recommend the default (not BFQ) kernel. I'm not sure it will speed up Hqplayer, but it sure sounds better.

 

You said this is a Ryzen 7 3700x right? Which motherboard and ram ?

 

I'm surprised that the load isn't spread more evenly across processor threads. Are you sure the hqplayer multicore settings are correct?

 

Larry


nuckleheadaudio.com

Share this post


Link to post
Share on other sites

Thanks Larry for looking.

 

Silly me I switched yesterday the kernel to the default but since I was running in ramroot after one reboot went back of course, let me switched that back. Yes the default kernel is newer and core distribution could possibly be enhanced.

 

it is a 3800X with a Gigabyte Aorus Master and 32 GB Kit of HyperX Predator 2666 MHZ CL13

 

The load is kind of dependent on filter used, poli xtr so far is the more even on each core (comparisons on the HQP thread) see below the exact link

 

 

Share this post


Link to post
Share on other sites


04/06/2020 Audiolinux menu 218 with full support of Merging Ravenna driver also on 5.x kernels with the new aes67-linux-daemon. Web Interface 2 at ipaddress:5001 now improved and fully working. If you were using previous version, please disable first old daemon with

systemctl --user stop ravenna-alsa

 

I remember that you can access Audiolinux from a remote PC in 4 ways:

 

1) NoMachine remote Desktop (only lxqt version)

2) From command line with ssh [email protected]
3) WEB INTERFACE 1 in a browser at ipaddress:8500
4) WEB INTERFACE 2 in a browser at ipaddress:5001

 

You can disable or enable web interfaces in EXPERT menu.

WEB INTERFACE 2 is easier with touch screen and search function, but only in WEB INTERFACE 1 you will have all the options available (including editor)

 

 


AudioLinux --> https://www.audio-linux.com

developer of AudioLinux realtime OS

Share this post


Link to post
Share on other sites
On 5/23/2020 at 2:53 AM, hifi25nl said:
A revolutionary kernel is on testing. Stay tuned!

Can you give us an estimate of when can we expect to see this?  Thanks!


NUC7PJYH/AL --> Berkeley Alpha USB --> Jeff Rowland Aeris --> Jeff Rowland 625 S2 --> Focal Utopia 3 Diablos with 2 x Focal Electra SW 1000 BE subs

 

i7-6700K/Windows 10 Version 1903/HDPLEX 200W/HDPLEX 400W DC-ATX --> EVGA Nu Audio Card --> Focal CMS50's 

Share this post


Link to post
Share on other sites
On 6/8/2020 at 4:28 AM, hifi25nl said:

I am working on it. At least kernel compilation is fine. However there are other technical problems to be solved. Waiting for a special version of alsa for example. 

I cannot give a date at this time. 

 

 

 

i won't ask for a date :) but as an audiolinux user, could you give us any insights into how the revolutionary kernel might improve audio:  latency, processor occupancy, etc? (can't hurt to ask)

 

cheers

Share this post


Link to post
Share on other sites
9 hours ago, hifi25nl said:

Yes, hqplayer 4.18.0 is available for update from yesterday morning.

 

For the new kernel, exceptional latency, 1-2 microseconds max.

 

sounds outstanding!

thanks

Share this post


Link to post
Share on other sites

i know the recommended way to update hqplayer is to disable ramroot mode at startup, update hqplayer, then enable ramroot.

however, i do not have a monitor so i can't catch the Y/N option for ramroot on startup.

 

therefore, i've tried two things:

1.  in ramroot mode, update hqplayer via menu, it finds and downloads the latest 4.18.0, seems to install in console, but when i check it is still on 4.17.1

2.  went into console and used sudo ramroot -D to disable ramroot, went back into menu to update hqplayer but with the same result.

 

any suggestions?  maybe uninstall current hqplayer first?  or is my music network connected and keeping it from being updated--maybe disable first?

Share this post


Link to post
Share on other sites
46 minutes ago, cat6man said:

any suggestions?

Have you try rebooting AL after download was completed and system save to memory stick?

Share this post


Link to post
Share on other sites

The right and easy way in ramroot mode would be:

 

1) In UPDATE menu  2 "Install/Update HQPlayer embedded"

3) In UPDATE menu 14 "Save System (if in ram mode)"

 

Please be sure that you have enough RAM available.

If you see you still have the previous version, do the update in terminal mode, so you can see errors:

yay -Sy hqplayer-embedded --noconfirm


AudioLinux --> https://www.audio-linux.com

developer of AudioLinux realtime OS

Share this post


Link to post
Share on other sites
1 hour ago, elan120 said:

Have you try rebooting AL after download was completed and system save to memory stick?

 

nope, that doesn't do it

Share this post


Link to post
Share on other sites

If the above suggestion is not working, please do it in terminal with

yay -Sy hqplayer-embedded --noconfirm

You could have network down or RAM full


AudioLinux --> https://www.audio-linux.com

developer of AudioLinux realtime OS

Share this post


Link to post
Share on other sites
22 minutes ago, hifi25nl said:

The right and easy way in ramroot mode would be:

 

1) In UPDATE menu  2 "Install/Update HQPlayer embedded"

3) In UPDATE menu 14 "Save System (if in ram mode)"

 

Please be sure that you have enough RAM available.

If you see you still have the previous version, do the update in terminal mode, so you can see errors:

yay -Sy hqplayer-embedded --noconfirm

 

the first 'right and easy way' is what i had tried before.

 

with the 2nd terminal mode command, i got an error 'no space left on device' and it failed to create package.

so i guess i have enough ram to run audio-linux but not enough to update in ramroot mode.

 

for now i'll just go back to 241 installation and start from scratch........that's fine......just wanted to confirm i was doing it correctly

 

p.s. really excited about your new OS!!!!!!!!!!!!!

 

 

Share this post


Link to post
Share on other sites

Some news for Raspberry!

 

28/06/2020 Raspberry version 1.2 with the new Web Interface at ipaddress:5001 and full system update is now available!

 

29/06/2020 Raspberry menu version 103 with the new Web Interface at ipaddress:5001

If you have Audiolinux < 1.2, you should reboot and enable the new service with the option 6 "WEB INTERFACE 2 enable/disable" in EXPERT menu

 

30/06/2020 Raspberry menu 104 with:
1) New kernel update script. Now you can install new realtime kernel 5.4.45 or stable kernel 4.19.71
I think we are the first to compile 5.4.45 realtime kernel for Raspberry!
2) New option in EXPERT Menu for disabling HDMI
3) Fixes to Web Interface 2 scripts
4) New "IRQ monitor" in status menu


AudioLinux --> https://www.audio-linux.com

developer of AudioLinux realtime OS

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now



×
×
  • Create New...