Jump to content
lmitche

Audiolinux Server configurations, Software, Hardware, and Listening Impressions

Recommended Posts

On 3/28/2020 at 10:39 PM, Johnseye said:

My second question is how "Assign isolated core to applications" works with "Isolated CPU cores".  I run both Roon Server and HQPlayer Embedded.  Is it possible to give Roon 1 core and HQPlayer Embedded 2 of the 3 cores isolated for audio applications, while 1 of the cores is dedicated to the system?

 

Note: Messing with such things related to HQPlayer will certainly screw up HQPlayer's operation. So don't do it.

 


Signalyst - Developer of HQPlayer

Pulse & Fidelity - Software Defined Amplifiers

Share this post


Link to post
Share on other sites
2 hours ago, Miska said:

 

Note: Messing with such things related to HQPlayer will certainly screw up HQPlayer's operation. So don't do it.

 

 

HQPlayer doesn't respond well to having dedicated cores?  Or it performs better having access to all available cores?


Digital chain: Synology DS1815+ -> Modified Buffalo switch-> SOtM sNH-10G-> Custom Audiolinux server (sCLK-EX modified motherboard, Mutec REF 10)-> EtherRegen-> AL NUC NA (sCLK-EX modified)->  Holo Spring L3 -> Audio Research LS28-> Benchmark AHB2 -> Paradigm Persona 9H, JL Fathom sub

Power: Paul Hynes SR7, Uptone LPS-1.2, sPS-500, Topaz 91001-31 Isolation Transformer

Analog chain: VPI Prime with Ortofon Quintet Black cart -> Simaudio Neo 310LP-> Audio Research LS28-> Benchmark AHB2 -> Paradigm Persona 9H

Share this post


Link to post
Share on other sites
1 hour ago, Johnseye said:

 

HQPlayer doesn't respond well to having dedicated cores?  Or it performs better having access to all available cores?

John, there are indeed controls in Audiolinux to do what you want.  I used them in my builds for many years until recent versions of Roon. SQ significantly improved without any CPU pinning or dedicated cores in the January release. My guess is that Roon took control of resource allocation in an improved way, and AL just sounds best without constraints.

 

While I no longer use hqplayer, we do know that Jussi manages resources as well.

 

Given all this, I'd recommend staying away for these controls. There are plenty of other tweaks that you can explore that will raise sq with Audiolinux.


nuckleheadaudio.com

Share this post


Link to post
Share on other sites
12 hours ago, Johnseye said:

HQPlayer doesn't respond well to having dedicated cores?  Or it performs better having access to all available cores?

 

HQPlayer does it's own core allocation based on the CPU topology. And if that gets messed up the performance will suffer a lot.

 


Signalyst - Developer of HQPlayer

Pulse & Fidelity - Software Defined Amplifiers

Share this post


Link to post
Share on other sites

I have setup AL with ramroot. However, it often fails to load into RAM. It then says:

RAMROOT: Active: no - Configured: yes

Often I have to reboot a second time to get: 

RAMROOT: Active: no - Configured: yes

 

Any idea?


 

Share this post


Link to post
Share on other sites
2 hours ago, bodiebill said:

I have setup AL with ramroot. However, it often fails to load into RAM. It then says:

RAMROOT: Active: no - Configured: yes

Often I have to reboot a second time to get: 

RAMROOT: Active: no - Configured: yes

 

Any idea?

When I had this problem here is what Piero recommended:

 

Please reboot answering N at boot prompt and as root type:


mkinitcpio -p linux-rt
or
mkinitcpio -p linux-rt-bfq


depending on which kernel you use


then reboot once more allowing ram boot.
 


nuckleheadaudio.com

Share this post


Link to post
Share on other sites
On 4/20/2020 at 7:16 PM, lmitche said:

When I had this problem here is what Piero recommended:

 

Please reboot answering N at boot prompt and as root type:


mkinitcpio -p linux-rt
or
mkinitcpio -p linux-rt-bfq


depending on which kernel you use


then reboot once more allowing ram boot.

 

Thanks Imitche. Tried that a few days ago and occasionaly it still booted 'normally' (not from RAM). Not a big deal as a reboot corrects that, but maybe I will try what Piero recommended to me many months ago:

 

from command line:

sudo ramroot -D
sudo ramsave [when in RAM mode]
reboot
 

and then enable ramroot from scratch.


 

Share this post


Link to post
Share on other sites

@hifi25nl upon rebooting, when it asks to load root file system to zram if I choose 'N' it still loads to zram. It says "Loading / to zram..."

 

How can I prevent it from loading to ram? I would like to run some updates.

 

Thanks

 


Intel NUC NUC8i7BEH Roon Server running Audio Linux in RAM -> Sonore UltraRendu (Roon Endpoint) -> Uptone ISO Regen -> Singxer SU-1 KTE -> Holo Audio Spring Level 3 DAC -> Nord One UP Monoblocks -> Spendor LS3/5as | Music controlled via iPad (Power Conditioning: Audience adeptResponse aR12).  Twitter: @hirezaudio

Share this post


Link to post
Share on other sites

Is anyone running A-L with expert settings like managing individual cores, priorities, etc?

 

From threads about the Taiko Extreme, there are occasional mentions of tuning the system by

doing something to the cores but no details (I would assume they are considered proprietary).

Using high power PCs seems to be the consensus of a lot of folks (i'm reading between the lines here) who have experimented a lot and

it appears (?) that keeping the individual cores very lightly loaded is important, i.e. having each core idle and ready to do whatever is needed immediately.   Is there any way for us to identify which processes are using which cores?  Is there a way to better distribute the processes to cores?  Is it measurable?  As cpu occupancy?  As something else?

 

Besides cores, what else is important for an expert fine tuning?

 

 

Share this post


Link to post
Share on other sites

fyi..........new 2.4.1 version available for download.

 

everyone must be at home downloading it as the download is going pretty slow here, est. 2-4 hours

 

Share this post


Link to post
Share on other sites
30 minutes ago, cat6man said:

fyi..........new 2.4.1 version available for download.

 

everyone must be at home downloading it as the download is going pretty slow here, est. 2-4 hours

 

Thanks for the heads up. Here in The Netherlands it downloaded in less than a minute.


 

Share this post


Link to post
Share on other sites

Thanks for the update Piero. After updating system and Kernel I can see the Kernel is now 5.6.4-3 is there a way of confirming system is 4.4.0?

Also I run a server with AL and HQP to a NUC with HQP naa, I have been unable to get internet radio to play on my system could someone advise me how to achieve this please?

 

 

 

Share this post


Link to post
Share on other sites

You can check the original version of the installation with the command

cat /etc/motd

When updating with the options in update menu, the version remains that of the original installation.

 

You can have Internet radio with Roon,  LMS in headless and various other options in lxqt version, for example vlc-tunein-radio, a plugin for vlc player.

 

 


AudioLinux --> https://www.audio-linux.com

developer of AudioLinux realtime OS

Share this post


Link to post
Share on other sites

There's a bug at the new LQXT version's boot menu. It starts the command line by deafult. How can I change it to the windowed mode?

Share this post


Link to post
Share on other sites

I just checked and the default is fine.

 

If by chance you have changed it pressing inadvertently some key on the keyboard, go to audiolinux line and press D. This will restore the default boot option.

Unless there is a problem with graphic card....


AudioLinux --> https://www.audio-linux.com

developer of AudioLinux realtime OS

Share this post


Link to post
Share on other sites

Hi

is there a way to bring Audiolinux headless in standby or sleep mode and wake it up without a mouse? And or is it possible to power it down and stop Roon from scanning the hole library every time at startup...

 

i have a Xeon server one box setup with HQPlayer and Roon in Rammode...

 

thanks for helping 

Share this post


Link to post
Share on other sites

i am running both old and new version of audio-linux here.  the new version has a built in menu command for upgrading to the latest hqplayer-embedded.

 

for the older version, is there any reason i can't use the following, per old postings?

 

yaourt -S hqplayer-embedded

 

 

Share this post


Link to post
Share on other sites
15 hours ago, hifi25nl said:

A revolutionary kernel is on testing. Stay tuned!

 

if revolutionary <==> even better sound, can't wait for some details :)

Share this post


Link to post
Share on other sites

Good weekend everybody ...

Recently build a new PC, I'm a loyal HQPlayer user, since I am using a fanless chassis with TDP constraints I decided to use a 3800X, I know the AMD platform is not the best for HQPlayer but I was expecting with such CPU to be at least able to run ASDM7EC with DSD256 pushing it at its limits.

I installed latest AL, did all the updates including kernel, currently running 5.4.19-rt11-1-rt-bfq, changed from pstate to acpi, I am not doing any expert or realtime features just the default config, nor isolation cores or such.

When running HQPlayer with 7EC and DSD256 it stutters every 14 seconds or so. 2 cores are maxed out at 99% the remaining 6 will be at 38% average.

image.thumb.png.bcd7634aea73371dcf66d428186b43a5.png

I know there are issues with AMD preferred cores etc. it is just the difference is so pronounced that I wonder if my issue is a limitation completely of the CPU or the OS in this case, maybe there is a tweak which will allow to get more out of the unused cores.

If anyone has a clue on this feedback will be greatly appreciated.

 

Share this post


Link to post
Share on other sites
Plese be sure that there is nothing extreme in your configuration (priority, boot) set cpu governor to performance or max frequency turbo on and set hqplayer buffer to 250.
 
... And please test without Roon, I see a lot of threads there. If Roon is scanning library a lot of resources are lost. 

AudioLinux --> https://www.audio-linux.com

developer of AudioLinux realtime OS

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now



×
×
  • Create New...