Jump to content
lmitche

Audiolinux Server configurations, Software, Hardware, and Listening Impressions

Recommended Posts

Hi all,

 

I'm looking at how to change the period_count and buffer_size parameters in alsa for use with mpd and upmpdcli. I tried to add the parameters in .mpdconf but this does not work.

 

My .mpdconf :

audio_output {                                                                                                                              
        type            "alsa"                                                                                                              
        name            "PCM"                                                                                                               
        device          "hw:1,0"                                                                                                            
        auto_resample   "no"                                                                                                                
        auto_format     "no"                                                                                                                
        mixer_type      "disabled"                                                                                                          
        buffer_size     "100"                                                                                                               
        period_count    "3"                                                                                                                 
}    

 

What plays :

 

[[email protected] ~]$ more /proc/asound/card1/pcm0p/sub0/hw_params                                                                     
access: RW_INTERLEAVED                                                                                                                      
format: S24_3LE                                                                                                                             
subformat: STD                                                                                                                              
channels: 2                                                                                                                                 
rate: 44100 (44100/1)                                                                                                                       
period_size: 5513                                                                                                                           
buffer_size: 22050  

Any idea on what is needed to change those settings. I used to play a lot with those in Daphile and would like to try them on this config.

 

Thanks

David

 

Share this post


Link to post
Share on other sites

Hello, I use a jcat network netcard under audiolinux. It seems that JPLay is providing under windows some tweaks for this network card (see attachment). Marcin, under the jcat thread is mentioning that he has limited knowledge on linux. According to you is it possible to tweak the same parameters under audiolinux ? 

 

best regards 

JCAT_NET_getting_the_most.pdf


patatorz.com / Leedh E2 glass / dCS Vivaldi / JCAT Netcard Femto / Cybershaft OP21A / Ypsilon Phaethon

Share this post


Link to post
Share on other sites

I have not succedded in installing hqplayer-embedded.

 

The yay -Sy hqplayer-embedded command shows errors :

 

 
error: failed retrieving file 'polkit-0.116-4-x86_64.pkg.tar.zst' from mirrors.evowise.com : The requested URL returned error: 404
error: failed retrieving file 'polkit-0.116-4-x86_64.pkg.tar.zst' from mirror.rackspace.com : The requested URL returned error: 404
error: failed retrieving file 'polkit-0.116-4-x86_64.pkg.tar.zst' from mirror.rackspace.com : The requested URL returned error: 404
warning: failed to retrieve some files
 
 
and it ends with :
error: failed to commit transaction (unexpected error)
Errors occurred, no packages were upgraded.
Error installing repo packages
 
Is there an issue with the package ?
 

Share this post


Link to post
Share on other sites

This can happen for various reasons:

 

1) Archlinux servers are not in sync yet. Wait the next day...

2) You need a full system update before with

yay -Syu --noconfirm

3) For some reason the worldwide servers are blocked. 

 

In all cases is a good idea to switch to the servers of your country.

Go to SYSTEM menu and select File editor ROOT
Edit /etc/pacman.d/mirrorlist pressing F4
Put a # in front of worldwide servers
Remove # in front of the servers you want (those of your country)
Save with F4

Update database with

yay -Syy --noconfirm

 

EDIT: before switching servers is better to clean the already downloaded packages with

yay -Scc --noconfirm
 


AudioLinux --> https://www.audio-linux.com

developer of AudioLinux realtime OS

Share this post


Link to post
Share on other sites

Thanks Piero, it worked now.

 

It is available on port 8088, however, I can't see in the list of upnp devices in bubbleupnpserver. Is there something to do to get it HQPlayer as an upnp renderer ?

 

 

 

Share this post


Link to post
Share on other sites

Does AL auto-negotiate network speed or must it be set in a config file?

 

I am adding an EtherRegen to my system and its "B" side runs at 100Mbps which will feed my AL NUC.

 

Currently I have a straight bridged connection from my server at 1G so I am trying to anticipate issues.

 

Really looking forward to this addition!

 

 



"Don't Believe Everything You Think"

System

Share this post


Link to post
Share on other sites

I am getting data noise coming thru my system.  Using a NUC - Holo Spring - Crack.

Any ideas how it comes in and how to eliminate?


TIDAL - ROON - Audiolinux - HQPlayerD - NUC DNKE - NUC PJYH - Signature Silver - Keces PS - Lush - Holo Spring Dac Level 3 - Bottlehead Crack Upgraded - HD-650 - N400 - GR Research V2 - Dennis Murphy Pioneer BS22.

Share this post


Link to post
Share on other sites
30 minutes ago, cat6man said:

is hqpe 4.15.0 available for updating?

Yes, did the update last night.

Share this post


Link to post
Share on other sites
46 minutes ago, elan120 said:

Yes, did the update last night.

thanks

Share this post


Link to post
Share on other sites
On 2/14/2020 at 9:57 AM, hifi25nl said:

Please check the content of /etc/fstab

 

I have discovered a problem in UUID assignment, so the mount script will not work correctly. The reason is that a command with last updated version of util-linux is giving a different output.
I will fix it in the next Audiolinux menu release.

If you want to fix it now you can change manually the line in /opt/scripts/local_mount.sh (as root) from
UUID="$(lsblk -f | grep "$drive" | awk '{ print $4 }')"
to
UUID="$(lsblk -f | grep "$drive" | awk '{ print $5 }')"

 

-> I have been working a lot on the new web interface, now  beta version is almost ready! Now easy to use with touch screen and with search function!

 

 

 

 

I have the same problem.

 

I downloaded the new 4.3 image. I mount a drive I can see the contain but after a rebbot everything disappears and the script has the modification ($5).

Share this post


Link to post
Share on other sites
21 hours ago, hifi25nl said:

The only way to see what's happening is to send me the content of the file /etc/fstab.

 

If you want to fix it yourself take a look here:

https://www.audio-linux.com/html/mount.html

 

 

I' very angry. I spent min. 8 hours to find out what is it.

 

I'm not 100% percent sure but quite I am.

 

I bought 2 pieces from this: https://www.amazon.com/Patriot-128GB-Supersonic-Transfer-Speeds/dp/B07NLNJB9C

 

Patriot 128GB Supersonic Rage Elite USB 3.1 Type A, USB 3.0 Flash Drive with Transfer Speeds of Up to 400MB/sec

 

These are high quality, extreme fast drives with good reputation.

 

But.

 

Both are useless to use with AL. I can write the image with Rufus on the drives but it works so slowly and with full of animalities, for example this mounting problems and many others. I took may 16GB Sandisk drive and I could without any problem install to it and I can use it. This is stabil and fast now, works as it should be.

 

 

 

Share this post


Link to post
Share on other sites

I bought a new Kingston USB drive, it seems ok, but I have another problem with mounting.

 

It mounts automatically drives under run/media/audiolinux/

 

Why is that? How can I turn it off?

Share this post


Link to post
Share on other sites
5 hours ago, hifi25nl said:

i guess you are using lxqt version. Go to file explorer (pcmanfm) and in preferences disable automount

 

Yes, this is the lqxt version and we've been one through this with the 3.X version, this was the first thing I checked and the automountig isn't checked.

Share this post


Link to post
Share on other sites

hi,

 

is hqplayer embedded 4.15.2 available?

this seems to have some important start/stop fixes

 

thanks

 

Share this post


Link to post
Share on other sites

Looking for some guidance on how Audiolinux treats CPU cores for audio applications.  When I select "All but the first" exclusively for audio I get one processor available in Roon.  If Audiolinux considers Roon an audio application wouldn't it have 3 processors available?

 

My second question is how "Assign isolated core to applications" works with "Isolated CPU cores".  I run both Roon Server and HQPlayer Embedded.  Is it possible to give Roon 1 core and HQPlayer Embedded 2 of the 3 cores isolated for audio applications, while 1 of the cores is dedicated to the system?

 

What combinations have you tried with core isolation and what are your impressions?


Digital chain: Synology DS1815+ -> Modified Buffalo switch-> SOtM sNH-10G-> Custom Audiolinux server (sCLK-EX modified motherboard, Mutec REF 10)-> EtherRegen-> AL NUC NA (sCLK-EX modified)->  Holo Spring L3 -> Audio Research LS28-> Benchmark AHB2 -> Paradigm Persona 9H, JL Fathom sub

Power: Paul Hynes SR7, Uptone LPS-1.2, sPS-500, Topaz 91001-31 Isolation Transformer

Analog chain: VPI Prime with Ortofon Quintet Black cart -> Simaudio Neo 310LP-> Audio Research LS28-> Benchmark AHB2 -> Paradigm Persona 9H

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now



×
×
  • Create New...