Jump to content
lmitche

Audiolinux Server configurations, Software, Hardware, and Listening Impressions

Rate this topic

Recommended Posts

one issue found here.

 

with AL1.0, i was very happy to use the HQPD controller app on my android phone and tablet to choose my music.

 

with AL2.1, i can no longer get the HQPD controller app to connect to the NUC running hqplayer embedded.

i know that the devices can connect via a browser.

a direct browser login to HQPlayer-embedded at 192.168.1.xxx:8088 works fine but HQPD controller running on the same devices now fails to connect, so something changed in how hqpd controller app needs to access hqplayer-embedded in 2.1

 

cheers

 

 

Share this post


Link to post
Share on other sites

HQPlayer is playing from HQPDcontrol now as I am writing this post. 

 

Please check Host in settings and refresh database in HQPDcontrol.

It is also better to stop HQPlayer and restart it after a change of configuration.

 


AudioLinux --> https://www.audio-linux.com

developer of AudioLinux realtime OS

Share this post


Link to post
Share on other sites
18 minutes ago, hifi25nl said:

HQPlayer is playing from HQPDcontrol now as I am writing this post. 

 

Please check Host in settings and refresh database in HQPDcontrol.

It is also better to stop HQPlayer and restart it after a change of configuration.

 

 

host is fine, but i get a 'connecting to 192.168.1.xxx' constantly at the bottom of the page.

normally, that message comes up and disappears after 1 second.

 

i'm re-scanning my whole music library now, and will try to refresh database in hqpdcontrol when it finishes.

Share this post


Link to post
Share on other sites

hqpdcontrol shows 'connecting to 192.xxx.xxx.xxx' for 1 second, it disappears like it has connected, then comes back and stays on as if it lost it and cannot reconnect

 

running v4.2.0 of hqpdcontrol

Share this post


Link to post
Share on other sites

re-booted with AL1.0 and the app connects and works fine

re-booted wtih AL2.1 and now app connects and works fine

 

no idea what the problem was..............i had tried rebooting AL2.1 multiple times without success, but after this sequence it worked.

 

seems ok now

 

Share this post


Link to post
Share on other sites

question:

if i'm running in ramroot, and i update the hqplayer library via hqplayer-embedded interface (ip:8088), is it saved?

do i have to re-build ramroot?  or maybe i need to exit ramroot, update library, then re-enable ramroot?

 

Share this post


Link to post
Share on other sites
19 hours ago, Emmings said:

Just want to say a HUGE thank you to Piero for the hotfix

Thanks from me too. Updating to menu 208 solved my instability with orange and green profile.

 

Share this post


Link to post
Share on other sites

Over here, I've just started a comparison between AL2 kernel 5 with and without the BFQ scheduler on my NUC endpoint vs. Euphony Stylus/EP. The two AL configs do sound different and curiously without BFQ AL2 sounds very much like Euphony Stylus/EP.

 

I haven't changed my preference for AL2 BFQ but it is early days. Stay tuned.

 

Larry

 


nuckleheadaudio.com

Share this post


Link to post
Share on other sites
29 minutes ago, lmitche said:

Over here, I've just started a comparison between AL2 kernel 5 with and without the BFQ scheduler on my NUC endpoint vs. Euphony Stylus/EP. The two AL configs do sound different and curiously without BFQ AL2 sounds very much like Euphony Stylus/EP.

 

I haven't changed my preference for AL2 BFQ but it is early days. Stay tuned.

 

Larry

 

 

BFQ scheduler?

i assume that is default ON in latest AL2?

probably somewhere in the thread, but where in menu is this selectable?

Share this post


Link to post
Share on other sites
34 minutes ago, cat6man said:

 

BFQ scheduler?

i assume that is default ON in latest AL2?

probably somewhere in the thread, but where in menu is this selectable?

The BFQ scheduler has been the default as long as I can remember. One can choose between the two on the kernel update menu.

 

I made three USB sticks, one for each config, so it's easy to switch between them.


nuckleheadaudio.com

Share this post


Link to post
Share on other sites
6 hours ago, lmitche said:

The BFQ scheduler has been the default as long as I can remember. One can choose between the two on the kernel update menu.

 

I made three USB sticks, one for each config, so it's easy to switch between them.

Very interesting... have you developed a preference yet? Can you briefly describe the difference in sound with and without the BFQ scheduler?

Share this post


Link to post
Share on other sites
15 minutes ago, lmitche said:

Not yet. I do prefer AL2 BFQ over Euphony Stylus/EP. They both sound great, with ES/EP sounding a bit more technically correct but find AL2 BFQ is just more musically engaging.

 

I am hoping AL2 non-BFQ has elements of both. Time will tell.

Ok thanks... I might give it a listen myself 👍

Share this post


Link to post
Share on other sites

I am working now on Audiolinux Raspberry pi 4 with 4GB RAM. 

Finally a good Raspberry for Audio without the problems on USB of previous version.

 

I managed to compile Raspberry kernel 4.19.x with real-time patch for Archlinux  (it was quite a work!) and I have already tested the CPU latency performance: 6 times less than in Pi 3 with an absolute value comparing well with standard PC!

 

Moreover I did manage to enable ramroot with a little extra configuration (only version 4 GB) and is working very well. 

 

At last the new pi 4 will have practically all options of standard headless Audiolinux plus some additions for Raspberry.

 

Audiolinux Raspberry pi 3 version 1.0 is already out! With menu similar to Audiolinux headless and many updates. So also profiles for example.

 

SPECIAL OFFER for previous subscribers to Raspberry Audiolinux:
1) Update to versions 1.0 Pi 3  + Pi 4 for the special price of 30 $ paid directly to [email protected] with PayPal. This will add an extra year to your subscription.
2) With 60 $ you can have Raspberry unlimited time support for both versions.

 


AudioLinux --> https://www.audio-linux.com

developer of AudioLinux realtime OS

Share this post


Link to post
Share on other sites

Hello Piero,

 

i have a friend who changed the pi3 of the metrum ambre for the pi4. I bringed my ambre with my pi3 and we used the same OS (sorry gentooplayer as it was available for both pi3 and pi4). The result was really great with the pi4 versus the pi3 on the system of the friend : more details, more fluidity and more weight. I need now to convert my ambre with the pi4.

 

I also have the 4go version so would be happy to test the ram root 🙂

 

im ready for testing if needed.


patatorz.com / Leedh E2 glass / dCS Vivaldi / Ypsilon Phaethon

Share this post


Link to post
Share on other sites

Just installed the AudioLinux 1.0 for Pi4 on my Metrum Ambre. Seems ok as of now. Will start to play with settings.

 

Thanks Piero


patatorz.com / Leedh E2 glass / dCS Vivaldi / Ypsilon Phaethon

Share this post


Link to post
Share on other sites
On 11/17/2019 at 4:05 PM, lmitche said:

Not yet. I do prefer AL2 BFQ over Euphony Stylus/EP. They both sound great, with ES/EP sounding a bit more technically correct but find AL2 BFQ is just more musically engaging.

 

I am hoping AL2 non-BFQ has elements of both. Time will tell.

 

Any additional comments regarding SQ?  I've not yet installed AL2 but am planning to soon.  Thx.

Share this post


Link to post
Share on other sites
On 12/1/2019 at 2:44 PM, lpost said:

 

Any additional comments regarding SQ?  I've not yet installed AL2 but am planning to soon.  Thx.

OK, to my ears AL2.0 Roonserver/Roonbridge endpoint both without the BFQ scheduler and AL2.0 Roonserver without BFQ/Euphony Stylus sound pretty much the same. They are very close. Its a matter of taste which is best.

 

Having said that, I like AL2.0 Roonserver without BFQ and AL2.0 Roonbridge with BFQ better. This configuration just sounds more musical to me. YMMV

 

I did go back to all BFQ, and determined the server just sounds better without.

 


nuckleheadaudio.com

Share this post


Link to post
Share on other sites
21 hours ago, lmitche said:

After writing this I realized that my configuration was less than optimal. After fixing that oversight, the AL2.0 real-time, non-BFQ config on both the Roonserver and endpoint running Roonbridge beats all other options. It is the most natural and coherent of the options tested here today.

 

Thanks, wanted to try this configuration, however run into a problem:

I am running ramroot mode. When rebooting and trying to say no to copying the system to ram, I can press 'n' as much as I like, but nothing happens, so it goes ahead to copy to ram again. I tried several usb ports and several keyboards. @hifi25nl Any idea?


 

Share this post


Link to post
Share on other sites
52 minutes ago, bodiebill said:

I tried several usb ports and several keyboards. @hifi25nl Any idea?

 

I experience the same though I'm not yet running AL2 rather ALprevious, for what it's worth.  Frustrating.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now



×
×
  • Create New...