Jump to content
lmitche

Audiolinux Server configurations, Software, Hardware, and Listening Impressions

Rate this topic

Recommended Posts

I am just uploading a 16 GB version. Wait at least 30'

Remember that the size of your target drive could be less than 16, even if the manufacturer declare otherwise.

 

HOTFIX only for headless version: please update menu to version 201


AudioLinux --> https://www.audio-linux.com

developer of AudioLinux realtime OS

Share this post


Link to post
Share on other sites

I have got audiolinux 2.0 up and running on my endpoint NUC and so far I'm liking the sound quality change very much.... It seems to be smoother, less forced with more ease and a cleaner sound....and I don't even have ramroot working yet.

 

All I need running on this NUC is roonbridge so I'm going to have to remove all unused applications to try and get ramroot working on my 4gb RAM.

 

Last time I used yaourt to remove roon server and hqplayer.... what can I use with audiolinux 2.0? What commands and syntax do I need to get right to remove all applications except for roon bridge?

Share this post


Link to post
Share on other sites

Hello, just installed the 2.0 on my new setup (Supermicro / Xeon / M2 Samsung 970 evo plus). No problem so far and very smooth. I will deep dive like @Bricki in the sound quality and the different options.

 

Great job Piero !


patatorz.com / Leedh E2 glass / dCS Vivaldi / Ypsilon Phaethon

Share this post


Link to post
Share on other sites
1 hour ago, Bricki said:

Last time I used yaourt to remove roon server and hqplayer.... what can I use with audiolinux 2.0? What commands and syntax do I need to get right to remove all applications except for roon bridge?

 

The best way is 

pacman -R application-name 

as root

 

If you want also to remove some dependencies:

pamac remove application-name -o

as user. A little dangerous since it could remove too much... best to do before configuring Audiolinux.


AudioLinux --> https://www.audio-linux.com

developer of AudioLinux realtime OS

Share this post


Link to post
Share on other sites
3 hours ago, Bricki said:

I have got audiolinux 2.0 up and running on my endpoint NUC and so far I'm liking the sound quality change very much.... It seems to be smoother, less forced with more ease and a cleaner sound....and I don't even have ramroot working yet.

 

All I need running on this NUC is roonbridge so I'm going to have to remove all unused applications to try and get ramroot working on my 4gb RAM.

 

Last time I used yaourt to remove roon server and hqplayer.... what can I use with audiolinux 2.0? What commands and syntax do I need to get right to remove all applications except for roon bridge?

 

Hi Bricki, which profile do you use ?

 

BR


patatorz.com / Leedh E2 glass / dCS Vivaldi / Ypsilon Phaethon

Share this post


Link to post
Share on other sites
4 hours ago, Patatorz said:

 

Hi Bricki, which profile do you use ?

 

BR

I have been using the auto profile and making my own menu selections back to my favorite settings👍

Share this post


Link to post
Share on other sites
7 hours ago, hifi25nl said:

 

The best way is 

pacman -R application-name 

as root

 

If you want also to remove some dependencies:

pamac remove application-name -o

as user. A little dangerous since it could remove too much... best to do before configuring Audiolinux.

I am still struggling to get it small enough to use ramroot on 4gb. I have used pacman to remove hqplayer-embedded, hqplayer-network-audio-daemon and roonserver. Last time this was enough to get ramroot working.

 

Should I start again with the new 16gb image or will that have no impact on the ramroot size?

 

Are there any other installed applications I can delete? I tried airplay but it wasn't found.

 

I also tried to remove dependencies but I think that because I already removed the applications with pacman it didn't work... should I try again with new image and use pamac with the -o option

Share this post


Link to post
Share on other sites

Try to remove some dependencies left, no necessary to reinstall (a little risky, as I said before)

pamac remove ffmpeg libgmpris rygel adduser-deb shairport-sync -o

(pay attention to what is removing before pressing Y)

 

-> shairport-sync is linux AirPlay


AudioLinux --> https://www.audio-linux.com

developer of AudioLinux realtime OS

Share this post


Link to post
Share on other sites
12 minutes ago, hifi25nl said:

Try to remove some dependencies left, no necessary to reinstall (a little risky, as I said before)

pamac remove ffmpeg libgmpris rygel adduser-deb shairport-sync -o

(pay attention to what is removing before pressing Y)

 

-> shairport-sync is linux AirPlay

Excellent thanks👍... I will try these tonight and let you know tomorrow

Share this post


Link to post
Share on other sites

@hifi25nl -- i'm running into an issue with v2.  i use AL with roon server on a nuc 8i5.  the issue is that roon server crashes. it was happening initially when i was trying to restore the roon database, but got around that by not changing any default settings within AL (couldn't import the databse with the "red" profile OR if i updated roon).  by not changing any of the default settings, i was able to restore the database, but roon now crashes after a few seconds of playing a song.

 

i did update the system in this order:

* update AL menu and then rebooted

* update system and then rebooted

* update kernel and then rebooted

 

thoughts?  unfortunately, AL v2 isn't usable for me at this point.


source:  intel nuc8i5 (roon rock) > intel nuc6i5 (win 10, ao, roon bridge, dirac v1) > schiit yggdrasil (gen 5, analog 2)
headphone rig:  bryston bha-1 > senn hd600
two-channel rig:  luminous audio axiom ii xlr walker mod > parasound a21 > monitor audio gx100

Share this post


Link to post
Share on other sites
8 minutes ago, jcn3 said:

@hifi25nl -- i'm running into an issue with v2.  i use AL with roon server on a nuc 8i5.  the issue is that roon server crashes. it was happening initially when i was trying to restore the roon database, but got around that by not changing any default settings within AL (couldn't import the databse with the "red" profile OR if i updated roon).  by not changing any of the default settings, i was able to restore the database, but roon now crashes after a few seconds of playing a song.

 

i did update the system in this order:

* update AL menu and then rebooted

* update system and then rebooted

* update kernel and then rebooted

 

thoughts?  unfortunately, AL v2 isn't usable for me at this point.

Which version of the menu are you running?

 

Menu 2.1 is likely to fix this issue.

 

Larry


nuckleheadaudio.com

Share this post


Link to post
Share on other sites
25 minutes ago, lmitche said:

Which version of the menu are you running?

 

Menu 2.1 is likely to fix this issue.

 

Larry

 

first thing i did was update the menu, the system, and the kernel -- so unfortunately menu 2.1 didn't help.


source:  intel nuc8i5 (roon rock) > intel nuc6i5 (win 10, ao, roon bridge, dirac v1) > schiit yggdrasil (gen 5, analog 2)
headphone rig:  bryston bha-1 > senn hd600
two-channel rig:  luminous audio axiom ii xlr walker mod > parasound a21 > monitor audio gx100

Share this post


Link to post
Share on other sites
11 minutes ago, jcn3 said:

 

first thing i did was update the menu, the system, and the kernel -- so unfortunately menu 2.1 didn't help.

What does, $systemctl | grep rtapp, return?


nuckleheadaudio.com

Share this post


Link to post
Share on other sites

Please

Check memory:

free --giga

Check hard disk space:

df -H 

After check periodically the status of roonserver:

systemctl status roonserver

Be sure that roonserver is the ONLY service enabled:

-> Go to Audio menu, stop all services and re-enable roonserver

 

It could also be the "Roon linux bug" (not yet fully resolved by Roon). Typically is solved restarting  Roon after boot.

 

For further questions contact me at support address. 

 


 

 


AudioLinux --> https://www.audio-linux.com

developer of AudioLinux realtime OS

Share this post


Link to post
Share on other sites
28 minutes ago, hifi25nl said:

Please

Check memory:

free --giga

Check hard disk space:

df -H 

After check periodically the status of roonserver:

systemctl status roonserver

Be sure that roonserver is the ONLY service enabled:

-> Go to Audio menu, stop all services and re-enable roonserver

 

It could also be the "Roon linux bug" (not yet fully resolved by Roon). Typically is solved restarting  Roon after boot.

 

For further questions contact me at support address. 

 


 

 

 

i boot from a 32g usb drive.  nuc has 16g of ram.  here's the memory:

 

image.png.bbc5571f85f1093990a9ca5efd39da25.png

 

roon is pretty hosed right now, here's the output from "show audio services".  i get the same after stopping all audio services and restarting roon server.

 

image.png.3ae443fef894b4520268cffac05100c0.png

 

here's the output from systemctl status roonserver right after i stopped audio services, restarted roon server, and then played a song (which crashed after 5 sec):

 

image.png.3c540efcc86ed09b01bb9982f8c2bade.png

 

 

image.png


source:  intel nuc8i5 (roon rock) > intel nuc6i5 (win 10, ao, roon bridge, dirac v1) > schiit yggdrasil (gen 5, analog 2)
headphone rig:  bryston bha-1 > senn hd600
two-channel rig:  luminous audio axiom ii xlr walker mod > parasound a21 > monitor audio gx100

Share this post


Link to post
Share on other sites

Did you check free hard disk space with df -H?

 

Check also

systemctl status rtapp.timer

It should be disabled

 

You should check also:

networkctl

Systemd network does not like unconfigured interfaces. If possible, if you have more than one network card, disable it in BIOS and disable WiFi

 

Is the output of 

ls -l /var/roon

like this one?
drwxr-xr-x 4 root root 4096 13 ago 16.55 RAATServer
drwxr-xr-x 5 root root 4096 13 ago 16.55 RoonBridge
drwxr-xr-x 3 root root 4096 13 ago 16.32 RoonGoer
drwxr-xr-x 7 root root 4096  2 nov 16.16 RoonServer

 

Note: in general it is recommended to rebuild database from scratch with new installation.

 

I don't have other reports of Roon malfunctioning until now and in my 2 systems Roon is working fine.

 

EDIT: if you have enabled ramroot before, be sure that roon "ramroot service" is disabled

systemctl status roonserver2

 


AudioLinux --> https://www.audio-linux.com

developer of AudioLinux realtime OS

Share this post


Link to post
Share on other sites
35 minutes ago, hifi25nl said:

Did you check free hard disk space with df -H?

 

Check also

systemctl status rtapp.timer

It should be disabled

 

You should check also:

networkctl

Systemd network does not like unconfigured interfaces. If possible, if you have more than one network card, disable it in BIOS and disable WiFi

 

Is the output of 

ls -l /var/roon

like this one?
drwxr-xr-x 4 root root 4096 13 ago 16.55 RAATServer
drwxr-xr-x 5 root root 4096 13 ago 16.55 RoonBridge
drwxr-xr-x 3 root root 4096 13 ago 16.32 RoonGoer
drwxr-xr-x 7 root root 4096  2 nov 16.16 RoonServer

 

Note: in general it is recommended to rebuild database from scratch with new installation.

 

I don't have other reports of Roon malfunctioning until now and in my 2 systems Roon is working fine.

 

EDIT: if you have enabled ramroot before, be sure that roon "ramroot service" is disabled

systemctl status roonserver2

 

 

not running ramroot -- i always do that last when things are sorted out.  it's not reasonable to rebuild the roon database from scratch -- all of the items added to your library from tidal or qobuz will be gone -- not clear why a restore would create a problem.

 

here's df -H

image.png.fc80b118168fa35dc175eb490830ba32.png

 

here's systemctl status rtapp.timer

image.png.a487b06e0c84e825585f6b852dccc4ab.png

 

here's networkctl

image.png.d4e1251becf50366f8729feaae62a210.png

 

here's ls -l /var/roon (i'm not running roonbridge)

 

image.png.9f63205bf3307b7153e909eabe738b48.png

 


source:  intel nuc8i5 (roon rock) > intel nuc6i5 (win 10, ao, roon bridge, dirac v1) > schiit yggdrasil (gen 5, analog 2)
headphone rig:  bryston bha-1 > senn hd600
two-channel rig:  luminous audio axiom ii xlr walker mod > parasound a21 > monitor audio gx100

Share this post


Link to post
Share on other sites

As you can see you are out of drive space!

Look at /dev/sda2. 100% use

Like this the system cannot work and you must reinstall because this can produce unrecoverable errors on files.

 

As clearly stated on website: 

6) Launch gparted and extend the ext4 partition until covering the remaining part of the hard disk (this will fix also GPT size errors. note that you will need more than the default size for Roon database)

 

 

 


AudioLinux --> https://www.audio-linux.com

developer of AudioLinux realtime OS

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...