Jump to content
lmitche

Audiolinux Server configurations, Software, Hardware, and Listening Impressions

Rate this topic

Recommended Posts

 Thank you for the quick response I will try it.   I will try rebooting and reloading first. 

 But, if it does not work I do not know how to find directories to find the .config file in Linux. 

 Will you please look at my other screenshots to see if my settings look OK. 

 What is one time network time service? 

 What is one time I RQ thread? 

 I have never seen these two lines before, are they new? 

 The first screen shows my CPU speed has 3.9 GHz max.   Recommended 3.5 GHz max.  Is that what CPU speed 3500.009 is?

 Is that correct for boot mode standard? 

Share this post


Link to post
Share on other sites

 I loaded the new kernel and the ACPI driver. 

 At first I thought it was going to take me a minute to learn how to hear this new sound.   There’s more energy to it, like pushing out a strong breath.

 I’m not playing the music that impresses me technically, I’m playing my old favorites to see if they give me the emotional response like they used to when I first heard them  on a record.

Share this post


Link to post
Share on other sites
On 6/14/2019 at 8:34 AM, hifi25nl said:

3 is for CPU0 and CPU1, if all other cores are isolated (CPU2 CPU3 etc.)

 

If you have all cores less the first (CPU0) isolated, the right value should be 1 

Hello Everyone, I'm trying to optimize my AL config following this thread, I have followed Piero's comments and others but still need some help.

 

ENABLING CORES FOR AUDIO (italics are actual text from AL)

How many cores do you want to use exclusively for audio?
1) All but the first
2) Half
3) Only one (random, excluding first)
4) Disable

I select 1 as I would like to use 3 cores for audio and 1 for system

But it shows this

ISOLATED CPU CORES FOR AUDIO: 1

Which confuses me as I understand only ONE core for audio, which statement is correct in this case?

And even more confusing is the cpumask output which is not a number but an F

[[email protected] ~]$ cat /sys/bus/workqueue/devices/writeback/cpumask
f

 

ENABLING REALTIME EXPERT CONFIG

This specific option is on the default, what is your experience with it? leave it on or off?
echo 0 >/sys/devices/system/machinecheck/machinecheck3/check_interval

 

Thanks

Share this post


Link to post
Share on other sites

How many physical cores do you have? If you have only 2 this is correct.

Isolated cores will disable hyper-threading so if you have core0 and core1 only, if you select all but the first, you should have only the second core (1) isolated.

 

If you have more than 2 physical cores, for example 4, please check the file /boot/loader/entries/audiolinux.conf

You should have isolcpus=1-3 in the kernel line


AudioLinux --> https://www.audio-linux.com

developer of AudioLinux realtime OS

Share this post


Link to post
Share on other sites
24 minutes ago, hifi25nl said:

How many physical cores do you have? If you have only 2 this is correct.

Isolated cores will disable hyper-threading so if you have core0 and core1 only, if you select all but the first, you should have only the second core (1) isolated.

 

If you have more than 2 physical cores, for example 4, please check the file /boot/loader/entries/audiolinux.conf

You should have isolcpus=1-3 in the kernel line

Thanks Piero, of course HT is disabled, only 2 cores so 1 used for audio

 

It is correct, thanks for the assistance

 

Oh this option

echo 0 >/sys/devices/system/machinecheck/machinecheck3/check_interval

Is it recommended?

 

 

Share this post


Link to post
Share on other sites

I would try all...:

 

echo 1000 > /proc/sys/vm/stat_interval
echo 0 > /sys/bus/workqueue/devices/writeback/numa
echo 1 > /sys/bus/workqueue/devices/writeback/cpumask
echo -1 > /proc/sys/kernel/sched_rt_runtime_us
echo 0 >/sys/devices/system/machinecheck/machinecheck3/check_interval
echo 0 > /proc/sys/kernel/watchdog
echo 0 > /proc/sys/kernel/nmi_watchdog

echo 1500 > /proc/sys/vm/dirty_writeback_centisecs
 

The line echo 1 > /sys/bus/workqueue/devices/writeback/cpumask should be used only in your case (general purpose cpu equivalent to CPU0)


AudioLinux --> https://www.audio-linux.com

developer of AudioLinux realtime OS

Share this post


Link to post
Share on other sites
2 minutes ago, hifi25nl said:

I would try all...:

 

echo 1000 > /proc/sys/vm/stat_interval
echo 0 > /sys/bus/workqueue/devices/writeback/numa
echo 1 > /sys/bus/workqueue/devices/writeback/cpumask
echo -1 > /proc/sys/kernel/sched_rt_runtime_us
echo 0 >/sys/devices/system/machinecheck/machinecheck3/check_interval
echo 0 > /proc/sys/kernel/watchdog
echo 0 > /proc/sys/kernel/nmi_watchdog

echo 1500 > /proc/sys/vm/dirty_writeback_centisecs
 

The line echo 1 > /sys/bus/workqueue/devices/writeback/cpumask should be used only in your case (general purpose cpu equivalent to CPU0)

Perfect, thank you so much for clarifying

 

 

Share this post


Link to post
Share on other sites
23 hours ago, hifi25nl said:

I would try all...:

 

echo 1000 > /proc/sys/vm/stat_interval
echo 0 > /sys/bus/workqueue/devices/writeback/numa
echo 1 > /sys/bus/workqueue/devices/writeback/cpumask
echo -1 > /proc/sys/kernel/sched_rt_runtime_us
echo 0 >/sys/devices/system/machinecheck/machinecheck3/check_interval
echo 0 > /proc/sys/kernel/watchdog
echo 0 > /proc/sys/kernel/nmi_watchdog

echo 1500 > /proc/sys/vm/dirty_writeback_centisecs
 

The line echo 1 > /sys/bus/workqueue/devices/writeback/cpumask should be used only in your case (general purpose cpu equivalent to CPU0)

 

If I Enabled Only One core for music in my 8 core CPU (random but say core 3 only), would the offset for

 

echo x > /sys/bus/workqueue/devices/writeback/cpumask

 

be x = 247?

 

ie.  In the web link you posted above to calculate the offset, we should be selecting the NOT FOR MUSIC cores? So for Enabled Only One core 3, we select 1,2,4,5,6,7,8 for the calculation?

 

Since the cores are random each time a power cycle occurs, does that mean we have to edit this offset and enter the proper number again should the random core switch?

Share this post


Link to post
Share on other sites

If you want only one core isolated , after choosing random, you can edit isolcpus in /boot/loader/entries/audiolinux.conf with your preferred core.

For example: isolcpus=7 

This will stick after a reboot (random does not mean that will change each time)

 

When using the calculator you must be sure that Hyper-Threading is disabled.

For example, if you choose only core 7 (core 8 in the calculator) the cpumask number should be 128


AudioLinux --> https://www.audio-linux.com

developer of AudioLinux realtime OS

Share this post


Link to post
Share on other sites
8 hours ago, hifi25nl said:

When using the calculator you must be sure that Hyper-Threading is disabled.

What calculator are you guys talking about?


NUC7PJYH/AL --> Berkeley Alpha USB --> Jeff Rowland Aeris --> Jeff Rowland 625 S2 --> Focal Utopia 3 Diablos with 2 x Focal Electra SW 1000 BE subs

 

i7-6700K/Windows 10/HDPLEX 200W/HDPLEX 400W DC-ATX --> ISO REGEN/LPS-1.2 --> iFi iDSD Micro --> Focal CMS50's 

Share this post


Link to post
Share on other sites

@hifi25nl I see that the Ryzen 9 (3950X 16 cores and 3900X 12 cores) are actually two chiplets, so the 3950X is 8+8 and the 3900X is 6+6.  Do these CPUs require NUMA support in AL?


NUC7PJYH/AL --> Berkeley Alpha USB --> Jeff Rowland Aeris --> Jeff Rowland 625 S2 --> Focal Utopia 3 Diablos with 2 x Focal Electra SW 1000 BE subs

 

i7-6700K/Windows 10/HDPLEX 200W/HDPLEX 400W DC-ATX --> ISO REGEN/LPS-1.2 --> iFi iDSD Micro --> Focal CMS50's 

Share this post


Link to post
Share on other sites
On 7/4/2019 at 9:33 AM, Gavin1977 said:

is it best best to run from USB Flash Drive to memory only (i.e. no Optane and no 2.5" disk)?

 

IMO - Yes. And remove the USB Flash Drive after AudioLinux loads in RAM. 

But in my system, I don't hear any difference if loading to memory from Optane instead of USB Flash Drive. The data transfer to memory, essentially the booting, is faster this way. 

Share this post


Link to post
Share on other sites
12 hours ago, Nenon said:

 

IMO - Yes. And remove the USB Flash Drive after AudioLinux loads in RAM. 

But in my system, I don't hear any difference if loading to memory from Optane instead of USB Flash Drive. The data transfer to memory, essentially the booting, is faster this way. 

Thanks - I'll make that my next port of call.

Share this post


Link to post
Share on other sites

Hello all - I am new on this forum.

Enthusiasted by the long thread elsewhere on this forum I installed a humble nuc7p (on an LPS) as my Roon bridge.

Running AL on it and from there straight by USB (good home made cable) into my Devialet amp.

Until recently the sound quality was almost undistinguishable from the wifi or ethernet connection from the Roon core to the Dev.

The latest addition on AL, moving from p-state to ACPI, made a small but very significant step upward in the sq.

The sound now has obtained a more 3D chracter; more depth not (only) in soundstage but around the instruments and voices.

Once heard I definitely want to keep this and not go back.

Obviously this is just my personal experience, with my ears in my system; not more, not less.

But the change in sound perception this last step did for me is so rewarding it motivated me to post this as feedback on AL.

 

Thanks Piero, great work!

Share this post


Link to post
Share on other sites
On 6/21/2019 at 8:36 PM, elan120 said:

 

To change from intel pstate to acpi, try the following:

 

 

  • Open menu and change ramroot from enable to disable.
  • Re-boot, make sure it is boot to Audiolinux in boot menu (top choice) during boot process.
  • Go to menu selection “1” - “Configuration”.
  • Select “0” (Change scaling driver to acpi or intel pstate) and follow with “Yes” when new screen come up to change from intel pstate to acpi.  Note, only do this once to make scaling driver change to acpi; if done twice, it will change from acpi back to intel pstate.
  • Re-boot, check system menu, now scaling driver should be acpi.
  • Re-enable ramroot.

 

For changing to acapi in headless AL I do the following:

 

- Configuration > 19. Disable ramroot

- Save

- Reboot

- Configuration > 21. Set CPU governor (...)

- 0. Change scaling driver to acpi (...)

- reboot

 

ACPI status shown on the top of first page, ramroot would be enabled back as usual.

 

Share this post


Link to post
Share on other sites

I purchased and installed AL few days ago in my Asus P10-WS, 4 core 25W TDP Xeon audio pC. Sounds really nice with JPlay Femto USB card and Holo Spring 2 DAC and Singxer SU-1. I got an Audio Note/EVGA Nu Audio PCIe sound card as well. Officially it is Windows only. However it uses an Xmos USB chip internally as a "virtual" USB device. I am using the audio PC as Roon Bridge, Roon running in my iMac Pro. Roon sees the Nu Audio board as 2 different cards. One way it sounds distorted and the other way it is few decibel quite than the level actually is, and this way DSD converted automatically to PCM which is strange as I do not use Roon to convert DSD to PCM. So my question is there any way to get the Nu Audio board working properly in AL? Any suggestion what to check, change? Thanks in advance. 

Share this post


Link to post
Share on other sites
On 7/11/2019 at 2:18 AM, ferenc said:

I purchased and installed AL few days ago in my Asus P10-WS, 4 core 25W TDP Xeon audio pC. Sounds really nice with JPlay Femto USB card and Holo Spring 2 DAC and Singxer SU-1. I got an Audio Note/EVGA Nu Audio PCIe sound card as well. Officially it is Windows only. However it uses an Xmos USB chip internally as a "virtual" USB device. I am using the audio PC as Roon Bridge, Roon running in my iMac Pro. Roon sees the Nu Audio board as 2 different cards. One way it sounds distorted and the other way it is few decibel quite than the level actually is, and this way DSD converted automatically to PCM which is strange as I do not use Roon to convert DSD to PCM. So my question is there any way to get the Nu Audio board working properly in AL? Any suggestion what to check, change? Thanks in advance. 

Hi Ferenc,

 

It's been a week since your post and no one has responded. I for one have never heard of the Nu Audio board. Did you ever get this resolved?

 

Does the virtual USB port show up when you type lsusb into the command line?

 

Larry


nuckleheadaudio.com

Share this post


Link to post
Share on other sites
On 7/4/2019 at 10:33 AM, Gavin1977 said:

BEST

Euphony

Audiolinux (RAM Boot / Extreme)

.

.

.

.

Roon Rock / Audiolinux (Boot from USB)

.

MacBook Pro

WORST

Pardon me asking, when you did this comparison from BEST to WORST did you followed the same exact testing for all OS's and conditions? meaning consistently using the same player (from your 3rd line) in this case ROON? I'm asking because to me these is a difference between ROON playing and STYLUS playing in Euphony (I prefer Stylus) and would like to know your opinion. Thanks

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...