Jump to content
lmitche

Audiolinux Server configurations, Software, Hardware, and Listening Impressions

Rate this topic

Recommended Posts

6 hours ago, hifi25nl said:

Also in the option 4 "Realtime expert configuration" I have enabled a default configuration.  At least 2 users have found a sound improvement.

 

 

Everything is commented out - what should be uncommented for the default config?

Share this post


Link to post
Share on other sites

1286394688_ScreenShot2019-06-13at4_35_20PM.thumb.jpg.961cc29a33d4451f8b67044692b2107a.jpg  

 

I added the lines you suggested, ran ram save, rebooted and when I go back into check the lines are there but this is what I get when I exit.  Is this the normal exit code to report inactive?

Share this post


Link to post
Share on other sites
12 hours ago, lmitche said:

Yes, I could hear the change to ACPI from the first note. Nicely done Piero!

 

Clarity improves again. This is really getting ridiculous!

Yes I like what I hear as well... clarity is improved as if a layer of murkiness has been stripped away...

 

After selecting acpi on my Celeron NUC in the menu under the scaling driver field I have written " noorunknowncpufreqdriverisactiveonthiscpu"

 

However I still got an increase in clarity and I haven't even put ramroot back on and it already sounds better

 

 

Share this post


Link to post
Share on other sites
15 minutes ago, mozes said:

For those who are using LMS server with Audiolinux, does it support DSD? 

 

Well I tried running LMS on another machine (under macOS) and the most current version of Squeezelite endpoint under AudioLinux on my NUC. 

PCM played fine, but DSD tracks stayed silent (despite confirming DSF and DFF formats on advanced screens in LMS).  

Share this post


Link to post
Share on other sites
12 minutes ago, Superdad said:

 

Well I tried running LMS on another machine (under macOS) and the most current version of Squeezelite endpoint under AudioLinux on my NUC. 

PCM played fine, but DSD tracks stayed silent (despite confirming DSF and DFF formats on advanced screens in LMS).  

This is exactly what happened with LMS running on Win 10 as well. No matter what I tried , DSD remained silent.

Share this post


Link to post
Share on other sites
9 hours ago, hifi25nl said:

I suggest this:


echo 1000 > /proc/sys/vm/stat_interval
echo 0 > /sys/bus/workqueue/devices/writeback/numa
#echo 3 > /sys/bus/workqueue/devices/writeback/cpumask
echo -1 > /proc/sys/kernel/sched_rt_runtime_us
echo 0 > /proc/sys/kernel/watchdog
echo 0 > /proc/sys/kernel/nmi_watchdog
echo 1500 > /proc/sys/vm/dirty_writeback_centisecs

 

Do these settings apply to AMD CPU systems, Intel CPU systems or both? 

Did you intend to remove the # from the 3rd line or is it intentionally left there?

 

Thanks Piero! 

Share this post


Link to post
Share on other sites

The third line is about isolated cores

 

#Set the affinity to only include the general purpose CPUs (in this case CPU0 and CPU1).
#echo 3 > /sys/bus/workqueue/devices/writeback/cpumask

 

3 is for CPU0 and CPU1.

A calculator can be found here: http://store.tomandmiu.com/cal-cam.php

 

Configuration should work with all systems, AMD or Intel. 


AudioLinux --> https://www.audio-linux.com

developer of AudioLinux realtime OS

Share this post


Link to post
Share on other sites

What I meant to ask was - should the script be:

 

#echo 3 > /sys/bus/workqueue/devices/writeback/cpumask

or 

echo 3 > /sys/bus/workqueue/devices/writeback/cpumask

 

Thanks.

Share this post


Link to post
Share on other sites

You could enable it, if you want, taking out # in front, only if isolated cores enabled:

echo 3 > /sys/bus/workqueue/devices/writeback/cpumask

In that case you should calculate the mask (now 3 equivalent to CPU and CPU1) with the calculator above for the cores not isolated


AudioLinux --> https://www.audio-linux.com

developer of AudioLinux realtime OS

Share this post


Link to post
Share on other sites
2 hours ago, hifi25nl said:

You could enable it, if you want, taking out # in front, only if isolated cores enabled:

echo 3 > /sys/bus/workqueue/devices/writeback/cpumask

In that case you should calculate the mask (now 3 equivalent to CPU and CPU1) with the calculator above for the cores not isolated

Sorry to be so slow, but is 3 the correct value for all cores but one isolated? That seems to be what you and the cited webpage are saying.

Share this post


Link to post
Share on other sites
1 hour ago, hifi25nl said:

3 is for CPU0 and CPU1, if all other cores are isolated (CPU2 CPU3 etc.)

 

If you have all cores less the first (CPU0) isolated, the right value should be 1 

Thanks. What has confused me is that the webpage you cited shows two CPUs per core. I’m trying to translate. 

Share this post


Link to post
Share on other sites
8 hours ago, mozes said:

For those who are using LMS server with Audiolinux, does it support DSD? 

 

7 hours ago, Superdad said:

 

Well I tried running LMS on another machine (under macOS) and the most current version of Squeezelite endpoint under AudioLinux on my NUC. 

PCM played fine, but DSD tracks stayed silent (despite confirming DSF and DFF formats on advanced screens in LMS).  

 

Guys,

 

I've played DSD through LMS to SL no problem. Do you have the DSDPlayer plugin installed on LMS? See my post:

 

 

Share this post


Link to post
Share on other sites
15 minutes ago, austinpop said:

I've played DSD through LMS to SL no problem. Do you have the DSDPlayer plugin installed on LMS? See my post:

I installed LMS version 7.9 which supports DSD format by default. I also checked the file format like Alex did. I will check your post.

Share this post


Link to post
Share on other sites
7 minutes ago, mozes said:

I installed LMS version 7.9 which supports DSD format by default. I also checked the file format like Alex did. I will check your post.

 

I haven't used LMS in months, so it's possible it's a new problem.

Share this post


Link to post
Share on other sites
22 minutes ago, austinpop said:

 

I haven't used LMS in months, so it's possible it's a new problem.

I know, you are a Roon fan ;)

Share this post


Link to post
Share on other sites
On 6/13/2019 at 7:41 AM, hifi25nl said:

Now you can select intel_psate or acpi as scaling governor. AMD Ryzen users should use acpi

Possible options:

     0 "Change scaling driver to acpi or intel pstate"
     1 "PERFORMANCE Turbo on"
     2 "PERFORMANCE Turbo off"
     3 "CUSTOM FREQUENCY"

You should reboot to make the changes fully effective

 

@hifi25nl I'm having trouble getting the selection to acpi to stick. I have tried it several times but it keeps rebooting as intel_pstate. 


Intel NUC NUC8i7BEH Roon Server running Audio Linux in RAM -> Sonore UltraRendu (Roon Endpoint) -> Uptone ISO Regen -> Singxer SU-1 KTE -> Holo Audio Spring Level 3 DAC -> Nord One UP Monoblocks -> Spendor LS3/5as | Music controlled via iPad (Power Conditioning: Audience adeptResponse aR12).  Twitter: @hirezaudio

Share this post


Link to post
Share on other sites
13 minutes ago, drjimwillie said:

I am having the same issue. 

Is it possible we do not have the acpi driver?

 

When I disabled ramroot from the menu, then rebooted then changed to acpi - it worked.

 

Piero told me "To check that you have disabled intel pstate driver you should have intel_pstate=disable in /boot/loader/entries/audiolinux.conf" 

 

I confirmed on mine after I disabling ramroot, rebooting, changing to acpi, rebooting again.


Intel NUC NUC8i7BEH Roon Server running Audio Linux in RAM -> Sonore UltraRendu (Roon Endpoint) -> Uptone ISO Regen -> Singxer SU-1 KTE -> Holo Audio Spring Level 3 DAC -> Nord One UP Monoblocks -> Spendor LS3/5as | Music controlled via iPad (Power Conditioning: Audience adeptResponse aR12).  Twitter: @hirezaudio

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...