Jump to content
lmitche

Audiolinux Server configurations, Software, Hardware, and Listening Impressions

Rate this topic

Recommended Posts

On 4/4/2019 at 9:16 AM, hifi25nl said:

Also Stylus, as I pointed out in another post, is probably MPD with a different interface that the one used in Cantata for example. The web service is called mpdweb (...) 

Piero, in AL does "native" MPD (or some form of it) also integrate to HQPe to provide MPD as front end to HQP upsampling?  I ask cuz Stylus (and users confirm) claims integration. Thx

Share this post


Link to post
Share on other sites

If you want you can check yourself in the directory /srv/node/mpdweb/, specifically the files app.js hqplayerd_player.js etc.

For what I know Stylus is only a sort of unified graphical interface to MPD, HQPlayer etc. 

Since I am also graduated in physics... I would like to know experimentally where an "integration of MPD and HQPlayer" is done in the code :)

 

There are now many  available interfaces for HQPlayer: BubbleUPnP, Mconnect, HQPDontrol... 


AudioLinux --> https://www.audio-linux.com

developer of AudioLinux realtime OS

Share this post


Link to post
Share on other sites
On 4/5/2019 at 1:32 AM, lmitche said:

I did this same change here yesterday. The result was harsh, so as suggested I lowered real-time priority to standard and ended up with a better result than when I started

I followed your advice and got an increase in clarity as well.

 

I set real time priority back to standard in the menu...is it necessary to deactivate isolated CPU cores and choose standard priority for isolated CPU cores as well?? Been a while since I did that and I can't remember what the options were in the isolated CPU cores script but I thought that you had to select real time priority either standard or extreme when setting up isolated CPU cores?

Share this post


Link to post
Share on other sites

I played with isolated CPU cores earlier on both server and endpoint  - while there is an illusion of increased detail in my system, the sound is also harder or harsher. I have since removed them from my setup.

 

I haven't played to ALSA config. Does it affect Squeezelite as well ?

Share this post


Link to post
Share on other sites
1 minute ago, Dev said:

I played with isolated CPU cores earlier on both server and endpoint  - while there is an illusion of increased detail in my system, the sound is also harder or harsher. I have since removed them from my setup.

 

I haven't played to ALSA config. Does it affect Squeezelite as well ?

It's a Roon only world here.

Share this post


Link to post
Share on other sites
3 hours ago, lmitche said:

Bricki,

 

Good to know you duplicated my results.

 

I changed the real-time priority to standard on the server side as well. This resulted in a further improvement in sound quality. Percent idle has increased. I am hearing a distinct improvement in tonal contrast and detail in the mids that adds beauty to female vocals and brass instruments.

 

It still isn't as relaxed as I think it can be. Next I'll try moving boot from extreme to standard.

 

SQ is ridiculously good. Small changes are creating increasing returns.

Ok thanks

 

I will try going back to standard real-time priority on the server too.

 

Did you add the asound.conf file on the server as well?

Share this post


Link to post
Share on other sites
On 4/10/2019 at 10:36 AM, lmitche said:

I changed the real-time priority to standard on the server side as well. This resulted in a further improvement in sound quality. Percent idle has increased. I am hearing a distinct improvement in tonal contrast and detail in the mids that adds beauty to female vocals and brass instruments.

I have changed real time priority to standard on my server now as well with similar results.

 

I have also gone back into the isolated CPU cores script and selected standard for the boot priority... It still boots into BFQjail but I think BFQjail is running in standard mode. I think this results in another improvement.

 

Next step for me is to try BFQjail in standard mode on my endpoint.

 

For those who thought that isolated CPU cores sounded too bright, it might be worth a revisit running everything in standard mode... particularly selecting standard in the isolated CPU cores set up

Share this post


Link to post
Share on other sites
49 minutes ago, hifi25nl said:

I will try to make a summary of different configurations, in order of CPU load.

 

First the standard audiolinux kernel is now linux-rt-bfq without NUMA enabled. You can install it from menu as usual, even if the version number is the same.

This is because system performance is better in this case.

With NUMA disabled CUDA acceleration in HQPlayer will not work. You can install the one with NUMA enabled downloading the files from https://www.audio-linux.com/ftp/packages/kernel/last/linux-rt-bfq-numa/ Contact support if you have some doubt.

 

Ok, this is the sequence of configurations:

 

1) Extreme/Extreme2 boot + Extreme priority

2) Standard boot + Extreme priority

3) Standard boot + Standard priority

4) Standard boot + disabled manual priority assignment. This can be done as root with:

systemctl disable rtapp.timer

systemctl disable rtirq

 

If you have a powerful processor and a good cooling system option 1) could be the best but with weak processors I would try to scale down CPU utilization using the other options, for example using option 3)

If you have chosen to use a not powerful power supply because you think this choice is better for sound, you cannot use your system the same way as a 1000 Watt system...you should find the right balance between power and latency.

 

 

I can confirm the NUMA-disabled kernel is a significant jump in SQ.

Share this post


Link to post
Share on other sites
49 minutes ago, austinpop said:

 

I can confirm the NUMA-disabled kernel is a significant jump in SQ.

@austinpopThat is very good news.  Should I take the time to A/B on the server with Euphony or wait some more?  Endpoint might be simpler just boot off of USB.  Where are you on the settings?

Share this post


Link to post
Share on other sites
2 hours ago, hifi25nl said:

I will try to make a summary of different configurations, in order of CPU load.

 

First the standard audiolinux kernel is now linux-rt-bfq without NUMA enabled. You can install it from menu as usual, even if the version number is the same.

This is because system performance is better in this case.

With NUMA disabled CUDA acceleration in HQPlayer will not work. You can install the one with NUMA enabled downloading the files from https://www.audio-linux.com/ftp/packages/kernel/last/linux-rt-bfq-numa/ Contact support if you have some doubt.

 

Ok, this is the sequence of configurations:

 

1) Extreme/Extreme2 boot + Extreme priority

2) Standard boot + Extreme priority

3) Standard boot + Standard priority

4) Standard boot + disabled manual priority assignment. This can be done as root with:

systemctl disable rtapp.timer

systemctl disable rtirq

 

If you have a powerful processor and a good cooling system option 1) could be the best but with weak processors I would try to scale down CPU utilization using the other options, for example using option 3)

If you have chosen to use a not powerful power supply because you think this choice is better for sound, you cannot use your system the same way as a 1000 Watt system...you should find the right balance between power and latency.

 

Please confirm is  the package without NUMA enabled "audiolinux mini 112" dated 3/27/19?

I prefer to do a fresh install as kernel upgrades do have a failure rate

Share this post


Link to post
Share on other sites
3 hours ago, hifi25nl said:

With NUMA disabled CUDA acceleration in HQPlayer will not work. You can install the one with NUMA enabled downloading the files from https://www.audio-linux.com/ftp/packages/kernel/last/linux-rt-bfq-numa/ Contact support if you have some doubt.

Will networkaudio be affected (not working) running as HQPlayer NAA with NUMA disabled?  I assume this only make HQPlayer not working but not affect networkaudio.

Share this post


Link to post
Share on other sites
2 hours ago, bobfa said:

@austinpopThat is very good news.  Should I take the time to A/B on the server with Euphony or wait some more?  Endpoint might be simpler just boot off of USB.  Where are you on the settings?

 

Hi Bob,

 

I ran out of time before heading to Chicago (en route now) to do the server. I tried on the endpoint only, with the following AL changes. I tried this first:

  • Boot set to standard (BFQ)
  • Priority set to Normal
  • ALSA conf file fix
  • blacklist items

Not sure I heard much of a difference. Maybe a slight improvement (less harsh). Then I tried:

  • NUMA-off kernel. I updated everything - kernel, packages, and AL menu

This was a noticeable improvement. Much more natural and less harsh. Finally I tried:

  • kernel line parameters

Here again, I don't think I heard anything much different.

 

With all of the above, AL/RAM on the endpoint gets close to, but does not quite match, the SQ of Euphony on the endpoint. Still, I see this as great progress. Competition is good, and we benefit from a continuing focus on SQ.

 

I won't be able to try the server until next week after AXPONA. Hopefully others will report.

Share this post


Link to post
Share on other sites

Hi Piero @hifi25nl

 

If I update the kernel and run BFQjail in standard mode, am I still using the NUMA disabled kernel? Or do I need to disable isolated CPU cores and boot into standard mode to use the NUMA disabled kernel?

Share this post


Link to post
Share on other sites
34 minutes ago, Bricki said:

Hi Piero @hifi25nl

 

If I update the kernel and run BFQjail in standard mode, am I still using the NUMA disabled kernel? Or do I need to disable isolated CPU cores and boot into standard mode to use the NUMA disabled kernel?

Try this to verify numa or not. #numactl --sho

Share this post


Link to post
Share on other sites
5 minutes ago, lmitche said:

Try this to verify numa or not. #numactl --sho

Ok thanks 👍. What should the output be if It's disabled? I will try that when I get home from work tonight 😁

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...