Jump to content
IGNORED

GentooPlayer


Recommended Posts

Grazie @antonellocaroli, good to know.  

 

I have updated the database a lot over the past few days. No joy, as of yet...  

Leaving the setting blank doesn’t show artwork. 
 

I’ll try some other iOS apps 🤞

Synology NAS DS216SE + TF cards -> GentooPlayer in RAM on mini fanless/supercap NUC -> Audio GD R-27 -> S.A.T. Infinity monoblocks -> Gallo Stradas + TR-3 sub Hifiman HE560

Link to post
Share on other sites

Hi @antonellocaroli... there are some  settings that give error!!

 

 

Mac Mini with JRMC26 or Audirvana  / Raspberry4B_4GB(GentooPlayer_LMS) / Raspberry Rpi3B+: Allo DigiOne(GentooPlayer) - M2Tech Evo DAC Two Plus/iPurifier2 - Schiit Vali 2 - Densen DM20pre/30pwr amps - Spendor SP2/3E, Sennheiser HD600 & HD25Aluminum - Audeze Sine

Cables: Vovox, DIY, Furutech. 

Portable sources: iPad, DELL Laptop with JRiver MC26

Link to post
Share on other sites
15 minutes ago, antonellocaroli said:

just to understand .... which settings and which errors?

"Failed to load script info. Try to reload the page. Error message:
Failed to connect to the server"

 

This is the error for "Set governor".

Well actually now hat I tried again except from the above (that I am mainly interested)  and "setMyMPD procces" all the others seem to work!

Mac Mini with JRMC26 or Audirvana  / Raspberry4B_4GB(GentooPlayer_LMS) / Raspberry Rpi3B+: Allo DigiOne(GentooPlayer) - M2Tech Evo DAC Two Plus/iPurifier2 - Schiit Vali 2 - Densen DM20pre/30pwr amps - Spendor SP2/3E, Sennheiser HD600 & HD25Aluminum - Audeze Sine

Cables: Vovox, DIY, Furutech. 

Portable sources: iPad, DELL Laptop with JRiver MC26

Link to post
Share on other sites
9 hours ago, DomieMic65 said:

"Failed to load script info. Try to reload the page. Error message:
Failed to connect to the server"

 

This is the error for "Set governor".

Well actually now hat I tried again except from the above (that I am mainly interested)  and "setMyMPD procces" all the others seem to work!

set governor should work...have you tried gp-update?

MyMpd set you're right I have to check....

Link to post
Share on other sites
6 hours ago, antonellocaroli said:

set governor should work...have you tried gp-update?

MyMpd set you're right I have to check....

Just tried again after gp-update but it still gives error

May be it has to do with kernel 5.4.65?

Mac Mini with JRMC26 or Audirvana  / Raspberry4B_4GB(GentooPlayer_LMS) / Raspberry Rpi3B+: Allo DigiOne(GentooPlayer) - M2Tech Evo DAC Two Plus/iPurifier2 - Schiit Vali 2 - Densen DM20pre/30pwr amps - Spendor SP2/3E, Sennheiser HD600 & HD25Aluminum - Audeze Sine

Cables: Vovox, DIY, Furutech. 

Portable sources: iPad, DELL Laptop with JRiver MC26

Link to post
Share on other sites
Just now, antonellocaroli said:

Solved

I deed!!!

Thank you once more!!!!!

Gentooplayer support is perfect!!

Mac Mini with JRMC26 or Audirvana  / Raspberry4B_4GB(GentooPlayer_LMS) / Raspberry Rpi3B+: Allo DigiOne(GentooPlayer) - M2Tech Evo DAC Two Plus/iPurifier2 - Schiit Vali 2 - Densen DM20pre/30pwr amps - Spendor SP2/3E, Sennheiser HD600 & HD25Aluminum - Audeze Sine

Cables: Vovox, DIY, Furutech. 

Portable sources: iPad, DELL Laptop with JRiver MC26

Link to post
Share on other sites
1 hour ago, antonellocaroli said:

following this discussion, intrigued I compiled a kernel with patches, adapted to version 5.x , for rpi3/usb bridge
I called this kernel test, you can find it in this update...


image.png.ce268701f4ff8a69630e34711f1b3b12.png
 

Is it because I mentioned "poker" to switch to the new version of Gentooplayer ??
Is the game worth it? 🙃

Link to post
Share on other sites

I have a problem with upnp on audirvana. I have searched on audirvana forums as well about this problem.

Many users have reported white noise during playback of off-line/online content. Its very disturbing. I fear for my speakers/hps & most importantly my hearing.

 

I am using Gentoo player 5.4.65-GentooPlayer-MIN-NOGRAPH-RCU+ ramroot/Profile 1 on rpi4b 4gb on Metrum Ambre. Source is audirvana 3.5.40 (3570) running(offline/streaming tidal/qobuz) on MacBook pro 2014 via Ethernet -->Uptone Etherregen--> Ambre-->Pavane>amps>hps/speakers. Running only upmpd & mpd. 

After ramroot: 3130MB free of total 3859MB.

 

I have tried using other profiles & no profiles. The problem(white noise) persists. 

 

This problem is not there with roonbridge. 

 

Is anyone facing the same problem ?

 

Kindly advise.

 

 

Link to post
Share on other sites

Info.

Some users have had problems with their internet connection.

the problem was caused by using the router to assign the fixed ip to a pc (via the mac adresse). (I didn't like this way)
At the same time they set a fixed ip on the pc and disable the Dhcp. 
By disabling the dhcp, the router, through the function above, can no longer route the pc to the internet, because to do so it needs the dhcp to be active on the pc. This is normal, the router uses a dhcp server to do this.

If you want to use a fixed ip and disable dhcp, my advice is not to use the router function for fixed ip, but to do it from the pc, in this case you can disable dhcp.

 

Link to post
Share on other sites

Hi,

 

I tried to used Ramdisk with 5.4.65-201012 Test kernel.
But there are errors !

 

Choose your operation:

 [0 - 15]:3

 do you want to start the ramdisk? y/n
y

Copyng root filesystem to RAM...


 wait...



 wait...

Could not find platform independent libraries <prefix>
Could not find platform dependent libraries <exec_prefix>
Consider setting $PYTHONHOME to <prefix>[:<exec_prefix>]


 wait...


 [Copy necessary files]

du: cannot access '/opt/logitechmediaserver': No such file or directory
du: cannot access '/opt/RoonBridge': No such file or directory
du: cannot access '/opt/icedtea-bin*': No such file or directory
du: cannot access '/opt/bubbleupnp': No such file or directory

 wait...


 wait...


 wait...

/etc/default/ramdisk.sh: line 185:  3895 Killed                  rsync -a /newuser1/ /mnt/.ramdisk/ramdisk5
rsync: connection unexpectedly closed (206716 bytes received so far) [generator]
rsync error: error in rsync protocol data stream (code 12) at io.c(228) [generator=3.2.3]

 wait...


 wait...

Killed

 

 But after reboot :

 

Quote

 

figlet: big: Unable to open font file
  Profile1
 RamSystem Mode 1
 Free memory: 10MB of total 967MB

 5.4.65-GentooPlayer-MIN-NOGRAPH-TEST+
 ───────────────────────────────────────
 GentooPlayer   | 22:03 | dom 18/10/2020
 ───────────────────────────────────────
 v3.00      | Raspberry Pi 3B/3B+ (aarch64)
 ───────────────────────────────────────

 


 

Link to post
Share on other sites
7 hours ago, Zauurx said:

Hi,

 

I tried to used Ramdisk with 5.4.65-201012 Test kernel.
But there are errors !

 

Choose your operation:

 [0 - 15]:3

 do you want to start the ramdisk? y/n
y

Copyng root filesystem to RAM...


 wait...



 wait...

Could not find platform independent libraries <prefix>
Could not find platform dependent libraries <exec_prefix>
Consider setting $PYTHONHOME to <prefix>[:<exec_prefix>]


 wait...


 [Copy necessary files]

du: cannot access '/opt/logitechmediaserver': No such file or directory
du: cannot access '/opt/RoonBridge': No such file or directory
du: cannot access '/opt/icedtea-bin*': No such file or directory
du: cannot access '/opt/bubbleupnp': No such file or directory

 wait...


 wait...


 wait...

/etc/default/ramdisk.sh: line 185:  3895 Killed                  rsync -a /newuser1/ /mnt/.ramdisk/ramdisk5
rsync: connection unexpectedly closed (206716 bytes received so far) [generator]
rsync error: error in rsync protocol data stream (code 12) at io.c(228) [generator=3.2.3]

 wait...


 wait...

Killed

 

 But after reboot :

 


 

seems to be a problem of full ram.

show me systeminfo and the result of the command du -sh /*
outside the ramsistem?

Link to post
Share on other sites

Finally, I reinstalled everything quietly .. choose Profile 3 (as on version 2.15).

And all in RAM.
But I have a return of random blanks ... no clicks .. some blanks .. rare.

 

System : NAA on Allo USBridge with NAA/GentooPlayer on IPV6

 

  _____            _              _____  _                       
 / ____|          | |            |  __ \| |                      
| |  __  ___ _ __ | |_ ___   ___ | |__) | | __ _ _   _  ___ _ __ 
| | |_ |/ _ \ '_ \| __/ _ \ / _ \|  ___/| |/ _` | | | |/ _ \ '__|
| |__| |  __/ | | | || (_) | (_) | |    | | (_| | |_| |  __/ |   
 \_____|\___|_| |_|\__\___/ \___/|_|    |_|\__,_|\__, |\___|_|   
                                                  __/ |          
                                                 |___/           
 Profile3
 Profile:      Profile3
 RamSystem:   Mode 3
 Free memory: 395MB of total 967MB

 Kernel:   5.4.65-GentooPlayer-MIN-NOGRAPH-TEST+
 ───────────────────────────────────────
 GentooPlayer   | 15:05 | lun 19/10/2020 
 ───────────────────────────────────────
 v3.00      | Raspberry Pi 3B/3B+ (aarch64)
 ───────────────────────────────────────
 eth0       | 192.168.1.122
 ───────────────────────────────────────

Players Info:
Squeezelite-R2          [Disabled]
Squeezelite             [Disabled]
Networkaudiod           [Enabled]
LigitechMediaServer     [Disabled]
BubbleUpnp              [Disabled]
HQPlayer Embedded       [Disabled]
Mpd                     [Disabled]
UpMpdCli                [Disabled]
RoonBridge              [Disabled]
RoonServer              [Disabled]
Mpd-Sima                [Disabled]
MYmpd                   [Disabled]
minimserver             [Disabled]
shairport-sync          [Disabled]
spotify-connect         [Disabled]

GP-Service Info:
gpchronystop   [Enabled]
gpgovernor     [Enabled]
gphavagedstop  [Enabled]
gpireteonline  [Enabled]
gpkernel1      [Enabled]
gprtclock      [Enabled]
gpsetprofile3  [Enabled]
gpsetrestart   [Enabled]

dwc_otg.lpm_enable=0 console=tty1 root=/dev/mmcblk0p2 rootfstype=ext4 elevator=deadline fsck.repair=yes rootwait noibrs noibpb nopti nospectre_v2 nospectre_v1 l1tf=off nospec_store_bypass_disable no_stf_barrier mds=off mitigations=off maxcpus=2 isolcpus=1 nohz_full=1 rcu_nocbs=1


###############################
*** Scanning for playback devices ***
Card 0, ID `DAC55688069', name `ADI-2 DAC (55688069)'
  Device 0, ID `USB Audio', name `USB Audio', 1 subdevices (1 available)
    2 channels, sampling rate 44100..768000 Hz
    Sample formats: S32_LE
    Buffer size range from 16 to 131072
    Period size range from 8 to 65536

      Subdevice 0, name `subdevice #0'
###############################


AUDIO CARDS
CARD	TYPE			ADDRESS			NAME
--------------------------------------------------------------------------------------------------------
    card0	USB Audio card		usb1  --> 2a39:3fd3	RME ADI-2 DAC
card0	STATUS  --> closed
--------------------------------------------------------------------------------------------------------


Filesystem     Type      Size  Used Avail Use% Mounted on
/dev/root      ext4       29G  2.8G   25G  10% /
devtmpfs       devtmpfs   10M     0   10M   0% /dev
tmpfs          tmpfs      97M  276K   97M   1% /run
shm            tmpfs     484M     0  484M   0% /dev/shm
/dev/mmcblk0p1 vfat      352M  219M  134M  63% /boot
none           tmpfs      12M  9.4M  2.0M  83% /bin
none           tmpfs      16M   13M  2.9M  81% /etc
none           tmpfs     9.7M  7.7M  2.0M  80% /sbin
none           tmpfs      35M   25M   11M  71% /lib
none           tmpfs     9.6M  8.5M  1.1M  90% /lib64
none           tmpfs     414M  378M   37M  92% /usr
none           tmpfs      32M  2.6M   30M   8% /var
none           tmpfs      49M     0   49M   0% /tmp
none           tmpfs      77M   61M   16M  80% /opt
none           tmpfs      56M  6.1M   50M  11% /root


[  OK  ] Root access verified.

 ─────────────────────────────────────────────────────
 Gentooplayer CPU Info
 Use cpu-governor to change CPU / performance options
 ─────────────────────────────────────────────────────
 Architecture |     aarch64
 Temp         |     41'c : 105'f | Optimal temperature.
 Governor     |     powersave

                 Current Freq    Min Freq   Max Freq
 CPU0         |      600 MHz      600 MHz    1200 MHz
 CPU1         |      600 MHz      600 MHz    1200 MHz
 CPU2         |      600 MHz      600 MHz    1200 MHz
 CPU3         |      600 MHz      600 MHz    1200 MHz

[ INFO ] GentooPlayer-CPU_info | CPU current frequency, may be affected by this script, due to the processing required to run it.
 - if the temperature is not displayed, first run the command: sensors-detect --auto

 

image.thumb.png.675d60591797f45f4694d02b15f2d1a9.pngimage.thumb.png.675d60591797f45f4694d02b15f2d1a9.png

Link to post
Share on other sites

By honesty, I need to test more .. I think the blanks are coming from the NUC because of high resolution files (+ convolution and HQP).

There are some network optimisation with this test kernel ? for ASIX chips ? ;)

Link to post
Share on other sites
14 minutes ago, Zauurx said:

Finally, I reinstalled everything quietly .. choose Profile 3 (as on version 2.15).

And all in RAM.
But I have a return of random blanks ... no clicks .. some blanks .. rare.

 

System : NAA on Allo USBridge with NAA/GentooPlayer on IPV6

 


  _____            _              _____  _                       
 / ____|          | |            |  __ \| |                      
| |  __  ___ _ __ | |_ ___   ___ | |__) | | __ _ _   _  ___ _ __ 
| | |_ |/ _ \ '_ \| __/ _ \ / _ \|  ___/| |/ _` | | | |/ _ \ '__|
| |__| |  __/ | | | || (_) | (_) | |    | | (_| | |_| |  __/ |   
 \_____|\___|_| |_|\__\___/ \___/|_|    |_|\__,_|\__, |\___|_|   
                                                  __/ |          
                                                 |___/           
 Profile3
 Profile:      Profile3
 RamSystem:   Mode 3
 Free memory: 395MB of total 967MB

 Kernel:   5.4.65-GentooPlayer-MIN-NOGRAPH-TEST+
 ───────────────────────────────────────
 GentooPlayer   | 15:05 | lun 19/10/2020 
 ───────────────────────────────────────
 v3.00      | Raspberry Pi 3B/3B+ (aarch64)
 ───────────────────────────────────────
 eth0       | 192.168.1.122
 ───────────────────────────────────────

Players Info:
Squeezelite-R2          [Disabled]
Squeezelite             [Disabled]
Networkaudiod           [Enabled]
LigitechMediaServer     [Disabled]
BubbleUpnp              [Disabled]
HQPlayer Embedded       [Disabled]
Mpd                     [Disabled]
UpMpdCli                [Disabled]
RoonBridge              [Disabled]
RoonServer              [Disabled]
Mpd-Sima                [Disabled]
MYmpd                   [Disabled]
minimserver             [Disabled]
shairport-sync          [Disabled]
spotify-connect         [Disabled]

GP-Service Info:
gpchronystop   [Enabled]
gpgovernor     [Enabled]
gphavagedstop  [Enabled]
gpireteonline  [Enabled]
gpkernel1      [Enabled]
gprtclock      [Enabled]
gpsetprofile3  [Enabled]
gpsetrestart   [Enabled]

dwc_otg.lpm_enable=0 console=tty1 root=/dev/mmcblk0p2 rootfstype=ext4 elevator=deadline fsck.repair=yes rootwait noibrs noibpb nopti nospectre_v2 nospectre_v1 l1tf=off nospec_store_bypass_disable no_stf_barrier mds=off mitigations=off maxcpus=2 isolcpus=1 nohz_full=1 rcu_nocbs=1


###############################
*** Scanning for playback devices ***
Card 0, ID `DAC55688069', name `ADI-2 DAC (55688069)'
  Device 0, ID `USB Audio', name `USB Audio', 1 subdevices (1 available)
    2 channels, sampling rate 44100..768000 Hz
    Sample formats: S32_LE
    Buffer size range from 16 to 131072
    Period size range from 8 to 65536

      Subdevice 0, name `subdevice #0'
###############################


AUDIO CARDS
CARD	TYPE			ADDRESS			NAME
--------------------------------------------------------------------------------------------------------
    card0	USB Audio card		usb1  --> 2a39:3fd3	RME ADI-2 DAC
card0	STATUS  --> closed
--------------------------------------------------------------------------------------------------------


Filesystem     Type      Size  Used Avail Use% Mounted on
/dev/root      ext4       29G  2.8G   25G  10% /
devtmpfs       devtmpfs   10M     0   10M   0% /dev
tmpfs          tmpfs      97M  276K   97M   1% /run
shm            tmpfs     484M     0  484M   0% /dev/shm
/dev/mmcblk0p1 vfat      352M  219M  134M  63% /boot
none           tmpfs      12M  9.4M  2.0M  83% /bin
none           tmpfs      16M   13M  2.9M  81% /etc
none           tmpfs     9.7M  7.7M  2.0M  80% /sbin
none           tmpfs      35M   25M   11M  71% /lib
none           tmpfs     9.6M  8.5M  1.1M  90% /lib64
none           tmpfs     414M  378M   37M  92% /usr
none           tmpfs      32M  2.6M   30M   8% /var
none           tmpfs      49M     0   49M   0% /tmp
none           tmpfs      77M   61M   16M  80% /opt
none           tmpfs      56M  6.1M   50M  11% /root


[  OK  ] Root access verified.

 ─────────────────────────────────────────────────────
 Gentooplayer CPU Info
 Use cpu-governor to change CPU / performance options
 ─────────────────────────────────────────────────────
 Architecture |     aarch64
 Temp         |     41'c : 105'f | Optimal temperature.
 Governor     |     powersave

                 Current Freq    Min Freq   Max Freq
 CPU0         |      600 MHz      600 MHz    1200 MHz
 CPU1         |      600 MHz      600 MHz    1200 MHz
 CPU2         |      600 MHz      600 MHz    1200 MHz
 CPU3         |      600 MHz      600 MHz    1200 MHz

[ INFO ] GentooPlayer-CPU_info | CPU current frequency, may be affected by this script, due to the processing required to run it.
 - if the temperature is not displayed, first run the command: sensors-detect --auto

 

image.thumb.png.675d60591797f45f4694d02b15f2d1a9.pngimage.thumb.png.675d60591797f45f4694d02b15f2d1a9.png

 

Does changing the governor and lowering the frequency of the cpu bring you benefits?
It's something I never do, in my opinion it only increases latencies.

Link to post
Share on other sites
1 hour ago, Zauurx said:

Howto mesure latencies ?

there is software specially designed for testing...

here are some examples on usb bridge:

 

with governor set to performance  (the last column is important)

 

image.png.2e0f3243023334beeda94332d7f9ce30.png

 

 

with governor powersave

 

image.png.fc5ee2e18e132a468ed1c22df9cca57e.png

 

 

this with an RT kernel

 

image.thumb.png.a1644a8f652f4d85462dca90e85b14c0.png

 

 

but sure latency has a certain importance in audio production, in reproduction instead it has never been demonstrated that it can be important, that's why my question, since many people tend to reduce the working frequency of the cpu, I wondered if it is done because we notice some improvements in listening? I don't think...

Link to post
Share on other sites
12 hours ago, antonellocaroli said:

there is software specially designed for testing...

here are some examples on usb bridge:

 

with governor set to performance  (the last column is important)

 

image.png.2e0f3243023334beeda94332d7f9ce30.png

 

 

with governor powersave

 

image.png.fc5ee2e18e132a468ed1c22df9cca57e.png

 

 

this with an RT kernel

 

image.thumb.png.a1644a8f652f4d85462dca90e85b14c0.png

 

 

but sure latency has a certain importance in audio production, in reproduction instead it has never been demonstrated that it can be important, that's why my question, since many people tend to reduce the working frequency of the cpu, I wondered if it is done because we notice some improvements in listening? I don't think...

 

RT kernel with governor set to performance

 

image.png.8e9c12a4ec4b3c03a80cb1369b9d42eb.png

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


×
×
  • Create New...