Jump to content
IGNORED

GentooPlayer


Recommended Posts

1 minute ago, antonellocaroli said:

what version of GP do you use?

have you tried updating? gp-update

 No, I have not tried gp-update. I must do it?

 

_____            _              _____  _                       
 / ____|          | |            |  __ \| |                      
| |  __  ___ _ __ | |_ ___   ___ | |__) | | __ _ _   _  ___ _ __ 
| | |_ |/ _ \ '_ \| __/ _ \ / _ \|  ___/| |/ _` | | | |/ _ \ '__|
| |__| |  __/ | | | || (_) | (_) | |    | | (_| | |_| |  __/ |   
 \_____|\___|_| |_|\__\___/ \___/|_|    |_|\__,_|\__, |\___|_|   
                                                  __/ |          
                                                 |___/           
 Profile:     Profile not Setting
 RamSystem:   Mode 3
 Free memory: 1217MB of total 1908MB

 Kernel:   4.19.106-GentooPlayer-ST+
 ───────────────────────────────────────
 GentooPlayer   | 14:44 | dom 09/08/2020 
 ───────────────────────────────────────
 v2.15      | Raspberry Pi 4B+ (aarch64)
 ───────────────────────────────────────
 eth0       | 192.168.1.100
 ───────────────────────────────────────

Players Info:
Squeezelite-R2          [Enabled]
Squeezelite             [Enabled]
Networkaudiod           [Disabled]
LigitechMediaServer     [Disabled]
BubbleUpnp              [Disabled]
HQPlayer Embedded       [Disabled]
Mpd                     [Disabled]
UpMpdCli                [Disabled]
RoonBridge              [Enabled]
RoonServer              [Disabled]
Mpd-Sima                [Disabled]
MYmpd                   [Disabled]
minimserver             [Disabled]
shairport-sync          [Disabled]
spotifyd                [Disabled]

*** Scanning for playback devices ***
Card 0, ID `HugoTT2', name `HugoTT2'
  Device 0, ID `USB Audio', name `USB Audio', 1 subdevices (0 available)
Error opening sound device for card 0, device 0: Device or resource busy.  Skipping.


AUDIO CARDS
CARD    TYPE            ADDRESS            NAME
--------------------------------------------------------------------------------------------------------
    card0    USB Audio card        usb1  --> 245f:0815    Chord Electronics Ltd
card0    STATUS  --> access: RW_INTERLEAVED format: S32_LE subformat: STD channels: 2 rate: 44100 (44100/1) period_size: 882 buffer_size: 1764
--------------------------------------------------------------------------------------------------------


Filesystem     Type      Size  Used Avail Use% Mounted on
/dev/root      ext4       14G  3.0G   11G  23% /
devtmpfs       devtmpfs   10M     0   10M   0% /dev
tmpfs          tmpfs     191M  416K  191M   1% /run
cgroup_root    tmpfs      10M     0   10M   0% /sys/fs/cgroup
shm            tmpfs     955M   12K  955M   1% /dev/shm
none           tmpfs      12M  9.4M  2.0M  83% /bin
none           tmpfs      15M   12M  2.9M  81% /etc
none           tmpfs     9.6M  7.6M  2.0M  80% /sbin
none           tmpfs      99M   88M   12M  89% /lib
none           tmpfs     9.4M  8.4M  1.1M  90% /lib64
none           tmpfs     352M  317M   35M  91% /usr
none           tmpfs      32M  3.9M   29M  12% /var
none           tmpfs      25M   52K   25M   1% /tmp
none           tmpfs      74M   58M   16M  79% /opt
none           tmpfs      56M  6.6M   49M  12% /root
/dev/mmcblk0p1 vfat      352M  250M  103M  71% /boot


[  OK  ] Root access verified.

 ─────────────────────────────────────────────────────
 Gentooplayer CPU Info
 Use cpu-governor to change CPU / performance options
 ─────────────────────────────────────────────────────
 Architecture |     aarch64
 Temp         |     63'c : 145'f | Running hot, not recommended.
 Governor     |     performance

                 Current Freq    Min Freq   Max Freq
 CPU0         |      1500 MHz      600 MHz    1500 MHz
 CPU1         |      1500 MHz      600 MHz    1500 MHz
 CPU2         |      1500 MHz      600 MHz    1500 MHz
 CPU3         |      1500 MHz      600 MHz    1500 MHz

[ INFO ] GentooPlayer-CPU_info | CPU current frequency, may be affected by this script, due to the processing required to run it.
 - if the temperature is not displayed, first run the command: sensors-detect --auto

 

 

 

Link to post
Share on other sites
1 minute ago, OPM said:

 No, I have not tried gp-update. I must do it?

 

_____            _              _____  _                       
 / ____|          | |            |  __ \| |                      
| |  __  ___ _ __ | |_ ___   ___ | |__) | | __ _ _   _  ___ _ __ 
| | |_ |/ _ \ '_ \| __/ _ \ / _ \|  ___/| |/ _` | | | |/ _ \ '__|
| |__| |  __/ | | | || (_) | (_) | |    | | (_| | |_| |  __/ |   
 \_____|\___|_| |_|\__\___/ \___/|_|    |_|\__,_|\__, |\___|_|   
                                                  __/ |          
                                                 |___/           
 Profile:     Profile not Setting
 RamSystem:   Mode 3
 Free memory: 1217MB of total 1908MB

 Kernel:   4.19.106-GentooPlayer-ST+
 ───────────────────────────────────────
 GentooPlayer   | 14:44 | dom 09/08/2020 
 ───────────────────────────────────────
 v2.15      | Raspberry Pi 4B+ (aarch64)
 ───────────────────────────────────────
 eth0       | 192.168.1.100
 ───────────────────────────────────────

Players Info:
Squeezelite-R2          [Enabled]
Squeezelite             [Enabled]
Networkaudiod           [Disabled]
LigitechMediaServer     [Disabled]
BubbleUpnp              [Disabled]
HQPlayer Embedded       [Disabled]
Mpd                     [Disabled]
UpMpdCli                [Disabled]
RoonBridge              [Enabled]
RoonServer              [Disabled]
Mpd-Sima                [Disabled]
MYmpd                   [Disabled]
minimserver             [Disabled]
shairport-sync          [Disabled]
spotifyd                [Disabled]

*** Scanning for playback devices ***
Card 0, ID `HugoTT2', name `HugoTT2'
  Device 0, ID `USB Audio', name `USB Audio', 1 subdevices (0 available)
Error opening sound device for card 0, device 0: Device or resource busy.  Skipping.


AUDIO CARDS
CARD    TYPE            ADDRESS            NAME
--------------------------------------------------------------------------------------------------------
    card0    USB Audio card        usb1  --> 245f:0815    Chord Electronics Ltd
card0    STATUS  --> access: RW_INTERLEAVED format: S32_LE subformat: STD channels: 2 rate: 44100 (44100/1) period_size: 882 buffer_size: 1764
--------------------------------------------------------------------------------------------------------


Filesystem     Type      Size  Used Avail Use% Mounted on
/dev/root      ext4       14G  3.0G   11G  23% /
devtmpfs       devtmpfs   10M     0   10M   0% /dev
tmpfs          tmpfs     191M  416K  191M   1% /run
cgroup_root    tmpfs      10M     0   10M   0% /sys/fs/cgroup
shm            tmpfs     955M   12K  955M   1% /dev/shm
none           tmpfs      12M  9.4M  2.0M  83% /bin
none           tmpfs      15M   12M  2.9M  81% /etc
none           tmpfs     9.6M  7.6M  2.0M  80% /sbin
none           tmpfs      99M   88M   12M  89% /lib
none           tmpfs     9.4M  8.4M  1.1M  90% /lib64
none           tmpfs     352M  317M   35M  91% /usr
none           tmpfs      32M  3.9M   29M  12% /var
none           tmpfs      25M   52K   25M   1% /tmp
none           tmpfs      74M   58M   16M  79% /opt
none           tmpfs      56M  6.6M   49M  12% /root
/dev/mmcblk0p1 vfat      352M  250M  103M  71% /boot


[  OK  ] Root access verified.

 ─────────────────────────────────────────────────────
 Gentooplayer CPU Info
 Use cpu-governor to change CPU / performance options
 ─────────────────────────────────────────────────────
 Architecture |     aarch64
 Temp         |     63'c : 145'f | Running hot, not recommended.
 Governor     |     performance

                 Current Freq    Min Freq   Max Freq
 CPU0         |      1500 MHz      600 MHz    1500 MHz
 CPU1         |      1500 MHz      600 MHz    1500 MHz
 CPU2         |      1500 MHz      600 MHz    1500 MHz
 CPU3         |      1500 MHz      600 MHz    1500 MHz

[ INFO ] GentooPlayer-CPU_info | CPU current frequency, may be affected by this script, due to the processing required to run it.
 - if the temperature is not displayed, first run the command: sensors-detect --auto

 

 

You're using a ramsystem, you make changes in ram when you reboot, you lose them...

you should exit the ramsystem, enable spotify(librespot), verify that it works, do a ramsystem reset and go back to ram.....

the ramsystem, in theory, should be used after configuration is complete.....

Link to post
Share on other sites
Hace 11 minutos, antonellocaroli dijo:

 

Estás usando un ramsystem, haces cambios en RAM cuando reinicias, los pierdes ...

debes salir del ramsystem, habilitar spotify (librespot), verificar que funciona, hacer un reinicio del ramsystem y volver a ram .....

el ramsystem, en teoría, debe utilizar después de que se complete la configuración .....

I have done gp-update and now Spotify works.
But now I don't know how to do a ramsystem reboot. How it is performed?

Link to post
Share on other sites

Something strange happens. Now I can't get into the web-interface but Roon can see the endpoint.
I have rebooted RPI4 but with no luck.
How do I solve it?

Link to post
Share on other sites
3 minutes ago, OPM said:

Something strange happens. Now I can't get into the web-interface but Roon can see the endpoint.
I have rebooted RPI4 but with no luck.
How do I solve it?

did you happen to have shairport-sync enabled?

Link to post
Share on other sites
3 minutes ago, antonellocaroli said:

what it says in the shell 
rc-status

Sorry but I don't know how to open a shell. I am ignorant of computer code.

Link to post
Share on other sites

@OPM if you main computer is a pc with Windows10 follow these instructions to enable ssh, it is needed to open a shell

https://www.pugetsystems.com/labs/hpc/How-To-Use-SSH-Client-and-Server-on-Windows-10-1470/

if you are on Mac then open Terminal app located in Utilities and type 

ssh [email protected] of the GentooPlayer raspberry

hit enter and type raspiroot

hit enter again

now you are in the shell and you can type the command @antonellocaroli told you

Stefano

 

My audio system

Link to post
Share on other sites
9 hours ago, stefano_mbp said:

@OPM if you main computer is a pc with Windows10 follow these instructions to enable ssh, it is needed to open a shell

https://www.pugetsystems.com/labs/hpc/How-To-Use-SSH-Client-and-Server-on-Windows-10-1470/

if you are on Mac then open Terminal app located in Utilities and type 

ssh [email protected] of the GentooPlayer raspberry

hit enter and type raspiroot

hit enter again

now you are in the shell and you can type the command @antonellocaroli told you

Thanks

 

I have a problem with Spotify. It played 2 songs and then stopped and disconnected. Now the endpoint has disappeared and I can't play Spotify.

Spotify is not stable?

Link to post
Share on other sites
16 minutes ago, OPM said:

Thanks

 

I have a problem with Spotify. It played 2 songs and then stopped and disconnected. Now the endpoint has disappeared and I can't play Spotify.

Spotify is not stable?

try not to use ramsystem, I've never tested librespot in ram...

 

Besides, I don't have a premium spotify subscription... so I can't test it...

Link to post
Share on other sites
19 minutes ago, antonellocaroli said:

intenta no usar ramsystem, nunca he probado librespot en ram ...

 

Además, no tengo una suscripción premium de Spotify ... así que no puedo probarla ...

Now it works. Thank you.

 

When NAA is on and I'm playing from roon, SqueezeLite and RoonBridge don't work. It is normal?

Link to post
Share on other sites
28 minutes ago, OPM said:

Now it works. Thank you.

 

When NAA is on and I'm playing from roon, SqueezeLite and RoonBridge don't work. It is normal?

yes, that's normal.  when hqplayer connects to networkaudiod, it takes possession of the audio output, and does not release it until you close hqplayer and / or open the setting in hqplayer ... so it releases it ....

Link to post
Share on other sites

Can someone explain to me what kernels are for? Does the change produce any change in the sound?
I don't understand most of the options out there. any option settings that improve the sound?

Link to post
Share on other sites
37 minutes ago, Exocer said:

hqplayer embedded default credentials are not working via the GUI for me. should the default hqplayer/password work?

 

Thanks

Problem solved. Please disregard.

Link to post
Share on other sites
2 hours ago, antonellocaroli said:

😀No, I already have a lot of tests to do with my system...😂

YES .. and I think these tests (VitOS) are truncated.
GentooPlayer works very well .. at home with Naa in IPV6 on Allo USBridge (NUC windows upstream, with double ethernet card). 👍

 

Question : howto made an IP fix (ipv4 AND ipv6) with ipv6 "preference" ?

Link to post
Share on other sites
19 hours ago, Zauurx said:

Question : howto made an IP fix (ipv4 AND ipv6) with ipv6 "preference" ?

Sorry, but I don't understand the question.
what would you like to do?

Participating in an existing IPv6 network ?

Creating a local IPv6 over IPv4 tunnel ?

Enabling IPv6 on your router, possibly via a tunnel (several ISP uses 6rd...) ?

 

Do you know what ipv4 and ipv6 are?

https://www.guru99.com/difference-ipv4-vs-ipv6.html

Link to post
Share on other sites

Historically I built a classic network: Tenda Mesh point <> cisco Meraki <> NUC <> USBridge GentooPLayer in dhcp 4 and 6.
I am using HQP in ipv6 between the nuc and the USBridge. IPV4 for the rest and Roon as a remote control.
I have a USB ethernet adapter with its power supply for the NUC.
I wanted to use the Intel inboard ethernet.
So now I have 2 ethernet cards on the NUC and I have isolated the HQP / USBridge connection leaving only IPV6 (IPV4 removal on this card).

Tenda Mesh point <> netcard 1 > ROON > HQP > netcard 2 > USBridge

HQP receive in IPV4 and send in IPV6
Of course, there is no bridge and so if I can administer the NUC via VNC, I cannot see the USBridge via SSH as before.
She is still in dynamic ipv and has kept her IP since HQP sees her.
So if I want to configure it, I must reconnect it directly to the Mesh box.

But you are right, as I did not put the 2 cards in bridge, even in IPfixe, I could not manage it.

Roon_server_scan_rezo.JPG

Roon_server_scan_rezo_2.JPG

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


×
×
  • Create New...