Jump to content
Sign in to follow this  
Panelhead

Super Duper Update

Recommended Posts

  I was planning on creating a new back up disc this morning using Super Duper. It automatically downloaded an update. 

  Now it is asking for full system access to copy the external data drive to another. It was not an issue before. 

  Is this normal?


 

2012 Mac Mini, i5 - 2.5 GHz, 16 GB RAM. SSD,  PM/PV software, Focusrite Clarett 4Pre 4 channel interface. Daysequerra M4.0X Broadcast monitor., My_Ref Evolution rev a , Klipsch La Scala II, Blue Sky Sub 12

Clarett used as ADC for vinyl rips.

Corning Optical Thunderbolt cable used to connect computer to 4Pre. Dac fed by iFi iPower and Noise Trapper isolation transformer. 

Share this post


Link to post
Share on other sites
2 hours ago, Panelhead said:

  I was planning on creating a new back up disc this morning using Super Duper. It automatically downloaded an update. 

  Now it is asking for full system access to copy the external data drive to another. It was not an issue before. 

  Is this normal?

I can't say for sure - but with the arrival of macos Mojave, there are new security measures and as a result new pop-up requests from certain apps requiring the user to grant certain levels of access to the system. So while you should exercise care, if SuperDuper updated itself from within the app, then it's very likely that the request you're getting is normal and legit.

Share this post


Link to post
Share on other sites

  Thanks, I checked the website and the full access requirement was listed for use with Mojave. 

  Not comfortable with that. 


 

2012 Mac Mini, i5 - 2.5 GHz, 16 GB RAM. SSD,  PM/PV software, Focusrite Clarett 4Pre 4 channel interface. Daysequerra M4.0X Broadcast monitor., My_Ref Evolution rev a , Klipsch La Scala II, Blue Sky Sub 12

Clarett used as ADC for vinyl rips.

Corning Optical Thunderbolt cable used to connect computer to 4Pre. Dac fed by iFi iPower and Noise Trapper isolation transformer. 

Share this post


Link to post
Share on other sites
40 minutes ago, Panelhead said:

  Thanks, I checked the website and the full access requirement was listed for use with Mojave. 

  Not comfortable with that. 

 

Thanks for taking the time to check! It's helpful for others here to know that it's a known issue officially recognized by the app's developer.

 

Off course you shouldn't do anything you're not comfortable with. For what it's worth, though, SuperDuper! is a very reputable app, and the access it's asking for isn't a new level of access - it's the same access as it used to have; it's just that Mojave tightened things up so now apps have to ask permission to do things they formerly didn't have to ask the user's permission for.

 

Again, not arguing with your point of view, just FYI.

Share this post


Link to post
Share on other sites
2 hours ago, Panelhead said:

  Thanks, I checked the website and the full access requirement was listed for use with Mojave. 

  Not comfortable with that. 

 

No need to worry. Apple changed some things in Mojave. To do what they used to do, some apps need special permission now when they did not with previous versions of macOS. You can trust well know apps. It's apps you never heard of that you need to worry about.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×
×
  • Create New...