Jump to content
IGNORED

AudioLinux and NUC Troubleshooting and Tuning


Message added by austinpop

Summary of useful findings and recommendations

 

This section will be a living repository of useful info from this thread. It's very similar to a wiki and will be maintained by a small group of thread moderators.

 

Before you get started please refer to the Audio-Linux website to ensure you have the latest info and the proper versions of the OS. Audio-Linux.com  

 

**** Updated for AL 1.30 menu 118 or later.

 

  "First Run" setup for headless.  

 

Setup your NUC with a keyboard, mouse, and monitor to the NUC BIOS settings.  From the menu note the IP address of the machine to SSH into.  From a MAC the macOS terminal program supports SSH:

324537708_ScreenShot2019-01-28at3_02_19PM.thumb.png.739dc7f9cdb05e04da806c7c66877332.png

 

Then it is simpler to cut and paste into the terminal session. After entering the password for the audiolinuxuser you will be presented with the AL headless menu:

 

1518375894_ScreenShot2019-01-28at3_04_18PM.thumb.png.a7b2867a163f8f014e56e52ff69f94b4.png

 

Option 8 takes you to the command line for the following basic setup.  You will need to be the Root user for this setup and the su command first:

 

su

 

Fix the time zone:  (this is my timezone - look in directory /usr/share/zoneinfo)

 

timedatectl set-timezone America/Chicago
 

Setup and Start NTP daemon (to keep the system time in sync)

 

*** the config file is now properly filled in.

 

Now Start the daemon

 

timedatectl set-ntp true

 

 

NOTE: Sometimes the system takes a little while to get synced up.
 

Set hostname  (this provides a unique name for the machine on your network.  Replace <NAME> with your chosen name)

 

hostnamectl set-hostname <NAME> 
 

Once the above items are set up your machine is ready to be configured for say a Roon bridge/endpoint. That is done using the AL menu.  To return to the menu do the following commands.

 

exit

menu

 

----------------------------------

 

For most of us, the following basic settings are key.

From the configuration menu:

6. START and enable Roonbridge

15. SET Realtime Priority to extreme

16. ENABLE ramroot (reboot after)

 

Return to the main menu and reboot the NUC using 

 

11 Reboot

 

------------------

Roon Server setup is a bit more complex and we will cover it completely a bit later.  The key is where you are booting from and where the Roon database is stored.  In general; say a 32gb OPTANE "SSD".

 

  • You have to partition the SSD into a boot drive and a storage drive.  
  • The transfer the USB stick install to the boot partition.  
  • Reboot from the boot partition.  
  • Do the basic setup. Timezone and name
  • Transfer the Roon Database to the storage drive
  • Start the Roon Server
  • .....

 

----------------- 

The machine will reboot and from the display attached to the NUC you can watch it boot up and load into RAM.  Once the AudioLinux menu is showing the endpoint should be available in Roon.    This completes the basic startup sequence.  The system is ready to start testing.    

 

 

Recommended Posts

2 hours ago, Aberrant-Decoder said:

hi,whenever i assign a cpu to roon appliance, does that include the roon server,or is there a way to assign  cpu specifically to roonserver.  my setup is 1 pc as roon server,seezelie player out by usb to my dac.

thanks

The names of Roon processes are

/opt/RoonServer/RoonMono/bin/RoonServer
/opt/RoonServer/RoonMono/bin/RoonAppliance
/opt/RoonServer/Server/processreaper
/opt/RoonServer/RoonMono/bin/RAATServer

My choice some time ago was to choose RoonAppliance for priority and core assignment but this can change on future menu releases.

For core assignment maybe all process above will be transferred to the selected core.

For priority the choice is more difficult but it seems from a post at RoonLabs that "RoonServer.exe is very very lightweight, and all it does is watchdog RoonAppliance.exe"

I guess is the same on linux.

AudioLinux --> https://www.audio-linux.com

developer of AudioLinux realtime OS

Link to post
Share on other sites

 

Yesterday I updated all of my devices to Roon 1.8. My Audiolinux endpoint still shows in Roon as being version 1.7 and “Up to Date”.

 

Does anyone know if there a Linux update to 1.8 and if so, should I just go into the Audiolinux menu on the endpoint and manually run the update?

 

Thanks!
Paul 
 


"Don't Believe Everything You Think"

System

Link to post
Share on other sites

You should go to to UPDATE menu to install new version. I have uploaded packages yesterday morning.
Note that roonserver is version 1.8 and roonbridge 1.7.
There is not a correspondence between roonserver and roonbridge version. For example when roonserver was 1.8, roonbridge was version 1.0

AudioLinux --> https://www.audio-linux.com

developer of AudioLinux realtime OS

Link to post
Share on other sites
14 minutes ago, hifi25nl said:

You should go to to UPDATE menu to install new version. I have uploaded packages yesterday morning.
Note that roonserver is version 1.8 and roonbridge 1.7.
There is not a correspondence between roonserver and roonbridge version. For example when roonserver was 1.8, roonbridge was version 1.0

Thanks Piero. Much appreciated.


"Don't Believe Everything You Think"

System

Link to post
Share on other sites
51 minutes ago, hifi25nl said:

You should go to to UPDATE menu to install new version. I have uploaded packages yesterday morning.
Note that roonserver is version 1.8 and roonbridge 1.7.
There is not a correspondence between roonserver and roonbridge version. For example when roonserver was 1.8, roonbridge was version 1.0

 

I went to the update menu and chose Roon. When I initiated the update there was an immediate reply that my "audio applications had been updated" but there was no installation that happened.

 

In Roon the version on my NUC shows 1.7 build 571.

 

Is that correct and the most current?


"Don't Believe Everything You Think"

System

Link to post
Share on other sites

Be sure that you are on menu 260

 

To check version

yay -Q roonserver

yay -Q roonbridge

First is 1.8, second is 1.7

 

To see errors, install it from console

yay -Sy roonserver

For roonbridge

yay -Sy roonbridge

 

If you see errors about some file that already exists in filesystem, before updating Roon, delete the application directory

sudo rm -rf /opt/RoonServer

sudo rm -rf /opt/RoonBridge

and after install Roon with the commands reported above.

 

This problem can happen if you tried to update from a control point in smartphone or another PC

You should update roon ONLY from Update menu

AudioLinux --> https://www.audio-linux.com

developer of AudioLinux realtime OS

Link to post
Share on other sites
  • 1 month later...

Hi Piero:

Have you experienced (or someone) that after configuring and getting ready AL 2.9, enabling RAMROOT, booting successfully, all the sudden you cannot longer boot from the USB flash drive, if I mount /dev/sdb2 on some other Linux box it shows the contents as normal but if I mount /dev/sdb1 there is nothing there, it just stopped booting, I can of course redo the install but don't want to fail again, could it be related to the RAMROOT config? just curious

 

Link to post
Share on other sites

If you have another linux system the content for example of the headless version should be

 

[[email protected] ~]$ sudo fdisk -l
[sudo] password for root:  
Disk /dev/sde: 28.64 GiB, 30752636928 bytes, 60063744 sectors
Disk model: Ultra USB 3.0    
Units: sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disklabel type: gpt
Disk identifier: 524A1828-2002-4187-B469-3E7A2DE53ED0

Device       Start      End  Sectors  Size Type
/dev/sde1     2048  1001471   999424  488M EFI System
/dev/sde2  1001472 27813887 26812416 12.8G Linux filesystem

 

If you have the same output as above, I need to see the error messages at the first stages of boot on a screen, if possible.


 

AudioLinux --> https://www.audio-linux.com

developer of AudioLinux realtime OS

Link to post
Share on other sites

I'll send you the fdisk output from the other system, there is no boot at all, just that the device is not bootable, I am using UEFI of course, and it worked initially even after enabling ramroot but just suddenly went into that, I just build another system but would like to troubleshoot the failing one

 

Link to post
Share on other sites
5 hours ago, hifi25nl said:

If you have the same output as above

Disk /dev/sdb: 57.3 GiB, 61530439680 bytes, 120176640 sectors
Units: sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disklabel type: gpt
Disk identifier: 524A1828-2002-4187-B469-3E7A2DE53ED0

Device       Start       End   Sectors  Size Type
/dev/sdb1     2048   1001471    999424  488M EFI System
/dev/sdb2  1001472 120174591 119173120 56.8G Linux filesystem

 

 

Same output but like I said there is no boot error or message, just no boot at all

Link to post
Share on other sites

Piero for prioritizing the enp1s0 adapter before the file to be edited was rtirq.conf adding the adapter on the RTIRQ_NAME_LIST, is this still the case?

or should the rtnet.conf file be used adding INTERFACE="enp1s0"

 

RTIRQ_NON_THREADED has "rtc snd" this basically instructs these processes to use all cores but not threads or does it limit the rtc and snd apps to be single core?

Link to post
Share on other sites
1 hour ago, luisma said:

I'll send you the fdisk output from the other system, there is no boot at all, just that the device is not bootable, I am using UEFI of course, and it worked initially even after enabling ramroot but just suddenly went into that, I just build another system but would like to troubleshoot the failing one

 

I would check first http://www.audio-linux.com/html/boot.html

 

Note that the last ramroot version is 2.0.1-2

It should be updated by updating menu, exit from menu, restart it but you can update with

yay -Sy ramroot --noconfirm

The last menu will also set initramfs compression to gzip. See

IMPORTANT: since the new mkinitcpio package will use a new compression format, installations with linux-rt-lts kernel will not boot  if you make a system update.
If you are using instead the last linux-rt or linux-rt-bfq-dev kernels the system should boot normally.

Please be sure that in the file /etc/mkinitcpio.conf you have

COMPRESSION="gzip"

not

#COMPRESSION="gzip"

 

 
30 minutes ago, luisma said:

Piero for prioritizing the enp1s0 adapter before the file to be edited was rtirq.conf adding the adapter on the RTIRQ_NAME_LIST, is this still the case?

or should the rtnet.conf file be used adding INTERFACE="enp1s0"

 

RTIRQ_NON_THREADED has "rtc snd" this basically instructs these processes to use all cores but not threads or does it limit the rtc and snd apps to be single core?

Now there is the option 1 "REALTIME MANUAL ASSIGNMENT configuration" in Expert menu where you can set priority without manually edit the files that are

/etc/rtirq.conf

/etc/rtnet.conf

/etc/rtapp/rtapp.conf

 

Note that RTIRQ_NON_THREADED should have the same values as RTIRQ_NAME_LIST and that rtc should be removed (suggestion by rtirq developer - rtapp will not work correctly with rtc included) and snd should be removed also if you are using a USB DAC;

 

A little guide:

 

The logic of prioritization lies in this rule:
Priority must increase from upstream to downstream

Let's take for example a computer with the DAC connected directly. The audio stream goes this way:
audio application (rtapp) -> output (USB or other, rtirq)
In an APPLICATION / OUTPUT / NETWORK scheme, i.e. RTAPP / RTIRQ / RTNET, some possible values are these:
90/95 / -
85/90 / -
80/85 / -
Where it is noted that rtnet, ie the network priority is not defined. It would be absurd in this case to give Internet traffic a high priority.
I note that the operating system will perform the operation with the highest priority first. This is an important constraint. If it fails to do so within a reasonable time, the system will begin to produce errors or go into total lockdown.
Because of this it is not necessarily true that higher values are better. It depends on the processor power, motherboard latency etc.

Now let's take a system with the server sending the signal over Ethernet to a second computer to which the DAC is connected. On the first computer configured as a Bridge, an Ethernet output is connected to the router, while the second is connected directly to the Ethernet socket of the second computer. The second computer is obviously NOT configured in Bridge mode.
In this case it would not make sense to prioritize the USB output on the server, so on the server the configuration could be:
SERVER CONFIGURATION
90 / - / 95
85 / - / 90
80 / - / 85
-> These values are somewhat arbitrary. If you are having problems, it is recommended that you disable rtnet.
On the second computer (endpoint) instead:
ENDPOINT CONFIGURATION
90/95/85
85/90/80
80/85/75
As you can see the network has the lowest value since the stream is now ETHERNET -> APPLICATION -> IRQ / DAC
-> These values are somewhat arbitrary. If you are having problems, it is recommended that you disable rtnet.

If, on the other hand, both computers are connected to the router, you must disable rtnet, since in this case the Internet traffic would also pass through the endpoint. This is precisely the reason for using the Bridge on the first computer, which serves to prevent internet traffic from traveling on the same cable used by the signal.
 

AudioLinux --> https://www.audio-linux.com

developer of AudioLinux realtime OS

Link to post
Share on other sites
8 minutes ago, hifi25nl said:

Piero I was able to boot initially, update menu, update kernel, update system, then customize a few things like realtime processes and such, then ramroot, after ramroot I was able to boot, did a clean up, saved the system and then I wasn't able to boot anymore, I think you are assuming I cannot boot the image, of course I could, it is just after that for no apparent reason the system stopped booting

 

12 minutes ago, hifi25nl said:

Now there is the option 1 "REALTIME MANUAL ASSIGNMENT configuration" in Expert menu where you can set priority without manually edit the files that are

/etc/rtirq.conf

/etc/rtnet.conf

/etc/rtapp/rtapp.conf

Thank you for the detailed explanation, now I get it ...

 

Link to post
Share on other sites

You should check the content of mkinitcpio.conf as suggested in the post and be sure that you have the right value before updating system kernel or enabling ramroot.

This problem is not a bug but a decision from archlinux to change default compression to zst. 

...But linux-rt-lts 5.4.x cannot support this.

No problem with kernel 5.10 5.11

 

 

 

 

AudioLinux --> https://www.audio-linux.com

developer of AudioLinux realtime OS

Link to post
Share on other sites
27 minutes ago, hifi25nl said:

You should check the content of mkinitcpio.conf as suggested

1. Update Menu

2. Update to later RT 5.11 kernel

3. Update system

4. I have COMPRESSION="gzip"

 

That was not the issue something else was, if you are interested I still have the USB flash and it is accessible, but I'm already running another install so I'm fine

Link to post
Share on other sites
  • 1 month later...

Is it possible to span multiple HDDs into one volume in audiolinux?

 

Luxury question: If it IS possible to span, is it possible to do it in a way where failure of one of the drives will not kill the entire volume?

 

I'm asking, because I want to install audiolinux onto a desktop and use the spanned volume as one part of a redundant backup solution for my music.  Thanks much!

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


×
×
  • Create New...