Jump to content
rickca

AudioLinux and NUC Troubleshooting and Tuning

austinpop

Summary of useful findings and recommendations

 

This section will be a living repository of useful info from this thread. It's very similar to a wiki and will be maintained by a small group of thread moderators.

 

Before you get started please refer to the Audio-Linux website to ensure you have the latest info and the proper versions of the OS. Audio-Linux.com  

 

**** Updated for AL 1.30 menu 118 or later.

 

  "First Run" setup for headless.  

 

Setup your NUC with a keyboard, mouse, and monitor to the NUC BIOS settings.  From the menu note the IP address of the machine to SSH into.  From a MAC the macOS terminal program supports SSH:

324537708_ScreenShot2019-01-28at3_02_19PM.thumb.png.739dc7f9cdb05e04da806c7c66877332.png

 

Then it is simpler to cut and paste into the terminal session. After entering the password for the audiolinuxuser you will be presented with the AL headless menu:

 

1518375894_ScreenShot2019-01-28at3_04_18PM.thumb.png.a7b2867a163f8f014e56e52ff69f94b4.png

 

Option 8 takes you to the command line for the following basic setup.  You will need to be the Root user for this setup and the su command first:

 

su

 

Fix the time zone:  (this is my timezone - look in directory /usr/share/zoneinfo)

 

timedatectl set-timezone America/Chicago
 

Setup and Start NTP daemon (to keep the system time in sync)

 

*** the config file is now properly filled in.

 

Now Start the daemon

 

timedatectl set-ntp true

 

 

NOTE: Sometimes the system takes a little while to get synced up.
 

Set hostname  (this provides a unique name for the machine on your network.  Replace <NAME> with your chosen name)

 

hostnamectl set-hostname <NAME> 
 

Once the above items are set up your machine is ready to be configured for say a Roon bridge/endpoint. That is done using the AL menu.  To return to the menu do the following commands.

 

exit

menu

 

----------------------------------

 

For most of us, the following basic settings are key.

From the configuration menu:

6. START and enable Roonbridge

15. SET Realtime Priority to extreme

16. ENABLE ramroot (reboot after)

 

Return to the main menu and reboot the NUC using 

 

11 Reboot

 

------------------

Roon Server setup is a bit more complex and we will cover it completely a bit later.  The key is where you are booting from and where the Roon database is stored.  In general; say a 32gb OPTANE "SSD".

 

  • You have to partition the SSD into a boot drive and a storage drive.  
  • The transfer the USB stick install to the boot partition.  
  • Reboot from the boot partition.  
  • Do the basic setup. Timezone and name
  • Transfer the Roon Database to the storage drive
  • Start the Roon Server
  • .....

 

----------------- 

The machine will reboot and from the display attached to the NUC you can watch it boot up and load into RAM.  Once the AudioLinux menu is showing the endpoint should be available in Roon.    This completes the basic startup sequence.  The system is ready to start testing.    

 

 

Message added by austinpop

Rate this topic

Recommended Posts

I thought I would try the headless version of Audiolinux - guess what... everything works straight off apart from upmpdcli which fails to launch and would not reinstall.  I didn't have to do any searching for workarounds, Alsa and audio output worked first time, WiFi from the menu also worked (WiFi setup in the audiolinux menu in lxqt fails to recognise my WFi network, that's why I had to resort to installing wicd network manager).

 

So my experience with the headless version couldn't be any different, I think it's great.  I just need to get upmpdcli  working.  I also think that the lxqt version presently needs work and has the potential to cause frustrations for many.

 

My system is nuc7i7dnhe, 16 GB RAM, Optane H10 SSD.  Running Audiolinux off USB at present. Naim DAC V1.

Share this post


Link to post
Share on other sites

Still struggling to get  Audiolinux on the NUC to recognise the directly connected server worked fine with Ubuntu. I can share the internet from the server  but no network? Are there any network tips? 

Piero has been helping, he is on holiday at the moment, so dont want to pester him too much. 

Share this post


Link to post
Share on other sites
1 hour ago, dctom said:

Still struggling to get  Audiolinux on the NUC to recognise the directly connected server worked fine with Ubuntu. I can share the internet from the server  but no network? Are there any network tips? 

Piero has been helping, he is on holiday at the moment, so dont want to pester him too much. 

 

Not sure it is what you want, anyway: I was able to get AL on the NUC see server after assigning IP address through AL settings (network config, etc)

Share this post


Link to post
Share on other sites

Login on using SSH in Terminal on a Mac as suggested by Austinpop on the sticky post of this forum works great for accessing the headless version...

 

I still can't  get upmpdcli to launch and run as a service - tried stopping all of the audio services and then restarting, but no joy.  So I tried reinstalling, but I get errors:

 

1058445451_Screenshot2019-07-20at21_30_06.png.17d4ed79560b6c5d0e051199c329bc44.png

 

Any suggestions?

Share this post


Link to post
Share on other sites
20 hours ago, dctom said:

Still struggling to get  Audiolinux on the NUC to recognise the directly connected server worked fine with Ubuntu. I can share the internet from the server  but no network? Are there any network tips? 

Piero has been helping, he is on holiday at the moment, so dont want to pester him too much. 

You running multihomed? wireless to the internet and then network to an NAA? sorry not much info, I am running that config I just mentioned 

Share this post


Link to post
Share on other sites

I have wired ethernet to a server computer which is bridged then directly connected to a NUC, the two machines can share internet access. 

Have managed to get the server to show audiolinux NUC now. 

I now want to play HQplayer from the server to the NUC, the NUC has got HQplayer and NAA installed. Not sure how to get NAA up and running on the NUC?

Share this post


Link to post
Share on other sites
3 hours ago, dctom said:

I have wired ethernet to a server computer which is bridged then directly connected to a NUC, the two machines can share internet access. 

Have managed to get the server to show audiolinux NUC now. 

I now want to play HQplayer from the server to the NUC, the NUC has got HQplayer and NAA installed. Not sure how to get NAA up and running on the NUC?

 

You may enable NAA in AL menu.

Share this post


Link to post
Share on other sites
23 hours ago, Gavin1977 said:

Login on using SSH in Terminal on a Mac as suggested by Austinpop on the sticky post of this forum works great for accessing the headless version...

 

I still can't  get upmpdcli to launch and run as a service - tried stopping all of the audio services and then restarting, but no joy.  So I tried reinstalling, but I get errors:

 

1058445451_Screenshot2019-07-20at21_30_06.png.17d4ed79560b6c5d0e051199c329bc44.png

 

Any suggestions?

 

Answer to this is to follow the upgrading system advice:

 

For updating the system (expert users)
pacman -Syu
after this, you can update the AUR packages with
yaourt -Syua

 

Then install the package - uPNP now working!! YAY!!

Share this post


Link to post
Share on other sites
On 7/16/2019 at 8:40 AM, Gavin1977 said:

Anyone know what software works well for configuring AudioLinux as a DLNA endpoint/client?

 

I ask because I just found this great app called iEast Play, which I believe is a DLNA controller used in a number of cheap streamers including Nords new EasyStream - however it looks really super... TIDAL, Deezer Qobuz it does the lot.

 

Also, just thought I'd mention that those of you that aren't running AL headless, check out the wicd network manager - miles easier than setting up WiFi with wpa supplicant which is a pain to use.  Instructions available in this YouTube clip here.

Forget this iEast app - only works with EasyStream Systems.  Linn Kazoo working great for me at the moment for uPNP control via my iPhone to Audiolinux NUC.

Share this post


Link to post
Share on other sites
11 hours ago, AnotherSpin said:

 

You may enable NAA in AL menu.

 

Thanks have got NAA running now but server not "seeing" the DAC in the settings menu in HQp with NAA as backend.

Share this post


Link to post
Share on other sites

Ok, you have router -> server-> NAA endpoint networked, and you have MIska's image with HQPE and NAA on a NUC, correct? HQP on a server should see Miska's NAA now. Maybe, restart of both server and endpint or changing between IPv4 and IPv6 in HQP output settings would help. You may try Miska's image with NAA only as well.

Share this post


Link to post
Share on other sites

thanks

I have audiolinux installed on my endpoint NUC and it is networked - I have the desktop version of HQP on the NUC  - is HPQE the embedded version? do I need HQPE instead of desktop HQPlayer ? I do have NAA on the NUC.

Just to say I am using Piero's audiolinux OS ( https://www.audio-linux.com/ ) the endpoint - am I right in thinking HQPE is a standalone OS.

From what I have read the server with desktop HQp should be able to recognise my DAC when network audio is selected in the settings of HQp on the server with NAA running on the client (NUC) - maybe I am wrong in this? 

 

Share this post


Link to post
Share on other sites

Ok, I can tell you what I have. Mac mini with HQP desktop, networked to NUC booted from audiolinux headless on USB stick. It works ok. I also could do the same with NUC booted from free Miska's NAA on USB stick, either sole or paired with HQP Embedded (Miska has two types of NAA Image). Euphony on USB stick also works ok. Have no idea why you need HQP on NUC? NAA image on USB stick works for NAA endpoint.

Share this post


Link to post
Share on other sites

I guess I have little experience of this type of configuration - but it has gradually dawned on me you don't need to have HQp on the endpoint😕

I just need to get the NAA up and running.

Interestingly I have just installed HQp4 on both machines using ubuntu, there is now an option to run it in client mode on the endpoint and it is playing from the server but with no sound so far!!!

 

I would like to try the NAA on a USB stick, do you have a link for that image please?

 

Share this post


Link to post
Share on other sites

@austinpop

Could you add this to your sticky "Summary of useful findings and recommendations" as I think it would be useful for newcomers.  After much effort (and advice from Piero) I now have AudioLinux working perfectly and am very happy.  I would suggest that the following steps are therefore recommended as 'good practice' for a new installation.

 

Before your suggestion to enable RAMROOT please include the following guidance:

 

1. Exit to console and run system upgrade (network connection to internet required obviously)

For updating the system (expert users)
pacman -Syu


after this, update the AUR packages with
yaourt -Syua

 

Running the latest version will help avoid any unexpected behaviour of audiolinux (e.g. WiFi config not working correctly etc...).

 

2.  Set default soundcard, by following guidance here: https://www.alsa-project.org/wiki/Setting_the_default_device, which is:

 

Find your desired card with:

   cat /proc/asound/cards

and then create /etc/asound.conf with following:

   defaults.pcm.card 1
   defaults.ctl.card 1

Replace "1" with number of your card determined above.

 

I found this to be important as audiolinux sometimes wouldn't allow me to set and retain the desired audiocard/DAC within AlsaMixer.  This config file means that it'll always work.

 

3. Very important - only run one audio service at a time! For example don't run RoonBridge and uPNP functions at the same time as it will cause a conflict with no sound / unexpected behaviour.  Stop and disable all audio services, then select the service you want (reboot might also be required)

Share this post


Link to post
Share on other sites
6 hours ago, Gavin1977 said:

@austinpop

Could you add this to your sticky "Summary of useful findings and recommendations" as I think it would be useful for newcomers.  After much effort (and advice from Piero) I now have AudioLinux working perfectly and am very happy.  I would suggest that the following steps are therefore recommended as 'good practice' for a new installation.

 

Before your suggestion to enable RAMROOT please include the following guidance:

 

1. Exit to console and run system upgrade (network connection to internet required obviously)

For updating the system (expert users)
pacman -Syu


after this, update the AUR packages with
yaourt -Syua

 

Running the latest version will help avoid any unexpected behaviour of audiolinux (e.g. WiFi config not working correctly etc...).

 

2.  Set default soundcard, by following guidance here: https://www.alsa-project.org/wiki/Setting_the_default_device, which is:

 

Find your desired card with:

   cat /proc/asound/cards

and then create /etc/asound.conf with following:

   defaults.pcm.card 1
   defaults.ctl.card 1

Replace "1" with number of your card determined above.

 

I found this to be important as audiolinux sometimes wouldn't allow me to set and retain the desired audiocard/DAC within AlsaMixer.  This config file means that it'll always work.

 

3. Very important - only run one audio service at a time! For example don't run RoonBridge and uPNP functions at the same time as it will cause a conflict with no sound / unexpected behaviour.  Stop and disable all audio services, then select the service you want (reboot might also be required)

 

Actually the content in sticky up top was created by @bobfa, so I'd as him to consider the changes you recommend. 

 

(The AS topic owner actions have some quirks, so the sticky shows the owner to be whoever originally created the message, not who last edited it.)

Share this post


Link to post
Share on other sites
12 minutes ago, austinpop said:

 

Actually the content in sticky up top was created by @bobfa, so I'd as him to consider the changes you recommend. 

 

(The AS topic owner actions have some quirks, so the sticky shows the owner to be whoever originally created the message, not who last edited it.)

I am on a very poor internet connection.  I will try to figure this out when I am in better cover coverage

Share this post


Link to post
Share on other sites

i'm running AL on a nuc running roon core.  booting from usb and ramroot enabled.

 

one thing i've noticed is that over time, more and more ram is consumed.  as this occurs, the nuc seems to search more slowly.  i'm assuming some cache is not being cleaned up.

 

is there any setting or anything i need to know about to prevent this from happening?

 

current approach is to save system and reboot.  it works, but not really convenient.

 

@hifi25nl - thoughts?


source:  intel nuc8i5 (audiolinux, roon core) > intel nuc6i5 (win10, ao, fidelizer pro, dirac live, roon) > schiit yggdrasil (gen 5, analog 2)
headphone rig:  bryston bha-1 > senn hd600
two-channel rig:  bryston bha-1 > parasound a21 > monitor audio gx100

Share this post


Link to post
Share on other sites

In Audiolinux there is the main menu option 14 "Clean system" that will remove downloaded packages after an update and some cache content.

I don't think this is your problem however. Roon will increase cache and library size in time. The only solution is to transfer Roon library to another Hard Disk/Partition with the option 5 "TRANSFER Roon database to/from another drive" in configuration menu.

 

 


AudioLinux --> https://www.audio-linux.com

developer of AudioLinux realtime OS

Share this post


Link to post
Share on other sites
22 hours ago, Gavin1977 said:

cat /proc/asound/cards

Hi Gavin, this specific file is empty in my case

cat /proc/asound/cards

[[email protected] audiolinux]# cat /proc/asound/cards
--- no soundcards ---

 

Maybe has been moved to alternate path need to look

 

Share this post


Link to post
Share on other sites
1 hour ago, luisma said:

Hi Gavin, this specific file is empty in my case

cat /proc/asound/cards

[[email protected] audiolinux]# cat /proc/asound/cards
--- no soundcards ---

 

Maybe has been moved to alternate path need to look

 

How odd - this works for me and shows me list of cards?  Since providing these instructions I have also found that Audiolinux actually contains menu options for this already (I didn't know about it due to lack of clear instructions).  Go to 4. Export menu then 6. Alsa System Wide Configuration.  

Share this post


Link to post
Share on other sites

I'm trying to figure out how I can mount a USB stick on AL, and then share it to the network. I want to try using my NUC as a single box solution, with AL on an octane drive, running Roon, and having all music on a USB drive/stick.

I managed to mount the USB stick, it needs to be formatted in NTFS, or in EXT4, and I can access it in the terminal.

There is also a network drive showing up, named "audiolinux", with the folders "audiolinux" and "Downloads". In "audiolinux" are the subfolders "Downloads" and "Music". So I can drag and drop music from my computer into the Music folder for instance, but the space on the optane drive is limited off course.

How can I share a mounted USB drive with the network? I tried mounting it at /media/samba, but that does not seem to work.

Share this post


Link to post
Share on other sites

You should edit as root /etc/samba/smb.conf and add something like this:

 

[MyMusic]
path = /media/samba
available = yes
public = yes
guest ok = yes
writable = yes

 

Samba server must be up. As root type

systemctl enable smb

systemctl enable nmb

 

Finally reboot

 


AudioLinux --> https://www.audio-linux.com

developer of AudioLinux realtime OS

Share this post


Link to post
Share on other sites
1 hour ago, hifi25nl said:

You should edit as root /etc/samba/smb.conf and add something like this:

 

[MyMusic]
path = /media/samba
available = yes
public = yes
guest ok = yes
writable = yes

 

Samba server must be up. As root type

systemctl enable smb

systemctl enable nmb

 

Finally reboot

 

 

Thank you very much! This was what I needed. I've added the folders, and can now access them over the network. Great support, thanks Piero!

Share this post


Link to post
Share on other sites
Returning After an 8 month hiatus from everything audio, I have downloaded the latest links (headless & lxqt) from Piero but I'm struggling to copy it on the USB stick. If anyone's posted a link on how to do this (Mac specific) please point me towards it. Anyone have success copying the img with Etcher?
 
I use a Mac book pro as a server and plan on using the Celeron NuC as headless endpoint.
 
 
 
 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...