Jump to content
rickca

AudioLinux and NUC Troubleshooting and Tuning

austinpop

Summary of useful findings and recommendations

 

This section will be a living repository of useful info from this thread. It's very similar to a wiki and will be maintained by a small group of thread moderators.

 

Before you get started please refer to the Audio-Linux website to ensure you have the latest info and the proper versions of the OS. Audio-Linux.com  

 

**** Updated for AL 1.30 menu 118 or later.

 

  "First Run" setup for headless.  

 

Setup your NUC with a keyboard, mouse, and monitor to the NUC BIOS settings.  From the menu note the IP address of the machine to SSH into.  From a MAC the macOS terminal program supports SSH:

324537708_ScreenShot2019-01-28at3_02_19PM.thumb.png.739dc7f9cdb05e04da806c7c66877332.png

 

Then it is simpler to cut and paste into the terminal session. After entering the password for the audiolinuxuser you will be presented with the AL headless menu:

 

1518375894_ScreenShot2019-01-28at3_04_18PM.thumb.png.a7b2867a163f8f014e56e52ff69f94b4.png

 

Option 8 takes you to the command line for the following basic setup.  You will need to be the Root user for this setup and the su command first:

 

su

 

Fix the time zone:  (this is my timezone - look in directory /usr/share/zoneinfo)

 

timedatectl set-timezone America/Chicago
 

Setup and Start NTP daemon (to keep the system time in sync)

 

*** the config file is now properly filled in.

 

Now Start the daemon

 

timedatectl set-ntp true

 

 

NOTE: Sometimes the system takes a little while to get synced up.
 

Set hostname  (this provides a unique name for the machine on your network.  Replace <NAME> with your chosen name)

 

hostnamectl set-hostname <NAME> 
 

Once the above items are set up your machine is ready to be configured for say a Roon bridge/endpoint. That is done using the AL menu.  To return to the menu do the following commands.

 

exit

menu

 

----------------------------------

 

For most of us, the following basic settings are key.

From the configuration menu:

6. START and enable Roonbridge

15. SET Realtime Priority to extreme

16. ENABLE ramroot (reboot after)

 

Return to the main menu and reboot the NUC using 

 

11 Reboot

 

------------------

Roon Server setup is a bit more complex and we will cover it completely a bit later.  The key is where you are booting from and where the Roon database is stored.  In general; say a 32gb OPTANE "SSD".

 

  • You have to partition the SSD into a boot drive and a storage drive.  
  • The transfer the USB stick install to the boot partition.  
  • Reboot from the boot partition.  
  • Do the basic setup. Timezone and name
  • Transfer the Roon Database to the storage drive
  • Start the Roon Server
  • .....

 

----------------- 

The machine will reboot and from the display attached to the NUC you can watch it boot up and load into RAM.  Once the AudioLinux menu is showing the endpoint should be available in Roon.    This completes the basic startup sequence.  The system is ready to start testing.    

 

 

Message added by austinpop

Rate this topic

Recommended Posts

Hello,

I wan’t to try HQPlayer Embedded with AL headless and control it via Bubble UPnP on Android.

What are the steps to make it work with Bubble UPnP and what should I see as renderer In Bubble?

Should I enable and start HQPlayer service and should I enable and start upmpdcli service as well? 

Thanks Monge

Share this post


Link to post
Share on other sites

No, upmpdcli has nothing to do with hqplayerd, that is using Rygel.

You should have

<upnp interface="auto"> in /home/audiolinux/.hqplayer/hqplayerd.xml

but in Audiolinux is already there.

 

In Bubble UPnP you will see HQPlayer, the value defined in

<title value="HQPlayer"/>


AudioLinux --> https://www.audio-linux.com

developer of AudioLinux realtime OS

Share this post


Link to post
Share on other sites
On ‎1‎/‎24‎/‎2019 at 5:39 AM, ray-dude said:

The ArchLinux site (linked from the audiolinux site) has lots of good info on how to setup wireless networking, but it took a long time to wade through.  I distilled down my findings into a simple recipe that I use, that may be useful to others that want to play with WLANs on their NUC (I've used this on both my NUC7i7DNKE and NUC7CJYH)

* Make sure WiFi on in bios

* Install WPA supplicant

pacman -S wpa_supplicant

this doesn't work:

see pic:

1233460941_pacman-Swpa_supplicant.thumb.jpg.360554c66a2b6f3d9e2070a96e5f68f6.jpg

 

...but there is a: 

 

at:  http://mirror.rackspace.com/archlinux/core/os/x86_64/

 

but I don't know what to do?

 

any help/suggestions?

Share this post


Link to post
Share on other sites
2 minutes ago, hifi25nl said:

And I hope That you did't mess the network configuration, since I see a static IP on Ethernet. 

No, I don't think I messed with anything, I just followed the instructions on 'AS'. Thanks!

Share this post


Link to post
Share on other sites

I finally got round to testing the ethernet limiting option and noticed a noticible improvement in sound quality at 100mbps. 

 

I'd done the hardware equivelant of this in the past with similar results. 

 

The problem I'm having however is that although a limit of 100mbps works perfectly for bit perfect pcm it produces stuttering/total drop off when upsampling to dsd512. The problem is present in both Roon and HQPlayer. 

 

On paper 100mbps should be enough but in practice it isn't working out so well. 

 

Has anyone else run into this problem? 

 

Share this post


Link to post
Share on other sites
1 hour ago, rettib2001 said:

I finally got round to testing the ethernet limiting option and noticed a noticible improvement in sound quality at 100mbps. 

 

I'd done the hardware equivelant of this in the past with similar results. 

 

The problem I'm having however is that although a limit of 100mbps works perfectly for bit perfect pcm it produces stuttering/total drop off when upsampling to dsd512. The problem is present in both Roon and HQPlayer. 

 

On paper 100mbps should be enough but in practice it isn't working out so well. 

 

Has anyone else run into this problem? 

 

 

Though I am not using Audiolinux at the moment, I am upsampling and streaming at DSD512 quite happily with the last run of Ethernet cable coming from a 100mbps port. I would look at your network setup and/or hardware as one possibility.


One never knows, do one? - Fats Waller

The fairest thing we can experience is the mysterious. It is the fundamental emotion which stands at the cradle of true art and true science. - Einstein

Computer, Audirvana -> microRendu -> USPCB -> ISO Regen (powered by LPS-1) -> Ghent JSSG360 USB cable -> Pro-Ject Pre Box S2 DAC ->

Spectral DMC-12 & DMA-150 -> Vandersteen 3A Signature.

Share this post


Link to post
Share on other sites
1 hour ago, Jud said:

 

Though I am not using Audiolinux at the moment, I am upsampling and streaming at DSD512 quite happily with the last run of Ethernet cable coming from a 100mbps port. I would look at your network setup and/or hardware as one possibility.

 

That's encouraging. Time to take a closer look at my network... I have a feeling it could take some time to figure out. 

 

Thanks for the reply 

Share this post


Link to post
Share on other sites

@hifi25nl Piero,

 

Wondering if you could help with this. I've been enjoying Audiolinux on my NUC7i7DNBE greatly, and have been using Roon Bridge which always connects without any issues, 100% reliable.

 

I used to love using HQplayer before I moved to Audiolinux. With audiolinux, switching to the NAA service, I keep getting dropped connections with my HQplayer computer which is connected to the same Brocade ICX6650 switch. It takes a while before the HQPlayer desktop program can recognize the AL NAA.

 

I assumed this was a problem with HQP, so I posted in the HQP forum, and Jussi suggested using his NAA image to boot. Using that, it's 100% reliable with the same exact hardware, so I think in my case it is some Audiolinux setting which is off.

 

Any suggestions? I have 4GB RAM on my NUC which should be enough for NAA. Not sure why the connection is so flaky.

 

Thanks!

Yeang

Share this post


Link to post
Share on other sites

Here HQPlayer to NAA is working very fine. This is most probably a network configuration problem.

 

You should check that:

1) You have the last version of NAA

2) Your network connection is properly set in audiolinux (both Audiolinux and Jussi NAA image are using the same systemd network)

Type networkctl and be sure that all interfaces are up. If you re using DHCP you should have

 

[Network]
DHCP=yes

 

in the file /etc/systemd/network/auto.network

With this you will have both ipv4 and ipv6 enabled, good if you have selected ipv6 in the hqplayer configuration file.

 

If you have further problems you can contact me directly at [email protected]


AudioLinux --> https://www.audio-linux.com

developer of AudioLinux realtime OS

Share this post


Link to post
Share on other sites
9 hours ago, seatrope said:

@hifi25nl Piero,

 

Wondering if you could help with this. I've been enjoying Audiolinux on my NUC7i7DNBE greatly, and have been using Roon Bridge which always connects without any issues, 100% reliable.

 

I used to love using HQplayer before I moved to Audiolinux. With audiolinux, switching to the NAA service, I keep getting dropped connections with my HQplayer computer which is connected to the same Brocade ICX6650 switch. It takes a while before the HQPlayer desktop program can recognize the AL NAA.

 

I assumed this was a problem with HQP, so I posted in the HQP forum, and Jussi suggested using his NAA image to boot. Using that, it's 100% reliable with the same exact hardware, so I think in my case it is some Audiolinux setting which is off.

 

Any suggestions? I have 4GB RAM on my NUC which should be enough for NAA. Not sure why the connection is so flaky.

 

Thanks!

Yeang

I am running your same config and it is working just fine, as a matter of fact my system is "multihomed" which poses other issues with connectivity and it is just fine. Let me ask you are using HQP Desktop or Embedded HQPe? I'm on HQPe but the discovery engine it is the same I believe, Jussi can confirm that.

 

 

Share this post


Link to post
Share on other sites
9 hours ago, seatrope said:

@hifi25nl Piero,

 

Wondering if you could help with this. I've been enjoying Audiolinux on my NUC7i7DNBE greatly, and have been using Roon Bridge which always connects without any issues, 100% reliable.

 

I used to love using HQplayer before I moved to Audiolinux. With audiolinux, switching to the NAA service, I keep getting dropped connections with my HQplayer computer which is connected to the same Brocade ICX6650 switch. It takes a while before the HQPlayer desktop program can recognize the AL NAA.

 

I assumed this was a problem with HQP, so I posted in the HQP forum, and Jussi suggested using his NAA image to boot. Using that, it's 100% reliable with the same exact hardware, so I think in my case it is some Audiolinux setting which is off.

 

Any suggestions? I have 4GB RAM on my NUC which should be enough for NAA. Not sure why the connection is so flaky.

 

Thanks!

Yeang

1. Be sure you are not "blacklisting" any modules in /etc/modprobe.d/blacklist.conf

2. In console mode send the output of "networkctl" and "ip addr show" 

 

 

 

Share this post


Link to post
Share on other sites
9 hours ago, hifi25nl said:

Here HQPlayer to NAA is working very fine. This is most probably a network configuration problem.

 

You should check that:

1) You have the last version of NAA

2) Your network connection is properly set in audiolinux (both Audiolinux and Jussi NAA image are using the same systemd network)

Type networkctl and be sure that all interfaces are up. If you re using DHCP you should have

 

[Network]
DHCP=yes

 

in the file /etc/systemd/network/auto.network

With this you will have both ipv4 and ipv6 enabled, good if you have selected ipv6 in the hqplayer configuration file.

 

If you have further problems you can contact me directly at [email protected]

 

I use HQPlayer desktop to AL headless NAA, works fine.

Share this post


Link to post
Share on other sites

Could well be the blacklisting. @luisma @AnotherSpin @hifi25nl thanks so much for the tips.

 

I'll go back to a vanilla install and see if it works.

 

How much RAM do you guys have on the NAA machine? I have only 4GB, wonder if enough for NAA (it is enough for roonbridge for sure).

 

I use HQP desktop 3.25 not the embedded version.

 

@luisma I had a multihomed setup for a while, Miska yelled at me for that. It was too much trouble so i quit using that and went back to waiting for EtherRegen lol.

Share this post


Link to post
Share on other sites
9 minutes ago, seatrope said:

 

How much RAM do you guys have on the NAA machine? I have only 4GB, wonder if enough for NAA (it is enough for roonbridge for sure).

 

 

It is stated on AL site that you need 16GB RAM for entire system and 8GB for headless.

Share this post


Link to post
Share on other sites
4 minutes ago, AnotherSpin said:

 

It is stated on AL site that you need 16GB RAM for entire system and 8GB for headless.

 

True, but Piero had OK'd 4GB of ram for headless Roonbridge with Ramroot... this could be an issue with NAA i guess.

 

@hifi25nl Piero, do you know if 4GB ram is enough for NAA, with ramroot, using AL headless? 

 

Share this post


Link to post
Share on other sites
13 minutes ago, seatrope said:

Could well be the blacklisting. @luisma @AnotherSpin @hifi25nl thanks so much for the tips.

 

I'll go back to a vanilla install and see if it works.

 

How much RAM do you guys have on the NAA machine? I have only 4GB, wonder if enough for NAA (it is enough for roonbridge for sure).

 

I use HQP desktop 3.25 not the embedded version.

 

@luisma I had a multihomed setup for a while, Miska yelled at me for that. It was too much trouble so i quit using that and went back to waiting for EtherRegen lol.

I have 4 GB on mine, Miska yelled at me too but reality is multihomed with AL works and lately Miska's NAA image was giving me issues, his image is great but cannot be change

Share this post


Link to post
Share on other sites

 

13 minutes ago, seatrope said:

 

True, but Piero had OK'd 4GB of ram for headless Roonbridge with Ramroot... this could be an issue with NAA i guess.

 

@hifi25nl Piero, do you know if 4GB ram is enough for NAA, with ramroot, using AL headless? 

 

It is enough 4 GB, send me the output of the commands I sent you before

 

Share this post


Link to post
Share on other sites
Just now, luisma said:

I have 4 GB on mine, Miska yelled at me too but reality is multihomed with AL works and lately Miska's NAA image was giving me issues, his image is great but cannot be change

 

By some reason I like Jussi's NAA image a lot, even with comparison with both AL and Euphony.

 

Share this post


Link to post
Share on other sites
7 minutes ago, luisma said:

 

It is enough 4 GB, send me the output of the commands I sent you before

 

Will do, thanks @luisma. Right now running Jussi's NAA image but will swap over soon. 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...