Jump to content
chrisS

Spotify bit perfect to external dac

Rate this topic

Recommended Posts

No idea what's happening, as I haven't quite managed to duplicate your problem.

 

The closest I've come occurs when I deliberately try to upset things by using foobar2000's own control buttons (eg pause, stop, etc) or shutdown foobar2000 with the Spotify app still playing. Even then it doesn't consistently cause a problem  and only with the latest version 1.4 of foobar2000 - the previous version 1.3.20 of foobar200 doesn't appear to fail at all!

 

Also, I've always managed to get things going again just by stopping the playback in the Spotify app, selecting the computer as the connected (audio output) device, starting the playback again and then finally re-selecting the foobar2000 Renderer as the connected device.


We are far more united and have far more in common with each other than things that divide us.

-- Jo Cox

Share this post


Link to post
Share on other sites

Hi John thanks for that, i have got the latest version of Foobar, considered rolling it back to to 1:3 to see if it made a difference, may do yet, anyway was playing with it and switched off gapless playback in Foobar, that seemed to work, track advancing fine, except it decides to track advance to a different artist after a couple of tracks !!! and on one occasion threw up the error in the screenshot shown.

 

Cheers Chris

track change issue.PNG

Share this post


Link to post
Share on other sites

Ok it wasn't changing artists within Spotify as i briefly thought, Foobar had a playlist stored from when i last played some WAV files from my hard drive, it was playing a couple of tracks from Spotify then switching to the stored list !!!, cleared foobar stopped that issue, still failing to change tracks reliably, increased Buffer to 2990 ms again plays a few tracks now before sound fails on track advance. do you think its worth rolling Foobar back to 1:3

 

Cheers Chris

Share this post


Link to post
Share on other sites

Hi Chris,

 

Definitely worth seeing if the foobar2000 version 1.3.20 doesn't cause the same problems, available here:

https://foobar2000.org/old

 

You should be able to keep your current foobar2000, as there's no need to roll it back if you install the older version as a portable installation. That way you could use foobar2000 1.3.20 just for the UPnP renderer and avoid any last used playlist problems by not creating any playlist tabs in the first place. I'd remove the foo_upnp plugin from your current version first, though. You don't want to have two conflicting foobar2000 UPnP renderers confusing your Spotify setup's interfaces.

 


Also, you mentioned switching off gapless playback support. It might help, as I've noticed that the next track provided by Spotify's online server reaches foobar2000 playback engine's track queue, via the various interfaces, only just before it finishes playing the current track. Normally, a UPnP renderer is told the next track to fetch just after the current track has started playing, to give it the best possible chance of avoiding gapless playback failures due to timing issues.


However, what exactly did you do to when you "switched off gapless in Foobar"? As far as I'm aware there's no such setting in foobar2000 for its playback engine, which the foobar2000 UPnP renderer provides the audio file track streams for. Neither is there a gapless setting for the foobar2000 UPnP renderer itself. There is a completely unrelated gapless setting for the foobar2000 UPnP controller, which you aren't using (in Configure > Tools  > UPnP > Controller) - is that what you switched off?

 

The easiest way to switch off gapless in your Spotify setup would be further up the chain, in the UPnP/DLNA bridge LMS plugin's settings:

image.thumb.png.18014aeaec717a86ff1ff8ed65b24371.png


We are far more united and have far more in common with each other than things that divide us.

-- Jo Cox

Share this post


Link to post
Share on other sites

Hi John, unchecking gapless playback in LMS fixed it, it now changes track, if anything a little to quickly, the only issue left was that it didn't go on to playing similar genre tracks when the playist by the selected artist ends, did a bit of playing, and in LMS under Performance ,set database memory config to Max, that seems to have cured that, see screenshot of where i unchecked Gapless playback in Foo, it isn't specific as to which part it works on, just looks like it is the Gapless playback function for whole programme.

 

Are you saying that i can run 2 copies of Foobar 2000 on the same machine, ? that might be very desirable, 1 set up for Spotty and another to play Wav files from a hard drive, how would you do that.

 

Cheers Chris

Gapless control.PNG

Share this post


Link to post
Share on other sites
8 hours ago, chrisS said:

see screenshot of where i unchecked Gapless playback in Foo, it isn't specific as to which part it works on, just looks like it is the Gapless playback function for whole programme.

 

You need to make sure you know exactly where you've gone to in foobar's settings, Chris. If you look carefully, the gapless option is in the Tools>UPnP>Controller section, so it's for setting gapless playback support in the foo_upnp plugin's UPnP controller (which you aren't using) rather than for foobar as a whole. Admittedly the help text next to the tick box is a bit cryptic, if you haven't realised you are in the UPnP controller's settings section.

 

 

8 hours ago, chrisS said:

Are you saying that i can run 2 copies of Foobar 2000 on the same machine, ? that might be very desirable, 1 set up for Spotty and another to play Wav files from a hard drive, how would you do that.

 

Indeed, just select the Portable installation option when you run its setup application:

image.thumb.png.adb3843de365846d0f32f2b0e5bd581f.png

 

 

 

8 hours ago, chrisS said:

the only issue left was that it didn't go on to playing similar genre tracks when the playist by the selected artist ends, did a bit of playing, and in LMS under Performance ,set database memory config to Max, that seems to have cured that

 

That is interesting - it might be worth switching gapless back on in the UPnP/DLNA bridge plugin's settings and seeing if the Max database memory config setting also sorts out your gapless track advance issue.

 

 


We are far more united and have far more in common with each other than things that divide us.

-- Jo Cox

Share this post


Link to post
Share on other sites

Hi John been away for a few days, but back to playing with it today, have 2 copies of Foobar running now, see image, only snag with that was getting Wasapi loaded to components, if i clicked on get more components in the programme itself when you click install it brings up the first copy of Foobar, and puts it there, i had to take it from downloads and drag and drop it into components tray, on 2nd portable copy, that worked.

 

Its all  working now, except that the spotty system, will no longer play similar genre tracks when an artists playlist ends, can't figure out why, no settings have changed, it just doesn't do it anymore.

 

 

Cheers Chris

 

 

2X FOOBAR.PNG

Share this post


Link to post
Share on other sites

@Cebolla

Thank you for taking the time to make these instructions. After fumbling through a variety of forums and lots of fiddling with the various plugins, I have finally got my Spotify tracks playing through f2k and I couldn't have done it without your posts in this thread 😉 I'm surprised there isn't more discussion around this process since we almost all have Spotify and a DAC - perhaps everyone's got a fancy streamer and doesn't need to bypass Window's volume control on their PC 🤓

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...