Jump to content
IGNORED

Piano 2.1 + Kali + Raspberry 3B no mp3 no lossless 24 bits SOLVED


Recommended Posts

Hi,

 

I have the Piano 2.1 and the Kali with raspberry  3B.

 

Playing FLAC goes very well with very good sound.

 

But when I play a mp3 file or a 24 bits FLAC all I hear is a very loud digital hiss, and no music.

I tried the latest Volumio and the latest raspbian, both with the same results.

 

Is this a known software bug or is a device broken, and so yes, which one?

How can I find out?

 

kernel Linux 4.14.43-v7+, previous one had the same problems.

 

In my /boot/config.txt I have:

dtoverlay=allo-piano-dac-plus-pcm512x-audio,glb_mclk

 

Also tried:

dtoverlay=allo-piano-dac-plus-pcm512x-audio

 

I can give more info, just ask.

 

I also have the Boss, this one is very good, plays all my files.

Link to post
Share on other sites

If you haven't figured this out yet, it's been covered in the volumio forum -- bug crept in w/ new kernel, until it's ironed out need to set re-sampling to 32 bits. HTH.

 

BTW, how do you like that set-up. Been considering exactly that for myself. Happy with the separate sub-out's? Thx.

Link to post
Share on other sites

Thx,

I tried re-sampling on my raspbian OS with no luck.

I could not find a good how-to,  so perhaps it was my fault I did not succeed.

(I prefer Raspbian over Volumio)

 

BTW,

I like both set-ups, the Boss and the Piano+Kali. They both have their qualities.

I do not know yet which one I like best.

I guess it also depends on the kind of music you want to listen.

 

Both my systems have 2 Allo power supplies.

 

Link to post
Share on other sites

My first impression:

Piano + Kali: lots of detail, very open, very accurate, but also reveiling bad recordings as such. This in dual mono setting. Dual Allo power supply.

Boss: very smooth, good for relaxed listening. Dual Allo power supply.

 

The retailer had super low noise power supplies, I had to return them, they introduced clicks in the sound. Allo is good.

BTW,

Is it possible to install an older kernel in raspbian, and so yes, which version, to overcome mentioned problem?

Link to post
Share on other sites

SOLVED:

 

edit /etc/mpd.conf:

 

audio_output {
        type            "alsa"
        name            "My ALSA Device"
# add for mp3 and 24 bit-FLAC:
format          "192000:32:2"

}

 

 

edit /boot/config.txt:

 

dtparam=audio=off

dtoverlay=allo-piano-dac-plus-pcm512x-audio,glb_mclk

 

reboot

 

 

Link to post
Share on other sites

For playing of SACD I guess the Pi 3B Plus is better than the Pi 3B.

I found the buffer time of 30 seconds is better than the default of 0,5 s.

 

I play the music over wifi, perhaps ethernet or USB disk is better, don't know the bottleneck yet.

 

edit /etc/mpd.conf:

 

audio_output {
        type            "alsa"
        name            "My ALSA Device"
# add for mp3 and 24 bit-FLAC:
format          "192000:32:2"

# add for better playing dsf SACD files:

buffer_time             "30000000"    # microseconds = 30 seconds

}

Link to post
Share on other sites


×
×
  • Create New...