Jump to content
IGNORED

Seagate FreeAgent Standby Problem


Recommended Posts

Against the better advice I've received on this forum, I purchased a pair of Seagate external hard drives (FreeAgent Desk for Mac) to house my media library and serve as a backup drive. Under normal read/write operations, they work great: fast and quiet. But I have a problem accessing my external drive after it enters standby mode, forcing a hard reboot to restore normal operation.

 

When doing my research, there were the normal amount of "dead drive" complaints, but also some older mentions of a sleep/wake problem with OS X. Apparently, the drives were forced to sleep every 15 min or so, but this was resolved with some updated firmware. It seems that the problem has taken another form, though. I guess it serves me right for trying to save a couple of bucks.

 

My setup:

Mac Mini

OS X 10.6

iTunes 9/Boxee

Seagate FreeAgent Desk for Mac via firewire 800 (Library)

Seagate FreeAgent Desk for Mac daisy chained via firewire 800 (Time Machine)

 

Problem:

The external hard drive holding my library will not wake from sleep causing applications that access it (iTunes/Boxee/Disk Utility/Finder) to freeze. If I put the computer to sleep manually, which also puts the external drives into standby, I can wake the entire system after a short period of time and everything functions fine. However, if the Mini is put to sleep for an extended period of time, the drive will not wake. I've also tried preventing the Mini for sleeping and unchecked the "put hard disks to sleep when possible" option in the power settings. The Seagate drive will still go to sleep after a period of inactivity causing the system hang. I don’t have this problem with the Time Machine drive. This drive does not go into standby unless the Mini does, and when I wake the computer, the Time Machine drive wakes normally. However, if the Library drive goes into standby, then the Time Machine drive will also freeze.

 

I was able to prevent the Library drive from sleeping using an applet called Keep Drive Spinning. I set it to ping the drive every 15 min. This restored normal operation- Mini and Time Machine drives sleep and wake normally. However, the Library drive stays awake the all of the time.

 

Has anyone else experienced a problem like this? I would like restore normal sleep/wake function to my system. Does anyone with OS X experience know of something I can do to change the way the drive is brought out of standby?

 

Link to comment

I have this with my music/video library on it, connected to the mini via USB, and so far no problem.

 

Like you, I saw it on sale (Costco) and bought it. Only a few months later did I stop to read the comments on the Costco web site. They are quite critical (and I have no reason to doubt their truth).

 

Since mine is working fine, I decided not to touch it, but I make sure to back up the contents onto a pocket drive which I then stick in a fire safe.

 

I specifically DON'T use time machine with it or any other functionality. I just have a symbolic link (the unix kind, not the mac kind) to the directory, and I also gave iTunes the path to the music library.

 

Also, the first thing I did when I got it was reformat it to HFS+. I assume if you are using time machine you did this too, because HFS+ (or zfs) is required for Time Machine, or, that being the "Mac edition" it already came that way. If not, it might be worth a try.

 

Hardware-wise, the only differences I have are lack of firewire, and no second external drive daisy-chained. Try using USB2 and see if that works.

 

Link to comment

Scratch what I said about "Keep Drive Spinning." It doesn't work. Every time I go to use my Mini, the drives are in standby and won't wake up. Short of returning these to Amazon, what are my options for getting a functioning computer back? I feel like I'm back on my Window Millennium machine with the number of hard reboots I'm doing.

 

Link to comment

You could tickle it every 60 seconds to keep it awake with a shell script like this:

 

 

#!/bin/zsh -f

while 1=1

do

touch /Volumes/yourdiskname/foo.jnk

sleep 60

done

 

 

 

Save that to a text file, make it executable, and run it and see if it stays awake. (This creates an endless loop, but only very briefly taxes the system once every 60 seconds).

 

But mine doesn't suffer from this problem, so may I suggest you first try just having one disk mounted directly, and see if that stays awake? There may be some sort of disk arbitration issue with the daisy chain.

 

Link to comment

Can you post the output from the unix command

 

pmset -g

 

Then we can see what the current settings are.

 

You can use pmset to change the spindown time.

 

 

sudo pmset -a disksleep 360

 

will for example put your disks to sleep after 360 minutes of inactivity.

 

sudo pmset -a disksleep 0

 

Will prevent the disks from going to sleep.

 

 

Link to comment

I messed around some more. I set the "Keep Disk Spinning" app to touch the drives every 60 seconds. I also am keeping the mini from sleeping (disksleep 0), then the drives stay away, as well. No problems unless I manually sleep the computer- then the drives freeze in standby.

 

I'm not totally familiar with terminal. How do I "pmset" an external drive?

 

Link to comment
  • 1 month later...

With this same drive, when I wake from sleep, half the time the firewire seagate freeagent doesn't come back and I get a warning message.

 

Totally frustrating.

 

Let's both contact Seagate about this and refer to this thread. I want them to fix it or take it back.

 

Link to comment

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


×
×
  • Create New...