Jump to content
joey_corleone

McIntosh d1100 "fade-in" problem

Rate this topic

Recommended Posts

Hello,

 

I just added a new McIntosh d1100 to my system. Generally speaking, it works great, but there are a few quirky things that I was hoping I could get some help with.

 

My setup: Roon core runs on a dedicated Ubuntu Linux VM. I have Roon endpoint on a few Macbook’s, my iPad and my iPhone. I have a Raspberry Pi 2b with the latest build of dietpi on it, and Roon Bridge installed. I then utilize the USB to connect to the McIntosh d1100. Everything is running the latest builds of Roon. DSD over PCM (DoP) is my DSD strategy. Raspberry Pi and Roon Core is hard wired 1Gbps Ethernet

 

My issues: Pretty much in summary the "fade-in" issue described in part 1 of the d1100 review posted here at computer audiophile

 

  • Whenever I play an album, there is this weird thing where I miss the first bit of the first track. How much I miss seems to depend on source. For 16/44 CD quality, it is the first fraction of a second. For DSD it could be 2-3 seconds. In Roon, you can see the file playing the first few seconds, but the DAC does not lock and start outputting sound until between about 0.5s to 3s later, depending on source.For example, when playing The Beatles Please Please Me album, starting with “I saw her standing there”, you don’t hear the first part of Paul’s count in. When kicking off “A Hard Day’s Night”, you miss the first part of that epic first chord. This seems to happen regardless of what the source is (PCM, DSD, Various sample rates) and on every album

 

  • There is an intermittent issue with losing lock between tracks of an album. What happens is that at the end of one track of the album, typically during silence or low output parts during the last 3-5 seconds of the track, the DAC loses lock. Roon will still show the track playing. Then, Roon will move to the next track, the DAC regains lock and away it goes. It’s like a little “blip”. Sometimes, I end up missing just the first split second of the next track. This doesn’t happen between ALL tracks, or even between the same two tracks consistently. The issue seems to happen more frequently with DSD or high resolution PCM.

 

Sometimes, other than missing the first second or so of the first track, the album plays fine, with the DAC consistently keeping lock track to track. Other times, the DAC continually loses lock when one track ends, and locks back on for the start of the next track. Other times, it will lose lock after one track, then lock on for the next track, but I miss the first half second or so of the next track. This happens, but not all the time, and not between every track on an album. Very inconsistent.

 

I have tried playing with difference resync timer values, anywhere from 0.1s to 1s to 2s to even 5s just to see what would happen, as well as trying 250ms buffer to no avail. I also tried plugging my MacBook Air running Roon endpoint directly into the DAC, and experience the same problems.

 

I think what I am hitting is a result of how McIntosh implemented the firmware on their d1100.  McIntosh’ solution will likely be “use JRiver”, as they have a setting to add 2 seconds of silence between tracks that seemingly fixes this. I don’t want to use JRiver though…

 

Anything I can do or any ideas other than pray for future firmware that addresses this? It sounds GREAT, but losing the first few seconds of every album and the inconsistent inter-track behavior is really taking away from the album experience.

 

Thank You

Share this post


Link to post
Share on other sites

To elaborate more on the root cause and observations

  • When you start playing an album, the DAC is muted until it sees a signal with a certain very low amplitude

  • At the end of a track, if the signal flat lines the DAC mutes and loses lock. This in turn causes the problem where the very start of the next track is muted

  • At the end of a track, as long as the input signal and thus the fixed output of the DAC is not completely flat lined, it will keep lock and transition beautifully to the next track with no problems

 

This explains why some albums and tracks exhibit issue #2 and some do not.

 

 

 

Joey

Share this post


Link to post
Share on other sites

@joey_corleone It's the McIntosh USB ASIO driver.  My D150 does the same thing.  Went through 3 firmware versions - a PITA because you have to change the chip not just update by USB or something - and that was the best they could get to.  It's usually just the first track for me, whole albums play through after that.

Share this post


Link to post
Share on other sites
2 hours ago, Solstice380 said:

@joey_corleone It's the McIntosh USB ASIO driver.  My D150 does the same thing.  Went through 3 firmware versions - a PITA because you have to change the chip not just update by USB or something - and that was the best they could get to.  It's usually just the first track for me, whole albums play through after that.

 

I am not using Windows at any point in my chain, so I don’t think ASIO has anything to do with this. Roon Bridge is running on a light weight Linux box. Also, the first generation D1100 had issues with DSD pops, but they resolved that with hardware and firmware updates in subsequent batches. I think what I am seeing is actually a side effect of the firmware they implemented to fix the DSD popping issue

Share this post


Link to post
Share on other sites

@joey_corleone Apparently it’s the whole USB implementation, then.  It’s the same one in all of their DACs.  The DSD popping was the reason they did the “fade in”.   I understood at the time that it was due to the trigger level they set to determine if their was a data stream to unmute.  Popping is due to the relays. 

Share this post


Link to post
Share on other sites
4 hours ago, Solstice380 said:

@joey_corleone Apparently it’s the whole USB implementation, then.  It’s the same one in all of their DACs.  The DSD popping was the reason they did the “fade in”.   I understood at the time that it was due to the trigger level they set to determine if their was a data stream to unmute.  Popping is due to the relays. 

 

Did you end up keeping your d150 and finding any kind of solution?

Share this post


Link to post
Share on other sites
6 hours ago, joey_corleone said:

 

Did you end up keeping your d150 and finding any kind of solution?

 

I’ve kept it because I have the MCT450 for CD/SACDs that I haven’t ripped yet.   I use my Lampizator Golden Atlantic and a dCS Debussy now for USB through the network.  Neither of those have that issue using the same player software and NAA renderers.  (Win 10 NUCs and SoTM 200 Ultra/txUSB Ultra)

 

Still have that delayed fade in on the D150.  It’s a great sounding DAC so I could overlook it - but the D150 only does it on the first song with HQPlayer - so it’s not too annoying.  

Share this post


Link to post
Share on other sites

Thanks. At this stage, I have tried Windows with the McIntosh ASIO driver using Roon, Foobar 2000, and VNC, Mac OSX with Roon, QuickTime, VNC, Vox and JRiver, and Linux on a Roon Bridge, and cannot get it to behave.

 

In all cases I lose the first fraction of a second of the first album track and intermittently lose the first fraction of a second when an album naturally transitions tracks.

 

The only exception I found was that if you use JRiver, and enable the feature to add silence at start for hardware synchronization, it solves the first issue. However, that still did not solve the second.

 

If there is no reasonable solution proposed soon, I will have no choice but to return my D1100 and get something that works better with my setup.

Share this post


Link to post
Share on other sites

Looking at some changes to my system. I am now running a pair of McIntosh MC60 amplifiers my dad handed down. I really wanted to want a C2600, or stretch for the 1100 stack. I have a turntable also.

 

this problem with the DAC implementation, and some reports of Linux driver issues/lack, made me remove McIntosh preamp/DAC/phono from my list.

 

computer Audio continues to be my main listening, so the DAC continues to be about the most important part.


[Home Digital] Bricasti M12 > McIntosh MC60 > Zu Druid V + Undertone (BHSE + Voce)

[Home Analog] Technics SL-1200G > K&K Audio Phono Amp (Zu DL-103/Benz Glider-SL/Denon DL-301 II)

[Office] Laptop > Kitsune R2R lvl3 > Violectric V281 > Focal Utopia Headphones (balanced)

[beach/Travel] Laptop > DragonFly Red > Ether Headphones

Share this post


Link to post
Share on other sites

The D1100, as far as I can tell anyway, is missing a feature my MAC7200 has, which eliminates the "muting" of the USB input.  Reading the manual of the MAC7200 I found a USB AutoMute On and Off control.  It works. I listen to albums rather than playlists so I generally don't have any problems with switching sample rates from song to song.

Screen Shot 2018-08-31 at 2.21.47 PM.png


No electron left behind...

Share this post


Link to post
Share on other sites
10 minutes ago, AudioDoctor said:

The D1100, as far as I can tell anyway, is missing a feature my MAC7200 has, which eliminates the "muting" of the USB input.  Reading the manual of the MAC7200 I found a USB AutoMute On and Off control.  It works. I listen to albums rather than playlists so I generally don't have any problems with switching sample rates from song to song.

Screen Shot 2018-08-31 at 2.21.47 PM.png

 

Thanks for the post. Actually, the feature you are referring to here is exactly what they added to firmware 1.03 on the d1100 to address this.

Share this post


Link to post
Share on other sites
Just now, AudioDoctor said:

Ah.  I was looking through my manual and didn't see this in there.  I will look into the new Firmware.

 

Yeah, you won’t find it in the manual, as the feature was added for 1.03 after I worked directly with McIntosh on this problem. If you contact McIntosh or your dealer, you should have no problem getting setup with 1.03

Share this post


Link to post
Share on other sites
On 8/31/2018 at 12:47 PM, joey_corleone said:

 

Yeah, you won’t find it in the manual, as the feature was added for 1.03 after I worked directly with McIntosh on this problem. If you contact McIntosh or your dealer, you should have no problem getting setup with 1.03

Just to confirm, this will eliminate the forced muting of the initial tracks? That’s awesome. I run roon from Mac and even with the same bitrate I get jostled by the stop and start. 

Share this post


Link to post
Share on other sites
1 hour ago, MonstaChuck said:

Just to confirm, this will eliminate the forced muting of the initial tracks? That’s awesome. I run roon from Mac and even with the same bitrate I get jostled by the stop and start. 

 

Yes! With 1.03 you can toggle USB auto mute. If you disable this feature, it will fix the issue.

 

However, be aware that if you disable it, you will have “pops” in the following circumstances

 

1) Start of first track

2) 5 seconds after stop or pause

 

What I do is set the resync delay for the d1100 to 1000ms in Roon. When I start an album, I have my c1100 on mute. I press play. The 1000ms delay gives me time to press the button to unmute before the first note. Result is I miss the “pop” but don’t miss any music whatsoever. At the end of an album or if I pause, I mute to avoid the pop.

 

This will fix the issue where you miss the first fraction of a second of initial tracks and the first fraction of a second of some other tracks.

Share this post


Link to post
Share on other sites

I suppose this begs the question, why does it "pop" in the first place? My Esoteric K-03's DAC doesn't make any such sounds. I have an MA9000 and have the same fade-in problem. I guess I need to contact Mc's tech department to find out about the firmware 1.0.3 update.

Share this post


Link to post
Share on other sites
47 minutes ago, DeathFugue said:

I suppose this begs the question, why does it "pop" in the first place? My Esoteric K-03's DAC doesn't make any such sounds. I have an MA9000 and have the same fade-in problem. I guess I need to contact Mc's tech department to find out about the firmware 1.0.3 update.

 

That's the question everyone would like an answer to isn't it. There are plenty of DAC manufacturers that have found ways around this problem. 


No electron left behind...

Share this post


Link to post
Share on other sites

I solved the problem: I'm using the DAC in my Esoteric SACD player! No pops, clicks, or any noise between tracks. I think my Audivrana+ inserted a tiny burst of static to trick the Mc DAC into not fading. (It still does on the first track.) Those little bursts are especially irritating in gapless recordings. The only downside is the Esoteric will only play up to 24/192 files. I only have a handful of higher res, and my Oppo 205 will play them until I buy a new stand alone DAC in the near future.

Share this post


Link to post
Share on other sites

Weird, I don't get Audirvana playing any bits of static at the beginning of any tracks. I did get rid of my D1100 though.


No electron left behind...

Share this post


Link to post
Share on other sites

I meant it still fades the first track/has bursts of noise if I use the MA 9000's DAC. I can hear a faint relay click in the Esoteric's DAC when it first plays, which is quite faint, otherwise all is quiet now. I plan to get either a Mytek Brooklyn+ or ExaSound E32 MKII (if my wife is feeling generous!!).

Share this post


Link to post
Share on other sites

Yes, the noise is still there just faint-er.

 

Every DAC has this problem, most handle it like the Esoteric, some don't.


No electron left behind...

Share this post


Link to post
Share on other sites

I also have a K-03x which is what I use most of the time. From my MacBook I use Roon via USB to the K-03x, and I use an XLR / AES cable from the esoteric to the D1100 digitally for comparisons sake. There’s a positive here I’ll explain in the next paragraph. I forget what other settings I changed, but for either the hiccups occur I think when you change the bitrate and the USB “handshake” is invoked. Both the esoteric and the d1100 have issues here. If I remember correctly even when switching albums with the same bitrate the d1100 needed to be quickly reintroduced with my Mac and there’s the fade in. With the esoteric it only happens with changing bitrates and I get that subtle click click     click. 

 

By doing it it this way, my esoteric holds on to the bitrate and sends that digital bitrate signal to the d1100 via the aes / xlr cable until the bitrate changes, no fade in or static between tracks.

 

Kind of related is a separate roon esoteric bitrate mac rant. If I play 96khz or 192khz tracks on the esoteric it freezes when I try to play 88khz or 44.1khz tracks right after. It’s bizarre. If I use audirvana no issues. If I use jriver on a pc no issues. To get around this I have roon play 96khz tracks as 88khz and 192khz as 176khz. It’s a quirk, and I’ll eventually get a barebones pc or the roon Nucleus for a smoother experience. 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now



×
×
  • Create New...