Jump to content
IGNORED

Asus STX II essence


Heman
 Share

Recommended Posts

I have a brand new ASUS STXII essnce card. I installed it in my z370 msi gaming pro carbon board. I plugged in the molex and installed the drivers. I have the STXII panel installed succesfully, but there is no sound coming out. No red light being emitted from optic port. I plugged it in a different motherboard and it worked. I run windows 10 pro and have updated my windows to creation pack. How do I get it to work on my Z370 msi gaming board?

Link to comment
Share on other sites

44 minutes ago, Heman said:

I have a brand new ASUS STXII essnce card. I installed it in my z370 msi gaming pro carbon board. I plugged in the molex and installed the drivers. I have the STXII panel installed succesfully, but there is no sound coming out. No red light being emitted from optic port. I plugged it in a different motherboard and it worked. I run windows 10 pro and have updated my windows to creation pack. How do I get it to work on my Z370 msi gaming board?

That doesn't sound good. Can you see it under Windows device manager? If so does it show errors?  If you can't see it at all, that would make  me wonder if there is a bios setting problem

Regards,

Dave

 

Audio system

Link to comment
Share on other sites

5 hours ago, Heman said:

THX for the reply. I can see it under windows device manager and there are no errors. Like it said it installed clean but wont make a sound or show the red light indicative of optic connections

Its been a while since I used mine. Am i correct in remembering that the Asus has its own control panel app to configure it? I  recall most of my like issues occurred when I made an error on the Asus control panel app. I also seem to remember digital out was an either/or option... you had to choose analog or digital out in the control panel.

Regards,

Dave

 

Audio system

Link to comment
Share on other sites

You mean pcm and Dolby digital live. That doesn’t do anything. I tried analog too. Issue is that red light not being emitted or lit. I need the optic connection. I think this is a software issue or compatibility. Any advice?

Link to comment
Share on other sites

  • 1 month later...

I realize it's been  over a month since last activity on this, and you might have already solved problem, but I thought I'd chime in.  I also have this card in one of my setups and Asus instructs you to go into BIOS and disable any on-board audio on the motherboard (i.e., "HD Audio" was something I had to disable in BIOS first).  Remember that all audio will be processed through this card, rather than the noisy motherboard audio.

 

Another issue that could be a problem, and a resolution limiting factor, is using an optical connection, vs. a coaxial S/PDIF cable.  The optical connection will only support up to 24/96 whereas a coaxial S/PDIF cable will support up to the cards highest output of 24/192.  An optical connection (especially a plastic one) doesn't provide a nearly as reliable digital signal connection as a coaxial cable interconnect does.  This is also why an optical connection is limited to 24/96.  There really is more to it than ones and zero's, especially when you take error correction into account.

 

Hope that helps (if you haven't already solved it!)

 

 

Link to comment
Share on other sites

 

REMOVE the intenal motherboard sound card from the motherboard BIOS settings usually integrated options

Install card into motherboard

Install all the latest drivers from MANUFACTURERS website

Check Device manager to make sure everything has been recognised by your windows operating system

Play a song and then go to the bottom right of your desktop and choose speaker icon or arrow pointing up and choose the speaker icon

Right hand click mouse and choose playback device

Left click mouse button select your music output source and set as default device and default communication device

(you can then go into configure and set stereo 5.1 atmos etc) also if your using an external amp like an AV Receiver you need to go into properties Enhancements and make sure the Loudness Equalisation is ticked to get the full volume.

 

If this does not work then you have a more serious problem

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share



×
×
  • Create New...