Jump to content
IGNORED

Anyone using HQPD app?


Recommended Posts

41 minutes ago, andru26 said:

@Ales Prochazka I am getting a connection refused error, similar to the one described by lucretius. I am running HQP desktop 3.25.3 and the latest HQPDcontrol. I have enabled "Allow control form network" on Desktop side and also removed&rescanned my entire library. 
None of these fixed the issue and I can't get past this error. Adding screenshot showing the error.

 

Can you please advise how to correct this?

Many thanks!

Screenshot_2019-02-24-20-36-09.thumb.png.cad8c5f0bb8ba331b56e40be57b463ef.png

 

Dumb perhaps, but have you tried turning off any firewalls and/or using IPv4 addresses? Just a WAG though...

Anyone who considers protocol unimportant has never dealt with a cat DAC.

Robert A. Heinlein

Link to post
Share on other sites
On 2/22/2019 at 4:31 PM, Miska said:

 

Can you confirm it gets updated properly when browsing through the web interface? I assume you are re-scanning the content using the web interface. It should then get reflected through the web interface too. This same library content should end up in HQPDcontrol too when you select resync from HQPDcontrol menu.

 

 

i tried to re-scan from web interface but it seemed to take forever.

i had added one album to my /zNew Stuff/ subdirectory (contained about 100 albums).

 

i then re-scanned in hqplayer desktop, tried to re-sync with hqdpdcontrol and again did not see the new added album.

after stopping and restarting hqplayerd, re-sync with hqpdcontrol showed new album.

Link to post
Share on other sites
  • 1 month later...
On 2/24/2019 at 2:46 PM, andru26 said:

@Ales Prochazka Yes, just checked and I'm using IPv4 address. I also disabled Firewall, but no success. Do you have any other suggestions?

 

Has this been resolved? I have the same problem and would like to know the solution. I wonder if it is the firewall of the ISP that is causing the problem.

Link to post
Share on other sites
On 2/24/2019 at 8:47 PM, andru26 said:

@Ales Prochazka I am getting a connection refused error, similar to the one described by lucretius. I am running HQP desktop 3.25.3 and the latest HQPDcontrol. I have enabled "Allow control form network" on Desktop side and also removed&rescanned my entire library. 
None of these fixed the issue and I can't get past this error. Adding screenshot showing the error.

 

Can you please advise how to correct this?

Many thanks!

Screenshot_2019-02-24-20-36-09.thumb.png.cad8c5f0bb8ba331b56e40be57b463ef.png

 

At least in this case app on the phone is trying to connect to the phone itself where the HQPlayer Desktop is certainly not running on... So the entered address is wrong, it cannot be "localhost" / 127.0.0.1 / ::1.

 

Signalyst - Developer of HQPlayer

Pulse & Fidelity - Software Defined Amplifiers

Link to post
Share on other sites
10 minutes ago, Miska said:

 

At least in this case app on the phone is trying to connect to the phone itself where the HQPlayer Desktop is certainly not running on... So the entered address is wrong, it cannot be "localhost" / 127.0.0.1 / ::1.

 

 

I have used the address of the computer that runs HQP, but still with no success. What else am I doing wrong?

Link to post
Share on other sites
2 minutes ago, andru26 said:

I have used the address of the computer that runs HQP, but still with no success. What else am I doing wrong?

 

What error are you getting with that one? And you have the allow network control enabled? And your phone is on the same network?

 

Do you have another computer from which you could try to connect to the HQPlayer machine? For example with "telnet 192.168.1.11 4321" with the IP replaced with correct one.

 

Signalyst - Developer of HQPlayer

Pulse & Fidelity - Software Defined Amplifiers

Link to post
Share on other sites
14 minutes ago, Miska said:

 

What error are you getting with that one? And you have the allow network control enabled? And your phone is on the same network?

 

Do you have another computer from which you could try to connect to the HQPlayer machine? For example with "telnet 192.168.1.11 4321" with the IP replaced with correct one.

 

 

I have "allow network control" enabled and got my phone on same network. The error I get is "failed to connect to [ IP ] (port 4321) after 100ms"

I just tried connecting via telnet from another computer. When I do that I get this blank command window...not sure if it works or not.

 

telnet.png.00695a12bd7c44956916ea541c6b3e80.png

 

Link to post
Share on other sites
2 minutes ago, andru26 said:

 

I have "allow network control" enabled and got my phone on same network. The error I get is "failed to connect to [ IP ] (port 4321) after 100ms"

I just tried connecting via telnet from another computer. When I do that I get this blank command window...not sure if it works or not.

 

telnet.png.00695a12bd7c44956916ea541c6b3e80.png

 

 

If it gets connected then it is likely working. You could try to copy-paste this there and hit enter:

<?xml version="1.0" encoding="utf-8"?><GetInfo/>

It should give a response.

 

Signalyst - Developer of HQPlayer

Pulse & Fidelity - Software Defined Amplifiers

Link to post
Share on other sites
27 minutes ago, andru26 said:

OK, thanks. Will try a different phone and see if that makes any difference.

 

Just tried a second phone and got the same result. Looks like there might be something on the HQPlayer PC side that is not allowing the connection. 

FIY, I am running WIndows server 2012 R2 with AO installed in core mode.

 

Any help in solving this issue is much appreciated.

Link to post
Share on other sites
2 minutes ago, andru26 said:

And how should I test the connection between phone and computer?

 

One possibility is to run a web server like IIS temporarily on the computer and see if you can make phone load a page from it. Or something like, but that is fairly straightforward.

 

Signalyst - Developer of HQPlayer

Pulse & Fidelity - Software Defined Amplifiers

Link to post
Share on other sites

If you can connect, as you did previous, then there are only a few possible;e issues. 

 

Is your phone on the local area network? It won't work if you are on LTE, 4G, 3G, etc.  This seems obvious, but everybody makes that mistake occasionally. 

 

-Paul 

 

 

Anyone who considers protocol unimportant has never dealt with a cat DAC.

Robert A. Heinlein

Link to post
Share on other sites
7 hours ago, clang said:

I had tried Ping Tools. I have 3 computers at home and the Ping got through to none of them. If someone uses Rogers Cable in Canada I'd really appreciate his sharing his experience.

 

 

That didn't work for me either...

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


×
×
  • Create New...