Jump to content
flak

New second generation Dirac Live

Rate this topic

Recommended Posts

@michael123 Thanks for your kind comment.

 

Yes, I will probably resort to that idea for now but the whole idea behind vst chain measurement is that we can use the very same playback chain to measure the sound characteristics. I find jplay femto sound quite different than my other playback chains and I'd love to be able to use my preferred choice of playback combo to do the measurement.


Music Source: NAS[Synology], Qobuz, Tidal

Music Player: Roonserver[Mac mini]

Control PC: squeeze2upnp, fb2k, dirac, Jplay Femto, Fidelizer, AO(4D), WS2019 GUI, Mac mini w/HDPlex 200W

Audio PC: Jplay Femto(KS/1000hz), Fidelizer, AO(4D), WS2019 core, i7 w/HDPlex 200W

DDC: Iso Regen w/LPS1.2, Acousence afi+USB (USB to S/PDIF) w/Li-ion battery PS

DAC: Yggdrasil Analog 2

Share this post


Link to post
Share on other sites
7 minutes ago, shinyc said:

@michael123 Thanks for your kind comment.

 

Yes, I will probably resort to that idea for now but the whole idea behind vst chain measurement is that we can use the very same playback chain to measure the sound characteristics. I find jplay femto sound quite different than my other playback chains and I'd love to be able to use my preferred choice of playback combo to do the measurement.

 

But the latency you can and probably should discuss with Marcin IMHO

Share this post


Link to post
Share on other sites

I will give Marcin a try. I hope he is in a good mood :o


Music Source: NAS[Synology], Qobuz, Tidal

Music Player: Roonserver[Mac mini]

Control PC: squeeze2upnp, fb2k, dirac, Jplay Femto, Fidelizer, AO(4D), WS2019 GUI, Mac mini w/HDPlex 200W

Audio PC: Jplay Femto(KS/1000hz), Fidelizer, AO(4D), WS2019 core, i7 w/HDPlex 200W

DDC: Iso Regen w/LPS1.2, Acousence afi+USB (USB to S/PDIF) w/Li-ion battery PS

DAC: Yggdrasil Analog 2

Share this post


Link to post
Share on other sites
1 hour ago, macuniverse said:

I'm also having issues with my license. I get the following message when I click the "Dirac Live Processor" icon in the Dirac Live app

 

"You are missing the correct license ..." See below.

 

Actually, I login with the same account that I bought the license. After login I can check the license info and it's there and correct.

 

Looking forward to a solution so that I can try the latest and greatest. Thanks.

 

PS. I already created a ticket last Friday but no reply so far.

 

781369584_ScreenShot2019-12-17at00_40_21.thumb.jpg.9ef1b0868def0b37aba3c037dfb80a27.jpg

 

I'm having the same issue once in a while, here is a temporarily solution to fix it:
- When you get the error, press Dismiss (obviously ;))
- Go to the menu and press Logoff and the login back again

- Press the Dirac Live Processor again and it should let you in.

Share this post


Link to post
Share on other sites

Follow up from my previous post in case it helps someone else in future. 

 

After couple of  login/logouts (to overcome licensing issues) I finally managed to complete a chair setup measurement; @Alain13, thanks again for the tip. I also successfully created my first two filters.

 

Filters work as intended locally; i.e., PC connected to the audio system directly through USB DAC. I can select, enable/disable filters, change the gain provided I enable "Realtime Control" under "Audio Units" option of Audirvana player. Otherwise DLP2 (Dirac Live Processor 2) gain slider works (attenuate volume by -13dB) but the filter enable/disable switch is greyed out and looks like set to "disable" state (see the picture below). There is no way I can enable/select them.

 

However, the real issue, when I stream audio to a DLNA/UPnP renderer (MicroRendu in this case) from Audirvana over the LAN DLP2 is always greyed out. This defeats the purpose of using this plugin for me as my main audio transport is MicroRendu DLNA renderer over the local network. I did not test this under JRiver as it doesn't support any DSP over DLNA.

 

As it stands, it's unusable for me. Hopefully I get a quick answer from Dirac people as my setup is pretty standard and they should be able to test it easily.

 

Screen Shot 2019-12-17 at 18.48.42.jpg

Share this post


Link to post
Share on other sites
19 minutes ago, macuniverse said:

I did not test this under JRiver as it doesn't support any DSP over DLNA.

That's not true.  You just have to access the DSP differently.


Kal Rubinson

Music in the Round

Senior Contributing Editor, Stereophile

Share this post


Link to post
Share on other sites
1 minute ago, Kal Rubinson said:

That's not true.  You just have to access the DSP differently.

 

If I remember correctly the official response from JRiver people was "Not supported".

 

I understand you are referring to Options --> Media Network --> ... Advanced --> DSP Studio? I would appreciate if you have any pointers to how this can be setup properly; maybe I'm doing something wrong.

 

When I try to select DL2 filters with DSP Studio while audio playing to a DLNA renderer I get the message below from JRiver.

 

I actually tried it before anyway. Gain slider in the DL2 plugin works (I can turn the volume down to test) but the filters are still greyed out, not selectable. This is before selecting DLNA renderer as the active zone and playing to it. Additionally, DL2 plugin crashes JRiver in the process if I try to change things.

 

My version of JRiver is 24. Not sure if this works differently on v25/26.

Screen Shot 2019-12-18 at 02.18.26.jpg

Share this post


Link to post
Share on other sites
On 12/16/2019 at 2:06 AM, whoareyou said:

@flak

I have same issue as michael123.  I'm PM ticket to you

 

The missing Phase Correction license issue was fixed on Dirac's servers, if you saved a measurement project previously, just reload it and try to re-export the filter. For me it worked.

I would also logout and re-login before.

 

 

Share this post


Link to post
Share on other sites

I finally got the production version working and am finding it much more stable. However, I am experiencing image shifting to the left about 20% (if the center-to-left is100%). I recall someone complaining about this phenomenon some time ago and also recall there was a correction made in the code. Anyone else experiencing image shifting? If I bypass the Dirac filter, image returns to the center. I also noticed that degree of shift varies between various measurements.

 

PS. Image becomes vague after applying Dirac. hmmm


Music Source: NAS[Synology], Qobuz, Tidal

Music Player: Roonserver[Mac mini]

Control PC: squeeze2upnp, fb2k, dirac, Jplay Femto, Fidelizer, AO(4D), WS2019 GUI, Mac mini w/HDPlex 200W

Audio PC: Jplay Femto(KS/1000hz), Fidelizer, AO(4D), WS2019 core, i7 w/HDPlex 200W

DDC: Iso Regen w/LPS1.2, Acousence afi+USB (USB to S/PDIF) w/Li-ion battery PS

DAC: Yggdrasil Analog 2

Share this post


Link to post
Share on other sites
2 hours ago, shinyc said:

I finally got the production version working and am finding it much more stable. However, I am experiencing image shifting to the left about 20% (if the center-to-left is100%). I recall someone complaining about this phenomenon some time ago and also recall there was a correction made in the code. Anyone else experiencing image shifting? If I bypass the Dirac filter, image returns to the center. I also noticed that degree of shift varies between various measurements.

 

PS. Image becomes vague after applying Dirac. hmmm

 

Yes, that was me

 

Share this post


Link to post
Share on other sites
On 2/1/2019 at 2:18 AM, michelangelo said:

I have the same problem.
The error did not occur in the previous version of the DiracLiveProcessor.

I have also tested it with several mono recordings and the sound is shifted to the left.

Especially there he should come exactly from the middle.

 

Hi @michelangelo, Does the problem still persist or is it gone with the current version?


Music Source: NAS[Synology], Qobuz, Tidal

Music Player: Roonserver[Mac mini]

Control PC: squeeze2upnp, fb2k, dirac, Jplay Femto, Fidelizer, AO(4D), WS2019 GUI, Mac mini w/HDPlex 200W

Audio PC: Jplay Femto(KS/1000hz), Fidelizer, AO(4D), WS2019 core, i7 w/HDPlex 200W

DDC: Iso Regen w/LPS1.2, Acousence afi+USB (USB to S/PDIF) w/Li-ion battery PS

DAC: Yggdrasil Analog 2

Share this post


Link to post
Share on other sites

Hi,

I don't have this problem with the current version.


♦ iTunes ♦ Audirvana 3.5 ♦ Dirac Live ♦ Dynaudio Connect ♦ Dynaudio Focus 200 XD ♦ Allo Digione Signatur Player ♦ Dynaudio Focus 600 XD ♦

Share this post


Link to post
Share on other sites

@michelangelo, Thanks for your reply. Flak (Flavio) just informed me of a fix. I turned off both compensation check marks off in the DLP panel and all is well. Does anyone know what these settings do?


Music Source: NAS[Synology], Qobuz, Tidal

Music Player: Roonserver[Mac mini]

Control PC: squeeze2upnp, fb2k, dirac, Jplay Femto, Fidelizer, AO(4D), WS2019 GUI, Mac mini w/HDPlex 200W

Audio PC: Jplay Femto(KS/1000hz), Fidelizer, AO(4D), WS2019 core, i7 w/HDPlex 200W

DDC: Iso Regen w/LPS1.2, Acousence afi+USB (USB to S/PDIF) w/Li-ion battery PS

DAC: Yggdrasil Analog 2

Share this post


Link to post
Share on other sites
1 minute ago, shinyc said:

@michelangelo, Thanks for your reply. Flak (Flavio) just informed me of a fix. I turned off both compensation check marks off in the DLP panel and all is well. Does anyone know what these settings do?

 

Which ones?

Share this post


Link to post
Share on other sites

image.png.d4147f8a8957d3986460e5599403ce10.png

 

Turning off the delay compensation setting fixed the issue.


Music Source: NAS[Synology], Qobuz, Tidal

Music Player: Roonserver[Mac mini]

Control PC: squeeze2upnp, fb2k, dirac, Jplay Femto, Fidelizer, AO(4D), WS2019 GUI, Mac mini w/HDPlex 200W

Audio PC: Jplay Femto(KS/1000hz), Fidelizer, AO(4D), WS2019 core, i7 w/HDPlex 200W

DDC: Iso Regen w/LPS1.2, Acousence afi+USB (USB to S/PDIF) w/Li-ion battery PS

DAC: Yggdrasil Analog 2

Share this post


Link to post
Share on other sites
5 minutes ago, shinyc said:

image.png.d4147f8a8957d3986460e5599403ce10.png

 

Turning off the delay compensation setting fixed the issue.

 

Indeed, seen these

 

But what then will fix delay / gain?

Share this post


Link to post
Share on other sites

I asked the same question to flak and only explanation give to me was that they affect the 1st measurement position (the critical one) only in the set of 9(chair) or 17(sofa). Therefore, make sure the 1st measurement position is exactly in the sweet spot.


Music Source: NAS[Synology], Qobuz, Tidal

Music Player: Roonserver[Mac mini]

Control PC: squeeze2upnp, fb2k, dirac, Jplay Femto, Fidelizer, AO(4D), WS2019 GUI, Mac mini w/HDPlex 200W

Audio PC: Jplay Femto(KS/1000hz), Fidelizer, AO(4D), WS2019 core, i7 w/HDPlex 200W

DDC: Iso Regen w/LPS1.2, Acousence afi+USB (USB to S/PDIF) w/Li-ion battery PS

DAC: Yggdrasil Analog 2

Share this post


Link to post
Share on other sites
5 minutes ago, shinyc said:

I asked the same question to flak and only explanation give to me was that they affect the 1st measurement position (the critical one) only in the set of 9(chair) or 17(sofa). Therefore, make sure the 1st measurement position is exactly in the sweet spot.

 

Sweet Spot is sweet spot, we know where we sit.

 

Share this post


Link to post
Share on other sites

Home Audio Fidelity uses "two microphones in your ears (a.k.a. HRTF)" way to find sweet spot. Different algorithm. But you have to pay per measurement + turnaround time. In those regards, I prefer Dirac.


Music Source: NAS[Synology], Qobuz, Tidal

Music Player: Roonserver[Mac mini]

Control PC: squeeze2upnp, fb2k, dirac, Jplay Femto, Fidelizer, AO(4D), WS2019 GUI, Mac mini w/HDPlex 200W

Audio PC: Jplay Femto(KS/1000hz), Fidelizer, AO(4D), WS2019 core, i7 w/HDPlex 200W

DDC: Iso Regen w/LPS1.2, Acousence afi+USB (USB to S/PDIF) w/Li-ion battery PS

DAC: Yggdrasil Analog 2

Share this post


Link to post
Share on other sites
19 hours ago, shinyc said:

Home Audio Fidelity uses "two microphones in your ears (a.k.a. HRTF)" way to find sweet spot. Different algorithm. But you have to pay per measurement + turnaround time. In those regards, I prefer Dirac.

 

I have installed Dirac beta previously on two systems. The one in the larger room with ~4.5 meters between the speakers is that one where the left-shift is most exposed. The good part is at least I am not the only one and there is a workaround (question: how much do we lose because of this workaround??). The bad part is that I reported to QA this issue 2 months ago and they did nothing. The issue did not exist in Version 1. 

 

And btw we have Bosch laser meter, sweet spot is exactly in the center.

But should it be??

It is supposedly to be where we usually sit.

And what that compensation is for?

 

 

Share this post


Link to post
Share on other sites

We got reports (thanks Tom Reich) that there can be issues between Audirvana 3.5 and the Dirac Live Processor while Audirvana 3.2 seems to work as expected.
We'll try to know from the developer what has been changed between those two versions and hopefully find a solution together.
In the meantime (in case of issues) one can try using Audirvana 3.2 with Dirac to then use the created processor also in Audirvana 3.5

The latest 1.0.2 Dirac Processor is now available here:
https://live.dirac.com/download/

On Mac please remove the Dirac Processor files from these locations:
/Library/Audio/Plug-Ins/Components
/Library/Audio/Plug-Ins/VST
/Library/Audio/Plug-Ins/VST3
/Library/Application Support/Avid/Audio/Plug-Ins
to then restart the computer itself and install the DLP

On Windows I suggest the following:
1) Uninstall all previous versions of Beta Dirac Live processor in Settings > Apps under Apps&features
2) Delete folder C:\Users\<UserName>\AppData\Roaming\Dirac\Dirac_Live_Processor
If you want to save your filters, please move folder "filters" to a temporary location
3) Restart Windows and download the released Processor version from https://live.dirac.com/download/
If you moved your filter, now move them back to C:\Users\<UserName>\AppData\Roaming\Dirac\Dirac_Live_Processor


Warning: My posts may be biased even if in good faith, I work for Dirac Research :-)

Share this post


Link to post
Share on other sites

@flakThank you, Flavio!

 

I installed, reading the changelog 

 

The first one below - is that the left-shift?

 

  • Fixed - Individual speaker volume calibration bugfix
  • Fixed - Will no longer crash when changing filter in JRiver Media Center 25

 

Share this post


Link to post
Share on other sites
On 12/22/2019 at 3:44 AM, shinyc said:

I finally got the production version working and am finding it much more stable. However, I am experiencing image shifting to the left about 20% (if the center-to-left is100%). I recall someone complaining about this phenomenon some time ago and also recall there was a correction made in the code. Anyone else experiencing image shifting? If I bypass the Dirac filter, image returns to the center. I also noticed that degree of shift varies between various measurements.

 

PS. Image becomes vague after applying Dirac. hmmm

 

Did you try the new processor from Dec 19 (1.0.2)?

For me it looks like fixed, I used Sofa/Wide measurements

Share this post


Link to post
Share on other sites

Yes, I am on 1.0.2. I still need to turn off the "Delay compensation" setting. Only then, the centering issue is gone. Do you not have that issue even if the "Delay compensation" setting is on? I still do not know what exactly the setting does, though.


Music Source: NAS[Synology], Qobuz, Tidal

Music Player: Roonserver[Mac mini]

Control PC: squeeze2upnp, fb2k, dirac, Jplay Femto, Fidelizer, AO(4D), WS2019 GUI, Mac mini w/HDPlex 200W

Audio PC: Jplay Femto(KS/1000hz), Fidelizer, AO(4D), WS2019 core, i7 w/HDPlex 200W

DDC: Iso Regen w/LPS1.2, Acousence afi+USB (USB to S/PDIF) w/Li-ion battery PS

DAC: Yggdrasil Analog 2

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now



×
×
  • Create New...